GIS Namespace

[image]

A Sandcastle Documented Class Library
GIS Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS"]

Classes

 | Class | Description
Public class | GisTest | テスト専用の静的クラス


GisTest Class

[image]

A Sandcastle Documented Class Library
GisTest Class
Members See Also Send Feedback
テスト専用の静的クラス

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class GisTest
Visual Basic
Public NotInheritable Class GisTest
Visual C++
public ref class GisTest abstract sealed

Inheritance Hierarchy

System..::..Object
GIS..::..GisTest

See Also

GisTest Members
GIS Namespace


GisTest Members

[image] [image]

A Sandcastle Documented Class Library
GisTest Members
GisTest Class Methods See Also Send Feedback

The GisTest type exposes the following members.

Methods

Name Description
ReadNmeaToKmlPoint
Pointクラスのテスト

GNSSプロジェクトのGnssTestクラスの機能を利用してNMEAファイルから測位点情報を読み出し、KMLへPoint情報として出力します

ReadNmeaToRectangleField
RectangleFieldクラスとPolygonクラスのテスト

GNSSプロジェクトのGnssTestクラスの機能を利用してNMEAファイルからRectangleFieldオブジェクトを生成し、Polygonクラスを利用してKMLファイルを出力します。

ダイアログを利用してファイルを開きます。

SaveBigMapAsBmp
DEMクラスの読み込みテストおよびマネジメント機能のテスト、さらにマップの結合テストを実施します

指定した座標で張る長方形領域を含む地図を生成します。

座標を省略すると、BLH(33.0432, 130.559), BLH(32.6159, 130.9659)（熊本県付近）が使用されます。

Taskクラスを利用して処理がすぐに戻るようにしておりますが、実際には若干の間をおいてファイルが生成されることにご注意ください。

SaveDemFileInfoAsKml
フォルダを指定して、走査されたDEMファイルの一覧をKMLファイルへ出力する

ReaderクラスとManagerクラスの動作テストです。

ファイル名はDEMmaps.kmlです。

異種類のDEMは先読みされた方が優先して処理され、後読みされた異種のDEMはファイル出力されませんのでご注意ください。

Examples

CopyC#
GIS.GisTest.SaveDemFileInfoAsKml(Color.MediumBlue);
SaveDemFileInfoAsKml2
フォルダを指定して、走査されたDEMファイルの一覧をKMLファイルへ出力する

DEMクラスのDEM読み込みテストです。

全種類のDEMが種類毎にファイル出力されます。

ファイル名はDEMmaps_nn.kmlです（nnは番号）。

Examples

CopyC#
GIS.GisTest.SaveDemFileInfoAsKml2();
SaveMapAsBmp
読み込んだDEMファイルを一つだけビットマップファイルとして出力します

Readerクラスの読み込み機能及び、Mapクラスの画像出力機能のテストです。

出力するファイルは選べません。 ファイルを全て読み込むので処理にかなりの時間がかかります。

Examples

CopyC#
GIS.GisTest.SaveMapAsBmp();

See Also

GisTest Class
GIS Namespace


GisTest Methods

[image] [image]

A Sandcastle Documented Class Library
GisTest Methods
GisTest Class See Also Send Feedback

The GisTest type exposes the following members.

Methods

Name Description
ReadNmeaToKmlPoint
Pointクラスのテスト

GNSSプロジェクトのGnssTestクラスの機能を利用してNMEAファイルから測位点情報を読み出し、KMLへPoint情報として出力します

ReadNmeaToRectangleField
RectangleFieldクラスとPolygonクラスのテスト

GNSSプロジェクトのGnssTestクラスの機能を利用してNMEAファイルからRectangleFieldオブジェクトを生成し、Polygonクラスを利用してKMLファイルを出力します。

ダイアログを利用してファイルを開きます。

SaveBigMapAsBmp
DEMクラスの読み込みテストおよびマネジメント機能のテスト、さらにマップの結合テストを実施します

指定した座標で張る長方形領域を含む地図を生成します。

座標を省略すると、BLH(33.0432, 130.559), BLH(32.6159, 130.9659)（熊本県付近）が使用されます。

Taskクラスを利用して処理がすぐに戻るようにしておりますが、実際には若干の間をおいてファイルが生成されることにご注意ください。

SaveDemFileInfoAsKml
フォルダを指定して、走査されたDEMファイルの一覧をKMLファイルへ出力する

ReaderクラスとManagerクラスの動作テストです。

ファイル名はDEMmaps.kmlです。

異種類のDEMは先読みされた方が優先して処理され、後読みされた異種のDEMはファイル出力されませんのでご注意ください。

Examples

CopyC#
GIS.GisTest.SaveDemFileInfoAsKml(Color.MediumBlue);
SaveDemFileInfoAsKml2
フォルダを指定して、走査されたDEMファイルの一覧をKMLファイルへ出力する

DEMクラスのDEM読み込みテストです。

全種類のDEMが種類毎にファイル出力されます。

ファイル名はDEMmaps_nn.kmlです（nnは番号）。

Examples

CopyC#
GIS.GisTest.SaveDemFileInfoAsKml2();
SaveMapAsBmp
読み込んだDEMファイルを一つだけビットマップファイルとして出力します

Readerクラスの読み込み機能及び、Mapクラスの画像出力機能のテストです。

出力するファイルは選べません。 ファイルを全て読み込むので処理にかなりの時間がかかります。

Examples

CopyC#
GIS.GisTest.SaveMapAsBmp();

See Also

GisTest Class
GIS Namespace


ReadNmeaToKmlPoint Method

[image]

A Sandcastle Documented Class Library
GisTest..::..ReadNmeaToKmlPoint Method
GisTest Class See Also Send Feedback
Pointクラスのテスト

GNSSプロジェクトのGnssTestクラスの機能を利用してNMEAファイルから測位点情報を読み出し、KMLへPoint情報として出力します

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void ReadNmeaToKmlPoint()
Visual Basic
Public Shared Sub ReadNmeaToKmlPoint
Visual C++
public:
static void ReadNmeaToKmlPoint()

See Also

GisTest Class
GIS Namespace


ReadNmeaToRectangleField Method

[image]

A Sandcastle Documented Class Library
GisTest..::..ReadNmeaToRectangleField Method
GisTest Class See Also Send Feedback
RectangleFieldクラスとPolygonクラスのテスト

GNSSプロジェクトのGnssTestクラスの機能を利用してNMEAファイルからRectangleFieldオブジェクトを生成し、Polygonクラスを利用してKMLファイルを出力します。

ダイアログを利用してファイルを開きます。

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void ReadNmeaToRectangleField()
Visual Basic
Public Shared Sub ReadNmeaToRectangleField
Visual C++
public:
static void ReadNmeaToRectangleField()

See Also

GisTest Class
GIS Namespace


SaveBigMapAsBmp Method

[image]

A Sandcastle Documented Class Library
GisTest..::..SaveBigMapAsBmp Method
GisTest Class See Also Send Feedback
DEMクラスの読み込みテストおよびマネジメント機能のテスト、さらにマップの結合テストを実施します

指定した座標で張る長方形領域を含む地図を生成します。

座標を省略すると、BLH(33.0432, 130.559), BLH(32.6159, 130.9659)（熊本県付近）が使用されます。

Taskクラスを利用して処理がすぐに戻るようにしておりますが、実際には若干の間をおいてファイルが生成されることにご注意ください。

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SaveBigMapAsBmp(
    BLH x1,
    BLH x2
)
Visual Basic
Public Shared Sub SaveBigMapAsBmp ( _
    x1 As BLH, _
    x2 As BLH _
)
Visual C++
public:
static void SaveBigMapAsBmp(
    BLH x1,
    BLH x2
)

Parameters

x1
Type: BLH
座標1
x2
Type: BLH
座標2

See Also

GisTest Class
GIS Namespace


SaveDemFileInfoAsKml Method

[image]

A Sandcastle Documented Class Library
GisTest..::..SaveDemFileInfoAsKml Method
GisTest Class See Also Send Feedback
フォルダを指定して、走査されたDEMファイルの一覧をKMLファイルへ出力する

ReaderクラスとManagerクラスの動作テストです。

ファイル名はDEMmaps.kmlです。

異種類のDEMは先読みされた方が優先して処理され、後読みされた異種のDEMはファイル出力されませんのでご注意ください。

Examples

CopyC#
GIS.GisTest.SaveDemFileInfoAsKml(Color.MediumBlue);

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SaveDemFileInfoAsKml(
    Color color
)
Visual Basic
Public Shared Sub SaveDemFileInfoAsKml ( _
    color As Color _
)
Visual C++
public:
static void SaveDemFileInfoAsKml(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
色情報

See Also

GisTest Class
GIS Namespace


SaveDemFileInfoAsKml2 Method

[image]

A Sandcastle Documented Class Library
GisTest..::..SaveDemFileInfoAsKml2 Method
GisTest Class See Also Send Feedback
フォルダを指定して、走査されたDEMファイルの一覧をKMLファイルへ出力する

DEMクラスのDEM読み込みテストです。

全種類のDEMが種類毎にファイル出力されます。

ファイル名はDEMmaps_nn.kmlです（nnは番号）。

Examples

CopyC#
GIS.GisTest.SaveDemFileInfoAsKml2();

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SaveDemFileInfoAsKml2()
Visual Basic
Public Shared Sub SaveDemFileInfoAsKml2
Visual C++
public:
static void SaveDemFileInfoAsKml2()

See Also

GisTest Class
GIS Namespace


SaveMapAsBmp Method

[image]

A Sandcastle Documented Class Library
GisTest..::..SaveMapAsBmp Method
GisTest Class See Also Send Feedback
読み込んだDEMファイルを一つだけビットマップファイルとして出力します

Readerクラスの読み込み機能及び、Mapクラスの画像出力機能のテストです。

出力するファイルは選べません。 ファイルを全て読み込むので処理にかなりの時間がかかります。

Examples

CopyC#
GIS.GisTest.SaveMapAsBmp();

Namespace: GIS
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SaveMapAsBmp()
Visual Basic
Public Shared Sub SaveMapAsBmp
Visual C++
public:
static void SaveMapAsBmp()

See Also

GisTest Class
GIS Namespace


GIS.DigitalElevationModel Namespace

[image]

A Sandcastle Documented Class Library
GIS.DigitalElevationModel Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.DigitalElevationModel"]

Classes

 | Class | Description
Public class | DEM | 数値標高モデルを扱うクラス
Public class | DemSet | DEMファイル情報とマップを結合し、運用するためのクラス マップ情報とマップクラスとを一緒にする。
Public class | Manager | DEMマネージャー DEMのファイル群を同じモデルごとに管理するためのクラスです。
Public class | TerrainInformation | 地形情報を格納するためのクラス

Structures

 | Structure | Description
Public structure | Info | DEMファイルの属性を記した構造体 ファイルのさまざまな属性を提供します。
Public structure | TerrainInformation..::..Feature | 地形の特徴をまとめた構造体

Enumerations

 | Enumeration | Description
Public enumeration | Model | DEMマップのモデル（種別）を表す列挙体
Public enumeration | TerrainInformation..::..Feature..::..GeographicalFeature | 地形の特徴を表す


DEM Class

[image]

A Sandcastle Documented Class Library
DEM Class
Members See Also Send Feedback
数値標高モデルを扱うクラス

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DEM
Visual Basic
Public Class DEM
Visual C++
public ref class DEM

Inheritance Hierarchy

System..::..Object
GIS.DigitalElevationModel..::..DEM

See Also

DEM Members
GIS.DigitalElevationModel Namespace


DEM Members

[image] [image]

A Sandcastle Documented Class Library
DEM Members
DEM Class Constructors Methods Properties See Also Send Feedback

The DEM type exposes the following members.

Constructors

 | Name | Description
Public method | DEM | コンストラクタ

Methods

 | Name | Description
Public method | AddDir | ディレクトリを指定し、含まれいているDEMファイルを追加・管理下に置く ヘッダ情報のみ取得されます。
Public method | AddDirWithDialog | ダイアログを利用してディレクトリを指定し、含まれいているDEMファイルを追加・管理下に置く ヘッダ情報のみ取得されます。
Public method | CheckAvailability | 指定座標のデータを返すことが可能かどうかを返す
Public method | CreateMap | 指定領域をカバーするマップを生成する 取得可能なマップ規格のうち、最も細かく且つ指定領域でのカバー率が30%を超える系統を使って一つのマップを生成します。 この辺はユーザーの用途によって仕様がコロコロ変わりえる部分です。
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeight(BLH) | 指定された緯度経度の標高を返す 保持しているDEMモデルの内、分解能が最も細かいモデルの結果を返します。 該当なしの場合は、float.NaNを返します。
Public method | GetHeight(array<BLH>[]()[][]) | 指定された緯度経度に沿った標高を配列で返す
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveDemInfo | 保持しているDEMファイル情報をKML形式ファイルで出力する
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Count | 管理下にあるDEMファイルの数
Public property | Ready | 準備OK？ true: 利用準備完了

See Also

DEM Class
GIS.DigitalElevationModel Namespace


DEM Constructor

[image]

A Sandcastle Documented Class Library
DEM Constructor
DEM Class See Also Send Feedback
コンストラクタ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DEM()
Visual Basic
Public Sub New
Visual C++
public:
DEM()

See Also

DEM Class
GIS.DigitalElevationModel Namespace


DEM Methods

[image] [image]

A Sandcastle Documented Class Library
DEM Methods
DEM Class See Also Send Feedback

The DEM type exposes the following members.

Methods

 | Name | Description
Public method | AddDir | ディレクトリを指定し、含まれいているDEMファイルを追加・管理下に置く ヘッダ情報のみ取得されます。
Public method | AddDirWithDialog | ダイアログを利用してディレクトリを指定し、含まれいているDEMファイルを追加・管理下に置く ヘッダ情報のみ取得されます。
Public method | CheckAvailability | 指定座標のデータを返すことが可能かどうかを返す
Public method | CreateMap | 指定領域をカバーするマップを生成する 取得可能なマップ規格のうち、最も細かく且つ指定領域でのカバー率が30%を超える系統を使って一つのマップを生成します。 この辺はユーザーの用途によって仕様がコロコロ変わりえる部分です。
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeight(BLH) | 指定された緯度経度の標高を返す 保持しているDEMモデルの内、分解能が最も細かいモデルの結果を返します。 該当なしの場合は、float.NaNを返します。
Public method | GetHeight(array<BLH>[]()[][]) | 指定された緯度経度に沿った標高を配列で返す
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveDemInfo | 保持しているDEMファイル情報をKML形式ファイルで出力する
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DEM Class
GIS.DigitalElevationModel Namespace


AddDir Method

[image]

A Sandcastle Documented Class Library
DEM..::..AddDir Method
DEM Class See Also Send Feedback
ディレクトリを指定し、含まれいているDEMファイルを追加・管理下に置く

ヘッダ情報のみ取得されます。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int AddDir(
    string dirName
)
Visual Basic
Public Function AddDir ( _
    dirName As String _
) As Integer
Visual C++
public:
int AddDir(
    String^ dirName
)

Parameters

dirName
Type: System..::..String
走査したいフォルダ名

Return Value

追加されたDEMファイルの数

See Also

DEM Class
GIS.DigitalElevationModel Namespace


AddDirWithDialog Method

[image]

A Sandcastle Documented Class Library
DEM..::..AddDirWithDialog Method
DEM Class See Also Send Feedback
ダイアログを利用してディレクトリを指定し、含まれいているDEMファイルを追加・管理下に置く

ヘッダ情報のみ取得されます。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int AddDirWithDialog()
Visual Basic
Public Function AddDirWithDialog As Integer
Visual C++
public:
int AddDirWithDialog()

Return Value

追加されたDEMファイルの数

See Also

DEM Class
GIS.DigitalElevationModel Namespace


CheckAvailability Method

[image]

A Sandcastle Documented Class Library
DEM..::..CheckAvailability Method
DEM Class See Also Send Feedback
指定座標のデータを返すことが可能かどうかを返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckAvailability(
    BLH pos
)
Visual Basic
Public Function CheckAvailability ( _
    pos As BLH _
) As Boolean
Visual C++
public:
bool CheckAvailability(
    BLH pos
)

Parameters

pos
Type: BLH
指定座標（lat,lon）

Return Value

true: 使用可能

See Also

DEM Class
GIS.DigitalElevationModel Namespace


CreateMap Method

[image]

A Sandcastle Documented Class Library
DEM..::..CreateMap Method
DEM Class See Also Send Feedback
指定領域をカバーするマップを生成する

取得可能なマップ規格のうち、最も細かく且つ指定領域でのカバー率が30%を超える系統を使って一つのマップを生成します。

この辺はユーザーの用途によって仕様がコロコロ変わりえる部分です。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map CreateMap(
    RectangleField field
)
Visual Basic
Public Function CreateMap ( _
    field As RectangleField _
) As Map
Visual C++
public:
Map^ CreateMap(
    RectangleField^ field
)

Parameters

field
Type: RectangleField
領域

Return Value

生成したマップ

See Also

DEM Class
GIS.DigitalElevationModel Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
DEM..::..Finalize Method
DEM Class See Also Send Feedback
デスコンストラクタ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

DEM Class
GIS.DigitalElevationModel Namespace


GetHeight Method

[image] [image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method
DEM Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHeight(BLH) | 指定された緯度経度の標高を返す 保持しているDEMモデルの内、分解能が最も細かいモデルの結果を返します。 該当なしの場合は、float.NaNを返します。
Public method | GetHeight(array<BLH>[]()[][]) | 指定された緯度経度に沿った標高を配列で返す

See Also

DEM Class
DEM Members
GIS.DigitalElevationModel Namespace


GetHeight Method ()

[image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method ()
DEM Class See Also Send Feedback
指定された緯度経度の標高を返す

保持しているDEMモデルの内、分解能が最も細かいモデルの結果を返します。

該当なしの場合は、float.NaNを返します。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float GetHeight(
    BLH pos
)
Visual Basic
Public Function GetHeight ( _
    pos As BLH _
) As Single
Visual C++
public:
float GetHeight(
    BLH pos
)

Parameters

pos
Type: BLH
指定座標

Return Value

指定された座標のマップ情報を返す

See Also

DEM Class
GetHeight Overload
GIS.DigitalElevationModel Namespace


GetHeight Method ([])

[image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method (array<>[]()[][])
DEM Class See Also Send Feedback
指定された緯度経度に沿った標高を配列で返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[] GetHeight(
    BLH[] pos
)
Visual Basic
Public Function GetHeight ( _
    pos As BLH() _
) As Single()
Visual C++
public:
array<float>^ GetHeight(
    array<BLH>^ pos
)

Parameters

pos
Type: array<BLH>[]()[][]
座標の格納された配列

Return Value

指定された座標のマップ情報を返す

See Also

DEM Class
GetHeight Overload
GIS.DigitalElevationModel Namespace


SaveDemInfo Method

[image]

A Sandcastle Documented Class Library
DEM..::..SaveDemInfo Method
DEM Class See Also Send Feedback
保持しているDEMファイル情報をKML形式ファイルで出力する

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveDemInfo(
    string fname
)
Visual Basic
Public Sub SaveDemInfo ( _
    fname As String _
)
Visual C++
public:
void SaveDemInfo(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

DEM Class
GIS.DigitalElevationModel Namespace


DEM Properties

[image] [image]

A Sandcastle Documented Class Library
DEM Properties
DEM Class See Also Send Feedback

The DEM type exposes the following members.

Properties

 | Name | Description
Public property | Count | 管理下にあるDEMファイルの数
Public property | Ready | 準備OK？ true: 利用準備完了

See Also

DEM Class
GIS.DigitalElevationModel Namespace


Count Property

[image]

A Sandcastle Documented Class Library
DEM..::..Count Property
DEM Class See Also Send Feedback
管理下にあるDEMファイルの数

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

DEM Class
GIS.DigitalElevationModel Namespace


Ready Property

[image]

A Sandcastle Documented Class Library
DEM..::..Ready Property
DEM Class See Also Send Feedback
準備OK？

true: 利用準備完了

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Ready { get; }
Visual Basic
Public ReadOnly Property Ready As Boolean
    Get
Visual C++
public:
property bool Ready {
    bool get ();
}

See Also

DEM Class
GIS.DigitalElevationModel Namespace


DemSet Class

[image]

A Sandcastle Documented Class Library
DemSet Class
Members See Also Send Feedback
DEMファイル情報とマップを結合し、運用するためのクラス

マップ情報とマップクラスとを一緒にする。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DemSet
Visual Basic
Public Class DemSet
Visual C++
public ref class DemSet

Inheritance Hierarchy

System..::..Object
GIS.DigitalElevationModel..::..DemSet

See Also

DemSet Members
GIS.DigitalElevationModel Namespace


DemSet Members

[image] [image]

A Sandcastle Documented Class Library
DemSet Members
DemSet Class Constructors Methods Fields Properties See Also Send Feedback

The DemSet type exposes the following members.

Constructors

 | Name | Description
Public method | DemSet | マップのインスタンスを生成しないコンストラクタ DEMデータ情報について整理し、マップを管理する準備を行います。

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | DEM数値情報をメモリに読み出します 読み込み済みの場合は無視されます。
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 保持しているDEM情報を文字列として返す (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | map | 数値標高データを格納・管理するマップ

Properties

 | Name | Description
Public property | DataInfo | DEMの情報
Public property | DemMap | 数値標高モデルを格納したマップ
Public property | Error | エラー状況 true: エラーがあります。エラーの詳細はErrorMsgをご確認ください。
Public property | ErrorMsg | エラーメッセージ 何かしらの記述があれば、エラーがあることを示します。
Public property | FileName | ファイル名
Public property | Identity | 保持しているDEM情報とマップの一致性を確認します セルフテストの一環です。 true: 問題は見られない（矛盾なし）, false: 矛盾あり、若しくは評価不能
Public property | IsLoaded | マップをすでに読み込んでいるかどうか true: ロード済み

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


DemSet Constructor

[image]

A Sandcastle Documented Class Library
DemSet Constructor
DemSet Class See Also Send Feedback
マップのインスタンスを生成しないコンストラクタ

DEMデータ情報について整理し、マップを管理する準備を行います。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DemSet(
    string fileName,
    Info info,
    string parentFileName
)
Visual Basic
Public Sub New ( _
    fileName As String, _
    info As Info, _
    parentFileName As String _
)
Visual C++
public:
DemSet(
    String^ fileName,
    Info info,
    String^ parentFileName
)

Parameters

fileName
Type: System..::..String
ファイル名
info
Type: GIS.DigitalElevationModel..::..Info
マップ情報
parentFileName
Type: System..::..String
親ファイル名

元ファイルが圧縮ファイル等であった場合に利用してください。

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


DemSet Fields

[image] [image]

A Sandcastle Documented Class Library
DemSet Fields
DemSet Class See Also Send Feedback

The DemSet type exposes the following members.

Fields

 | Name | Description
Public field | map | 数値標高データを格納・管理するマップ

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


map Field

[image]

A Sandcastle Documented Class Library
DemSet..::..map Field
DemSet Class See Also Send Feedback
数値標高データを格納・管理するマップ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map map
Visual Basic
Public map As Map
Visual C++
public:
Map^ map

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


DemSet Methods

[image] [image]

A Sandcastle Documented Class Library
DemSet Methods
DemSet Class See Also Send Feedback

The DemSet type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | DEM数値情報をメモリに読み出します 読み込み済みの場合は無視されます。
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 保持しているDEM情報を文字列として返す (Overrides Object..::..ToString()()()().)

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


Load Method

[image]

A Sandcastle Documented Class Library
DemSet..::..Load Method
DemSet Class See Also Send Feedback
DEM数値情報をメモリに読み出します

読み込み済みの場合は無視されます。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Load()
Visual Basic
Public Function Load As Boolean
Visual C++
public:
bool Load()

Return Value

読み込みに成功するとtrueを返します。

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
DemSet..::..ToString Method
DemSet Class See Also Send Feedback
保持しているDEM情報を文字列として返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

DEM情報

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


DemSet Properties

[image] [image]

A Sandcastle Documented Class Library
DemSet Properties
DemSet Class See Also Send Feedback

The DemSet type exposes the following members.

Properties

 | Name | Description
Public property | DataInfo | DEMの情報
Public property | DemMap | 数値標高モデルを格納したマップ
Public property | Error | エラー状況 true: エラーがあります。エラーの詳細はErrorMsgをご確認ください。
Public property | ErrorMsg | エラーメッセージ 何かしらの記述があれば、エラーがあることを示します。
Public property | FileName | ファイル名
Public property | Identity | 保持しているDEM情報とマップの一致性を確認します セルフテストの一環です。 true: 問題は見られない（矛盾なし）, false: 矛盾あり、若しくは評価不能
Public property | IsLoaded | マップをすでに読み込んでいるかどうか true: ロード済み

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


DataInfo Property

[image]

A Sandcastle Documented Class Library
DemSet..::..DataInfo Property
DemSet Class See Also Send Feedback
DEMの情報

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Info DataInfo { get; }
Visual Basic
Public ReadOnly Property DataInfo As Info
    Get
Visual C++
public:
property Info DataInfo {
    Info get ();
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


DemMap Property

[image]

A Sandcastle Documented Class Library
DemSet..::..DemMap Property
DemSet Class See Also Send Feedback
数値標高モデルを格納したマップ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map DemMap { get; }
Visual Basic
Public ReadOnly Property DemMap As Map
    Get
Visual C++
public:
property Map^ DemMap {
    Map^ get ();
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


Error Property

[image]

A Sandcastle Documented Class Library
DemSet..::..Error Property
DemSet Class See Also Send Feedback
エラー状況

true: エラーがあります。エラーの詳細はErrorMsgをご確認ください。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Error { get; }
Visual Basic
Public ReadOnly Property Error As Boolean
    Get
Visual C++
public:
property bool Error {
    bool get ();
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


ErrorMsg Property

[image]

A Sandcastle Documented Class Library
DemSet..::..ErrorMsg Property
DemSet Class See Also Send Feedback
エラーメッセージ

何かしらの記述があれば、エラーがあることを示します。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ErrorMsg { get; private set; }
Visual Basic
Public Property ErrorMsg As String
    Get
    Private Set
Visual C++
public:
property String^ ErrorMsg {
    String^ get ();
    private: void set (String^ value);
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


FileName Property

[image]

A Sandcastle Documented Class Library
DemSet..::..FileName Property
DemSet Class See Also Send Feedback
ファイル名

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FileName { get; private set; }
Visual Basic
Public Property FileName As String
    Get
    Private Set
Visual C++
public:
property String^ FileName {
    String^ get ();
    private: void set (String^ value);
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


Identity Property

[image]

A Sandcastle Documented Class Library
DemSet..::..Identity Property
DemSet Class See Also Send Feedback
保持しているDEM情報とマップの一致性を確認します

セルフテストの一環です。

true: 問題は見られない（矛盾なし）, false: 矛盾あり、若しくは評価不能

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Identity { get; }
Visual Basic
Public ReadOnly Property Identity As Boolean
    Get
Visual C++
public:
property bool Identity {
    bool get ();
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


IsLoaded Property

[image]

A Sandcastle Documented Class Library
DemSet..::..IsLoaded Property
DemSet Class See Also Send Feedback
マップをすでに読み込んでいるかどうか

true: ロード済み

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsLoaded { get; }
Visual Basic
Public ReadOnly Property IsLoaded As Boolean
    Get
Visual C++
public:
property bool IsLoaded {
    bool get ();
}

See Also

DemSet Class
GIS.DigitalElevationModel Namespace


Info Structure

[image]

A Sandcastle Documented Class Library
Info Structure
Members See Also Send Feedback
DEMファイルの属性を記した構造体

ファイルのさまざまな属性を提供します。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct Info
Visual Basic
Public Structure Info
Visual C++
public value class Info

See Also

Info Members
GIS.DigitalElevationModel Namespace


Info Members

[image] [image]

A Sandcastle Documented Class Library
Info Members
Info Structure Constructors Methods Properties See Also Send Feedback

The Info type exposes the following members.

Constructors

 | Name | Description
Public method | Info | DEMファイルを管理するための構造体のコンストラクタ

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 文字列にして返す フォーマットは、「ファイル名」，「地点名」，「ID番号」，「マップサイズ」，「メッシュサイズ」，「コーナーの座標」，「マップ情報の読み込み状況」 (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Available | 利用可能かどうかを返す true: 利用可能です。 falseだとファイル自体を利用できないことを示します。
Public property | Field | 領域
Public property | ID | ID番号
Public property | MapModel | マップのモデル形式
Public property | MapName | マップ名
Public property | Size | マップサイズ（東西南北方向のメッシュ数）

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Info Constructor

[image]

A Sandcastle Documented Class Library
Info Constructor
Info Structure See Also Send Feedback
DEMファイルを管理するための構造体のコンストラクタ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Info(
    string mapName,
    int id,
    Pos size,
    RectangleField field,
    Model model
)
Visual Basic
Public Sub New ( _
    mapName As String, _
    id As Integer, _
    size As Pos, _
    field As RectangleField, _
    model As Model _
)
Visual C++
public:
Info(
    String^ mapName,
    int id,
    Pos size,
    RectangleField^ field,
    Model model
)

Parameters

mapName
Type: System..::..String
地図名

例：熊本

id
Type: System..::..Int32
ID番号
size
Type: GIS.MapBase..::..Pos
マップサイズ
field
Type: RectangleField
コーナーの座標
model
Type: GIS.DigitalElevationModel..::..Model
DEMモデル名

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Info Methods

[image] [image]

A Sandcastle Documented Class Library
Info Methods
Info Structure See Also Send Feedback

The Info type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 文字列にして返す フォーマットは、「ファイル名」，「地点名」，「ID番号」，「マップサイズ」，「メッシュサイズ」，「コーナーの座標」，「マップ情報の読み込み状況」 (Overrides ValueType..::..ToString()()()().)

See Also

Info Structure
GIS.DigitalElevationModel Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
Info..::..ToString Method
Info Structure See Also Send Feedback
文字列にして返す

フォーマットは、「ファイル名」，「地点名」，「ID番号」，「マップサイズ」，「メッシュサイズ」，「コーナーの座標」，「マップ情報の読み込み状況」

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

文字列化したDEMinfo

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Info Properties

[image] [image]

A Sandcastle Documented Class Library
Info Properties
Info Structure See Also Send Feedback

The Info type exposes the following members.

Properties

 | Name | Description
Public property | Available | 利用可能かどうかを返す true: 利用可能です。 falseだとファイル自体を利用できないことを示します。
Public property | Field | 領域
Public property | ID | ID番号
Public property | MapModel | マップのモデル形式
Public property | MapName | マップ名
Public property | Size | マップサイズ（東西南北方向のメッシュ数）

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Available Property

[image]

A Sandcastle Documented Class Library
Info..::..Available Property
Info Structure See Also Send Feedback
利用可能かどうかを返す

true: 利用可能です。 falseだとファイル自体を利用できないことを示します。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Available { get; }
Visual Basic
Public ReadOnly Property Available As Boolean
    Get
Visual C++
public:
property bool Available {
    bool get ();
}

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Field Property

[image]

A Sandcastle Documented Class Library
Info..::..Field Property
Info Structure See Also Send Feedback
領域

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RectangleField Field { get; private set; }
Visual Basic
Public Property Field As RectangleField
    Get
    Private Set
Visual C++
public:
property RectangleField^ Field {
    RectangleField^ get ();
    private: void set (RectangleField^ value);
}

See Also

Info Structure
GIS.DigitalElevationModel Namespace


ID Property

[image]

A Sandcastle Documented Class Library
Info..::..ID Property
Info Structure See Also Send Feedback
ID番号

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ID { get; private set; }
Visual Basic
Public Property ID As Integer
    Get
    Private Set
Visual C++
public:
property int ID {
    int get ();
    private: void set (int value);
}

See Also

Info Structure
GIS.DigitalElevationModel Namespace


MapModel Property

[image]

A Sandcastle Documented Class Library
Info..::..MapModel Property
Info Structure See Also Send Feedback
マップのモデル形式

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Model MapModel { get; private set; }
Visual Basic
Public Property MapModel As Model
    Get
    Private Set
Visual C++
public:
property Model MapModel {
    Model get ();
    private: void set (Model value);
}

See Also

Info Structure
GIS.DigitalElevationModel Namespace


MapName Property

[image]

A Sandcastle Documented Class Library
Info..::..MapName Property
Info Structure See Also Send Feedback
マップ名

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MapName { get; private set; }
Visual Basic
Public Property MapName As String
    Get
    Private Set
Visual C++
public:
property String^ MapName {
    String^ get ();
    private: void set (String^ value);
}

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Size Property

[image]

A Sandcastle Documented Class Library
Info..::..Size Property
Info Structure See Also Send Feedback
マップサイズ（東西南北方向のメッシュ数）

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos Size { get; private set; }
Visual Basic
Public Property Size As Pos
    Get
    Private Set
Visual C++
public:
property Pos Size {
    Pos get ();
    private: void set (Pos value);
}

See Also

Info Structure
GIS.DigitalElevationModel Namespace


Manager Class

[image]

A Sandcastle Documented Class Library
Manager Class
Members See Also Send Feedback
DEMマネージャー

DEMのファイル群を同じモデルごとに管理するためのクラスです。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Manager : IComparable
Visual Basic
Public Class Manager _
    Implements IComparable
Visual C++
public ref class Manager : IComparable

Inheritance Hierarchy

System..::..Object
GIS.DigitalElevationModel..::..Manager

See Also

Manager Members
GIS.DigitalElevationModel Namespace


Manager Members

[image] [image]

A Sandcastle Documented Class Library
Manager Members
Manager Class Constructors Methods Properties See Also Send Feedback

The Manager type exposes the following members.

Constructors

 | Name | Description
Public method | Manager | コンストラクタ

Methods

 | Name | Description
Public method | Add(DemSet) | マップをセットする 二重登録は致しません。 最初に登録されたマップの情報を用いてManagerオブジェクトを定義します。 2つ目以降のマップは、同系統とみなされなかった場合に登録を拒否されます。
Public method | Add(List<(Of <<'(DemSet>)>>)) | Listを使ってマップを追加します 引数で渡したリストは加工され、本オブジェクトに吸収されなかったものだけが残されるようにしています。 この副作用にはご注意ください。
Public method | CheckAvailability | 指定座標の値を返すことができるか返す
Public method | CompareTo | 自分自身がobjより小さいときはマイナスの数、大きいときはプラスの数、同じときは0を返す MeshSizeの面積を用いて比較を行います。 ListでのSortを意識しています。
Public method | CreateMap | 指定領域でマップを作成します 指定領域を含むマップを結合することでマップを生成します。 該当データが存在しない領域はfloat.NaNで埋めます。
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCoverRate | 指定領域のカバー率を返す 指定された領域全てのDEMマップを保持している場合は1.0を返します。
Public method | GetHashCode | ハッシュ値を返す (Overrides Object..::..GetHashCode()()()().)
Public method | GetHeight | 指定された緯度経度の標高を返す 該当なしの場合は、float.NaNを返します
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | 指定領域のDEMを可能ならばロードする
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 保持している全DEM情報を文字列として返す (Overrides Object..::..ToString()()()().)
Public method | ToStringAsKml | 保持している全DEMデータ情報をKML形式のテキストデータで返す ファイルへ保存する際はUTF-8で保存してください。

Properties

 | Name | Description
Public property | Count | 保持しているマップ数
Public property | MapSize | マップの大きさ 緯度経度[deg]で表した一つのマップの大きさ
Public property | MeshSize | メッシュの大きさ 緯度経度[deg]で表した一つのメッシュの大きさ
Public property | Ready | 利用可能であるか返す true: 利用可能

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Manager Constructor

[image]

A Sandcastle Documented Class Library
Manager Constructor
Manager Class See Also Send Feedback
コンストラクタ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Manager()
Visual Basic
Public Sub New
Visual C++
public:
Manager()

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Manager Methods

[image] [image]

A Sandcastle Documented Class Library
Manager Methods
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Methods

 | Name | Description
Public method | Add(DemSet) | マップをセットする 二重登録は致しません。 最初に登録されたマップの情報を用いてManagerオブジェクトを定義します。 2つ目以降のマップは、同系統とみなされなかった場合に登録を拒否されます。
Public method | Add(List<(Of <<'(DemSet>)>>)) | Listを使ってマップを追加します 引数で渡したリストは加工され、本オブジェクトに吸収されなかったものだけが残されるようにしています。 この副作用にはご注意ください。
Public method | CheckAvailability | 指定座標の値を返すことができるか返す
Public method | CompareTo | 自分自身がobjより小さいときはマイナスの数、大きいときはプラスの数、同じときは0を返す MeshSizeの面積を用いて比較を行います。 ListでのSortを意識しています。
Public method | CreateMap | 指定領域でマップを作成します 指定領域を含むマップを結合することでマップを生成します。 該当データが存在しない領域はfloat.NaNで埋めます。
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCoverRate | 指定領域のカバー率を返す 指定された領域全てのDEMマップを保持している場合は1.0を返します。
Public method | GetHashCode | ハッシュ値を返す (Overrides Object..::..GetHashCode()()()().)
Public method | GetHeight | 指定された緯度経度の標高を返す 該当なしの場合は、float.NaNを返します
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | 指定領域のDEMを可能ならばロードする
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 保持している全DEM情報を文字列として返す (Overrides Object..::..ToString()()()().)
Public method | ToStringAsKml | 保持している全DEMデータ情報をKML形式のテキストデータで返す ファイルへ保存する際はUTF-8で保存してください。

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Add Method

[image] [image]

A Sandcastle Documented Class Library
Manager..::..Add Method
Manager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Add(DemSet) | マップをセットする 二重登録は致しません。 最初に登録されたマップの情報を用いてManagerオブジェクトを定義します。 2つ目以降のマップは、同系統とみなされなかった場合に登録を拒否されます。
Public method | Add(List<(Of <<'(DemSet>)>>)) | Listを使ってマップを追加します 引数で渡したリストは加工され、本オブジェクトに吸収されなかったものだけが残されるようにしています。 この副作用にはご注意ください。

See Also

Manager Class
Manager Members
GIS.DigitalElevationModel Namespace


Add Method (DemSet)

[image]

A Sandcastle Documented Class Library
Manager..::..Add Method (DemSet)
Manager Class See Also Send Feedback
マップをセットする

二重登録は致しません。 最初に登録されたマップの情報を用いてManagerオブジェクトを定義します。 2つ目以降のマップは、同系統とみなされなかった場合に登録を拒否されます。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Add(
    DemSet map
)
Visual Basic
Public Function Add ( _
    map As DemSet _
) As Boolean
Visual C++
public:
bool Add(
    DemSet^ map
)

Parameters

map
Type: GIS.DigitalElevationModel..::..DemSet
マップオブジェクト

Return Value

セットに成功するとtureを返す

See Also

Manager Class
Add Overload
GIS.DigitalElevationModel Namespace


Add Method (List(DemSet))

[image]

A Sandcastle Documented Class Library
Manager..::..Add Method (List<(Of <(<'DemSet>)>)>)
Manager Class See Also Send Feedback
Listを使ってマップを追加します

引数で渡したリストは加工され、本オブジェクトに吸収されなかったものだけが残されるようにしています。 この副作用にはご注意ください。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<DemSet> Add(
    List<DemSet> maps
)
Visual Basic
Public Function Add ( _
    maps As List(Of DemSet) _
) As List(Of DemSet)
Visual C++
public:
List<DemSet^>^ Add(
    List<DemSet^>^ maps
)

Parameters

maps
Type: System.Collections.Generic..::..List <(Of <(<' DemSet >)>)>
追加したいマップ

Return Value

本オブジェクトに追加されなかったマップをListを使って返します。

See Also

Manager Class
Add Overload
GIS.DigitalElevationModel Namespace


CheckAvailability Method

[image]

A Sandcastle Documented Class Library
Manager..::..CheckAvailability Method
Manager Class See Also Send Feedback
指定座標の値を返すことができるか返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckAvailability(
    BLH pos
)
Visual Basic
Public Function CheckAvailability ( _
    pos As BLH _
) As Boolean
Visual C++
public:
bool CheckAvailability(
    BLH pos
)

Parameters

pos
Type: BLH
指定座標

Return Value

true: 値を返すことは可能

See Also

Manager Class
GIS.DigitalElevationModel Namespace


CompareTo Method

[image]

A Sandcastle Documented Class Library
Manager..::..CompareTo Method
Manager Class See Also Send Feedback
自分自身がobjより小さいときはマイナスの数、大きいときはプラスの数、同じときは0を返す

MeshSizeの面積を用いて比較を行います。

ListでのSortを意識しています。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
比較したいManagerクラスオブジェクト

Return Value

大きいときはプラスの数、同じときは0

Implements

IComparable..::..CompareTo(Object)

See Also

Manager Class
GIS.DigitalElevationModel Namespace


CreateMap Method

[image]

A Sandcastle Documented Class Library
Manager..::..CreateMap Method
Manager Class See Also Send Feedback
指定領域でマップを作成します

指定領域を含むマップを結合することでマップを生成します。

該当データが存在しない領域はfloat.NaNで埋めます。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map CreateMap(
    RectangleField field
)
Visual Basic
Public Function CreateMap ( _
    field As RectangleField _
) As Map
Visual C++
public:
Map^ CreateMap(
    RectangleField^ field
)

Parameters

field
Type: RectangleField
指定領域

Return Value

Mapオブジェクト

See Also

Manager Class
GIS.DigitalElevationModel Namespace


GetCoverRate Method

[image]

A Sandcastle Documented Class Library
Manager..::..GetCoverRate Method
Manager Class See Also Send Feedback
指定領域のカバー率を返す

指定された領域全てのDEMマップを保持している場合は1.0を返します。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetCoverRate(
    RectangleField field
)
Visual Basic
Public Function GetCoverRate ( _
    field As RectangleField _
) As Double
Visual C++
public:
double GetCoverRate(
    RectangleField^ field
)

Parameters

field
Type: RectangleField
指定領域

Return Value

カバー率

See Also

Manager Class
GIS.DigitalElevationModel Namespace


GetHashCode Method

[image]

A Sandcastle Documented Class Library
Manager..::..GetHashCode Method
Manager Class See Also Send Feedback
ハッシュ値を返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

ハッシュ値

See Also

Manager Class
GIS.DigitalElevationModel Namespace


GetHeight Method

[image]

A Sandcastle Documented Class Library
Manager..::..GetHeight Method
Manager Class See Also Send Feedback
指定された緯度経度の標高を返す

該当なしの場合は、float.NaNを返します

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float GetHeight(
    BLH pos
)
Visual Basic
Public Function GetHeight ( _
    pos As BLH _
) As Single
Visual C++
public:
float GetHeight(
    BLH pos
)

Parameters

pos
Type: BLH
指定座標

Return Value

指定された座標のマップ情報を返す

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Load Method

[image]

A Sandcastle Documented Class Library
Manager..::..Load Method
Manager Class See Also Send Feedback
指定領域のDEMを可能ならばロードする

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Load(
    RectangleField field
)
Visual Basic
Public Sub Load ( _
    field As RectangleField _
)
Visual C++
public:
void Load(
    RectangleField^ field
)

Parameters

field
Type: RectangleField
指定領域

See Also

Manager Class
GIS.DigitalElevationModel Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
Manager..::..ToString Method
Manager Class See Also Send Feedback
保持している全DEM情報を文字列として返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

DEM情報

See Also

Manager Class
GIS.DigitalElevationModel Namespace


ToStringAsKml Method

[image]

A Sandcastle Documented Class Library
Manager..::..ToStringAsKml Method
Manager Class See Also Send Feedback
保持している全DEMデータ情報をKML形式のテキストデータで返す

ファイルへ保存する際はUTF-8で保存してください。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToStringAsKml(
    Color color
)
Visual Basic
Public Function ToStringAsKml ( _
    color As Color _
) As String
Visual C++
public:
String^ ToStringAsKml(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
色情報

Return Value

テキスト形式のKMLポリゴン情報

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Manager Properties

[image] [image]

A Sandcastle Documented Class Library
Manager Properties
Manager Class See Also Send Feedback

The Manager type exposes the following members.

Properties

 | Name | Description
Public property | Count | 保持しているマップ数
Public property | MapSize | マップの大きさ 緯度経度[deg]で表した一つのマップの大きさ
Public property | MeshSize | メッシュの大きさ 緯度経度[deg]で表した一つのメッシュの大きさ
Public property | Ready | 利用可能であるか返す true: 利用可能

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Count Property

[image]

A Sandcastle Documented Class Library
Manager..::..Count Property
Manager Class See Also Send Feedback
保持しているマップ数

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Count { get; }
Visual Basic
Public ReadOnly Property Count As Integer
    Get
Visual C++
public:
property int Count {
    int get ();
}

See Also

Manager Class
GIS.DigitalElevationModel Namespace


MapSize Property

[image]

A Sandcastle Documented Class Library
Manager..::..MapSize Property
Manager Class See Also Send Feedback
マップの大きさ

緯度経度[deg]で表した一つのマップの大きさ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH MapSize { get; }
Visual Basic
Public ReadOnly Property MapSize As BLH
    Get
Visual C++
public:
property BLH MapSize {
    BLH get ();
}

See Also

Manager Class
GIS.DigitalElevationModel Namespace


MeshSize Property

[image]

A Sandcastle Documented Class Library
Manager..::..MeshSize Property
Manager Class See Also Send Feedback
メッシュの大きさ

緯度経度[deg]で表した一つのメッシュの大きさ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH MeshSize { get; }
Visual Basic
Public ReadOnly Property MeshSize As BLH
    Get
Visual C++
public:
property BLH MeshSize {
    BLH get ();
}

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Ready Property

[image]

A Sandcastle Documented Class Library
Manager..::..Ready Property
Manager Class See Also Send Feedback
利用可能であるか返す

true: 利用可能

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Ready { get; }
Visual Basic
Public ReadOnly Property Ready As Boolean
    Get
Visual C++
public:
property bool Ready {
    bool get ();
}

See Also

Manager Class
GIS.DigitalElevationModel Namespace


Model Enumeration

[image]

A Sandcastle Documented Class Library
Model Enumeration
See Also Send Feedback
DEMマップのモデル（種別）を表す列挙体

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Model
Visual Basic
Public Enumeration Model
Visual C++
public enum class Model

Members

Member name | Value | Description
Unknown | 0 | 不明なモデル
JPGIS2x_GML | 1 | 日本の国土地理院が整備しているDEMのGML形式
JPGIS2x | 2 | 日本の国土地理院が整備しているDEM

See Also

GIS.DigitalElevationModel Namespace


TerrainInformation Class

[image]

A Sandcastle Documented Class Library
TerrainInformation Class
Members See Also Send Feedback
地形情報を格納するためのクラス

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TerrainInformation
Visual Basic
Public Class TerrainInformation
Visual C++
public ref class TerrainInformation

Remarks

唯の高度情報ではなく、DEMと連動した高度な地形情報を扱うためのクラスとして整備する予定 開空度などを計算できるようにしたら面白いかもね。 ついでに、継承を使ってGPS用に拡張したって面白い。

Inheritance Hierarchy

System..::..Object
GIS.DigitalElevationModel..::..TerrainInformation

See Also

TerrainInformation Members
GIS.DigitalElevationModel Namespace


TerrainInformation Members

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation Members
TerrainInformation Class Constructors Methods See Also Send Feedback

The TerrainInformation type exposes the following members.

Constructors

 | Name | Description
Public method | TerrainInformation | 地形情報クラスのコンストラクタ Mapクラスによる初期化を行います。

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetGeoFeature | 地形情報を返す
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLevelOfSlope | 傾斜の度合いを返す
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TerrainInformation Class
GIS.DigitalElevationModel Namespace


TerrainInformation Constructor

[image]

A Sandcastle Documented Class Library
TerrainInformation Constructor
TerrainInformation Class See Also Send Feedback
地形情報クラスのコンストラクタ

Mapクラスによる初期化を行います。

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TerrainInformation(
    Map map
)
Visual Basic
Public Sub New ( _
    map As Map _
)
Visual C++
public:
TerrainInformation(
    Map^ map
)

Parameters

map
Type: GIS.MapBase..::..Map
DEMマップオブジェクト

Exceptions

Exception | Condition
System..::..SystemException | インスタンスを確保済みのMapをセットしなかった場合にスロー

See Also

TerrainInformation Class
GIS.DigitalElevationModel Namespace


TerrainInformation Methods

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation Methods
TerrainInformation Class See Also Send Feedback

The TerrainInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetGeoFeature | 地形情報を返す
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLevelOfSlope | 傾斜の度合いを返す
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TerrainInformation Class
GIS.DigitalElevationModel Namespace


GetGeoFeature Method

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..GetGeoFeature Method
TerrainInformation Class See Also Send Feedback
地形情報を返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TerrainInformation..::..Feature GetGeoFeature(
    Pos _pos
)
Visual Basic
Public Function GetGeoFeature ( _
    _pos As Pos _
) As TerrainInformation..::..Feature
Visual C++
public:
TerrainInformation..::..Feature GetGeoFeature(
    Pos _pos
)

Parameters

_pos
Type: GIS.MapBase..::..Pos
マップのアドレス

Return Value

特徴情報

Exceptions

Exception | Condition
System..::..SystemException | マップの範囲外を指定した場合にスロー

See Also

TerrainInformation Class
GIS.DigitalElevationModel Namespace


GetLevelOfSlope Method

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..GetLevelOfSlope Method
TerrainInformation Class See Also Send Feedback
傾斜の度合いを返す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static TerrainInformation..::..Feature..::..GeographicalFeature GetLevelOfSlope(
    double rateOfSlope
)
Visual Basic
Public Shared Function GetLevelOfSlope ( _
    rateOfSlope As Double _
) As TerrainInformation..::..Feature..::..GeographicalFeature
Visual C++
public:
static TerrainInformation..::..Feature..::..GeographicalFeature GetLevelOfSlope(
    double rateOfSlope
)

Parameters

rateOfSlope
Type: System..::..Double
傾斜の度合い（単位長あたりの高度差[m]）

Return Value

傾斜の度合いを列挙体で表現したもの

See Also

TerrainInformation Class
GIS.DigitalElevationModel Namespace


TerrainInformation.Feature Structure

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature Structure
TerrainInformation Class Members See Also Send Feedback
地形の特徴をまとめた構造体

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct Feature
Visual Basic
Public Structure Feature
Visual C++
public value class Feature

See Also

TerrainInformation..::..Feature Members
GIS.DigitalElevationModel Namespace


TerrainInformation.Feature Members

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature Members
TerrainInformation..::..Feature Structure Constructors Methods Properties See Also Send Feedback

地形情報を格納するためのクラス

The TerrainInformation..::..Feature type exposes the following members.

Constructors

 | Name | Description
Public method | TerrainInformation..::..Feature | 地形情報をまとめたクラスのコンストラクタ

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | GeoFeature | 周囲地形（ex. 急峻(Precipitous)）
Public property | Height | 高度[m]
Public property | MaxHeight | 周囲の地形から勘案した最高標高[m]
Public property | MinHeight | 周囲の地形から勘案した最低標高[m]

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


TerrainInformation.Feature Constructor

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature Constructor
TerrainInformation..::..Feature Structure See Also Send Feedback
地形情報をまとめたクラスのコンストラクタ

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Feature(
    double _myHeight,
    double _maxHeight,
    double _minHeight,
    TerrainInformation..::..Feature..::..GeographicalFeature _geoFeature
)
Visual Basic
Public Sub New ( _
    _myHeight As Double, _
    _maxHeight As Double, _
    _minHeight As Double, _
    _geoFeature As TerrainInformation..::..Feature..::..GeographicalFeature _
)
Visual C++
public:
Feature(
    double _myHeight,
    double _maxHeight,
    double _minHeight,
    TerrainInformation..::..Feature..::..GeographicalFeature _geoFeature
)

Parameters

_myHeight
Type: System..::..Double
高度[m]
_maxHeight
Type: System..::..Double
周囲の地形から勘案した最高標高[m]
_minHeight
Type: System..::..Double
周囲の地形から勘案した最低標高[m]
_geoFeature
Type: GIS.DigitalElevationModel..::..TerrainInformation..::..Feature..::..GeographicalFeature
周囲地形（ex. 急峻(Precipitous)）

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


TerrainInformation.Feature Methods

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature Methods
TerrainInformation..::..Feature Structure See Also Send Feedback

The TerrainInformation..::..Feature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


TerrainInformation.Feature Properties

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature Properties
TerrainInformation..::..Feature Structure See Also Send Feedback

The TerrainInformation..::..Feature type exposes the following members.

Properties

 | Name | Description
Public property | GeoFeature | 周囲地形（ex. 急峻(Precipitous)）
Public property | Height | 高度[m]
Public property | MaxHeight | 周囲の地形から勘案した最高標高[m]
Public property | MinHeight | 周囲の地形から勘案した最低標高[m]

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


GeoFeature Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature..::..GeoFeature Property
TerrainInformation..::..Feature Structure See Also Send Feedback
周囲地形（ex. 急峻(Precipitous)）

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TerrainInformation..::..Feature..::..GeographicalFeature GeoFeature { get; }
Visual Basic
Public ReadOnly Property GeoFeature As TerrainInformation..::..Feature..::..GeographicalFeature
    Get
Visual C++
public:
property TerrainInformation..::..Feature..::..GeographicalFeature GeoFeature {
    TerrainInformation..::..Feature..::..GeographicalFeature get ();
}

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


Height Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature..::..Height Property
TerrainInformation..::..Feature Structure See Also Send Feedback
高度[m]

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


MaxHeight Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature..::..MaxHeight Property
TerrainInformation..::..Feature Structure See Also Send Feedback
周囲の地形から勘案した最高標高[m]

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxHeight { get; }
Visual Basic
Public ReadOnly Property MaxHeight As Double
    Get
Visual C++
public:
property double MaxHeight {
    double get ();
}

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


MinHeight Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature..::..MinHeight Property
TerrainInformation..::..Feature Structure See Also Send Feedback
周囲の地形から勘案した最低標高[m]

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinHeight { get; }
Visual Basic
Public ReadOnly Property MinHeight As Double
    Get
Visual C++
public:
property double MinHeight {
    double get ();
}

See Also

TerrainInformation..::..Feature Structure
GIS.DigitalElevationModel Namespace


TerrainInformation.Feature.GeographicalFeature Enumeration

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Feature..::..GeographicalFeature Enumeration
TerrainInformation..::..Feature Structure See Also Send Feedback
地形の特徴を表す

Namespace: GIS.DigitalElevationModel
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GeographicalFeature
Visual Basic
Public Enumeration GeographicalFeature
Visual C++
public enum class GeographicalFeature

Members

Member name | Value | Description
Cliff | 0 | 崖
Precipitous | 1 | 急峻
Gentleness | 2 | なだらか
Flat | 3 | 平坦
NA | 4 | 不明

See Also

GIS.DigitalElevationModel Namespace


GIS.DigitalElevationModel.Reader Namespace

[image]

A Sandcastle Documented Class Library
GIS.DigitalElevationModel.Reader Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.DigitalElevationModel.Reader"]

Classes

 | Class | Description
Public class | JpgisGmlReader | JPGIS(GML)形式のDEMを読み出す静的クラス
Public class | Reader | DEMファイルを読み込むクラス 指定したファイルやフォルダを走査して、モデル情報を返します。 特にオブジェクトを作る必要もなさそうなのでスタティッククラスとしています。

Enumerations

 | Enumeration | Description
Public enumeration | ReadMode | DEMファイルの読み込みモードを規定する列挙体


JpgisGmlReader Class

[image]

A Sandcastle Documented Class Library
JpgisGmlReader Class
Members See Also Send Feedback
JPGIS(GML)形式のDEMを読み出す静的クラス

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class JpgisGmlReader
Visual Basic
Public Class JpgisGmlReader
Visual C++
public ref class JpgisGmlReader

Inheritance Hierarchy

System..::..Object
GIS.DigitalElevationModel.Reader..::..JpgisGmlReader

See Also

JpgisGmlReader Members
GIS.DigitalElevationModel.Reader Namespace


JpgisGmlReader Members

[image] [image]

A Sandcastle Documented Class Library
JpgisGmlReader Members
JpgisGmlReader Class Constructors Methods See Also Send Feedback

The JpgisGmlReader type exposes the following members.

Constructors

 | Name | Description
Public method | JpgisGmlReader | 静的コンストラクタ

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | 引数で渡されたテキストを走査してDEM情報クラスオブジェクトを返す フォーマット不一致の場合はnew Info()を返します。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues(String) | 引数で渡されたテキストを解析し、DEM値を読み出して返す
Public method | GetValues(String, Pos) | マップのサイズ情報の支援を受けた上で、指定されたテキストよりDEM値を読み出して返す
Public method | Match | GMLフォーマットに一致するかチェックし、その結果を返す 2012/5/22 未実装 常にtrueを返すので役に立っていません。
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JpgisGmlReader Class
GIS.DigitalElevationModel.Reader Namespace


JpgisGmlReader Constructor

[image]

A Sandcastle Documented Class Library
JpgisGmlReader Constructor
JpgisGmlReader Class See Also Send Feedback
静的コンストラクタ

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public JpgisGmlReader()
Visual Basic
Public Sub New
Visual C++
public:
JpgisGmlReader()

See Also

JpgisGmlReader Class
GIS.DigitalElevationModel.Reader Namespace


JpgisGmlReader Methods

[image] [image]

A Sandcastle Documented Class Library
JpgisGmlReader Methods
JpgisGmlReader Class See Also Send Feedback

The JpgisGmlReader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHeader | 引数で渡されたテキストを走査してDEM情報クラスオブジェクトを返す フォーマット不一致の場合はnew Info()を返します。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues(String) | 引数で渡されたテキストを解析し、DEM値を読み出して返す
Public method | GetValues(String, Pos) | マップのサイズ情報の支援を受けた上で、指定されたテキストよりDEM値を読み出して返す
Public method | Match | GMLフォーマットに一致するかチェックし、その結果を返す 2012/5/22 未実装 常にtrueを返すので役に立っていません。
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

JpgisGmlReader Class
GIS.DigitalElevationModel.Reader Namespace


GetHeader Method

[image]

A Sandcastle Documented Class Library
JpgisGmlReader..::..GetHeader Method
JpgisGmlReader Class See Also Send Feedback
引数で渡されたテキストを走査してDEM情報クラスオブジェクトを返す

フォーマット不一致の場合はnew Info()を返します。

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Info GetHeader(
    string fileName
)
Visual Basic
Public Function GetHeader ( _
    fileName As String _
) As Info
Visual C++
public:
Info GetHeader(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
解析対象のファイルへのパス

Return Value

正常に読み出せた場合はDEM情報クラスオブジェクトを返す

See Also

JpgisGmlReader Class
GIS.DigitalElevationModel.Reader Namespace


GetValues Method

[image] [image]

A Sandcastle Documented Class Library
JpgisGmlReader..::..GetValues Method
JpgisGmlReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValues(String) | 引数で渡されたテキストを解析し、DEM値を読み出して返す
Public method | GetValues(String, Pos) | マップのサイズ情報の支援を受けた上で、指定されたテキストよりDEM値を読み出して返す

See Also

JpgisGmlReader Class
JpgisGmlReader Members
GIS.DigitalElevationModel.Reader Namespace


GetValues Method (String)

[image]

A Sandcastle Documented Class Library
JpgisGmlReader..::..GetValues Method (String)
JpgisGmlReader Class See Also Send Feedback
引数で渡されたテキストを解析し、DEM値を読み出して返す

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[] GetValues(
    string fileName
)
Visual Basic
Public Function GetValues ( _
    fileName As String _
) As Single()
Visual C++
public:
array<float>^ GetValues(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
解析したいファイルのパス

Return Value

読み出されたDEM値（float型の一次元配列）

See Also

JpgisGmlReader Class
GetValues Overload
GIS.DigitalElevationModel.Reader Namespace


GetValues Method (String, Pos)

[image]

A Sandcastle Documented Class Library
JpgisGmlReader..::..GetValues Method (String, Pos)
JpgisGmlReader Class See Also Send Feedback
マップのサイズ情報の支援を受けた上で、指定されたテキストよりDEM値を読み出して返す

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[,] GetValues(
    string fileName,
    Pos size
)
Visual Basic
Public Function GetValues ( _
    fileName As String, _
    size As Pos _
) As Single(,)
Visual C++
public:
array<float,2>^ GetValues(
    String^ fileName,
    Pos size
)

Parameters

fileName
Type: System..::..String
解析対象ファイルのパス
size
Type: GIS.MapBase..::..Pos
マップサイズ

Return Value

読み出されたDEM値（float型の2次元配列）

読み出しに失敗するとnullを返します。

See Also

JpgisGmlReader Class
GetValues Overload
GIS.DigitalElevationModel.Reader Namespace


Match Method

[image]

A Sandcastle Documented Class Library
JpgisGmlReader..::..Match Method
JpgisGmlReader Class See Also Send Feedback
GMLフォーマットに一致するかチェックし、その結果を返す

2012/5/22　未実装　常にtrueを返すので役に立っていません。

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Match(
    ref string txt
)
Visual Basic
Public Function Match ( _
    ByRef txt As String _
) As Boolean
Visual C++
public:
bool Match(
    String^% txt
)

Parameters

txt
Type: System..::..String %
検査したいテキスト

Return Value

true: マッチ

See Also

JpgisGmlReader Class
GIS.DigitalElevationModel.Reader Namespace


Reader Class

[image]

A Sandcastle Documented Class Library
Reader Class
Members See Also Send Feedback
DEMファイルを読み込むクラス

指定したファイルやフォルダを走査して、モデル情報を返します。

特にオブジェクトを作る必要もなさそうなのでスタティッククラスとしています。

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Reader
Visual Basic
Public Class Reader
Visual C++
public ref class Reader

Inheritance Hierarchy

System..::..Object
GIS.DigitalElevationModel.Reader..::..Reader

See Also

Reader Members
GIS.DigitalElevationModel.Reader Namespace


Reader Members

[image] [image]

A Sandcastle Documented Class Library
Reader Members
Reader Class Constructors Methods See Also Send Feedback

The Reader type exposes the following members.

Constructors

 | Name | Description
Public method | Reader | 静的コンストラクタ

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadHeader | ファイルを読み込み、マップ情報を返す
Public method | ReadMap | 引数のマップ情報を利用してマップを読み込む
Public method | ScanDir | 指定されたフォルダを走査して、含まれるファイル情報を取得する
Public method | ScanDirWithDialog | フォルダの指定にダイアログを用いて、DEMを読み込む
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


Reader Constructor

[image]

A Sandcastle Documented Class Library
Reader Constructor
Reader Class See Also Send Feedback
静的コンストラクタ

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Reader()
Visual Basic
Public Sub New
Visual C++
public:
Reader()

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


Reader Methods

[image] [image]

A Sandcastle Documented Class Library
Reader Methods
Reader Class See Also Send Feedback

The Reader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReadHeader | ファイルを読み込み、マップ情報を返す
Public method | ReadMap | 引数のマップ情報を利用してマップを読み込む
Public method | ScanDir | 指定されたフォルダを走査して、含まれるファイル情報を取得する
Public method | ScanDirWithDialog | フォルダの指定にダイアログを用いて、DEMを読み込む
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


ReadHeader Method

[image]

A Sandcastle Documented Class Library
Reader..::..ReadHeader Method
Reader Class See Also Send Feedback
ファイルを読み込み、マップ情報を返す

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<DemSet> ReadHeader(
    string[] fileNames
)
Visual Basic
Public Function ReadHeader ( _
    fileNames As String() _
) As List(Of DemSet)
Visual C++
public:
List<DemSet^>^ ReadHeader(
    array<String^>^ fileNames
)

Parameters

fileNames
Type: array< System..::..String >[]()[][]
ファイル名

Return Value

マップ情報

圧縮ファイルの場合、一つのファイルに多数のマップが格納されている場合があるのでListで返します。

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


ReadMap Method

[image]

A Sandcastle Documented Class Library
Reader..::..ReadMap Method
Reader Class See Also Send Feedback
引数のマップ情報を利用してマップを読み込む

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map ReadMap(
    string fileName,
    Info info
)
Visual Basic
Public Function ReadMap ( _
    fileName As String, _
    info As Info _
) As Map
Visual C++
public:
Map^ ReadMap(
    String^ fileName,
    Info info
)

Parameters

fileName
Type: System..::..String
ファイル名
info
Type: GIS.DigitalElevationModel..::..Info
ファイルに含まれているDEMの情報

Return Value

マップのインスタンス

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


ScanDir Method

[image]

A Sandcastle Documented Class Library
Reader..::..ScanDir Method
Reader Class See Also Send Feedback
指定されたフォルダを走査して、含まれるファイル情報を取得する

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<DemSet> ScanDir(
    string dirName,
    ReadMode mode
)
Visual Basic
Public Function ScanDir ( _
    dirName As String, _
    mode As ReadMode _
) As List(Of DemSet)
Visual C++
public:
List<DemSet^>^ ScanDir(
    String^ dirName,
    ReadMode mode
)

Parameters

dirName
Type: System..::..String
フォルダ名
mode
Type: GIS.DigitalElevationModel.Reader..::..ReadMode
読み込みモード

Return Value

DEMファイル情報

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


ScanDirWithDialog Method

[image]

A Sandcastle Documented Class Library
Reader..::..ScanDirWithDialog Method
Reader Class See Also Send Feedback
フォルダの指定にダイアログを用いて、DEMを読み込む

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public List<DemSet> ScanDirWithDialog(
    ReadMode mode,
    Environment..::..SpecialFolder rootFolder
)
Visual Basic
Public Function ScanDirWithDialog ( _
    mode As ReadMode, _
    rootFolder As Environment..::..SpecialFolder _
) As List(Of DemSet)
Visual C++
public:
List<DemSet^>^ ScanDirWithDialog(
    ReadMode mode,
    Environment..::..SpecialFolder rootFolder
)

Parameters

mode
Type: GIS.DigitalElevationModel.Reader..::..ReadMode
読み込みモード
rootFolder
Type: System..::..Environment..::..SpecialFolder
探索開始とするルートディレクトリ

Return Value

List形式のDEM情報

See Also

Reader Class
GIS.DigitalElevationModel.Reader Namespace


ReadMode Enumeration

[image]

A Sandcastle Documented Class Library
ReadMode Enumeration
See Also Send Feedback
DEMファイルの読み込みモードを規定する列挙体

Namespace: GIS.DigitalElevationModel.Reader
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ReadMode
Visual Basic
Public Enumeration ReadMode
Visual C++
public enum class ReadMode

Members

Member name | Value | Description
HeaderOnly | 0 | ヘッダー情報のみ
HeaderAndValue | 1 | ヘッダーとともにDEM値も読み込む

See Also

GIS.DigitalElevationModel.Reader Namespace


GIS.KML Namespace

[image]

A Sandcastle Documented Class Library
GIS.KML Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.KML"]

Classes

 | Class | Description
Public class | Base<(Of <(<'T>)>)> | 各KML要素の共通プロパティ等をここで宣言しておく

Enumerations

 | Enumeration | Description
Public enumeration | StyleMode | スタイルの出力形式 内部に格納されたオブジェクト個々にスタイルを適用するかどうかを決定します。


Base(T) Class

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)> Class
Members See Also Send Feedback
各KML要素の共通プロパティ等をここで宣言しておく

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class Base<T>
where T : Base<T>
Visual Basic
Public MustInherit Class Base(Of T As Base(Of T))
Visual C++
generic<typename T>
where T : Base<T>
public ref class Base abstract

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GIS.KML.Base`1"]

Inheritance Hierarchy

System..::..Object
GIS.KML..::..Base<(Of <(<'T>)>)>
GIS.KML.Point..::..Point
GIS.KML.Polygon..::..Polygon

See Also

Base<(Of <(<'T>)>)> Members
GIS.KML Namespace


Base(T) Members

[image] [image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)> Members
Base<(Of <(<'T>)>)> Class Constructors Methods Fields Properties See Also Send Feedback

The Base<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Base<(Of <(<'T>)>)> | コンストラクタ

Methods

 | Name | Description
Public method | Add | 同じオブジェクトを内部へ格納する KMLコードのバインドを想定した機能です。
Public method | AddDescription | 説明文を追加する
 | ConvertColorToKmlColor | 色構造体をKMLのフォーマットに合わせて文字列化して返す 緊急避難的にstaticのpublicで作りました。Polygonの対応ができ次第、protectedへ属性変更する予定です。
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKmlCode | KMLコードを返す そのままファイルへ保存可能なテキストコードを返します。
Protected method | GetKmlCoreCode | KMLとしての本オブジェクトのコアコードを返す 継承したクラスがオーバーライドしてください。 スタイルコードは含まれません。
Protected method | GetStyleCode | スタイルコードを返す 継承したクラスがオーバーライドしてください。 [2012/6/6]スタイル自体も構造体にした方がよさそうですが、今は放置しておきます。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer | 同じ型の入れ子バッファ グルーピングを行う際に利用してください。

Properties

 | Name | Description
Public property | color | 色
Public property | description | 説明文
Public property | KmledDescription | KML用にタグを付けた説明文
Public property | name | 名前
Public property | StyleID | スタイルコードに使用するID
Protected property | StyleOriginalID | スタイルコードに使用可能なオブジェクト独自のIDを返す ハッシュコードを利用したIDを返します。
Public property | Time | 時刻情報

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


Base(T) Constructor

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)> Constructor
Base<(Of <(<'T>)>)> Class See Also Send Feedback
コンストラクタ

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Base()
Visual Basic
Public Sub New
Visual C++
public:
Base()

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


Base(T) Fields

[image] [image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)> Fields
Base<(Of <(<'T>)>)> Class See Also Send Feedback

The Base<(Of <(<'T>)>)> type exposes the following members.

Fields

 | Name | Description
Protected field | buffer | 同じ型の入れ子バッファ グルーピングを行う際に利用してください。

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


buffer Field

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..buffer Field
Base<(Of <(<'T>)>)> Class See Also Send Feedback
同じ型の入れ子バッファ

グルーピングを行う際に利用してください。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected List<T> buffer
Visual Basic
Protected buffer As List(Of T)
Visual C++
protected:
List<T>^ buffer

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


Base(T) Methods

[image] [image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)> Methods
Base<(Of <(<'T>)>)> Class See Also Send Feedback

The Base<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Add | 同じオブジェクトを内部へ格納する KMLコードのバインドを想定した機能です。
Public method | AddDescription | 説明文を追加する
 | ConvertColorToKmlColor | 色構造体をKMLのフォーマットに合わせて文字列化して返す 緊急避難的にstaticのpublicで作りました。Polygonの対応ができ次第、protectedへ属性変更する予定です。
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKmlCode | KMLコードを返す そのままファイルへ保存可能なテキストコードを返します。
Protected method | GetKmlCoreCode | KMLとしての本オブジェクトのコアコードを返す 継承したクラスがオーバーライドしてください。 スタイルコードは含まれません。
Protected method | GetStyleCode | スタイルコードを返す 継承したクラスがオーバーライドしてください。 [2012/6/6]スタイル自体も構造体にした方がよさそうですが、今は放置しておきます。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


Add Method

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..Add Method
Base<(Of <(<'T>)>)> Class See Also Send Feedback
同じオブジェクトを内部へ格納する

KMLコードのバインドを想定した機能です。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Add(
    T add
)
Visual Basic
Public Sub Add ( _
    add As T _
)
Visual C++
public:
void Add(
    T add
)

Parameters

add
Type: T
格納したいオブジェクト

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


AddDescription Method

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..AddDescription Method
Base<(Of <(<'T>)>)> Class See Also Send Feedback
説明文を追加する

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddDescription(
    string text
)
Visual Basic
Public Sub AddDescription ( _
    text As String _
)
Visual C++
public:
void AddDescription(
    String^ text
)

Parameters

text
Type: System..::..String
追加するテキスト

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


ConvertColorToKmlColor Method

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..ConvertColorToKmlColor Method
Base<(Of <(<'T>)>)> Class See Also Send Feedback
色構造体をKMLのフォーマットに合わせて文字列化して返す

緊急避難的にstaticのpublicで作りました。Polygonの対応ができ次第、protectedへ属性変更する予定です。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string ConvertColorToKmlColor(
    Color color
)
Visual Basic
Public Shared Function ConvertColorToKmlColor ( _
    color As Color _
) As String
Visual C++
public:
static String^ ConvertColorToKmlColor(
    Color color
)

Parameters

color
Type: System.Drawing..::..Color
色

Return Value

色情報

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


GetKmlCode Method

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..GetKmlCode Method
Base<(Of <(<'T>)>)> Class See Also Send Feedback
KMLコードを返す

そのままファイルへ保存可能なテキストコードを返します。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetKmlCode(
    StyleMode mode
)
Visual Basic
Public Function GetKmlCode ( _
    mode As StyleMode _
) As String
Visual C++
public:
String^ GetKmlCode(
    StyleMode mode
)

Parameters

mode
Type: GIS.KML..::..StyleMode

[Missing <param name="mode"/> documentation for "M:GIS.KML.Base`1.GetKmlCode(GIS.KML.StyleMode)"]

Return Value

KML完全コード

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


GetKmlCoreCode Method

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..GetKmlCoreCode Method
Base<(Of <(<'T>)>)> Class See Also Send Feedback
KMLとしての本オブジェクトのコアコードを返す

継承したクラスがオーバーライドしてください。

スタイルコードは含まれません。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual string GetKmlCoreCode()
Visual Basic
Protected Overridable Function GetKmlCoreCode As String
Visual C++
protected:
virtual String^ GetKmlCoreCode()

Return Value

本オブジェクトのコアコード

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


GetStyleCode Method

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..GetStyleCode Method
Base<(Of <(<'T>)>)> Class See Also Send Feedback
スタイルコードを返す

継承したクラスがオーバーライドしてください。

[2012/6/6]スタイル自体も構造体にした方がよさそうですが、今は放置しておきます。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual string GetStyleCode()
Visual Basic
Protected Overridable Function GetStyleCode As String
Visual C++
protected:
virtual String^ GetStyleCode()

Return Value

スタイルコード

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


Base(T) Properties

[image] [image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)> Properties
Base<(Of <(<'T>)>)> Class See Also Send Feedback

The Base<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | color | 色
Public property | description | 説明文
Public property | KmledDescription | KML用にタグを付けた説明文
Public property | name | 名前
Public property | StyleID | スタイルコードに使用するID
Protected property | StyleOriginalID | スタイルコードに使用可能なオブジェクト独自のIDを返す ハッシュコードを利用したIDを返します。
Public property | Time | 時刻情報

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


color Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..color Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
色

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Color color { get; set; }
Visual Basic
Public Property color As Color
    Get
    Set
Visual C++
public:
property Color color {
    Color get ();
    void set (Color value);
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


description Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..description Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
説明文

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string description { get; set; }
Visual Basic
Public Property description As String
    Get
    Set
Visual C++
public:
property String^ description {
    String^ get ();
    void set (String^ value);
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


KmledDescription Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..KmledDescription Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
KML用にタグを付けた説明文

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string KmledDescription { get; }
Visual Basic
Public ReadOnly Property KmledDescription As String
    Get
Visual C++
public:
property String^ KmledDescription {
    String^ get ();
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


name Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..name Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
名前

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string name { get; set; }
Visual Basic
Public Property name As String
    Get
    Set
Visual C++
public:
property String^ name {
    String^ get ();
    void set (String^ value);
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


StyleID Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..StyleID Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
スタイルコードに使用するID

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string StyleID { get; private set; }
Visual Basic
Public Property StyleID As String
    Get
    Private Set
Visual C++
public:
property String^ StyleID {
    String^ get ();
    private: void set (String^ value);
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


StyleOriginalID Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..StyleOriginalID Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
スタイルコードに使用可能なオブジェクト独自のIDを返す

ハッシュコードを利用したIDを返します。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected string StyleOriginalID { get; }
Visual Basic
Protected ReadOnly Property StyleOriginalID As String
    Get
Visual C++
protected:
property String^ StyleOriginalID {
    String^ get ();
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


Time Property

[image]

A Sandcastle Documented Class Library
Base<(Of <(<'T>)>)>..::..Time Property
Base<(Of <(<'T>)>)> Class See Also Send Feedback
時刻情報

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ITime Time { get; set; }
Visual Basic
Public Property Time As ITime
    Get
    Set
Visual C++
public:
property ITime^ Time {
    ITime^ get ();
    void set (ITime^ value);
}

See Also

Base<(Of <(<'T>)>)> Class
GIS.KML Namespace


StyleMode Enumeration

[image]

A Sandcastle Documented Class Library
StyleMode Enumeration
See Also Send Feedback
スタイルの出力形式

内部に格納されたオブジェクト個々にスタイルを適用するかどうかを決定します。

Namespace: GIS.KML
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum StyleMode
Visual Basic
Public Enumeration StyleMode
Visual C++
public enum class StyleMode

Members

Member name | Value | Description
Common | 0 | 共通のスタイル
Unique | 1 | 独自のスタイル

See Also

GIS.KML Namespace


GIS.KML.Point Namespace

[image]

A Sandcastle Documented Class Library
GIS.KML.Point Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.KML.Point"]

Classes

 | Class | Description
Public class | Point | KML形式の点を表すクラス 点をGoogle Earth上にプロットさせたい場合に便利です。

Enumerations

 | Enumeration | Description
Public enumeration | Icon | Pointのアイコンを表す列挙体


Icon Enumeration

[image]

A Sandcastle Documented Class Library
Icon Enumeration
See Also Send Feedback
Pointのアイコンを表す列挙体

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Icon
Visual Basic
Public Enumeration Icon
Visual C++
public enum class Icon

Members

Member name | Value | Description
placemark_circle | 0 | 中心にドットのある円
shaded_dot | 1 | 円

See Also

GIS.KML.Point Namespace


Point Class

[image]

A Sandcastle Documented Class Library
Point Class
Members See Also Send Feedback
KML形式の点を表すクラス

点をGoogle Earth上にプロットさせたい場合に便利です。

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Point : Base<Point>
Visual Basic
Public Class Point _
    Inherits Base(Of Point)
Visual C++
public ref class Point : public Base<Point^>

Inheritance Hierarchy

System..::..Object
GIS.KML..::..Base <(Of <(<'Point>)>)>
GIS.KML.Point..::..Point

See Also

Point Members
GIS.KML.Point Namespace


Point Members

[image] [image]

A Sandcastle Documented Class Library
Point Members
Point Class Constructors Methods Fields Properties See Also Send Feedback

The Point type exposes the following members.

Constructors

 | Name | Description
Public method | Point(Icon) | コンストラクタ
Public method | Point(BLH, Icon) | 座標の初期化付コンストラクタ
Public method | Point(BLH, DateTime, Icon) | 座標と時刻の初期化付コンストラクタ

Methods

 | Name | Description
Public method | Add | 同じオブジェクトを内部へ格納する KMLコードのバインドを想定した機能です。 (Inherited from Base<(Of <(<'T>)>)>.)
Public method | AddDescription | 説明文を追加する (Inherited from Base<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKmlCode | KMLコードを返す そのままファイルへ保存可能なテキストコードを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Protected method | GetKmlCoreCode | Placemarkコードを返す (Overrides Base<(Of <(<'T>)>)>..::..GetKmlCoreCode()()()().)
Protected method | GetStyleCode | スタイルコードを生成する スタイルコード生成後はPlacemarkとの整合性を保つためにStyleIDを変更しないでください。 (Overrides Base<(Of <(<'T>)>)>..::..GetStyleCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer | 同じ型の入れ子バッファ グルーピングを行う際に利用してください。 (Inherited from Base<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | color | 色 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | description | 説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | icon | アイコン
Public property | KmledDescription | KML用にタグを付けた説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | name | 名前 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | Pos | 位置座標
Public property | scale | スケール
Public property | StyleID | スタイルコードに使用するID (Inherited from Base<(Of <(<'T>)>)>.)
Protected property | StyleOriginalID | スタイルコードに使用可能なオブジェクト独自のIDを返す ハッシュコードを利用したIDを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | Time | 時刻情報 (Inherited from Base<(Of <(<'T>)>)>.)

See Also

Point Class
GIS.KML.Point Namespace


Point Constructor

[image] [image]

A Sandcastle Documented Class Library
Point Constructor
Point Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Point(Icon) | コンストラクタ
Public method | Point(BLH, Icon) | 座標の初期化付コンストラクタ
Public method | Point(BLH, DateTime, Icon) | 座標と時刻の初期化付コンストラクタ

See Also

Point Class
Point Members
GIS.KML.Point Namespace


Point Constructor (Icon)

[image]

A Sandcastle Documented Class Library
Point Constructor (Icon)
Point Class See Also Send Feedback
コンストラクタ

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point(
    Icon icon
)
Visual Basic
Public Sub New ( _
    icon As Icon _
)
Visual C++
public:
Point(
    Icon icon
)

Parameters

icon
Type: GIS.KML.Point..::..Icon

[Missing <param name="icon"/> documentation for "M:GIS.KML.Point.Point.#ctor(GIS.KML.Point.Icon)"]

See Also

Point Class
Point Overload
GIS.KML.Point Namespace


Point Constructor (, Icon)

[image]

A Sandcastle Documented Class Library
Point Constructor (, Icon)
Point Class See Also Send Feedback
座標の初期化付コンストラクタ

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point(
    BLH pos,
    Icon icon
)
Visual Basic
Public Sub New ( _
    pos As BLH, _
    icon As Icon _
)
Visual C++
public:
Point(
    BLH pos,
    Icon icon
)

Parameters

pos
Type: BLH
座標
icon
Type: GIS.KML.Point..::..Icon
アイコン

See Also

Point Class
Point Overload
GIS.KML.Point Namespace


Point Constructor (, DateTime, Icon)

[image]

A Sandcastle Documented Class Library
Point Constructor (, DateTime, Icon)
Point Class See Also Send Feedback
座標と時刻の初期化付コンストラクタ

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Point(
    BLH pos,
    DateTime time,
    Icon icon
)
Visual Basic
Public Sub New ( _
    pos As BLH, _
    time As DateTime, _
    icon As Icon _
)
Visual C++
public:
Point(
    BLH pos,
    DateTime time,
    Icon icon
)

Parameters

pos
Type: BLH
座標
time
Type: System..::..DateTime
時刻
icon
Type: GIS.KML.Point..::..Icon
アイコン

See Also

Point Class
Point Overload
GIS.KML.Point Namespace


Point Fields

[image] [image]

A Sandcastle Documented Class Library
Point Fields
Point Class See Also Send Feedback

The Point type exposes the following members.

Fields

 | Name | Description
Protected field | buffer | 同じ型の入れ子バッファ グルーピングを行う際に利用してください。 (Inherited from Base<(Of <(<'T>)>)>.)

See Also

Point Class
GIS.KML.Point Namespace


Point Methods

[image] [image]

A Sandcastle Documented Class Library
Point Methods
Point Class See Also Send Feedback

The Point type exposes the following members.

Methods

 | Name | Description
Public method | Add | 同じオブジェクトを内部へ格納する KMLコードのバインドを想定した機能です。 (Inherited from Base<(Of <(<'T>)>)>.)
Public method | AddDescription | 説明文を追加する (Inherited from Base<(Of <(<'T>)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKmlCode | KMLコードを返す そのままファイルへ保存可能なテキストコードを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Protected method | GetKmlCoreCode | Placemarkコードを返す (Overrides Base<(Of <(<'T>)>)>..::..GetKmlCoreCode()()()().)
Protected method | GetStyleCode | スタイルコードを生成する スタイルコード生成後はPlacemarkとの整合性を保つためにStyleIDを変更しないでください。 (Overrides Base<(Of <(<'T>)>)>..::..GetStyleCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Point Class
GIS.KML.Point Namespace


GetKmlCoreCode Method

[image]

A Sandcastle Documented Class Library
Point..::..GetKmlCoreCode Method
Point Class See Also Send Feedback
Placemarkコードを返す

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override string GetKmlCoreCode()
Visual Basic
Protected Overrides Function GetKmlCoreCode As String
Visual C++
protected:
virtual String^ GetKmlCoreCode() override

Return Value

Placemarkコード

See Also

Point Class
GIS.KML.Point Namespace


GetStyleCode Method

[image]

A Sandcastle Documented Class Library
Point..::..GetStyleCode Method
Point Class See Also Send Feedback
スタイルコードを生成する

スタイルコード生成後はPlacemarkとの整合性を保つためにStyleIDを変更しないでください。

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override string GetStyleCode()
Visual Basic
Protected Overrides Function GetStyleCode As String
Visual C++
protected:
virtual String^ GetStyleCode() override

Return Value

スタイルコード

See Also

Point Class
GIS.KML.Point Namespace


Point Properties

[image] [image]

A Sandcastle Documented Class Library
Point Properties
Point Class See Also Send Feedback

The Point type exposes the following members.

Properties

 | Name | Description
Public property | color | 色 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | description | 説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | icon | アイコン
Public property | KmledDescription | KML用にタグを付けた説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | name | 名前 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | Pos | 位置座標
Public property | scale | スケール
Public property | StyleID | スタイルコードに使用するID (Inherited from Base<(Of <(<'T>)>)>.)
Protected property | StyleOriginalID | スタイルコードに使用可能なオブジェクト独自のIDを返す ハッシュコードを利用したIDを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | Time | 時刻情報 (Inherited from Base<(Of <(<'T>)>)>.)

See Also

Point Class
GIS.KML.Point Namespace


icon Property

[image]

A Sandcastle Documented Class Library
Point..::..icon Property
Point Class See Also Send Feedback
アイコン

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Icon icon { get; set; }
Visual Basic
Public Property icon As Icon
    Get
    Set
Visual C++
public:
property Icon icon {
    Icon get ();
    void set (Icon value);
}

See Also

Point Class
GIS.KML.Point Namespace


Pos Property

[image]

A Sandcastle Documented Class Library
Point..::..Pos Property
Point Class See Also Send Feedback
位置座標

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH Pos { get; set; }
Visual Basic
Public Property Pos As BLH
    Get
    Set
Visual C++
public:
property BLH Pos {
    BLH get ();
    void set (BLH value);
}

See Also

Point Class
GIS.KML.Point Namespace


scale Property

[image]

A Sandcastle Documented Class Library
Point..::..scale Property
Point Class See Also Send Feedback
スケール

Namespace: GIS.KML.Point
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double scale { get; set; }
Visual Basic
Public Property scale As Double
    Get
    Set
Visual C++
public:
property double scale {
    double get ();
    void set (double value);
}

See Also

Point Class
GIS.KML.Point Namespace


GIS.KML.Polygon Namespace

[image]

A Sandcastle Documented Class Library
GIS.KML.Polygon Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.KML.Polygon"]

Classes

 | Class | Description
Public class | Polygon | Polygonクラス プロパティ名等はKMLに合わせています。


Polygon Class

[image]

A Sandcastle Documented Class Library
Polygon Class
Members See Also Send Feedback
Polygonクラス

プロパティ名等はKMLに合わせています。

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Polygon : Base<Polygon>
Visual Basic
Public Class Polygon _
    Inherits Base(Of Polygon)
Visual C++
public ref class Polygon : public Base<Polygon^>

Inheritance Hierarchy

System..::..Object
GIS.KML..::..Base <(Of <(<'Polygon>)>)>
GIS.KML.Polygon..::..Polygon

See Also

Polygon Members
GIS.KML.Polygon Namespace


Polygon Members

[image] [image]

A Sandcastle Documented Class Library
Polygon Members
Polygon Class Constructors Methods Fields Properties See Also Send Feedback

The Polygon type exposes the following members.

Constructors

 | Name | Description
Public method | Polygon | コンストラクタ

Methods

 | Name | Description
Public method | Add | 同じオブジェクトを内部へ格納する KMLコードのバインドを想定した機能です。 (Inherited from Base<(Of <(<'T>)>)>.)
Public method | AddDescription | 説明文を追加する (Inherited from Base<(Of <(<'T>)>)>.)
Public method | AddToInner(BLH) | 内側に点を追加する
Public method | AddToInner(array<BLH>[]()[][]) | 内側に点を追加する
Public method | AddToOuter(BLH) | 外側へ点を追加する
Public method | AddToOuter(array<BLH>[]()[][]) | 外側へ点を追加する
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKmlCode | KMLコードを返す そのままファイルへ保存可能なテキストコードを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Protected method | GetKmlCoreCode | 本インスタンスのポリゴンのコア部分のみのコードを返す (Overrides Base<(Of <(<'T>)>)>..::..GetKmlCoreCode()()()().)
Protected method | GetStyleCode | 本インスタンスのスタイルコードを返す (Overrides Base<(Of <(<'T>)>)>..::..GetStyleCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Protected field | buffer | 同じ型の入れ子バッファ グルーピングを行う際に利用してください。 (Inherited from Base<(Of <(<'T>)>)>.)

Properties

 | Name | Description
Public property | color | 色 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | description | 説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | KmledDescription | KML用にタグを付けた説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | name | 名前 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | StyleID | スタイルコードに使用するID (Inherited from Base<(Of <(<'T>)>)>.)
Protected property | StyleOriginalID | スタイルコードに使用可能なオブジェクト独自のIDを返す ハッシュコードを利用したIDを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | Time | 時刻情報 (Inherited from Base<(Of <(<'T>)>)>.)

See Also

Polygon Class
GIS.KML.Polygon Namespace


Polygon Constructor

[image]

A Sandcastle Documented Class Library
Polygon Constructor
Polygon Class See Also Send Feedback
コンストラクタ

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Polygon()
Visual Basic
Public Sub New
Visual C++
public:
Polygon()

See Also

Polygon Class
GIS.KML.Polygon Namespace


Polygon Fields

[image] [image]

A Sandcastle Documented Class Library
Polygon Fields
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Fields

 | Name | Description
Protected field | buffer | 同じ型の入れ子バッファ グルーピングを行う際に利用してください。 (Inherited from Base<(Of <(<'T>)>)>.)

See Also

Polygon Class
GIS.KML.Polygon Namespace


Polygon Methods

[image] [image]

A Sandcastle Documented Class Library
Polygon Methods
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Methods

 | Name | Description
Public method | Add | 同じオブジェクトを内部へ格納する KMLコードのバインドを想定した機能です。 (Inherited from Base<(Of <(<'T>)>)>.)
Public method | AddDescription | 説明文を追加する (Inherited from Base<(Of <(<'T>)>)>.)
Public method | AddToInner(BLH) | 内側に点を追加する
Public method | AddToInner(array<BLH>[]()[][]) | 内側に点を追加する
Public method | AddToOuter(BLH) | 外側へ点を追加する
Public method | AddToOuter(array<BLH>[]()[][]) | 外側へ点を追加する
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKmlCode | KMLコードを返す そのままファイルへ保存可能なテキストコードを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Protected method | GetKmlCoreCode | 本インスタンスのポリゴンのコア部分のみのコードを返す (Overrides Base<(Of <(<'T>)>)>..::..GetKmlCoreCode()()()().)
Protected method | GetStyleCode | 本インスタンスのスタイルコードを返す (Overrides Base<(Of <(<'T>)>)>..::..GetStyleCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Polygon Class
GIS.KML.Polygon Namespace


AddToInner Method

[image] [image]

A Sandcastle Documented Class Library
Polygon..::..AddToInner Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddToInner(BLH) | 内側に点を追加する
Public method | AddToInner(array<BLH>[]()[][]) | 内側に点を追加する

See Also

Polygon Class
Polygon Members
GIS.KML.Polygon Namespace


AddToInner Method ()

[image]

A Sandcastle Documented Class Library
Polygon..::..AddToInner Method ()
Polygon Class See Also Send Feedback
内側に点を追加する

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddToInner(
    BLH pos
)
Visual Basic
Public Sub AddToInner ( _
    pos As BLH _
)
Visual C++
public:
void AddToInner(
    BLH pos
)

Parameters

pos
Type: BLH
位置座標

See Also

Polygon Class
AddToInner Overload
GIS.KML.Polygon Namespace


AddToInner Method ([])

[image]

A Sandcastle Documented Class Library
Polygon..::..AddToInner Method (array<>[]()[][])
Polygon Class See Also Send Feedback
内側に点を追加する

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddToInner(
    BLH[] pos
)
Visual Basic
Public Sub AddToInner ( _
    pos As BLH() _
)
Visual C++
public:
void AddToInner(
    array<BLH>^ pos
)

Parameters

pos
Type: array<BLH>[]()[][]
位置座標

See Also

Polygon Class
AddToInner Overload
GIS.KML.Polygon Namespace


AddToOuter Method

[image] [image]

A Sandcastle Documented Class Library
Polygon..::..AddToOuter Method
Polygon Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddToOuter(BLH) | 外側へ点を追加する
Public method | AddToOuter(array<BLH>[]()[][]) | 外側へ点を追加する

See Also

Polygon Class
Polygon Members
GIS.KML.Polygon Namespace


AddToOuter Method ()

[image]

A Sandcastle Documented Class Library
Polygon..::..AddToOuter Method ()
Polygon Class See Also Send Feedback
外側へ点を追加する

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddToOuter(
    BLH pos
)
Visual Basic
Public Sub AddToOuter ( _
    pos As BLH _
)
Visual C++
public:
void AddToOuter(
    BLH pos
)

Parameters

pos
Type: BLH
位置座標

See Also

Polygon Class
AddToOuter Overload
GIS.KML.Polygon Namespace


AddToOuter Method ([])

[image]

A Sandcastle Documented Class Library
Polygon..::..AddToOuter Method (array<>[]()[][])
Polygon Class See Also Send Feedback
外側へ点を追加する

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddToOuter(
    BLH[] pos
)
Visual Basic
Public Sub AddToOuter ( _
    pos As BLH() _
)
Visual C++
public:
void AddToOuter(
    array<BLH>^ pos
)

Parameters

pos
Type: array<BLH>[]()[][]
位置座標

See Also

Polygon Class
AddToOuter Overload
GIS.KML.Polygon Namespace


GetKmlCoreCode Method

[image]

A Sandcastle Documented Class Library
Polygon..::..GetKmlCoreCode Method
Polygon Class See Also Send Feedback
本インスタンスのポリゴンのコア部分のみのコードを返す

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override string GetKmlCoreCode()
Visual Basic
Protected Overrides Function GetKmlCoreCode As String
Visual C++
protected:
virtual String^ GetKmlCoreCode() override

Return Value

ポリゴンのコアコード

See Also

Polygon Class
GIS.KML.Polygon Namespace


GetStyleCode Method

[image]

A Sandcastle Documented Class Library
Polygon..::..GetStyleCode Method
Polygon Class See Also Send Feedback
本インスタンスのスタイルコードを返す

Namespace: GIS.KML.Polygon
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override string GetStyleCode()
Visual Basic
Protected Overrides Function GetStyleCode As String
Visual C++
protected:
virtual String^ GetStyleCode() override

Return Value

スタイルコード

See Also

Polygon Class
GIS.KML.Polygon Namespace


Polygon Properties

[image] [image]

A Sandcastle Documented Class Library
Polygon Properties
Polygon Class See Also Send Feedback

The Polygon type exposes the following members.

Properties

 | Name | Description
Public property | color | 色 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | description | 説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | KmledDescription | KML用にタグを付けた説明文 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | name | 名前 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | StyleID | スタイルコードに使用するID (Inherited from Base<(Of <(<'T>)>)>.)
Protected property | StyleOriginalID | スタイルコードに使用可能なオブジェクト独自のIDを返す ハッシュコードを利用したIDを返します。 (Inherited from Base<(Of <(<'T>)>)>.)
Public property | Time | 時刻情報 (Inherited from Base<(Of <(<'T>)>)>.)

See Also

Polygon Class
GIS.KML.Polygon Namespace


GIS.KML.Time Namespace

[image]

A Sandcastle Documented Class Library
GIS.KML.Time Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.KML.Time"]

Structures

 | Structure | Description
Public structure | TimeSpan | 期間を表す構造体
Public structure | TimeStamp | ある瞬間の時間を表す構造体

Interfaces

 | Interface | Description
Public interface | ITime | 時制を表すインターフェイス


ITime Interface

[image]

A Sandcastle Documented Class Library
ITime Interface
Members See Also Send Feedback
時制を表すインターフェイス

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public interface ITime
Visual Basic
Public Interface ITime
Visual C++
public interface class ITime

See Also

ITime Members
GIS.KML.Time Namespace


ITime Members

[image] [image]

A Sandcastle Documented Class Library
ITime Members
ITime Interface Methods See Also Send Feedback

The ITime type exposes the following members.

Methods

 | Name | Description
Public method | GetKmlTime | 時刻情報をKMLのフォーマットで返します

See Also

ITime Interface
GIS.KML.Time Namespace


ITime Methods

[image] [image]

A Sandcastle Documented Class Library
ITime Methods
ITime Interface See Also Send Feedback

The ITime type exposes the following members.

Methods

 | Name | Description
Public method | GetKmlTime | 時刻情報をKMLのフォーマットで返します

See Also

ITime Interface
GIS.KML.Time Namespace


GetKmlTime Method

[image]

A Sandcastle Documented Class Library
ITime..::..GetKmlTime Method
ITime Interface See Also Send Feedback
時刻情報をKMLのフォーマットで返します

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
string GetKmlTime()
Visual Basic
Function GetKmlTime As String
Visual C++
String^ GetKmlTime()

Return Value

[Missing <returns> documentation for "M:GIS.KML.Time.ITime.GetKmlTime"]

See Also

ITime Interface
GIS.KML.Time Namespace


TimeSpan Structure

[image]

A Sandcastle Documented Class Library
TimeSpan Structure
Members See Also Send Feedback
期間を表す構造体

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct TimeSpan : ITime
Visual Basic
Public Structure TimeSpan _
    Implements ITime
Visual C++
public value class TimeSpan : ITime

See Also

TimeSpan Members
GIS.KML.Time Namespace


TimeSpan Members

[image] [image]

A Sandcastle Documented Class Library
TimeSpan Members
TimeSpan Structure Constructors Methods Properties See Also Send Feedback

The TimeSpan type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSpan | コンストラクタ 引数の時系列チェックは行っていませんのでご注意ください。

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetKmlTime | 文字列化します
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | End | 時刻
Public property | Start | 時刻

See Also

TimeSpan Structure
GIS.KML.Time Namespace


TimeSpan Constructor

[image]

A Sandcastle Documented Class Library
TimeSpan Constructor
TimeSpan Structure See Also Send Feedback
コンストラクタ

引数の時系列チェックは行っていませんのでご注意ください。

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpan(
    DateTime start,
    DateTime end
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    end As DateTime _
)
Visual C++
public:
TimeSpan(
    DateTime start,
    DateTime end
)

Parameters

start
Type: System..::..DateTime
開始時刻
end
Type: System..::..DateTime
終了時刻

See Also

TimeSpan Structure
GIS.KML.Time Namespace


TimeSpan Methods

[image] [image]

A Sandcastle Documented Class Library
TimeSpan Methods
TimeSpan Structure See Also Send Feedback

The TimeSpan type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetKmlTime | 文字列化します
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

TimeSpan Structure
GIS.KML.Time Namespace


GetKmlTime Method

[image]

A Sandcastle Documented Class Library
TimeSpan..::..GetKmlTime Method
TimeSpan Structure See Also Send Feedback
文字列化します

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetKmlTime()
Visual Basic
Public Function GetKmlTime As String
Visual C++
public:
virtual String^ GetKmlTime() sealed

Return Value

文字列化したタイムスパン

Implements

ITime..::..GetKmlTime()()()()

See Also

TimeSpan Structure
GIS.KML.Time Namespace


TimeSpan Properties

[image] [image]

A Sandcastle Documented Class Library
TimeSpan Properties
TimeSpan Structure See Also Send Feedback

The TimeSpan type exposes the following members.

Properties

 | Name | Description
Public property | End | 時刻
Public property | Start | 時刻

See Also

TimeSpan Structure
GIS.KML.Time Namespace


End Property

[image]

A Sandcastle Documented Class Library
TimeSpan..::..End Property
TimeSpan Structure See Also Send Feedback
時刻

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime End { get; private set; }
Visual Basic
Public Property End As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime End {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

TimeSpan Structure
GIS.KML.Time Namespace


Start Property

[image]

A Sandcastle Documented Class Library
TimeSpan..::..Start Property
TimeSpan Structure See Also Send Feedback
時刻

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime Start { get; private set; }
Visual Basic
Public Property Start As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Start {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

TimeSpan Structure
GIS.KML.Time Namespace


TimeStamp Structure

[image]

A Sandcastle Documented Class Library
TimeStamp Structure
Members See Also Send Feedback
ある瞬間の時間を表す構造体

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct TimeStamp : ITime
Visual Basic
Public Structure TimeStamp _
    Implements ITime
Visual C++
public value class TimeStamp : ITime

See Also

TimeStamp Members
GIS.KML.Time Namespace


TimeStamp Members

[image] [image]

A Sandcastle Documented Class Library
TimeStamp Members
TimeStamp Structure Constructors Methods Properties See Also Send Feedback

The TimeStamp type exposes the following members.

Constructors

 | Name | Description
Public method | TimeStamp | コンストラクタ

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetKmlTime | 文字列化します
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Epoch | 時刻

See Also

TimeStamp Structure
GIS.KML.Time Namespace


TimeStamp Constructor

[image]

A Sandcastle Documented Class Library
TimeStamp Constructor
TimeStamp Structure See Also Send Feedback
コンストラクタ

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeStamp(
    DateTime epoch
)
Visual Basic
Public Sub New ( _
    epoch As DateTime _
)
Visual C++
public:
TimeStamp(
    DateTime epoch
)

Parameters

epoch
Type: System..::..DateTime
タイムスタンプの時刻

See Also

TimeStamp Structure
GIS.KML.Time Namespace


TimeStamp Methods

[image] [image]

A Sandcastle Documented Class Library
TimeStamp Methods
TimeStamp Structure See Also Send Feedback

The TimeStamp type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetKmlTime | 文字列化します
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

TimeStamp Structure
GIS.KML.Time Namespace


GetKmlTime Method

[image]

A Sandcastle Documented Class Library
TimeStamp..::..GetKmlTime Method
TimeStamp Structure See Also Send Feedback
文字列化します

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string GetKmlTime()
Visual Basic
Public Function GetKmlTime As String
Visual C++
public:
virtual String^ GetKmlTime() sealed

Return Value

文字列化したタイムスタンプ

Implements

ITime..::..GetKmlTime()()()()

See Also

TimeStamp Structure
GIS.KML.Time Namespace


TimeStamp Properties

[image] [image]

A Sandcastle Documented Class Library
TimeStamp Properties
TimeStamp Structure See Also Send Feedback

The TimeStamp type exposes the following members.

Properties

 | Name | Description
Public property | Epoch | 時刻

See Also

TimeStamp Structure
GIS.KML.Time Namespace


Epoch Property

[image]

A Sandcastle Documented Class Library
TimeStamp..::..Epoch Property
TimeStamp Structure See Also Send Feedback
時刻

Namespace: GIS.KML.Time
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime Epoch { get; private set; }
Visual Basic
Public Property Epoch As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Epoch {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

TimeStamp Structure
GIS.KML.Time Namespace


GIS.MapBase Namespace

[image]

A Sandcastle Documented Class Library
GIS.MapBase Namespace
Send Feedback

[Missing <summary> documentation for "N:GIS.MapBase"]

Classes

 | Class | Description
Public class | Map | ラスタデータで構成される地図情報を扱うクラス DEM（デジタル標高モデル）等を扱うことを念頭に入れています。 要素を2次元配列として表現しています。 配列は[x,y]で宣言しており、画像でたとえると[0,0]が画面の左上、[x_max, y_max]が画面の右下としています。 画面の上が北で、右が東です。 東西方向をx、南北方向をyで表現しています。 xは増えるほどより東に位置することを表し、yは増えるほどより南に位置することを表します。
Public class | MapLocalFeature | マップの特徴量を計算or返すクラス

Structures

 | Structure | Description
Public structure | LocalData<(Of <(<'T>)>)> | とある座標のデータを表す、座標と値のセットの構造体 ジェネリックを利用して任意の座標系を表現します。
Public structure | MapField | マップ中の領域を整数値アドレスで表す構造体 Mapクラスのメソッドに対して領域を指定するのに使用することを想定しています。 インスタンス生成後、オブジェクト自身の領域を拡大することはできても縮小はできません。And()をうまく利用してください。
Public structure | MapLocalFeature..::..Feature | 局所的な特徴を表す構造体
Public structure | Pos | x,yの座標セット構造体 マップのアドレス計算用 相対アドレス計算用に負値にも対応しています。


LocalData(T) Structure

[image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)> Structure
Members See Also Send Feedback
とある座標のデータを表す、座標と値のセットの構造体

ジェネリックを利用して任意の座標系を表現します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct LocalData<T>
where T : struct, new()
Visual Basic
Public Structure LocalData(Of T As {Structure, New})
Visual C++
generic<typename T>
where T : value class, gcnew()
public value class LocalData

Type Parameters

T
アドレスを表現可能なGNSS.BLHもしくはGIS.MapBase.Posもしくは任意の構造体を指定してください。

See Also

LocalData<(Of <(<'T>)>)> Members
GIS.MapBase Namespace


LocalData(T) Members

[image] [image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)> Members
LocalData<(Of <(<'T>)>)> Structure Constructors Methods Properties See Also Send Feedback

The LocalData<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | LocalData<(Of <(<'T>)>)> | コンストラクタによる初期化（引数のvalueについては省略可能）

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 局所情報の文字列化 (Overrides ValueType..::..ToString()()()().)

Properties

 | Name | Description
Public property | Address | 座標
Public property | Value | 値

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


LocalData(T) Constructor

[image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)> Constructor
LocalData<(Of <(<'T>)>)> Structure See Also Send Feedback
コンストラクタによる初期化（引数のvalueについては省略可能）

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LocalData(
    T pos,
    float value
)
Visual Basic
Public Sub New ( _
    pos As T, _
    value As Single _
)
Visual C++
public:
LocalData(
    T pos,
    float value
)

Parameters

pos
Type: T
緯度・経度の座標
value
Type: System..::..Single
値

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


LocalData(T) Methods

[image] [image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)> Methods
LocalData<(Of <(<'T>)>)> Structure See Also Send Feedback

The LocalData<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 局所情報の文字列化 (Overrides ValueType..::..ToString()()()().)

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)>..::..ToString Method
LocalData<(Of <(<'T>)>)> Structure See Also Send Feedback
局所情報の文字列化

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

文字列化したLocalData

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


LocalData(T) Properties

[image] [image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)> Properties
LocalData<(Of <(<'T>)>)> Structure See Also Send Feedback

The LocalData<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Address | 座標
Public property | Value | 値

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


Address Property

[image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)>..::..Address Property
LocalData<(Of <(<'T>)>)> Structure See Also Send Feedback
座標

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public T Address { get; set; }
Visual Basic
Public Property Address As T
    Get
    Set
Visual C++
public:
property T Address {
    T get ();
    void set (T value);
}

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


Value Property

[image]

A Sandcastle Documented Class Library
LocalData<(Of <(<'T>)>)>..::..Value Property
LocalData<(Of <(<'T>)>)> Structure See Also Send Feedback
値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float Value { get; set; }
Visual Basic
Public Property Value As Single
    Get
    Set
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}

See Also

LocalData<(Of <(<'T>)>)> Structure
GIS.MapBase Namespace


Map Class

[image]

A Sandcastle Documented Class Library
Map Class
Members See Also Send Feedback
ラスタデータで構成される地図情報を扱うクラス

DEM（デジタル標高モデル）等を扱うことを念頭に入れています。

要素を2次元配列として表現しています。 配列は[x,y]で宣言しており、画像でたとえると[0,0]が画面の左上、[x_max, y_max]が画面の右下としています。 画面の上が北で、右が東です。 東西方向をx、南北方向をyで表現しています。 xは増えるほどより東に位置することを表し、yは増えるほどより南に位置することを表します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Map
Visual Basic
Public Class Map
Visual C++
public ref class Map

Inheritance Hierarchy

System..::..Object
GIS.MapBase..::..Map

See Also

Map Members
GIS.MapBase Namespace


Map Members

[image] [image]

A Sandcastle Documented Class Library
Map Members
Map Class Constructors Methods Properties See Also Send Feedback

The Map type exposes the following members.

Constructors

 | Name | Description
Public method | Map(RectangleField) | マップの領域を指定してインスタンスを生成するコンストラクタ 座標計算を特に使用しない場合を想定しています。 マップのサイズはマップデータの代入時に決定されます。 また、この時にマップデータのインスタンスが確保されます。
Public method | Map(Map) | コピーコンストラクタ パレメータを始め全てのパラメータをコピーしたインスタンスを生成します。
Public method | Map(RectangleField, Pos) | 領域の角の座標とマップのサイズ（ピクセル数）を指定することでマップを生成するコンストラクタ マップは0で初期化されます。
Public method | Map(RectangleField, Length) | 領域の角の座標とメッシュサイズを指定することでマップを生成するコンストラクタ マップの境界値が曖昧だけども任意のマップを生成したいという場合を想定しています。 なお、角の座標値はメッシュサイズに合わせて微調整されます。 マップは0で初期化されます。

Methods

 | Name | Description
Public method | AddValue(BLH, Single) | 座標（緯度・経度）に指定された値を加算する 加算値は負数でも構いません。
Public method | AddValue(Pos, Single) | 座標（マップ内のローカル座標）に指定された値を加算する 加算値は負数でも構いません。
Public method | AddValues(array<BLH>[]()[][], array<Single>[]()[][]) | 座標（緯度・経度の配列）に指定された値（配列）を加算する
Public method | AddValues(array<Pos>[]()[][], array<Single>[]()[][]) | 座標（マップ内のローカル座標）に指定された値（配列）を加算する
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetDifferentialPosition | 指定された座標を中心として、指定された相対アドレスの緯度と経度を返します。
Public method | GetDistance | 2地点間の距離[m]を返す
Public method | GetField | 指定された座標を中心とした、指定された半径 mを収めることができる領域を返す 返す領域はマップの領域から外に出ることも有り得ます。
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMap | マップを2次元配列で返す インスタンスは新たに生成しないので、高速アクセス・操作が可能です。 ただし、値をいじるとマップも変わるので注意して下さい。
Public method | GetMapBetween | 指定値の間にある値を持つ地点をマーキングしたマップを返す なお、条件には指定値は含まれない。 2つの引数が同値であれば無評価となり、0で初期化されたマップが返ります。
Public method | GetMapHigher | 指定値よりも高い値を持つ地点をマーキングしたマップを返す 返されたマップは、1.0を条件成立とする。条件不成立は0.0とする。
Public method | GetMapLower | 指定値よりも低い値を持つ地点をマーキングしたマップを返す 返されたマップは、1.0を条件成立とする。条件不成立は0.0とする。
Public method | GetMapMatch(Single) | 指定値にマッチする地点をマーキングしたマップを返す 指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。 走査範囲はマップ全体となります。
Public method | GetMapMatch(Single, MapField) | 指定値にマッチする地点をマーキングしたマップを返す 指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。 走査範囲については、fieldで指定して下さい。
Public method | GetMatchPosArray(Single) | 指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。 GetMapMatchを使用して、フラグの立った地点を配列として返します。 走査範囲はマップ全体となります。
Public method | GetMatchPosArray(Single, MapField) | 指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。 GetMapMatchを使用して、フラグの立った地点を配列として返します。 走査範囲については、fieldで指定して下さい。
Public method | GetMeshCorner | 指定座標の属するメッシュの右上・左上の座標を返す 任意に作出されたマップの位置を本クラスのメッシュ位置と一致させる用途での仕様を想定しています。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(BLH) | 指定座標のマップデータを返す 計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度
Public method | GetValue(Pos) | 指定座標のマップデータを返す マップ内のローカル座標を指定して下さい。
Public method | Initialize | マップの初期化メソッド マップサイズを定義済みであれば、マップの初期化を行います。 マップサイズが定義済みかどうかはIsSizeSetメソッドを参照してご確認ください。 なお、マップデータはデフォルトでは0.0fで上書きされます。
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Position2XYaddress | 指定座標のx,yアドレスを返す マップの要素番号は0～size-1であることに注意してください。 本メソッドはマップ領域外の座標を指定された場合でも本マップ内の相対アドレスを返します。
Public method | SaveAsImage | マップを画像として保存する 保存形式はImageFormatプロパティを通して設定可能です。 個人的都合により、値が非値もしくは0.0以下の箇所では背景として黒色を採用しています。 これは使いにくする仕様になっていますので、その内カラ―スケールを導入するかもしれません。 ファイルの出力には実時間で通常2秒以上かかりますのでTaskを利用して処理がすぐ戻るようにしています。 処理が戻った時点ではファイルができていないことにご注意ください。
Public method | SaveFileAsXml | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SaveFileForRcmdr | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SetMapData | マップデータをセットする データはディープコピーされます。
Public method | ToBLHarray | ローカルアドレスの配列を緯度・経度の配列へ変換して返す
Public method | ToString | 本マップの情報を文字列にして返す。 確認用です。 1要素毎に改行しています。 配列への格納順はマップの左上から右の方へ進めて右端で左端に返す様にしています。 (Overrides Object..::..ToString()()()().)
Public method | ToStringAsXml | 本マップの情報を、XMLフォーマットの文字列にして返す。 マップとしてはデフォルト形式です。 確認用です。
Public method | ToStringForRcmdr | 本マップの情報を、Rコマンダー用フォーマットの文字列にして返す 緯度・経度とマップ情報をカンマ区切りで出力します。 確認用です。
Public method | Useful(BLH) | 渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。
Public method | Useful(Pos) | 渡されたローカル座標がこのマップの範囲内にあるかどうかをBoolで返す。

Properties

 | Name | Description
Public property | Center | 本マップの中央の座標
Public property | Field | マップの座標（緯度・経度）
Public property | ImageFormat | マップを画像出力するときのフォーマット
Public property | IsErrorSize | newでセットしたマップサイズとSetMapでセットされたサイズ間に差があるとtrueとなる。
Public property | IsMapSet | マップがセット済みかどうかをtrue or falseで返す。 セットされていればtrue。
Public property | IsSizeSet | マップのサイズがセットされているかを確認する。 セットされていればtrue。
Public property | Item | 指定座標の値（例えば高度）を取得orセット 座標はマップのローカル座標（0～this.Size.x or y - 1） [0 ,0]がマップの左上を指し、xは右向きに正，yは下向きに正となります。
Public property | Length | マップのメッシュ数
Public property | Max | マップ中の最大値を取得する 走査するので少し時間がかかります。
Public property | MeshAspectRatio | メッシュのアスペクト比 N / E で定義している。つまり、1以上なら南北方向に長いメッシュである。
Public property | MeshSize | メッシュサイズ 南北方向・東西方向のメッシュの平均的サイズ[m]です。
Public property | Min | マップ中の最大値を取得する 走査するので少し時間がかかります。
Public property | Size | マップのサイズ メッシュの数でカウントしたマップのサイズを返します。

See Also

Map Class
GIS.MapBase Namespace


Map Constructor

[image] [image]

A Sandcastle Documented Class Library
Map Constructor
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Map(RectangleField) | マップの領域を指定してインスタンスを生成するコンストラクタ 座標計算を特に使用しない場合を想定しています。 マップのサイズはマップデータの代入時に決定されます。 また、この時にマップデータのインスタンスが確保されます。
Public method | Map(Map) | コピーコンストラクタ パレメータを始め全てのパラメータをコピーしたインスタンスを生成します。
Public method | Map(RectangleField, Pos) | 領域の角の座標とマップのサイズ（ピクセル数）を指定することでマップを生成するコンストラクタ マップは0で初期化されます。
Public method | Map(RectangleField, Length) | 領域の角の座標とメッシュサイズを指定することでマップを生成するコンストラクタ マップの境界値が曖昧だけども任意のマップを生成したいという場合を想定しています。 なお、角の座標値はメッシュサイズに合わせて微調整されます。 マップは0で初期化されます。

See Also

Map Class
Map Members
GIS.MapBase Namespace


Map Constructor ()

[image]

A Sandcastle Documented Class Library
Map Constructor ()
Map Class See Also Send Feedback
マップの領域を指定してインスタンスを生成するコンストラクタ

座標計算を特に使用しない場合を想定しています。 マップのサイズはマップデータの代入時に決定されます。 また、この時にマップデータのインスタンスが確保されます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map(
    RectangleField field
)
Visual Basic
Public Sub New ( _
    field As RectangleField _
)
Visual C++
public:
Map(
    RectangleField^ field
)

Parameters

field
Type: RectangleField
マップの領域情報

See Also

Map Class
Map Overload
GIS.MapBase Namespace


Map Constructor (Map)

[image]

A Sandcastle Documented Class Library
Map Constructor (Map)
Map Class See Also Send Feedback
コピーコンストラクタ

パレメータを始め全てのパラメータをコピーしたインスタンスを生成します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map(
    Map map
)
Visual Basic
Public Sub New ( _
    map As Map _
)
Visual C++
public:
Map(
    Map^ map
)

Parameters

map
Type: GIS.MapBase..::..Map
コピー元のマップ

See Also

Map Class
Map Overload
GIS.MapBase Namespace


Map Constructor (, Pos)

[image]

A Sandcastle Documented Class Library
Map Constructor (, Pos)
Map Class See Also Send Feedback
領域の角の座標とマップのサイズ（ピクセル数）を指定することでマップを生成するコンストラクタ

マップは0で初期化されます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map(
    RectangleField field,
    Pos _size
)
Visual Basic
Public Sub New ( _
    field As RectangleField, _
    _size As Pos _
)
Visual C++
public:
Map(
    RectangleField^ field,
    Pos _size
)

Parameters

field
Type: RectangleField
マップの領域情報
_size
Type: GIS.MapBase..::..Pos
縦横のマップサイズ

See Also

Map Class
Map Overload
GIS.MapBase Namespace


Map Constructor (, )

[image]

A Sandcastle Documented Class Library
Map Constructor (, )
Map Class See Also Send Feedback
領域の角の座標とメッシュサイズを指定することでマップを生成するコンストラクタ

マップの境界値が曖昧だけども任意のマップを生成したいという場合を想定しています。 なお、角の座標値はメッシュサイズに合わせて微調整されます。 マップは0で初期化されます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map(
    RectangleField field,
    Length _meshSize
)
Visual Basic
Public Sub New ( _
    field As RectangleField, _
    _meshSize As Length _
)
Visual C++
public:
Map(
    RectangleField^ field,
    Length _meshSize
)

Parameters

field
Type: RectangleField
作りたいマップの領域情報（緯度・経度）
_meshSize
Type: Length
メッシュサイズ[m]

See Also

Map Class
Map Overload
GIS.MapBase Namespace


Map Methods

[image] [image]

A Sandcastle Documented Class Library
Map Methods
Map Class See Also Send Feedback

The Map type exposes the following members.

Methods

 | Name | Description
Public method | AddValue(BLH, Single) | 座標（緯度・経度）に指定された値を加算する 加算値は負数でも構いません。
Public method | AddValue(Pos, Single) | 座標（マップ内のローカル座標）に指定された値を加算する 加算値は負数でも構いません。
Public method | AddValues(array<BLH>[]()[][], array<Single>[]()[][]) | 座標（緯度・経度の配列）に指定された値（配列）を加算する
Public method | AddValues(array<Pos>[]()[][], array<Single>[]()[][]) | 座標（マップ内のローカル座標）に指定された値（配列）を加算する
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetDifferentialPosition | 指定された座標を中心として、指定された相対アドレスの緯度と経度を返します。
Public method | GetDistance | 2地点間の距離[m]を返す
Public method | GetField | 指定された座標を中心とした、指定された半径 mを収めることができる領域を返す 返す領域はマップの領域から外に出ることも有り得ます。
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMap | マップを2次元配列で返す インスタンスは新たに生成しないので、高速アクセス・操作が可能です。 ただし、値をいじるとマップも変わるので注意して下さい。
Public method | GetMapBetween | 指定値の間にある値を持つ地点をマーキングしたマップを返す なお、条件には指定値は含まれない。 2つの引数が同値であれば無評価となり、0で初期化されたマップが返ります。
Public method | GetMapHigher | 指定値よりも高い値を持つ地点をマーキングしたマップを返す 返されたマップは、1.0を条件成立とする。条件不成立は0.0とする。
Public method | GetMapLower | 指定値よりも低い値を持つ地点をマーキングしたマップを返す 返されたマップは、1.0を条件成立とする。条件不成立は0.0とする。
Public method | GetMapMatch(Single) | 指定値にマッチする地点をマーキングしたマップを返す 指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。 走査範囲はマップ全体となります。
Public method | GetMapMatch(Single, MapField) | 指定値にマッチする地点をマーキングしたマップを返す 指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。 走査範囲については、fieldで指定して下さい。
Public method | GetMatchPosArray(Single) | 指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。 GetMapMatchを使用して、フラグの立った地点を配列として返します。 走査範囲はマップ全体となります。
Public method | GetMatchPosArray(Single, MapField) | 指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。 GetMapMatchを使用して、フラグの立った地点を配列として返します。 走査範囲については、fieldで指定して下さい。
Public method | GetMeshCorner | 指定座標の属するメッシュの右上・左上の座標を返す 任意に作出されたマップの位置を本クラスのメッシュ位置と一致させる用途での仕様を想定しています。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(BLH) | 指定座標のマップデータを返す 計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度
Public method | GetValue(Pos) | 指定座標のマップデータを返す マップ内のローカル座標を指定して下さい。
Public method | Initialize | マップの初期化メソッド マップサイズを定義済みであれば、マップの初期化を行います。 マップサイズが定義済みかどうかはIsSizeSetメソッドを参照してご確認ください。 なお、マップデータはデフォルトでは0.0fで上書きされます。
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Position2XYaddress | 指定座標のx,yアドレスを返す マップの要素番号は0～size-1であることに注意してください。 本メソッドはマップ領域外の座標を指定された場合でも本マップ内の相対アドレスを返します。
Public method | SaveAsImage | マップを画像として保存する 保存形式はImageFormatプロパティを通して設定可能です。 個人的都合により、値が非値もしくは0.0以下の箇所では背景として黒色を採用しています。 これは使いにくする仕様になっていますので、その内カラ―スケールを導入するかもしれません。 ファイルの出力には実時間で通常2秒以上かかりますのでTaskを利用して処理がすぐ戻るようにしています。 処理が戻った時点ではファイルができていないことにご注意ください。
Public method | SaveFileAsXml | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SaveFileForRcmdr | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SetMapData | マップデータをセットする データはディープコピーされます。
Public method | ToBLHarray | ローカルアドレスの配列を緯度・経度の配列へ変換して返す
Public method | ToString | 本マップの情報を文字列にして返す。 確認用です。 1要素毎に改行しています。 配列への格納順はマップの左上から右の方へ進めて右端で左端に返す様にしています。 (Overrides Object..::..ToString()()()().)
Public method | ToStringAsXml | 本マップの情報を、XMLフォーマットの文字列にして返す。 マップとしてはデフォルト形式です。 確認用です。
Public method | ToStringForRcmdr | 本マップの情報を、Rコマンダー用フォーマットの文字列にして返す 緯度・経度とマップ情報をカンマ区切りで出力します。 確認用です。
Public method | Useful(BLH) | 渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。
Public method | Useful(Pos) | 渡されたローカル座標がこのマップの範囲内にあるかどうかをBoolで返す。

See Also

Map Class
GIS.MapBase Namespace


AddValue Method

[image] [image]

A Sandcastle Documented Class Library
Map..::..AddValue Method
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddValue(BLH, Single) | 座標（緯度・経度）に指定された値を加算する 加算値は負数でも構いません。
Public method | AddValue(Pos, Single) | 座標（マップ内のローカル座標）に指定された値を加算する 加算値は負数でも構いません。

See Also

Map Class
Map Members
GIS.MapBase Namespace


AddValue Method (, Single)

[image]

A Sandcastle Documented Class Library
Map..::..AddValue Method (, Single)
Map Class See Also Send Feedback
座標（緯度・経度）に指定された値を加算する

加算値は負数でも構いません。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddValue(
    BLH _position,
    float value
)
Visual Basic
Public Sub AddValue ( _
    _position As BLH, _
    value As Single _
)
Visual C++
public:
void AddValue(
    BLH _position,
    float value
)

Parameters

_position
Type: BLH
指定座標（緯度・経度）
value
Type: System..::..Single
加算値

See Also

Map Class
AddValue Overload
GIS.MapBase Namespace


AddValue Method (Pos, Single)

[image]

A Sandcastle Documented Class Library
Map..::..AddValue Method (Pos, Single)
Map Class See Also Send Feedback
座標（マップ内のローカル座標）に指定された値を加算する

加算値は負数でも構いません。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddValue(
    Pos _position,
    float value
)
Visual Basic
Public Sub AddValue ( _
    _position As Pos, _
    value As Single _
)
Visual C++
public:
void AddValue(
    Pos _position,
    float value
)

Parameters

_position
Type: GIS.MapBase..::..Pos
指定座標（マップ内のローカル座標）
value
Type: System..::..Single
加算値

See Also

Map Class
AddValue Overload
GIS.MapBase Namespace


AddValues Method

[image] [image]

A Sandcastle Documented Class Library
Map..::..AddValues Method
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddValues(array<BLH>[]()[][], array<Single>[]()[][]) | 座標（緯度・経度の配列）に指定された値（配列）を加算する
Public method | AddValues(array<Pos>[]()[][], array<Single>[]()[][]) | 座標（マップ内のローカル座標）に指定された値（配列）を加算する

See Also

Map Class
Map Members
GIS.MapBase Namespace


AddValues Method ([], Single[])

[image]

A Sandcastle Documented Class Library
Map..::..AddValues Method (array<>[]()[][], array<Single>[]()[][])
Map Class See Also Send Feedback
座標（緯度・経度の配列）に指定された値（配列）を加算する

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddValues(
    BLH[] _position,
    float[] values
)
Visual Basic
Public Sub AddValues ( _
    _position As BLH(), _
    values As Single() _
)
Visual C++
public:
void AddValues(
    array<BLH>^ _position,
    array<float>^ values
)

Parameters

_position
Type: array<BLH>[]()[][]
指定座標配列（緯度・経度）
values
Type: array< System..::..Single >[]()[][]
加算値の配列（座標毎に個別に指定可能です）

See Also

Map Class
AddValues Overload
GIS.MapBase Namespace


AddValues Method (Pos[], Single[])

[image]

A Sandcastle Documented Class Library
Map..::..AddValues Method (array<Pos>[]()[][], array<Single>[]()[][])
Map Class See Also Send Feedback
座標（マップ内のローカル座標）に指定された値（配列）を加算する

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddValues(
    Pos[] _position,
    float[] values
)
Visual Basic
Public Sub AddValues ( _
    _position As Pos(), _
    values As Single() _
)
Visual C++
public:
void AddValues(
    array<Pos>^ _position,
    array<float>^ values
)

Parameters

_position
Type: array< GIS.MapBase..::..Pos >[]()[][]
指定座標配列
values
Type: array< System..::..Single >[]()[][]
加算値の配列（座標毎に個別に指定可能です）

See Also

Map Class
AddValues Overload
GIS.MapBase Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
Map..::..Finalize Method
Map Class See Also Send Feedback
デスコンストラクタ

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

Map Class
GIS.MapBase Namespace


GetDifferentialPosition Method

[image]

A Sandcastle Documented Class Library
Map..::..GetDifferentialPosition Method
Map Class See Also Send Feedback
指定された座標を中心として、指定された相対アドレスの緯度と経度を返します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH GetDifferentialPosition(
    BLH _center_position,
    Pos _delta_address
)
Visual Basic
Public Function GetDifferentialPosition ( _
    _center_position As BLH, _
    _delta_address As Pos _
) As BLH
Visual C++
public:
BLH GetDifferentialPosition(
    BLH _center_position,
    Pos _delta_address
)

Parameters

_center_position
Type: BLH
指定座標
_delta_address
Type: GIS.MapBase..::..Pos
相対座標（メッシュ数でカウントする）

Return Value

指定された座標のマップ情報を返す

See Also

Map Class
GIS.MapBase Namespace


GetDistance Method

[image]

A Sandcastle Documented Class Library
Map..::..GetDistance Method
Map Class See Also Send Feedback
2地点間の距離[m]を返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetDistance(
    Pos p1,
    Pos p2
)
Visual Basic
Public Function GetDistance ( _
    p1 As Pos, _
    p2 As Pos _
) As Double
Visual C++
public:
double GetDistance(
    Pos p1,
    Pos p2
)

Parameters

p1
Type: GIS.MapBase..::..Pos
地点1
p2
Type: GIS.MapBase..::..Pos
地点2

Return Value

2地点間の距離[m]

See Also

Map Class
GIS.MapBase Namespace


GetField Method

[image]

A Sandcastle Documented Class Library
Map..::..GetField Method
Map Class See Also Send Feedback
指定された座標を中心とした、指定された半径 mを収めることができる領域を返す

返す領域はマップの領域から外に出ることも有り得ます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapField GetField(
    Pos center,
    double radius
)
Visual Basic
Public Function GetField ( _
    center As Pos, _
    radius As Double _
) As MapField
Visual C++
public:
MapField GetField(
    Pos center,
    double radius
)

Parameters

center
Type: GIS.MapBase..::..Pos
中心座標
radius
Type: System..::..Double
半径[m]

Return Value

指定された範囲が収まるMapField

See Also

Map Class
GIS.MapBase Namespace


GetMap Method

[image]

A Sandcastle Documented Class Library
Map..::..GetMap Method
Map Class See Also Send Feedback
マップを2次元配列で返す

インスタンスは新たに生成しないので、高速アクセス・操作が可能です。 ただし、値をいじるとマップも変わるので注意して下さい。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[,] GetMap()
Visual Basic
Public Function GetMap As Single(,)
Visual C++
public:
array<float,2>^ GetMap()

Return Value

[Missing <returns> documentation for "M:GIS.MapBase.Map.GetMap"]

See Also

Map Class
GIS.MapBase Namespace


GetMapBetween Method

[image]

A Sandcastle Documented Class Library
Map..::..GetMapBetween Method
Map Class See Also Send Feedback
指定値の間にある値を持つ地点をマーキングしたマップを返す

なお、条件には指定値は含まれない。

2つの引数が同値であれば無評価となり、0で初期化されたマップが返ります。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map GetMapBetween(
    float value1,
    float value2
)
Visual Basic
Public Function GetMapBetween ( _
    value1 As Single, _
    value2 As Single _
) As Map
Visual C++
public:
Map^ GetMapBetween(
    float value1,
    float value2
)

Parameters

value1
Type: System..::..Single
値1
value2
Type: System..::..Single
値2

Return Value

マップ

See Also

Map Class
GIS.MapBase Namespace


GetMapHigher Method

[image]

A Sandcastle Documented Class Library
Map..::..GetMapHigher Method
Map Class See Also Send Feedback
指定値よりも高い値を持つ地点をマーキングしたマップを返す

返されたマップは、1.0を条件成立とする。条件不成立は0.0とする。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map GetMapHigher(
    float value
)
Visual Basic
Public Function GetMapHigher ( _
    value As Single _
) As Map
Visual C++
public:
Map^ GetMapHigher(
    float value
)

Parameters

value
Type: System..::..Single
閾値

Return Value

マップ

See Also

Map Class
GIS.MapBase Namespace


GetMapLower Method

[image]

A Sandcastle Documented Class Library
Map..::..GetMapLower Method
Map Class See Also Send Feedback
指定値よりも低い値を持つ地点をマーキングしたマップを返す

返されたマップは、1.0を条件成立とする。条件不成立は0.0とする。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map GetMapLower(
    float value
)
Visual Basic
Public Function GetMapLower ( _
    value As Single _
) As Map
Visual C++
public:
Map^ GetMapLower(
    float value
)

Parameters

value
Type: System..::..Single
閾値

Return Value

マップ

See Also

Map Class
GIS.MapBase Namespace


GetMapMatch Method

[image] [image]

A Sandcastle Documented Class Library
Map..::..GetMapMatch Method
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMapMatch(Single) | 指定値にマッチする地点をマーキングしたマップを返す 指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。 走査範囲はマップ全体となります。
Public method | GetMapMatch(Single, MapField) | 指定値にマッチする地点をマーキングしたマップを返す 指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。 走査範囲については、fieldで指定して下さい。

See Also

Map Class
Map Members
GIS.MapBase Namespace


GetMapMatch Method (Single)

[image]

A Sandcastle Documented Class Library
Map..::..GetMapMatch Method (Single)
Map Class See Also Send Feedback
指定値にマッチする地点をマーキングしたマップを返す

指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。

走査範囲はマップ全体となります。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map GetMapMatch(
    float value
)
Visual Basic
Public Function GetMapMatch ( _
    value As Single _
) As Map
Visual C++
public:
Map^ GetMapMatch(
    float value
)

Parameters

value
Type: System..::..Single
閾値

Return Value

マップ

See Also

Map Class
GetMapMatch Overload
GIS.MapBase Namespace


GetMapMatch Method (Single, MapField)

[image]

A Sandcastle Documented Class Library
Map..::..GetMapMatch Method (Single, MapField)
Map Class See Also Send Feedback
指定値にマッチする地点をマーキングしたマップを返す

指定座標の周囲を考慮して、指定値が指定座標の持つ値と合致するかをチェックし、合致した地点を1.0としたマップを返します。

走査範囲については、fieldで指定して下さい。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Map GetMapMatch(
    float value,
    MapField field
)
Visual Basic
Public Function GetMapMatch ( _
    value As Single, _
    field As MapField _
) As Map
Visual C++
public:
Map^ GetMapMatch(
    float value,
    MapField field
)

Parameters

value
Type: System..::..Single
閾値
field
Type: GIS.MapBase..::..MapField
マップ中の走査範囲領域

Return Value

マップ

See Also

Map Class
GetMapMatch Overload
GIS.MapBase Namespace


GetMatchPosArray Method

[image] [image]

A Sandcastle Documented Class Library
Map..::..GetMatchPosArray Method
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMatchPosArray(Single) | 指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。 GetMapMatchを使用して、フラグの立った地点を配列として返します。 走査範囲はマップ全体となります。
Public method | GetMatchPosArray(Single, MapField) | 指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。 GetMapMatchを使用して、フラグの立った地点を配列として返します。 走査範囲については、fieldで指定して下さい。

See Also

Map Class
Map Members
GIS.MapBase Namespace


GetMatchPosArray Method (Single)

[image]

A Sandcastle Documented Class Library
Map..::..GetMatchPosArray Method (Single)
Map Class See Also Send Feedback
指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。

GetMapMatchを使用して、フラグの立った地点を配列として返します。

走査範囲はマップ全体となります。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos[] GetMatchPosArray(
    float value
)
Visual Basic
Public Function GetMatchPosArray ( _
    value As Single _
) As Pos()
Visual C++
public:
array<Pos>^ GetMatchPosArray(
    float value
)

Parameters

value
Type: System..::..Single
閾値

Return Value

マッチした地点の座標を配列にしたもの

See Also

Map Class
GetMatchPosArray Overload
GIS.MapBase Namespace


GetMatchPosArray Method (Single, MapField)

[image]

A Sandcastle Documented Class Library
Map..::..GetMatchPosArray Method (Single, MapField)
Map Class See Also Send Feedback
指定値にマッチする地点の座標（マップのローカル座標）を配列で返します。

GetMapMatchを使用して、フラグの立った地点を配列として返します。

走査範囲については、fieldで指定して下さい。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos[] GetMatchPosArray(
    float value,
    MapField field
)
Visual Basic
Public Function GetMatchPosArray ( _
    value As Single, _
    field As MapField _
) As Pos()
Visual C++
public:
array<Pos>^ GetMatchPosArray(
    float value,
    MapField field
)

Parameters

value
Type: System..::..Single
閾値
field
Type: GIS.MapBase..::..MapField
マップ中の走査範囲領域

Return Value

マッチした地点の座標を配列にしたもの

See Also

Map Class
GetMatchPosArray Overload
GIS.MapBase Namespace


GetMeshCorner Method

[image]

A Sandcastle Documented Class Library
Map..::..GetMeshCorner Method
Map Class See Also Send Feedback
指定座標の属するメッシュの右上・左上の座標を返す

任意に作出されたマップの位置を本クラスのメッシュ位置と一致させる用途での仕様を想定しています。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RectangleField GetMeshCorner(
    BLH _position
)
Visual Basic
Public Function GetMeshCorner ( _
    _position As BLH _
) As RectangleField
Visual C++
public:
RectangleField^ GetMeshCorner(
    BLH _position
)

Parameters

_position
Type: BLH
指定座標（緯度・経度）

Return Value

メッシュの右上・左上の座標（緯度・経度）

See Also

Map Class
GIS.MapBase Namespace


GetValue Method

[image] [image]

A Sandcastle Documented Class Library
Map..::..GetValue Method
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetValue(BLH) | 指定座標のマップデータを返す 計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度
Public method | GetValue(Pos) | 指定座標のマップデータを返す マップ内のローカル座標を指定して下さい。

See Also

Map Class
Map Members
GIS.MapBase Namespace


GetValue Method ()

[image]

A Sandcastle Documented Class Library
Map..::..GetValue Method ()
Map Class See Also Send Feedback
指定座標のマップデータを返す

計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float GetValue(
    BLH _position
)
Visual Basic
Public Function GetValue ( _
    _position As BLH _
) As Single
Visual C++
public:
float GetValue(
    BLH _position
)

Parameters

_position
Type: BLH
座標（lat,lon）

Return Value

指定座標のマップデータ。ただし、該当なしの場合はfloat.NaNを返す。

See Also

Map Class
GetValue Overload
GIS.MapBase Namespace


GetValue Method (Pos)

[image]

A Sandcastle Documented Class Library
Map..::..GetValue Method (Pos)
Map Class See Also Send Feedback
指定座標のマップデータを返す

マップ内のローカル座標を指定して下さい。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float GetValue(
    Pos _pos
)
Visual Basic
Public Function GetValue ( _
    _pos As Pos _
) As Single
Visual C++
public:
float GetValue(
    Pos _pos
)

Parameters

_pos
Type: GIS.MapBase..::..Pos
マップ内のローカル座標

Return Value

指定座標があれば指定されたマップ内の値を返す。無ければfloat.NaNを返す。

See Also

Map Class
GetValue Overload
GIS.MapBase Namespace


Initialize Method

[image]

A Sandcastle Documented Class Library
Map..::..Initialize Method
Map Class See Also Send Feedback
マップの初期化メソッド

マップサイズを定義済みであれば、マップの初期化を行います。 マップサイズが定義済みかどうかはIsSizeSetメソッドを参照してご確認ください。 なお、マップデータはデフォルトでは0.0fで上書きされます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Initialize(
    float _value
)
Visual Basic
Public Sub Initialize ( _
    _value As Single _
)
Visual C++
public:
void Initialize(
    float _value
)

Parameters

_value
Type: System..::..Single
初期化で埋めたい数値

省略すると0.0とします。

See Also

Map Class
GIS.MapBase Namespace


Position2XYaddress Method

[image]

A Sandcastle Documented Class Library
Map..::..Position2XYaddress Method
Map Class See Also Send Feedback
指定座標のx,yアドレスを返す

マップの要素番号は0～size-1であることに注意してください。 本メソッドはマップ領域外の座標を指定された場合でも本マップ内の相対アドレスを返します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos Position2XYaddress(
    BLH _position
)
Visual Basic
Public Function Position2XYaddress ( _
    _position As BLH _
) As Pos
Visual C++
public:
Pos Position2XYaddress(
    BLH _position
)

Parameters

_position
Type: BLH
指定座標（緯度・経度）

Return Value

x,yアドレス

See Also

Map Class
GIS.MapBase Namespace


SaveAsImage Method

[image]

A Sandcastle Documented Class Library
Map..::..SaveAsImage Method
Map Class See Also Send Feedback
マップを画像として保存する

保存形式はImageFormatプロパティを通して設定可能です。

個人的都合により、値が非値もしくは0.0以下の箇所では背景として黒色を採用しています。 これは使いにくする仕様になっていますので、その内カラ―スケールを導入するかもしれません。

ファイルの出力には実時間で通常2秒以上かかりますのでTaskを利用して処理がすぐ戻るようにしています。 処理が戻った時点ではファイルができていないことにご注意ください。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SaveAsImage(
    string fname
)
Visual Basic
Public Function SaveAsImage ( _
    fname As String _
) As String
Visual C++
public:
String^ SaveAsImage(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

Return Value

保存したファイルのフルパス

See Also

Map Class
GIS.MapBase Namespace


SaveFileAsXml Method

[image]

A Sandcastle Documented Class Library
Map..::..SaveFileAsXml Method
Map Class See Also Send Feedback
指定ファイル名でデータを保存する

KMLに加工するメソッドもその内作りたいなぁ。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveFileAsXml(
    string fname
)
Visual Basic
Public Sub SaveFileAsXml ( _
    fname As String _
)
Visual C++
public:
void SaveFileAsXml(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

Map Class
GIS.MapBase Namespace


SaveFileForRcmdr Method

[image]

A Sandcastle Documented Class Library
Map..::..SaveFileForRcmdr Method
Map Class See Also Send Feedback
指定ファイル名でデータを保存する

KMLに加工するメソッドもその内作りたいなぁ。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveFileForRcmdr(
    string fname
)
Visual Basic
Public Sub SaveFileForRcmdr ( _
    fname As String _
)
Visual C++
public:
void SaveFileForRcmdr(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

Map Class
GIS.MapBase Namespace


SetMapData Method

[image]

A Sandcastle Documented Class Library
Map..::..SetMapData Method
Map Class See Also Send Feedback
マップデータをセットする

データはディープコピーされます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetMapData(
    float[,] _map
)
Visual Basic
Public Sub SetMapData ( _
    _map As Single(,) _
)
Visual C++
public:
void SetMapData(
    array<float,2>^ _map
)

Parameters

_map
Type: array< System..::..Single ,2>[,](,)[,][,]
マップのラスタデータ

See Also

Map Class
GIS.MapBase Namespace


ToBLHarray Method

[image]

A Sandcastle Documented Class Library
Map..::..ToBLHarray Method
Map Class See Also Send Feedback
ローカルアドレスの配列を緯度・経度の配列へ変換して返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH[] ToBLHarray(
    Pos[] posArray
)
Visual Basic
Public Function ToBLHarray ( _
    posArray As Pos() _
) As BLH()
Visual C++
public:
array<BLH>^ ToBLHarray(
    array<Pos>^ posArray
)

Parameters

posArray
Type: array< GIS.MapBase..::..Pos >[]()[][]
ローカルアドレスの配列

Return Value

緯度・経度に変換した配列

See Also

Map Class
GIS.MapBase Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
Map..::..ToString Method
Map Class See Also Send Feedback
本マップの情報を文字列にして返す。

確認用です。 1要素毎に改行しています。 配列への格納順はマップの左上から右の方へ進めて右端で左端に返す様にしています。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:GIS.MapBase.Map.ToString"]

See Also

Map Class
GIS.MapBase Namespace


ToStringAsXml Method

[image]

A Sandcastle Documented Class Library
Map..::..ToStringAsXml Method
Map Class See Also Send Feedback
本マップの情報を、XMLフォーマットの文字列にして返す。

マップとしてはデフォルト形式です。 確認用です。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToStringAsXml()
Visual Basic
Public Function ToStringAsXml As String
Visual C++
public:
String^ ToStringAsXml()

Return Value

[Missing <returns> documentation for "M:GIS.MapBase.Map.ToStringAsXml"]

See Also

Map Class
GIS.MapBase Namespace


ToStringForRcmdr Method

[image]

A Sandcastle Documented Class Library
Map..::..ToStringForRcmdr Method
Map Class See Also Send Feedback
本マップの情報を、Rコマンダー用フォーマットの文字列にして返す

緯度・経度とマップ情報をカンマ区切りで出力します。 確認用です。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToStringForRcmdr()
Visual Basic
Public Function ToStringForRcmdr As String
Visual C++
public:
String^ ToStringForRcmdr()

Return Value

[Missing <returns> documentation for "M:GIS.MapBase.Map.ToStringForRcmdr"]

See Also

Map Class
GIS.MapBase Namespace


Useful Method

[image] [image]

A Sandcastle Documented Class Library
Map..::..Useful Method
Map Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Useful(BLH) | 渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。
Public method | Useful(Pos) | 渡されたローカル座標がこのマップの範囲内にあるかどうかをBoolで返す。

See Also

Map Class
Map Members
GIS.MapBase Namespace


Useful Method ()

[image]

A Sandcastle Documented Class Library
Map..::..Useful Method ()
Map Class See Also Send Feedback
渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Useful(
    BLH _position
)
Visual Basic
Public Function Useful ( _
    _position As BLH _
) As Boolean
Visual C++
public:
bool Useful(
    BLH _position
)

Parameters

_position
Type: BLH
検査座標

Return Value

trueなら使用可能

See Also

Map Class
Useful Overload
GIS.MapBase Namespace


Useful Method (Pos)

[image]

A Sandcastle Documented Class Library
Map..::..Useful Method (Pos)
Map Class See Also Send Feedback
渡されたローカル座標がこのマップの範囲内にあるかどうかをBoolで返す。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Useful(
    Pos _position
)
Visual Basic
Public Function Useful ( _
    _position As Pos _
) As Boolean
Visual C++
public:
bool Useful(
    Pos _position
)

Parameters

_position
Type: GIS.MapBase..::..Pos
検査座標

Return Value

trueなら使用可能

Exceptions

Exception | Condition
System..::..SystemException | マップサイズがセットされていなければスロー

See Also

Map Class
Useful Overload
GIS.MapBase Namespace


Map Properties

[image] [image]

A Sandcastle Documented Class Library
Map Properties
Map Class See Also Send Feedback

The Map type exposes the following members.

Properties

 | Name | Description
Public property | Center | 本マップの中央の座標
Public property | Field | マップの座標（緯度・経度）
Public property | ImageFormat | マップを画像出力するときのフォーマット
Public property | IsErrorSize | newでセットしたマップサイズとSetMapでセットされたサイズ間に差があるとtrueとなる。
Public property | IsMapSet | マップがセット済みかどうかをtrue or falseで返す。 セットされていればtrue。
Public property | IsSizeSet | マップのサイズがセットされているかを確認する。 セットされていればtrue。
Public property | Item | 指定座標の値（例えば高度）を取得orセット 座標はマップのローカル座標（0～this.Size.x or y - 1） [0 ,0]がマップの左上を指し、xは右向きに正，yは下向きに正となります。
Public property | Length | マップのメッシュ数
Public property | Max | マップ中の最大値を取得する 走査するので少し時間がかかります。
Public property | MeshAspectRatio | メッシュのアスペクト比 N / E で定義している。つまり、1以上なら南北方向に長いメッシュである。
Public property | MeshSize | メッシュサイズ 南北方向・東西方向のメッシュの平均的サイズ[m]です。
Public property | Min | マップ中の最大値を取得する 走査するので少し時間がかかります。
Public property | Size | マップのサイズ メッシュの数でカウントしたマップのサイズを返します。

See Also

Map Class
GIS.MapBase Namespace


Center Property

[image]

A Sandcastle Documented Class Library
Map..::..Center Property
Map Class See Also Send Feedback
本マップの中央の座標

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH Center { get; }
Visual Basic
Public ReadOnly Property Center As BLH
    Get
Visual C++
public:
property BLH Center {
    BLH get ();
}

See Also

Map Class
GIS.MapBase Namespace


Field Property

[image]

A Sandcastle Documented Class Library
Map..::..Field Property
Map Class See Also Send Feedback
マップの座標（緯度・経度）

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RectangleField Field { get; set; }
Visual Basic
Public Property Field As RectangleField
    Get
    Set
Visual C++
public:
property RectangleField^ Field {
    RectangleField^ get ();
    void set (RectangleField^ value);
}

See Also

Map Class
GIS.MapBase Namespace


ImageFormat Property

[image]

A Sandcastle Documented Class Library
Map..::..ImageFormat Property
Map Class See Also Send Feedback
マップを画像出力するときのフォーマット

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ImageFormat ImageFormat { get; set; }
Visual Basic
Public Property ImageFormat As ImageFormat
    Get
    Set
Visual C++
public:
property ImageFormat^ ImageFormat {
    ImageFormat^ get ();
    void set (ImageFormat^ value);
}

See Also

Map Class
GIS.MapBase Namespace


IsErrorSize Property

[image]

A Sandcastle Documented Class Library
Map..::..IsErrorSize Property
Map Class See Also Send Feedback
newでセットしたマップサイズとSetMapでセットされたサイズ間に差があるとtrueとなる。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsErrorSize { get; }
Visual Basic
Public ReadOnly Property IsErrorSize As Boolean
    Get
Visual C++
public:
property bool IsErrorSize {
    bool get ();
}

See Also

Map Class
GIS.MapBase Namespace


IsMapSet Property

[image]

A Sandcastle Documented Class Library
Map..::..IsMapSet Property
Map Class See Also Send Feedback
マップがセット済みかどうかをtrue or falseで返す。

セットされていればtrue。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsMapSet { get; }
Visual Basic
Public ReadOnly Property IsMapSet As Boolean
    Get
Visual C++
public:
property bool IsMapSet {
    bool get ();
}

See Also

Map Class
GIS.MapBase Namespace


IsSizeSet Property

[image]

A Sandcastle Documented Class Library
Map..::..IsSizeSet Property
Map Class See Also Send Feedback
マップのサイズがセットされているかを確認する。 セットされていればtrue。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSizeSet { get; }
Visual Basic
Public ReadOnly Property IsSizeSet As Boolean
    Get
Visual C++
public:
property bool IsSizeSet {
    bool get ();
}

See Also

Map Class
GIS.MapBase Namespace


Item Property

[image]

A Sandcastle Documented Class Library
Map..::..Item Property
Map Class See Also Send Feedback
指定座標の値（例えば高度）を取得orセット

座標はマップのローカル座標（0～this.Size.x or y - 1）

[0 ,0]がマップの左上を指し、xは右向きに正，yは下向きに正となります。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float this[
    int x,
    int y
] { get; set; }
Visual Basic
Public Default Property Item ( _
    x As Integer, _
    y As Integer _
) As Single
    Get
    Set
Visual C++
public:
property float default[int x, int y] {
    float get (int x, int y);
    void set (int x, int y, float value);
}

Parameters

x
Type: System..::..Int32
x座標
y
Type: System..::..Int32
y座標

Return Value

マップの値

See Also

Map Class
GIS.MapBase Namespace


Length Property

[image]

A Sandcastle Documented Class Library
Map..::..Length Property
Map Class See Also Send Feedback
マップのメッシュ数

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
Visual C++
public:
property int Length {
    int get ();
}

See Also

Map Class
GIS.MapBase Namespace


Max Property

[image]

A Sandcastle Documented Class Library
Map..::..Max Property
Map Class See Also Send Feedback
マップ中の最大値を取得する

走査するので少し時間がかかります。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float Max { get; }
Visual Basic
Public ReadOnly Property Max As Single
    Get
Visual C++
public:
property float Max {
    float get ();
}

See Also

Map Class
GIS.MapBase Namespace


MeshAspectRatio Property

[image]

A Sandcastle Documented Class Library
Map..::..MeshAspectRatio Property
Map Class See Also Send Feedback
メッシュのアスペクト比

N / E で定義している。つまり、1以上なら南北方向に長いメッシュである。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MeshAspectRatio { get; }
Visual Basic
Public ReadOnly Property MeshAspectRatio As Double
    Get
Visual C++
public:
property double MeshAspectRatio {
    double get ();
}

See Also

Map Class
GIS.MapBase Namespace


MeshSize Property

[image]

A Sandcastle Documented Class Library
Map..::..MeshSize Property
Map Class See Also Send Feedback
メッシュサイズ

南北方向・東西方向のメッシュの平均的サイズ[m]です。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Length MeshSize { get; protected set; }
Visual Basic
Public Property MeshSize As Length
    Get
    Protected Set
Visual C++
public:
property Length MeshSize {
    Length get ();
    protected: void set (Length value);
}

See Also

Map Class
GIS.MapBase Namespace


Min Property

[image]

A Sandcastle Documented Class Library
Map..::..Min Property
Map Class See Also Send Feedback
マップ中の最大値を取得する

走査するので少し時間がかかります。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float Min { get; }
Visual Basic
Public ReadOnly Property Min As Single
    Get
Visual C++
public:
property float Min {
    float get ();
}

See Also

Map Class
GIS.MapBase Namespace


Size Property

[image]

A Sandcastle Documented Class Library
Map..::..Size Property
Map Class See Also Send Feedback
マップのサイズ

メッシュの数でカウントしたマップのサイズを返します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos Size { get; protected set; }
Visual Basic
Public Property Size As Pos
    Get
    Protected Set
Visual C++
public:
property Pos Size {
    Pos get ();
    protected: void set (Pos value);
}

See Also

Map Class
GIS.MapBase Namespace


MapField Structure

[image]

A Sandcastle Documented Class Library
MapField Structure
Members See Also Send Feedback
マップ中の領域を整数値アドレスで表す構造体

Mapクラスのメソッドに対して領域を指定するのに使用することを想定しています。

インスタンス生成後、オブジェクト自身の領域を拡大することはできても縮小はできません。And()をうまく利用してください。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct MapField
Visual Basic
Public Structure MapField
Visual C++
public value class MapField

See Also

MapField Members
GIS.MapBase Namespace


MapField Members

[image] [image]

A Sandcastle Documented Class Library
MapField Members
MapField Structure Constructors Methods Properties See Also Send Feedback

The MapField type exposes the following members.

Constructors

 | Name | Description
Public method | MapField(Pos) | 1つの座標をセットするコンストラクタ 自動的にPos(0, 0)をもう一点として張ります。 マップのサイズを表すのに便利かと思います。
Public method | MapField(Pos, Pos) | 2つの座標をセットするコンストラクタ 指定した座標の大小関係からマップの座標を自動的に決定します。

Methods

 | Name | Description
Public method | And | 引数で渡された領域と重ね合わせ、共通の領域を返す
Public method | CheckInclusion | 任意の地点が領域内にあるか確認する
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | 座標をセットして領域を再設定・拡張する 領域の中の座標を設定しても無視します。
Public method | ToString | 文字列化して返す フォーマットは、「左上の座標」，「右下の座標」 (Overrides ValueType..::..ToString()()()().)
Public method | Translate | 領域を平行移動させる 破壊的メソッド（オブジェクト自身の値を変更します）

Properties

 | Name | Description
Public property | AreaIsZero | 面積が存在するかを返す true: 面積は0。
Public property | LeftX | 左端のx値
Public property | LowerLeft | 左下の座標
Public property | LowerRight | 右下の座標
Public property | LowerY | 下端のy値
Public property | RightX | 右端のx値
Public property | UpperLeft | 左上の座標
Public property | UpperRight | 右上の座標
Public property | UpperY | 上端のy値

See Also

MapField Structure
GIS.MapBase Namespace


MapField Constructor

[image] [image]

A Sandcastle Documented Class Library
MapField Constructor
MapField Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | MapField(Pos) | 1つの座標をセットするコンストラクタ 自動的にPos(0, 0)をもう一点として張ります。 マップのサイズを表すのに便利かと思います。
Public method | MapField(Pos, Pos) | 2つの座標をセットするコンストラクタ 指定した座標の大小関係からマップの座標を自動的に決定します。

See Also

MapField Structure
MapField Members
GIS.MapBase Namespace


MapField Constructor (Pos)

[image]

A Sandcastle Documented Class Library
MapField Constructor (Pos)
MapField Structure See Also Send Feedback
1つの座標をセットするコンストラクタ

自動的にPos(0, 0)をもう一点として張ります。

マップのサイズを表すのに便利かと思います。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapField(
    Pos pos
)
Visual Basic
Public Sub New ( _
    pos As Pos _
)
Visual C++
public:
MapField(
    Pos pos
)

Parameters

pos
Type: GIS.MapBase..::..Pos

[Missing <param name="pos"/> documentation for "M:GIS.MapBase.MapField.#ctor(GIS.MapBase.Pos)"]

See Also

MapField Structure
MapField Overload
GIS.MapBase Namespace


MapField Constructor (Pos, Pos)

[image]

A Sandcastle Documented Class Library
MapField Constructor (Pos, Pos)
MapField Structure See Also Send Feedback
2つの座標をセットするコンストラクタ

指定した座標の大小関係からマップの座標を自動的に決定します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapField(
    Pos x1,
    Pos x2
)
Visual Basic
Public Sub New ( _
    x1 As Pos, _
    x2 As Pos _
)
Visual C++
public:
MapField(
    Pos x1,
    Pos x2
)

Parameters

x1
Type: GIS.MapBase..::..Pos
座標1
x2
Type: GIS.MapBase..::..Pos
座標2

See Also

MapField Structure
MapField Overload
GIS.MapBase Namespace


MapField Methods

[image] [image]

A Sandcastle Documented Class Library
MapField Methods
MapField Structure See Also Send Feedback

The MapField type exposes the following members.

Methods

 | Name | Description
Public method | And | 引数で渡された領域と重ね合わせ、共通の領域を返す
Public method | CheckInclusion | 任意の地点が領域内にあるか確認する
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | 座標をセットして領域を再設定・拡張する 領域の中の座標を設定しても無視します。
Public method | ToString | 文字列化して返す フォーマットは、「左上の座標」，「右下の座標」 (Overrides ValueType..::..ToString()()()().)
Public method | Translate | 領域を平行移動させる 破壊的メソッド（オブジェクト自身の値を変更します）

See Also

MapField Structure
GIS.MapBase Namespace


And Method

[image]

A Sandcastle Documented Class Library
MapField..::..And Method
MapField Structure See Also Send Feedback
引数で渡された領域と重ね合わせ、共通の領域を返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapField And(
    MapField field
)
Visual Basic
Public Function And ( _
    field As MapField _
) As MapField
Visual C++
public:
MapField And(
    MapField field
)

Parameters

field
Type: GIS.MapBase..::..MapField
ターゲットの領域

Return Value

共通領域

See Also

MapField Structure
GIS.MapBase Namespace


CheckInclusion Method

[image]

A Sandcastle Documented Class Library
MapField..::..CheckInclusion Method
MapField Structure See Also Send Feedback
任意の地点が領域内にあるか確認する

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckInclusion(
    Pos pos
)
Visual Basic
Public Function CheckInclusion ( _
    pos As Pos _
) As Boolean
Visual C++
public:
bool CheckInclusion(
    Pos pos
)

Parameters

pos
Type: GIS.MapBase..::..Pos
検査座標

Return Value

true: 領域内にある。

See Also

MapField Structure
GIS.MapBase Namespace


Set Method

[image]

A Sandcastle Documented Class Library
MapField..::..Set Method
MapField Structure See Also Send Feedback
座標をセットして領域を再設定・拡張する

領域の中の座標を設定しても無視します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    Pos pos
)
Visual Basic
Public Sub Set ( _
    pos As Pos _
)
Visual C++
public:
void Set(
    Pos pos
)

Parameters

pos
Type: GIS.MapBase..::..Pos
指定座標

See Also

MapField Structure
GIS.MapBase Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
MapField..::..ToString Method
MapField Structure See Also Send Feedback
文字列化して返す

フォーマットは、「左上の座標」，「右下の座標」

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:GIS.MapBase.MapField.ToString"]

See Also

MapField Structure
GIS.MapBase Namespace


Translate Method

[image]

A Sandcastle Documented Class Library
MapField..::..Translate Method
MapField Structure See Also Send Feedback
領域を平行移動させる

破壊的メソッド（オブジェクト自身の値を変更します）

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Translate(
    Pos shiftAmount
)
Visual Basic
Public Sub Translate ( _
    shiftAmount As Pos _
)
Visual C++
public:
void Translate(
    Pos shiftAmount
)

Parameters

shiftAmount
Type: GIS.MapBase..::..Pos
シフト量

x成分は正値で右へ，y成分は正値で下方へ領域が平行移動します。

See Also

MapField Structure
GIS.MapBase Namespace


MapField Properties

[image] [image]

A Sandcastle Documented Class Library
MapField Properties
MapField Structure See Also Send Feedback

The MapField type exposes the following members.

Properties

 | Name | Description
Public property | AreaIsZero | 面積が存在するかを返す true: 面積は0。
Public property | LeftX | 左端のx値
Public property | LowerLeft | 左下の座標
Public property | LowerRight | 右下の座標
Public property | LowerY | 下端のy値
Public property | RightX | 右端のx値
Public property | UpperLeft | 左上の座標
Public property | UpperRight | 右上の座標
Public property | UpperY | 上端のy値

See Also

MapField Structure
GIS.MapBase Namespace


AreaIsZero Property

[image]

A Sandcastle Documented Class Library
MapField..::..AreaIsZero Property
MapField Structure See Also Send Feedback
面積が存在するかを返す

true: 面積は0。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AreaIsZero { get; }
Visual Basic
Public ReadOnly Property AreaIsZero As Boolean
    Get
Visual C++
public:
property bool AreaIsZero {
    bool get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


LeftX Property

[image]

A Sandcastle Documented Class Library
MapField..::..LeftX Property
MapField Structure See Also Send Feedback
左端のx値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LeftX { get; }
Visual Basic
Public ReadOnly Property LeftX As Integer
    Get
Visual C++
public:
property int LeftX {
    int get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


LowerLeft Property

[image]

A Sandcastle Documented Class Library
MapField..::..LowerLeft Property
MapField Structure See Also Send Feedback
左下の座標

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos LowerLeft { get; }
Visual Basic
Public ReadOnly Property LowerLeft As Pos
    Get
Visual C++
public:
property Pos LowerLeft {
    Pos get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


LowerRight Property

[image]

A Sandcastle Documented Class Library
MapField..::..LowerRight Property
MapField Structure See Also Send Feedback
右下の座標

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos LowerRight { get; }
Visual Basic
Public ReadOnly Property LowerRight As Pos
    Get
Visual C++
public:
property Pos LowerRight {
    Pos get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


LowerY Property

[image]

A Sandcastle Documented Class Library
MapField..::..LowerY Property
MapField Structure See Also Send Feedback
下端のy値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int LowerY { get; }
Visual Basic
Public ReadOnly Property LowerY As Integer
    Get
Visual C++
public:
property int LowerY {
    int get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


RightX Property

[image]

A Sandcastle Documented Class Library
MapField..::..RightX Property
MapField Structure See Also Send Feedback
右端のx値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int RightX { get; }
Visual Basic
Public ReadOnly Property RightX As Integer
    Get
Visual C++
public:
property int RightX {
    int get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


UpperLeft Property

[image]

A Sandcastle Documented Class Library
MapField..::..UpperLeft Property
MapField Structure See Also Send Feedback
左上の座標

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos UpperLeft { get; }
Visual Basic
Public ReadOnly Property UpperLeft As Pos
    Get
Visual C++
public:
property Pos UpperLeft {
    Pos get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


UpperRight Property

[image]

A Sandcastle Documented Class Library
MapField..::..UpperRight Property
MapField Structure See Also Send Feedback
右上の座標

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos UpperRight { get; }
Visual Basic
Public ReadOnly Property UpperRight As Pos
    Get
Visual C++
public:
property Pos UpperRight {
    Pos get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


UpperY Property

[image]

A Sandcastle Documented Class Library
MapField..::..UpperY Property
MapField Structure See Also Send Feedback
上端のy値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int UpperY { get; }
Visual Basic
Public ReadOnly Property UpperY As Integer
    Get
Visual C++
public:
property int UpperY {
    int get ();
}

See Also

MapField Structure
GIS.MapBase Namespace


MapLocalFeature Class

[image]

A Sandcastle Documented Class Library
MapLocalFeature Class
Members See Also Send Feedback
マップの特徴量を計算or返すクラス

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MapLocalFeature
Visual Basic
Public Class MapLocalFeature
Visual C++
public ref class MapLocalFeature

Inheritance Hierarchy

System..::..Object
GIS.MapBase..::..MapLocalFeature

See Also

MapLocalFeature Members
GIS.MapBase Namespace


MapLocalFeature Members

[image] [image]

A Sandcastle Documented Class Library
MapLocalFeature Members
MapLocalFeature Class Constructors Methods See Also Send Feedback

The MapLocalFeature type exposes the following members.

Constructors

 | Name | Description
Public method | MapLocalFeature | コンストラクタ MapBase型のマップを渡して下さい。 渡されたマップは内部で参照されます。

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFeature | 指定座標の局所的な特徴を返す 指定座標がマップの座標範囲内であれば必ず特徴データを返します。
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapLocalFeature Class
GIS.MapBase Namespace


MapLocalFeature Constructor

[image]

A Sandcastle Documented Class Library
MapLocalFeature Constructor
MapLocalFeature Class See Also Send Feedback
コンストラクタ

MapBase型のマップを渡して下さい。

渡されたマップは内部で参照されます。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapLocalFeature(
    Map _map
)
Visual Basic
Public Sub New ( _
    _map As Map _
)
Visual C++
public:
MapLocalFeature(
    Map^ _map
)

Parameters

_map
Type: GIS.MapBase..::..Map
マップ

See Also

MapLocalFeature Class
GIS.MapBase Namespace


MapLocalFeature Methods

[image] [image]

A Sandcastle Documented Class Library
MapLocalFeature Methods
MapLocalFeature Class See Also Send Feedback

The MapLocalFeature type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetFeature | 指定座標の局所的な特徴を返す 指定座標がマップの座標範囲内であれば必ず特徴データを返します。
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapLocalFeature Class
GIS.MapBase Namespace


GetFeature Method

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..GetFeature Method
MapLocalFeature Class See Also Send Feedback
指定座標の局所的な特徴を返す

指定座標がマップの座標範囲内であれば必ず特徴データを返します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapLocalFeature..::..Feature GetFeature(
    int x,
    int y
)
Visual Basic
Public Function GetFeature ( _
    x As Integer, _
    y As Integer _
) As MapLocalFeature..::..Feature
Visual C++
public:
MapLocalFeature..::..Feature GetFeature(
    int x,
    int y
)

Parameters

x
Type: System..::..Int32
指定座標x
y
Type: System..::..Int32
指定座標y

Return Value

特徴データ（構造体）

Exceptions

Exception | Condition
System..::..SystemException | マップの範囲外を指定した場合にスロー

See Also

MapLocalFeature Class
GIS.MapBase Namespace


MapLocalFeature.Feature Structure

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature Structure
MapLocalFeature Class Members See Also Send Feedback
局所的な特徴を表す構造体

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct Feature
Visual Basic
Public Structure Feature
Visual C++
public value class Feature

See Also

MapLocalFeature..::..Feature Members
GIS.MapBase Namespace


MapLocalFeature.Feature Members

[image] [image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature Members
MapLocalFeature..::..Feature Structure Constructors Methods Properties See Also Send Feedback

マップの特徴量を計算or返すクラス

The MapLocalFeature..::..Feature type exposes the following members.

Constructors

 | Name | Description
Public method | MapLocalFeature..::..Feature | コンストラクタ

Methods

 | Name | Description
Public method | CheckBetween | 指定値が範囲内にあるのかを返す
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

 | Name | Description
Public property | Center | 指定メッシュの値
Public property | Max | 指定メッシュがとり得る周囲から勘案した最高値
Public property | Min | 指定メッシュがとり得る周囲から勘案した最低値

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


MapLocalFeature.Feature Constructor

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature Constructor
MapLocalFeature..::..Feature Structure See Also Send Feedback
コンストラクタ

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Feature(
    double _center,
    double _max,
    double _min
)
Visual Basic
Public Sub New ( _
    _center As Double, _
    _max As Double, _
    _min As Double _
)
Visual C++
public:
Feature(
    double _center,
    double _max,
    double _min
)

Parameters

_center
Type: System..::..Double
注目メッシュの持つ値
_max
Type: System..::..Double
注目メッシュが取り得る最高値
_min
Type: System..::..Double
注目メッシュが取り得る最低値

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


MapLocalFeature.Feature Methods

[image] [image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature Methods
MapLocalFeature..::..Feature Structure See Also Send Feedback

The MapLocalFeature..::..Feature type exposes the following members.

Methods

 | Name | Description
Public method | CheckBetween | 指定値が範囲内にあるのかを返す
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


CheckBetween Method

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature..::..CheckBetween Method
MapLocalFeature..::..Feature Structure See Also Send Feedback
指定値が範囲内にあるのかを返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckBetween(
    double value
)
Visual Basic
Public Function CheckBetween ( _
    value As Double _
) As Boolean
Visual C++
public:
bool CheckBetween(
    double value
)

Parameters

value
Type: System..::..Double
閾値

Return Value

true：範囲内にある

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


MapLocalFeature.Feature Properties

[image] [image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature Properties
MapLocalFeature..::..Feature Structure See Also Send Feedback

The MapLocalFeature..::..Feature type exposes the following members.

Properties

 | Name | Description
Public property | Center | 指定メッシュの値
Public property | Max | 指定メッシュがとり得る周囲から勘案した最高値
Public property | Min | 指定メッシュがとり得る周囲から勘案した最低値

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


Center Property

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature..::..Center Property
MapLocalFeature..::..Feature Structure See Also Send Feedback
指定メッシュの値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Center { get; }
Visual Basic
Public ReadOnly Property Center As Double
    Get
Visual C++
public:
property double Center {
    double get ();
}

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


Max Property

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature..::..Max Property
MapLocalFeature..::..Feature Structure See Also Send Feedback
指定メッシュがとり得る周囲から勘案した最高値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Max { get; }
Visual Basic
Public ReadOnly Property Max As Double
    Get
Visual C++
public:
property double Max {
    double get ();
}

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


Min Property

[image]

A Sandcastle Documented Class Library
MapLocalFeature..::..Feature..::..Min Property
MapLocalFeature..::..Feature Structure See Also Send Feedback
指定メッシュがとり得る周囲から勘案した最低値

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Min { get; }
Visual Basic
Public ReadOnly Property Min As Double
    Get
Visual C++
public:
property double Min {
    double get ();
}

See Also

MapLocalFeature..::..Feature Structure
GIS.MapBase Namespace


Pos Structure

[image]

A Sandcastle Documented Class Library
Pos Structure
Members See Also Send Feedback
x,yの座標セット構造体

マップのアドレス計算用

相対アドレス計算用に負値にも対応しています。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct Pos : IComparable
Visual Basic
Public Structure Pos _
    Implements IComparable
Visual C++
public value class Pos : IComparable

See Also

Pos Members
GIS.MapBase Namespace


Pos Members

[image] [image]

A Sandcastle Documented Class Library
Pos Members
Pos Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The Pos type exposes the following members.

Constructors

 | Name | Description
Public method | Pos | 初期値セット機能付きコンストラクタ

Methods

 | Name | Description
Public method | CompareTo | 比較用メソッド (0,0)からの距離によって大小を判定します。
Public method | Equals | objと自分自身が等価のときはtrueを返す (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | 引数で渡した座標との距離を返す
Public method | GetHashCode | ハッシュ値を返す (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 文字列化 (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Addition | 二項+演算子（これで足し算が簡単にできる）
Equality | 比較演算子==
Inequality | 比較演算子!=
Subtraction | 二項-演算子（これで足し算が簡単にできる）

Fields

 | Name | Description
Public field | x | アドレスx
Public field | y | アドレスy

Properties

 | Name | Description
Public property | Length | 長さ（原点からの距離） Math.Sqrt(x^2 + y^2)で定義しました。

See Also

Pos Structure
GIS.MapBase Namespace


Pos Constructor

[image]

A Sandcastle Documented Class Library
Pos Constructor
Pos Structure See Also Send Feedback
初期値セット機能付きコンストラクタ

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos(
    int x0,
    int y0
)
Visual Basic
Public Sub New ( _
    x0 As Integer, _
    y0 As Integer _
)
Visual C++
public:
Pos(
    int x0,
    int y0
)

Parameters

x0
Type: System..::..Int32
xの初期値
y0
Type: System..::..Int32
yの初期値

See Also

Pos Structure
GIS.MapBase Namespace


Pos Fields

[image] [image]

A Sandcastle Documented Class Library
Pos Fields
Pos Structure See Also Send Feedback

The Pos type exposes the following members.

Fields

 | Name | Description
Public field | x | アドレスx
Public field | y | アドレスy

See Also

Pos Structure
GIS.MapBase Namespace


x Field

[image]

A Sandcastle Documented Class Library
Pos..::..x Field
Pos Structure See Also Send Feedback
アドレスx

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int x
Visual Basic
Public x As Integer
Visual C++
public:
int x

See Also

Pos Structure
GIS.MapBase Namespace


y Field

[image]

A Sandcastle Documented Class Library
Pos..::..y Field
Pos Structure See Also Send Feedback
アドレスy

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int y
Visual Basic
Public y As Integer
Visual C++
public:
int y

See Also

Pos Structure
GIS.MapBase Namespace


Pos Methods

[image] [image]

A Sandcastle Documented Class Library
Pos Methods
Pos Structure See Also Send Feedback

The Pos type exposes the following members.

Methods

 | Name | Description
Public method | CompareTo | 比較用メソッド (0,0)からの距離によって大小を判定します。
Public method | Equals | objと自分自身が等価のときはtrueを返す (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | 引数で渡した座標との距離を返す
Public method | GetHashCode | ハッシュ値を返す (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | 文字列化 (Overrides ValueType..::..ToString()()()().)

See Also

Pos Structure
GIS.MapBase Namespace


CompareTo Method

[image]

A Sandcastle Documented Class Library
Pos..::..CompareTo Method
Pos Structure See Also Send Feedback
比較用メソッド

(0,0)からの距離によって大小を判定します。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CompareTo(
    Object obj
)
Visual Basic
Public Function CompareTo ( _
    obj As Object _
) As Integer
Visual C++
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: System..::..Object
比較したいPos型変数

Return Value

引数の方が大きければ負値を返す

Implements

IComparable..::..CompareTo(Object)

See Also

Pos Structure
GIS.MapBase Namespace


Equals Method

[image]

A Sandcastle Documented Class Library
Pos..::..Equals Method
Pos Structure See Also Send Feedback
objと自分自身が等価のときはtrueを返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
比較したいオブジェクト

Return Value

等価であればtrue

See Also

Pos Structure
GIS.MapBase Namespace


GetDistance Method

[image]

A Sandcastle Documented Class Library
Pos..::..GetDistance Method
Pos Structure See Also Send Feedback
引数で渡した座標との距離を返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetDistance(
    Pos origin
)
Visual Basic
Public Function GetDistance ( _
    origin As Pos _
) As Double
Visual C++
public:
double GetDistance(
    Pos origin
)

Parameters

origin
Type: GIS.MapBase..::..Pos
始点

Return Value

距離

See Also

Pos Structure
GIS.MapBase Namespace


GetHashCode Method

[image]

A Sandcastle Documented Class Library
Pos..::..GetHashCode Method
Pos Structure See Also Send Feedback
ハッシュ値を返す

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

xとyのXOR結果

See Also

Pos Structure
GIS.MapBase Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
Pos..::..ToString Method
Pos Structure See Also Send Feedback
文字列化

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

メンバ変数x,yを文字列化したしたstring型変数

See Also

Pos Structure
GIS.MapBase Namespace


Pos Operators

[image] [image]

A Sandcastle Documented Class Library
Pos Operators
Pos Structure See Also Send Feedback

The Pos type exposes the following members.

Operators

Name | Description
Addition | 二項+演算子（これで足し算が簡単にできる）
Equality | 比較演算子==
Inequality | 比較演算子!=
Subtraction | 二項-演算子（これで足し算が簡単にできる）

See Also

Pos Structure
GIS.MapBase Namespace


Addition Operator

[image]

A Sandcastle Documented Class Library
Pos..::..Addition Operator
Pos Structure See Also Send Feedback
二項+演算子（これで足し算が簡単にできる）

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Pos operator +(
    Pos c1,
    Pos c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As Pos, _
    c2 As Pos _
) As Pos
Visual C++
public:
static Pos operator +(
    Pos c1,
    Pos c2
)

Parameters

c1
Type: GIS.MapBase..::..Pos
被加算値
c2
Type: GIS.MapBase..::..Pos
加算値

Return Value

2値を加算した結果

See Also

Pos Structure
GIS.MapBase Namespace


Equality Operator

[image]

A Sandcastle Documented Class Library
Pos..::..Equality Operator
Pos Structure See Also Send Feedback
比較演算子==

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator ==(
    Pos c1,
    Pos c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As Pos, _
    c2 As Pos _
) As Boolean
Visual C++
public:
static bool operator ==(
    Pos c1,
    Pos c2
)

Parameters

c1
Type: GIS.MapBase..::..Pos
比較対象その1
c2
Type: GIS.MapBase..::..Pos
比較対象その2

Return Value

等しければture

See Also

Pos Structure
GIS.MapBase Namespace


Inequality Operator

[image]

A Sandcastle Documented Class Library
Pos..::..Inequality Operator
Pos Structure See Also Send Feedback
比較演算子!=

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator !=(
    Pos c1,
    Pos c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As Pos, _
    c2 As Pos _
) As Boolean
Visual C++
public:
static bool operator !=(
    Pos c1,
    Pos c2
)

Parameters

c1
Type: GIS.MapBase..::..Pos
比較対象その1
c2
Type: GIS.MapBase..::..Pos
比較対象その2

Return Value

等しくなければture

See Also

Pos Structure
GIS.MapBase Namespace


Subtraction Operator

[image]

A Sandcastle Documented Class Library
Pos..::..Subtraction Operator
Pos Structure See Also Send Feedback
二項-演算子（これで足し算が簡単にできる）

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Pos operator -(
    Pos c1,
    Pos c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As Pos, _
    c2 As Pos _
) As Pos
Visual C++
public:
static Pos operator -(
    Pos c1,
    Pos c2
)

Parameters

c1
Type: GIS.MapBase..::..Pos
被減算値
c2
Type: GIS.MapBase..::..Pos
減算値

Return Value

2値の引き算の結果

See Also

Pos Structure
GIS.MapBase Namespace


Pos Properties

[image] [image]

A Sandcastle Documented Class Library
Pos Properties
Pos Structure See Also Send Feedback

The Pos type exposes the following members.

Properties

 | Name | Description
Public property | Length | 長さ（原点からの距離） Math.Sqrt(x^2 + y^2)で定義しました。

See Also

Pos Structure
GIS.MapBase Namespace


Length Property

[image]

A Sandcastle Documented Class Library
Pos..::..Length Property
Pos Structure See Also Send Feedback
長さ（原点からの距離）

Math.Sqrt(x^2 + y^2)で定義しました。

Namespace: GIS.MapBase
Assembly: GIS (in GIS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
Visual C++
public:
property int Length {
    int get ();
}

Return Value

長さ

See Also

Pos Structure
GIS.MapBase Namespace