Signal_Process Namespace

[image]

A Sandcastle Documented Class Library
Signal_Process Namespace
フィードバックの送信

["N:Signal_Process" の為の説明文 <summary> が欠落しています。]

Classes

 | Class | Description
Public class | DFT | Discrete Fourier Transformクラス 使用する際には、プロジェクトにファイルを追加した後に、ソースヘッダに以下に示すカッコ内のコードを追加して下さい。 「 using Signal_Process; 」
Public class | FFTresult | FFT処理後の観測データを扱うクラス

Structures

 | Structure | Description
Public structure | FFTdata | データ格納用構造体
Public structure | FFTresult..::..Band | 帯域を定義する構造体
Public structure | FFTresult..::..FFTresultPlusFreq | FFTの処理データと周波数をセットにした構造体

Enumerations

 | Enumeration | Description
Public enumeration | DFT..::..Window | 窓関数の種類
Public enumeration | FFT_point | FFTデータ幅 データサイズ(2^n)をこの列挙体を使って宣言すれば間違えない.


DFT Class

[image]

A Sandcastle Documented Class Library
DFT Class
Members See Also フィードバックの送信
Discrete Fourier Transformクラス 使用する際には、プロジェクトにファイルを追加した後に、ソースヘッダに以下に示すカッコ内のコードを追加して下さい。 「 using Signal_Process; 」

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DFT
Visual Basic
Public Class DFT
Visual C++
public ref class DFT

Inheritance Hierarchy

System..::..Object
Signal_Process..::..DFT

See Also

DFT Members
Signal_Process Namespace


DFT Members

[image] [image]

A Sandcastle Documented Class Library
DFT Members
DFT Class Constructors Methods Properties See Also フィードバックの送信

The DFT type exposes the following members.

Constructors

 | Name | Description
Public method | DFT(Int32, DFT..::..Window) | デフォルトでは4096ポイントFFT/IFFT，窓関数の種別としてハミングウィンドウがセットされます。 指定ポイント数が2^Nではない場合、FFT_point＜2^Nとなる最小の2^Nを採用しますので注意.
Public method | DFT(FFT_point, DFT..::..Window) | デフォルトでは4096ポイントFFT/IFFT，窓関数の種別としてハミングウィンドウがセットされます。

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Public method | FFT(array<Double>[]()[][]) | 受け渡されたデータを使用してFFTを実行する
Public method | FFT(array<FFTdata>[]()[][]) | 実部・虚部を合わせて解析するFFT/IFFTメソッド
Public method | FFT(array<Double>[]()[][], Int64) | FFTを実行する
Public method | FFT(array<FFTdata>[]()[][], Int64) | FFTを実行する
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | FFTsize | FFT/IFFTデータ幅
Public property | Max | 変換後の配列に含まれる最大値を返す
Public property | Mean | 変換後の配列に含まれる平均値を返す
Public property | WindowKind | 窓関数の種別

See Also

DFT Class
Signal_Process Namespace


DFT Constructor

[image] [image]

A Sandcastle Documented Class Library
DFT Constructor
DFT Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | DFT(Int32, DFT..::..Window) | デフォルトでは4096ポイントFFT/IFFT，窓関数の種別としてハミングウィンドウがセットされます。 指定ポイント数が2^Nではない場合、FFT_point＜2^Nとなる最小の2^Nを採用しますので注意.
Public method | DFT(FFT_point, DFT..::..Window) | デフォルトでは4096ポイントFFT/IFFT，窓関数の種別としてハミングウィンドウがセットされます。

See Also

DFT Class
DFT Members
Signal_Process Namespace


DFT Constructor (Int32, DFT.Window)

[image]

A Sandcastle Documented Class Library
DFT Constructor (Int32, DFT..::..Window)
DFT Class See Also フィードバックの送信
  デフォルトでは4096ポイントFFT/IFFT，窓関数の種別としてハミングウィンドウがセットされます。 　指定ポイント数が2^Nではない場合、FFT_point＜2^Nとなる最小の2^Nを採用しますので注意.

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DFT(
    int FFT_point,
    DFT..::..Window window_kind
)
Visual Basic
Public Sub New ( _
    FFT_point As Integer, _
    window_kind As DFT..::..Window _
)
Visual C++
public:
DFT(
    int FFT_point,
    DFT..::..Window window_kind
)

Parameters

FFT_point
Type: System..::..Int32
FFT/IFFTポイント数
window_kind
Type: Signal_Process..::..DFT..::..Window
窓関数の種類

See Also

DFT Class
DFT Overload
Signal_Process Namespace


DFT Constructor (FFT_point, DFT.Window)

[image]

A Sandcastle Documented Class Library
DFT Constructor (FFT_point, DFT..::..Window)
DFT Class See Also フィードバックの送信
  デフォルトでは4096ポイントFFT/IFFT，窓関数の種別としてハミングウィンドウがセットされます。

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DFT(
    FFT_point FFT_point,
    DFT..::..Window window_kind
)
Visual Basic
Public Sub New ( _
    FFT_point As FFT_point, _
    window_kind As DFT..::..Window _
)
Visual C++
public:
DFT(
    FFT_point FFT_point,
    DFT..::..Window window_kind
)

Parameters

FFT_point
Type: Signal_Process..::..FFT_point
FFT/IFFTポイント数
window_kind
Type: Signal_Process..::..DFT..::..Window
窓関数の種類

See Also

DFT Class
DFT Overload
Signal_Process Namespace


DFT Methods

[image] [image]

A Sandcastle Documented Class Library
DFT Methods
DFT Class See Also フィードバックの送信

The DFT type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Public method | FFT(array<Double>[]()[][]) | 受け渡されたデータを使用してFFTを実行する
Public method | FFT(array<FFTdata>[]()[][]) | 実部・虚部を合わせて解析するFFT/IFFTメソッド
Public method | FFT(array<Double>[]()[][], Int64) | FFTを実行する
Public method | FFT(array<FFTdata>[]()[][], Int64) | FFTを実行する
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

DFT Class
Signal_Process Namespace


FFT Method

[image] [image]

A Sandcastle Documented Class Library
DFT..::..FFT Method
DFT Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | FFT(array<Double>[]()[][]) | 受け渡されたデータを使用してFFTを実行する
Public method | FFT(array<FFTdata>[]()[][]) | 実部・虚部を合わせて解析するFFT/IFFTメソッド
Public method | FFT(array<Double>[]()[][], Int64) | FFTを実行する
Public method | FFT(array<FFTdata>[]()[][], Int64) | FFTを実行する

See Also

DFT Class
DFT Members
Signal_Process Namespace


FFT Method (Double[])

[image]

A Sandcastle Documented Class Library
DFT..::..FFT Method (array<Double>[]()[][])
DFT Class See Also フィードバックの送信
受け渡されたデータを使用してFFTを実行する

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult FFT(
    double[] data
)
Visual Basic
Public Function FFT ( _
    data As Double() _
) As FFTresult
Visual C++
public:
FFTresult^ FFT(
    array<double>^ data
)

Parameters

data
Type: array< System..::..Double >[]()[][]
double型の配列に解析したいデータを格納してください

Return Value

FFT処理データ

See Also

DFT Class
FFT Overload
Signal_Process Namespace


FFT Method (FFTdata[])

[image]

A Sandcastle Documented Class Library
DFT..::..FFT Method (array<FFTdata>[]()[][])
DFT Class See Also フィードバックの送信
実部・虚部を合わせて解析するFFT/IFFTメソッド

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult FFT(
    FFTdata[] data
)
Visual Basic
Public Function FFT ( _
    data As FFTdata() _
) As FFTresult
Visual C++
public:
FFTresult^ FFT(
    array<FFTdata>^ data
)

Parameters

data
Type: array< Signal_Process..::..FFTdata >[]()[][]
FFTdatas型の配列に解析したいデータを格納してください

Return Value

FFT処理データ

See Also

DFT Class
FFT Overload
Signal_Process Namespace


FFT Method (Double[], Int64)

[image]

A Sandcastle Documented Class Library
DFT..::..FFT Method (array<Double>[]()[][], Int64)
DFT Class See Also フィードバックの送信
FFTを実行する

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult FFT(
    double[] data,
    long frequency
)
Visual Basic
Public Function FFT ( _
    data As Double(), _
    frequency As Long _
) As FFTresult
Visual C++
public:
FFTresult^ FFT(
    array<double>^ data,
    long long frequency
)

Parameters

data
Type: array< System..::..Double >[]()[][]
解析したいデータ配列
frequency
Type: System..::..Int64
サンプリング周波数[Hz]

Return Value

FFT処理データ

See Also

DFT Class
FFT Overload
Signal_Process Namespace


FFT Method (FFTdata[], Int64)

[image]

A Sandcastle Documented Class Library
DFT..::..FFT Method (array<FFTdata>[]()[][], Int64)
DFT Class See Also フィードバックの送信
FFTを実行する

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult FFT(
    FFTdata[] data,
    long frequency
)
Visual Basic
Public Function FFT ( _
    data As FFTdata(), _
    frequency As Long _
) As FFTresult
Visual C++
public:
FFTresult^ FFT(
    array<FFTdata>^ data,
    long long frequency
)

Parameters

data
Type: array< Signal_Process..::..FFTdata >[]()[][]
解析したいデータ配列
frequency
Type: System..::..Int64
サンプリング周波数[Hz]

Return Value

FFT処理データ

See Also

DFT Class
FFT Overload
Signal_Process Namespace


DFT Properties

[image] [image]

A Sandcastle Documented Class Library
DFT Properties
DFT Class See Also フィードバックの送信

The DFT type exposes the following members.

Properties

 | Name | Description
Public property | FFTsize | FFT/IFFTデータ幅
Public property | Max | 変換後の配列に含まれる最大値を返す
Public property | Mean | 変換後の配列に含まれる平均値を返す
Public property | WindowKind | 窓関数の種別

See Also

DFT Class
Signal_Process Namespace


FFTsize Property

[image]

A Sandcastle Documented Class Library
DFT..::..FFTsize Property
DFT Class See Also フィードバックの送信
FFT/IFFTデータ幅

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int FFTsize { get; }
Visual Basic
Public ReadOnly Property FFTsize As Integer
    Get
Visual C++
public:
property int FFTsize {
    int get ();
}

See Also

DFT Class
Signal_Process Namespace


Max Property

[image]

A Sandcastle Documented Class Library
DFT..::..Max Property
DFT Class See Also フィードバックの送信
変換後の配列に含まれる最大値を返す

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Max { get; }
Visual Basic
Public ReadOnly Property Max As Double
    Get
Visual C++
public:
property double Max {
    double get ();
}

See Also

DFT Class
Signal_Process Namespace


Mean Property

[image]

A Sandcastle Documented Class Library
DFT..::..Mean Property
DFT Class See Also フィードバックの送信
変換後の配列に含まれる平均値を返す

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Mean { get; }
Visual Basic
Public ReadOnly Property Mean As Double
    Get
Visual C++
public:
property double Mean {
    double get ();
}

See Also

DFT Class
Signal_Process Namespace


WindowKind Property

[image]

A Sandcastle Documented Class Library
DFT..::..WindowKind Property
DFT Class See Also フィードバックの送信
窓関数の種別

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DFT..::..Window WindowKind { get; set; }
Visual Basic
Public Property WindowKind As DFT..::..Window
    Get
    Set
Visual C++
public:
property DFT..::..Window WindowKind {
    DFT..::..Window get ();
    void set (DFT..::..Window value);
}

See Also

DFT Class
Signal_Process Namespace


DFT.Window Enumeration

[image]

A Sandcastle Documented Class Library
DFT..::..Window Enumeration
DFT Class See Also フィードバックの送信
窓関数の種類

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Window
Visual Basic
Public Enumeration Window
Visual C++
public enum class Window

Members

Member name | Value | Description
Hanning | 0 |
Perzen | 1 |
NoWindow | 2 |

See Also

Signal_Process Namespace


FFT_point Enumeration

[image]

A Sandcastle Documented Class Library
FFT_point Enumeration
See Also フィードバックの送信
FFTデータ幅 データサイズ(2^n)をこの列挙体を使って宣言すれば間違えない.

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum FFT_point
Visual Basic
Public Enumeration FFT_point
Visual C++
public enum class FFT_point

Members

Member name | Value | Description
size32 | 32 |
size64 | 64 |
size128 | 128 |
size256 | 256 |
size512 | 512 |
size1024 | 1024 |
size2048 | 2048 |
size4096 | 4096 |
size8192 | 8192 |

See Also

Signal_Process Namespace


FFTdata Structure

[image]

A Sandcastle Documented Class Library
FFTdata Structure
Members See Also フィードバックの送信
データ格納用構造体

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct FFTdata
Visual Basic
Public Structure FFTdata
Visual C++
public value class FFTdata

See Also

FFTdata Members
Signal_Process Namespace


FFTdata Members

[image] [image]

A Sandcastle Documented Class Library
FFTdata Members
FFTdata Structure Methods Fields See Also フィードバックの送信

The FFTdata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Set | データをセットする
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Abs | 絶対値
Public field | Im | 虚部
Public field | Log | 絶対値の対数
Public field | Power | パワー ：ところで、パワースペクトル密度 （Power Spectrum Density,PSD）は、Powerを周波数分解能で割れば求まります。
Public field | Re | 実部

See Also

FFTdata Structure
Signal_Process Namespace


FFTdata Fields

[image] [image]

A Sandcastle Documented Class Library
FFTdata Fields
FFTdata Structure See Also フィードバックの送信

The FFTdata type exposes the following members.

Fields

 | Name | Description
Public field | Abs | 絶対値
Public field | Im | 虚部
Public field | Log | 絶対値の対数
Public field | Power | パワー ：ところで、パワースペクトル密度 （Power Spectrum Density,PSD）は、Powerを周波数分解能で割れば求まります。
Public field | Re | 実部

See Also

FFTdata Structure
Signal_Process Namespace


Abs Field

[image]

A Sandcastle Documented Class Library
FFTdata..::..Abs Field
FFTdata Structure See Also フィードバックの送信
絶対値

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Abs
Visual Basic
Public Abs As Double
Visual C++
public:
double Abs

See Also

FFTdata Structure
Signal_Process Namespace


Im Field

[image]

A Sandcastle Documented Class Library
FFTdata..::..Im Field
FFTdata Structure See Also フィードバックの送信
虚部

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Im
Visual Basic
Public Im As Double
Visual C++
public:
double Im

See Also

FFTdata Structure
Signal_Process Namespace


Log Field

[image]

A Sandcastle Documented Class Library
FFTdata..::..Log Field
FFTdata Structure See Also フィードバックの送信
絶対値の対数

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Log
Visual Basic
Public Log As Double
Visual C++
public:
double Log

See Also

FFTdata Structure
Signal_Process Namespace


Power Field

[image]

A Sandcastle Documented Class Library
FFTdata..::..Power Field
FFTdata Structure See Also フィードバックの送信
パワー ：ところで、パワースペクトル密度 （Power Spectrum Density,PSD）は、Powerを周波数分解能で割れば求まります。

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Power
Visual Basic
Public Power As Double
Visual C++
public:
double Power

See Also

FFTdata Structure
Signal_Process Namespace


Re Field

[image]

A Sandcastle Documented Class Library
FFTdata..::..Re Field
FFTdata Structure See Also フィードバックの送信
実部

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Re
Visual Basic
Public Re As Double
Visual C++
public:
double Re

See Also

FFTdata Structure
Signal_Process Namespace


FFTdata Methods

[image] [image]

A Sandcastle Documented Class Library
FFTdata Methods
FFTdata Structure See Also フィードバックの送信

The FFTdata type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Set | データをセットする
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

FFTdata Structure
Signal_Process Namespace


Set Method

[image]

A Sandcastle Documented Class Library
FFTdata..::..Set Method
FFTdata Structure See Also フィードバックの送信
データをセットする

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    double _Re,
    double _Im
)
Visual Basic
Public Sub Set ( _
    _Re As Double, _
    _Im As Double _
)
Visual C++
public:
void Set(
    double _Re,
    double _Im
)

Parameters

_Re
Type: System..::..Double
実部
_Im
Type: System..::..Double
虚部

See Also

FFTdata Structure
Signal_Process Namespace


FFTresult Class

[image]

A Sandcastle Documented Class Library
FFTresult Class
Members See Also フィードバックの送信
FFT処理後の観測データを扱うクラス

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FFTresult
Visual Basic
Public Class FFTresult
Visual C++
public ref class FFTresult

Inheritance Hierarchy

System..::..Object
Signal_Process..::..FFTresult

See Also

FFTresult Members
Signal_Process Namespace


FFTresult Members

[image] [image]

A Sandcastle Documented Class Library
FFTresult Members
FFTresult Class Constructors Methods Properties See Also フィードバックの送信

The FFTresult type exposes the following members.

Constructors

 | Name | Description
Public method | FFTresult | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetData | 指定した要素番号のFFTの結果を取得
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetPSD(FFTresult..::..Band) | 指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す その2 帯域を指定できる構造体を使用しているので、配列での処理がやりやすくなったと思う。
Public method | GetPSD(Int64, Int64) | 指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Save | 結果をファイルに保存する
Public method | ToString | 結果を文字列で出力する (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | FrequencyResolution | 表現されている最小の周波数分解能[Hz]
Public property | Length | 観測データ数
Public property | MaxFrequency | 表現されている最大の周波数[Hz]

See Also

FFTresult Class
Signal_Process Namespace


FFTresult Constructor

[image]

A Sandcastle Documented Class Library
FFTresult Constructor
FFTresult Class See Also フィードバックの送信
コンストラクタ

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult(
    FFTdata[] setData,
    long fs,
    int FFTpoint
)
Visual Basic
Public Sub New ( _
    setData As FFTdata(), _
    fs As Long, _
    FFTpoint As Integer _
)
Visual C++
public:
FFTresult(
    array<FFTdata>^ setData,
    long long fs,
    int FFTpoint
)

Parameters

setData
Type: array< Signal_Process..::..FFTdata >[]()[][]
観測データ配列
fs
Type: System..::..Int64
元データのサンプリング周波数
FFTpoint
Type: System..::..Int32
FFTポイント数

See Also

FFTresult Class
Signal_Process Namespace


FFTresult Methods

[image] [image]

A Sandcastle Documented Class Library
FFTresult Methods
FFTresult Class See Also フィードバックの送信

The FFTresult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetData | 指定した要素番号のFFTの結果を取得
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetPSD(FFTresult..::..Band) | 指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す その2 帯域を指定できる構造体を使用しているので、配列での処理がやりやすくなったと思う。
Public method | GetPSD(Int64, Int64) | 指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Save | 結果をファイルに保存する
Public method | ToString | 結果を文字列で出力する (Overrides Object..::..ToString()()()().)

See Also

FFTresult Class
Signal_Process Namespace


GetData Method

[image]

A Sandcastle Documented Class Library
FFTresult..::..GetData Method
FFTresult Class See Also フィードバックの送信
指定した要素番号のFFTの結果を取得

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult..::..FFTresultPlusFreq GetData(
    int index
)
Visual Basic
Public Function GetData ( _
    index As Integer _
) As FFTresult..::..FFTresultPlusFreq
Visual C++
public:
FFTresult..::..FFTresultPlusFreq GetData(
    int index
)

Parameters

index
Type: System..::..Int32
要素番号（0～this.Lenght - 1）

Return Value

周波数と結びつけたFFT結果

See Also

FFTresult Class
Signal_Process Namespace


GetPSD Method

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..GetPSD Method
FFTresult Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | GetPSD(FFTresult..::..Band) | 指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す その2 帯域を指定できる構造体を使用しているので、配列での処理がやりやすくなったと思う。
Public method | GetPSD(Int64, Int64) | 指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す

See Also

FFTresult Class
FFTresult Members
Signal_Process Namespace


GetPSD Method (FFTresult.Band)

[image]

A Sandcastle Documented Class Library
FFTresult..::..GetPSD Method (FFTresult..::..Band)
FFTresult Class See Also フィードバックの送信
指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す その2 帯域を指定できる構造体を使用しているので、配列での処理がやりやすくなったと思う。

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetPSD(
    FFTresult..::..Band band
)
Visual Basic
Public Function GetPSD ( _
    band As FFTresult..::..Band _
) As Double
Visual C++
public:
double GetPSD(
    FFTresult..::..Band band
)

Parameters

band
Type: Signal_Process..::..FFTresult..::..Band
帯域

Return Value

パワースペクトル密度[V^2/Hz]

See Also

FFTresult Class
GetPSD Overload
Signal_Process Namespace


GetPSD Method (Int64, Int64)

[image]

A Sandcastle Documented Class Library
FFTresult..::..GetPSD Method (Int64, Int64)
FFTresult Class See Also フィードバックの送信
指定帯域におけるパワースペクトル密度 （Power Spectrum Density,PSD）を返す

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetPSD(
    long min_frequency,
    long max_frequency
)
Visual Basic
Public Function GetPSD ( _
    min_frequency As Long, _
    max_frequency As Long _
) As Double
Visual C++
public:
double GetPSD(
    long long min_frequency,
    long long max_frequency
)

Parameters

min_frequency
Type: System..::..Int64
帯域の下限周波数[Hz]
max_frequency
Type: System..::..Int64
帯域の上限周波数[Hz]

Return Value

パワースペクトル密度[V^2/Hz]

See Also

FFTresult Class
GetPSD Overload
Signal_Process Namespace


Save Method

[image]

A Sandcastle Documented Class Library
FFTresult..::..Save Method
FFTresult Class See Also フィードバックの送信
結果をファイルに保存する

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Save(
    string fname
)
Visual Basic
Public Sub Save ( _
    fname As String _
)
Visual C++
public:
void Save(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

FFTresult Class
Signal_Process Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
FFTresult..::..ToString Method
FFTresult Class See Also フィードバックの送信
結果を文字列で出力する

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

文字列で表した結果

See Also

FFTresult Class
Signal_Process Namespace


FFTresult Properties

[image] [image]

A Sandcastle Documented Class Library
FFTresult Properties
FFTresult Class See Also フィードバックの送信

The FFTresult type exposes the following members.

Properties

 | Name | Description
Public property | FrequencyResolution | 表現されている最小の周波数分解能[Hz]
Public property | Length | 観測データ数
Public property | MaxFrequency | 表現されている最大の周波数[Hz]

See Also

FFTresult Class
Signal_Process Namespace


FrequencyResolution Property

[image]

A Sandcastle Documented Class Library
FFTresult..::..FrequencyResolution Property
FFTresult Class See Also フィードバックの送信
表現されている最小の周波数分解能[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long FrequencyResolution { get; }
Visual Basic
Public ReadOnly Property FrequencyResolution As Long
    Get
Visual C++
public:
property long long FrequencyResolution {
    long long get ();
}

See Also

FFTresult Class
Signal_Process Namespace


Length Property

[image]

A Sandcastle Documented Class Library
FFTresult..::..Length Property
FFTresult Class See Also フィードバックの送信
観測データ数

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
Visual C++
public:
property int Length {
    int get ();
}

See Also

FFTresult Class
Signal_Process Namespace


MaxFrequency Property

[image]

A Sandcastle Documented Class Library
FFTresult..::..MaxFrequency Property
FFTresult Class See Also フィードバックの送信
表現されている最大の周波数[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long MaxFrequency { get; }
Visual Basic
Public ReadOnly Property MaxFrequency As Long
    Get
Visual C++
public:
property long long MaxFrequency {
    long long get ();
}

See Also

FFTresult Class
Signal_Process Namespace


FFTresult.Band Structure

[image]

A Sandcastle Documented Class Library
FFTresult..::..Band Structure
FFTresult Class Members See Also フィードバックの送信
帯域を定義する構造体

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct Band
Visual Basic
Public Structure Band
Visual C++
public value class Band

See Also

FFTresult..::..Band Members
Signal_Process Namespace


FFTresult.Band Members

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..Band Members
FFTresult..::..Band Structure Constructors Methods Fields Properties See Also フィードバックの送信

FFT処理後の観測データを扱うクラス

The FFTresult..::..Band type exposes the following members.

Constructors

 | Name | Description
Public method | FFTresult..::..Band | コンストラクタ

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Max | 最大周波数[Hz]
Public field | Min | 最小周波数[Hz]

Properties

 | Name | Description
Public property | BandWidth | バンド幅[Hz]
Public property | CenterFrequency | 中心周波数[Hz]

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


FFTresult.Band Constructor

[image]

A Sandcastle Documented Class Library
FFTresult..::..Band Constructor
FFTresult..::..Band Structure See Also フィードバックの送信
コンストラクタ

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Band(
    long max,
    long min
)
Visual Basic
Public Sub New ( _
    max As Long, _
    min As Long _
)
Visual C++
public:
Band(
    long long max,
    long long min
)

Parameters

max
Type: System..::..Int64
最大周波数[Hz]
min
Type: System..::..Int64
最小周波数[Hz]

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


FFTresult.Band Fields

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..Band Fields
FFTresult..::..Band Structure See Also フィードバックの送信

The FFTresult..::..Band type exposes the following members.

Fields

 | Name | Description
Public field | Max | 最大周波数[Hz]
Public field | Min | 最小周波数[Hz]

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


Max Field

[image]

A Sandcastle Documented Class Library
FFTresult..::..Band..::..Max Field
FFTresult..::..Band Structure See Also フィードバックの送信
最大周波数[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public readonly long Max
Visual Basic
Public ReadOnly Max As Long
Visual C++
public:
initonly long long Max

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


Min Field

[image]

A Sandcastle Documented Class Library
FFTresult..::..Band..::..Min Field
FFTresult..::..Band Structure See Also フィードバックの送信
最小周波数[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public readonly long Min
Visual Basic
Public ReadOnly Min As Long
Visual C++
public:
initonly long long Min

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


FFTresult.Band Methods

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..Band Methods
FFTresult..::..Band Structure See Also フィードバックの送信

The FFTresult..::..Band type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


FFTresult.Band Properties

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..Band Properties
FFTresult..::..Band Structure See Also フィードバックの送信

The FFTresult..::..Band type exposes the following members.

Properties

 | Name | Description
Public property | BandWidth | バンド幅[Hz]
Public property | CenterFrequency | 中心周波数[Hz]

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


BandWidth Property

[image]

A Sandcastle Documented Class Library
FFTresult..::..Band..::..BandWidth Property
FFTresult..::..Band Structure See Also フィードバックの送信
バンド幅[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long BandWidth { get; }
Visual Basic
Public ReadOnly Property BandWidth As Long
    Get
Visual C++
public:
property long long BandWidth {
    long long get ();
}

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


CenterFrequency Property

[image]

A Sandcastle Documented Class Library
FFTresult..::..Band..::..CenterFrequency Property
FFTresult..::..Band Structure See Also フィードバックの送信
中心周波数[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public long CenterFrequency { get; }
Visual Basic
Public ReadOnly Property CenterFrequency As Long
    Get
Visual C++
public:
property long long CenterFrequency {
    long long get ();
}

See Also

FFTresult..::..Band Structure
Signal_Process Namespace


FFTresult.FFTresultPlusFreq Structure

[image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq Structure
FFTresult Class Members See Also フィードバックの送信
FFTの処理データと周波数をセットにした構造体

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct FFTresultPlusFreq
Visual Basic
Public Structure FFTresultPlusFreq
Visual C++
public value class FFTresultPlusFreq

See Also

FFTresult..::..FFTresultPlusFreq Members
Signal_Process Namespace


FFTresult.FFTresultPlusFreq Members

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq Members
FFTresult..::..FFTresultPlusFreq Structure Constructors Methods Fields See Also フィードバックの送信

FFT処理後の観測データを扱うクラス

The FFTresult..::..FFTresultPlusFreq type exposes the following members.

Constructors

 | Name | Description
Public method | FFTresult..::..FFTresultPlusFreq | コンストラクタ

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Fields

 | Name | Description
Public field | data | FFT処理後のデータ
Public field | frequency | 周波数[Hz]

See Also

FFTresult..::..FFTresultPlusFreq Structure
Signal_Process Namespace


FFTresult.FFTresultPlusFreq Constructor

[image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq Constructor
FFTresult..::..FFTresultPlusFreq Structure See Also フィードバックの送信
コンストラクタ

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresultPlusFreq(
    FFTdata x,
    long freq
)
Visual Basic
Public Sub New ( _
    x As FFTdata, _
    freq As Long _
)
Visual C++
public:
FFTresultPlusFreq(
    FFTdata x,
    long long freq
)

Parameters

x
Type: Signal_Process..::..FFTdata
FFT処理後のデータ
freq
Type: System..::..Int64
周波数[Hz]

See Also

FFTresult..::..FFTresultPlusFreq Structure
Signal_Process Namespace


FFTresult.FFTresultPlusFreq Fields

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq Fields
FFTresult..::..FFTresultPlusFreq Structure See Also フィードバックの送信

The FFTresult..::..FFTresultPlusFreq type exposes the following members.

Fields

 | Name | Description
Public field | data | FFT処理後のデータ
Public field | frequency | 周波数[Hz]

See Also

FFTresult..::..FFTresultPlusFreq Structure
Signal_Process Namespace


data Field

[image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq..::..data Field
FFTresult..::..FFTresultPlusFreq Structure See Also フィードバックの送信
FFT処理後のデータ

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public readonly FFTdata data
Visual Basic
Public ReadOnly data As FFTdata
Visual C++
public:
initonly FFTdata data

See Also

FFTresult..::..FFTresultPlusFreq Structure
Signal_Process Namespace


frequency Field

[image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq..::..frequency Field
FFTresult..::..FFTresultPlusFreq Structure See Also フィードバックの送信
周波数[Hz]

Namespace: Signal_Process
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public readonly long frequency
Visual Basic
Public ReadOnly frequency As Long
Visual C++
public:
initonly long long frequency

See Also

FFTresult..::..FFTresultPlusFreq Structure
Signal_Process Namespace


FFTresult.FFTresultPlusFreq Methods

[image] [image]

A Sandcastle Documented Class Library
FFTresult..::..FFTresultPlusFreq Methods
FFTresult..::..FFTresultPlusFreq Structure See Also フィードバックの送信

The FFTresult..::..FFTresultPlusFreq type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

FFTresult..::..FFTresultPlusFreq Structure
Signal_Process Namespace


WAVE_file Namespace

[image]

A Sandcastle Documented Class Library
WAVE_file Namespace
フィードバックの送信

["N:WAVE_file" の為の説明文 <summary> が欠落しています。]

Classes

 | Class | Description
Public class | wave | waveファイルを扱うためのクラス
Public class | wave..::..MusicData | 音声データを格納するクラス

Structures

 | Structure | Description
Public structure | wave..::..MusicUnit | 左右の音を格納する構造体

Enumerations

 | Enumeration | Description
Public enumeration | wave..::..Channel | モノラル/ステレオ
Public enumeration | wave..::..MusicData..::..Channel | 左右を指定するために使用する
Public enumeration | wave..::..MusicData..::..UsableChannel | データの入っている方を教えるのに使用する


wave Class

[image]

A Sandcastle Documented Class Library
wave Class
Members See Also フィードバックの送信
waveファイルを扱うためのクラス

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class wave
Visual Basic
Public Class wave
Visual C++
public ref class wave

Inheritance Hierarchy

System..::..Object
WAVE_file..::..wave

See Also

wave Members
WAVE_file Namespace


wave Members

[image] [image]

A Sandcastle Documented Class Library
wave Members
wave Class Constructors Methods Properties See Also フィードバックの送信

The wave type exposes the following members.

Constructors

 | Name | Description
Public method | wave | wave クラスの新しいインスタンスを初期化します。

Methods

 | Name | Description
Public method | Close | ファイルを閉じる
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デストラクタ. (Overrides Object..::..Finalize()()()().)
Public method | GetArrSize | 指定時間分のデータを読み込むのに必要となる配列サイズを返す
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Open(String) | ファイル名（またはパス）の指定でファイルを開く
Public method | Open(OpenFileDialog) | ダイアログを使ってファイルを開く
Public method | Read(Double) | 指定時間分の音声データを返す
Public method | Read(Int32) | 指定ポイント数の音声データを読み込む。 モノラルなら、Left/Rightどちらにも格納される。
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | Ch | 読み込んだファイルがステレオかどうかを示す
Public property | FileName | ファイル名
Public property | IsOpen | ファイルを開けたか状態をチェック
Public property | NowTime | 読み出し位置までの経過時刻[s]を返す
Public property | ReadLimit | データを最後まで読み切るとtrue
Public property | Resolution | 量子化分解能
Public property | SamplingRate | サンプリング周波数

See Also

wave Class
WAVE_file Namespace


wave Constructor

[image]

A Sandcastle Documented Class Library
wave Constructor
wave Class See Also フィードバックの送信
wave クラスの新しいインスタンスを初期化します。

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public wave()
Visual Basic
Public Sub New
Visual C++
public:
wave()

See Also

wave Class
WAVE_file Namespace


wave Methods

[image] [image]

A Sandcastle Documented Class Library
wave Methods
wave Class See Also フィードバックの送信

The wave type exposes the following members.

Methods

 | Name | Description
Public method | Close | ファイルを閉じる
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デストラクタ. (Overrides Object..::..Finalize()()()().)
Public method | GetArrSize | 指定時間分のデータを読み込むのに必要となる配列サイズを返す
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Open(String) | ファイル名（またはパス）の指定でファイルを開く
Public method | Open(OpenFileDialog) | ダイアログを使ってファイルを開く
Public method | Read(Double) | 指定時間分の音声データを返す
Public method | Read(Int32) | 指定ポイント数の音声データを読み込む。 モノラルなら、Left/Rightどちらにも格納される。
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

wave Class
WAVE_file Namespace


Close Method

[image]

A Sandcastle Documented Class Library
wave..::..Close Method
wave Class See Also フィードバックの送信
ファイルを閉じる

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

wave Class
WAVE_file Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
wave..::..Finalize Method
wave Class See Also フィードバックの送信
  デストラクタ.

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

wave Class
WAVE_file Namespace


GetArrSize Method

[image]

A Sandcastle Documented Class Library
wave..::..GetArrSize Method
wave Class See Also フィードバックの送信
指定時間分のデータを読み込むのに必要となる配列サイズを返す

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int GetArrSize(
    double time_width
)
Visual Basic
Public Function GetArrSize ( _
    time_width As Double _
) As Integer
Visual C++
public:
int GetArrSize(
    double time_width
)

Parameters

time_width
Type: System..::..Double
指定時間幅[s]

Return Value

指定時間のデータを格納するに足るデータサイズ

See Also

wave Class
WAVE_file Namespace


Open Method

[image] [image]

A Sandcastle Documented Class Library
wave..::..Open Method
wave Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Open(String) | ファイル名（またはパス）の指定でファイルを開く
Public method | Open(OpenFileDialog) | ダイアログを使ってファイルを開く

See Also

wave Class
wave Members
WAVE_file Namespace


Open Method (String)

[image]

A Sandcastle Documented Class Library
wave..::..Open Method (String)
wave Class See Also フィードバックの送信
ファイル名（またはパス）の指定でファイルを開く

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Open(
    string fname
)
Visual Basic
Public Function Open ( _
    fname As String _
) As Boolean
Visual C++
public:
bool Open(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名（絶対パス・相対パスでも良い）

Return Value

["M:WAVE_file.wave.Open(System.String)" の為の説明文 <returns> が欠落しています。]

See Also

wave Class
Open Overload
WAVE_file Namespace


Open Method (OpenFileDialog)

[image]

A Sandcastle Documented Class Library
wave..::..Open Method (OpenFileDialog)
wave Class See Also フィードバックの送信
ダイアログを使ってファイルを開く

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Open(
    OpenFileDialog dialog
)
Visual Basic
Public Function Open ( _
    dialog As OpenFileDialog _
) As Boolean
Visual C++
public:
bool Open(
    OpenFileDialog^ dialog
)

Parameters

dialog
Type: System.Windows.Forms..::..OpenFileDialog
ダイアログオブジェクト

Return Value

開けたかどうかをtrue/falseで返す。成功ならtrue。

Remarks

ファイルオープンの状態は、IsOpenプロパティに反映されます

See Also

wave Class
Open Overload
WAVE_file Namespace


Read Method

[image] [image]

A Sandcastle Documented Class Library
wave..::..Read Method
wave Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Read(Double) | 指定時間分の音声データを返す
Public method | Read(Int32) | 指定ポイント数の音声データを読み込む。 モノラルなら、Left/Rightどちらにも格納される。

See Also

wave Class
wave Members
WAVE_file Namespace


Read Method (Double)

[image]

A Sandcastle Documented Class Library
wave..::..Read Method (Double)
wave Class See Also フィードバックの送信
指定時間分の音声データを返す

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public wave..::..MusicData Read(
    double time_width
)
Visual Basic
Public Function Read ( _
    time_width As Double _
) As wave..::..MusicData
Visual C++
public:
wave..::..MusicData^ Read(
    double time_width
)

Parameters

time_width
Type: System..::..Double
指定時間幅[s]

Return Value

音声データクラス

Remarks

オーバーロードを利用して同じ名前でメソッドを定義した

See Also

wave Class
Read Overload
WAVE_file Namespace


Read Method (Int32)

[image]

A Sandcastle Documented Class Library
wave..::..Read Method (Int32)
wave Class See Also フィードバックの送信
指定ポイント数の音声データを読み込む。 モノラルなら、Left/Rightどちらにも格納される。

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public wave..::..MusicUnit[] Read(
    int size
)
Visual Basic
Public Function Read ( _
    size As Integer _
) As wave..::..MusicUnit()
Visual C++
public:
array<wave..::..MusicUnit>^ Read(
    int size
)

Parameters

size
Type: System..::..Int32
データサイズ[point]

Return Value

ファイルを完読すると、0を書き込んで返す

See Also

wave Class
Read Overload
WAVE_file Namespace


wave Properties

[image] [image]

A Sandcastle Documented Class Library
wave Properties
wave Class See Also フィードバックの送信

The wave type exposes the following members.

Properties

 | Name | Description
Public property | Ch | 読み込んだファイルがステレオかどうかを示す
Public property | FileName | ファイル名
Public property | IsOpen | ファイルを開けたか状態をチェック
Public property | NowTime | 読み出し位置までの経過時刻[s]を返す
Public property | ReadLimit | データを最後まで読み切るとtrue
Public property | Resolution | 量子化分解能
Public property | SamplingRate | サンプリング周波数

See Also

wave Class
WAVE_file Namespace


Ch Property

[image]

A Sandcastle Documented Class Library
wave..::..Ch Property
wave Class See Also フィードバックの送信
読み込んだファイルがステレオかどうかを示す

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public wave..::..Channel Ch { get; }
Visual Basic
Public ReadOnly Property Ch As wave..::..Channel
    Get
Visual C++
public:
property wave..::..Channel Ch {
    wave..::..Channel get ();
}

See Also

wave Class
WAVE_file Namespace


FileName Property

[image]

A Sandcastle Documented Class Library
wave..::..FileName Property
wave Class See Also フィードバックの送信
ファイル名

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FileName { get; }
Visual Basic
Public ReadOnly Property FileName As String
    Get
Visual C++
public:
property String^ FileName {
    String^ get ();
}

See Also

wave Class
WAVE_file Namespace


IsOpen Property

[image]

A Sandcastle Documented Class Library
wave..::..IsOpen Property
wave Class See Also フィードバックの送信
ファイルを開けたか状態をチェック

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsOpen { get; }
Visual Basic
Public ReadOnly Property IsOpen As Boolean
    Get
Visual C++
public:
property bool IsOpen {
    bool get ();
}

See Also

wave Class
WAVE_file Namespace


NowTime Property

[image]

A Sandcastle Documented Class Library
wave..::..NowTime Property
wave Class See Also フィードバックの送信
読み出し位置までの経過時刻[s]を返す

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double NowTime { get; }
Visual Basic
Public ReadOnly Property NowTime As Double
    Get
Visual C++
public:
property double NowTime {
    double get ();
}

See Also

wave Class
WAVE_file Namespace


ReadLimit Property

[image]

A Sandcastle Documented Class Library
wave..::..ReadLimit Property
wave Class See Also フィードバックの送信
データを最後まで読み切るとtrue

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool ReadLimit { get; }
Visual Basic
Public ReadOnly Property ReadLimit As Boolean
    Get
Visual C++
public:
property bool ReadLimit {
    bool get ();
}

See Also

wave Class
WAVE_file Namespace


Resolution Property

[image]

A Sandcastle Documented Class Library
wave..::..Resolution Property
wave Class See Also フィードバックの送信
量子化分解能

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Resolution { get; }
Visual Basic
Public ReadOnly Property Resolution As Integer
    Get
Visual C++
public:
property int Resolution {
    int get ();
}

See Also

wave Class
WAVE_file Namespace


SamplingRate Property

[image]

A Sandcastle Documented Class Library
wave..::..SamplingRate Property
wave Class See Also フィードバックの送信
サンプリング周波数

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int SamplingRate { get; }
Visual Basic
Public ReadOnly Property SamplingRate As Integer
    Get
Visual C++
public:
property int SamplingRate {
    int get ();
}

See Also

wave Class
WAVE_file Namespace


wave.Channel Enumeration

[image]

A Sandcastle Documented Class Library
wave..::..Channel Enumeration
wave Class See Also フィードバックの送信
モノラル/ステレオ

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Channel
Visual Basic
Public Enumeration Channel
Visual C++
public enum class Channel

Members

Member name | Value | Description
Monoral | 0 |
Stereo | 1 |

See Also

WAVE_file Namespace


wave.MusicData Class

[image]

A Sandcastle Documented Class Library
wave..::..MusicData Class
wave Class Members See Also フィードバックの送信
音声データを格納するクラス

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MusicData
Visual Basic
Public Class MusicData
Visual C++
public ref class MusicData

Inheritance Hierarchy

System..::..Object
WAVE_file..::..wave..::..MusicData

See Also

wave..::..MusicData Members
WAVE_file Namespace


wave.MusicData Members

[image] [image]

A Sandcastle Documented Class Library
wave..::..MusicData Members
wave..::..MusicData Class Constructors Methods Properties See Also フィードバックの送信

waveファイルを扱うためのクラス

The wave..::..MusicData type exposes the following members.

Constructors

 | Name | Description
Public method | wave..::..MusicData | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetData | 指定された片方のデータを返す
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | Size | データ長
Public property | UsableCH | 使用可能なチャンネル

See Also

wave..::..MusicData Class
WAVE_file Namespace


wave.MusicData Constructor

[image]

A Sandcastle Documented Class Library
wave..::..MusicData Constructor
wave..::..MusicData Class See Also フィードバックの送信
コンストラクタ

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MusicData(
    wave..::..MusicUnit[] _data
)
Visual Basic
Public Sub New ( _
    _data As wave..::..MusicUnit() _
)
Visual C++
public:
MusicData(
    array<wave..::..MusicUnit>^ _data
)

Parameters

_data
Type: array< WAVE_file..::..wave..::..MusicUnit >[]()[][]
音声データ配列

See Also

wave..::..MusicData Class
WAVE_file Namespace


wave.MusicData Methods

[image] [image]

A Sandcastle Documented Class Library
wave..::..MusicData Methods
wave..::..MusicData Class See Also フィードバックの送信

The wave..::..MusicData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetData | 指定された片方のデータを返す
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

wave..::..MusicData Class
WAVE_file Namespace


GetData Method

[image]

A Sandcastle Documented Class Library
wave..::..MusicData..::..GetData Method
wave..::..MusicData Class See Also フィードバックの送信
指定された片方のデータを返す

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double[] GetData(
    wave..::..MusicData..::..Channel ch
)
Visual Basic
Public Function GetData ( _
    ch As wave..::..MusicData..::..Channel _
) As Double()
Visual C++
public:
array<double>^ GetData(
    wave..::..MusicData..::..Channel ch
)

Parameters

ch
Type: WAVE_file..::..wave..::..MusicData..::..Channel
Channel列挙体

Return Value

double型の配列

See Also

wave..::..MusicData Class
WAVE_file Namespace


wave.MusicData Properties

[image] [image]

A Sandcastle Documented Class Library
wave..::..MusicData Properties
wave..::..MusicData Class See Also フィードバックの送信

The wave..::..MusicData type exposes the following members.

Properties

 | Name | Description
Public property | Size | データ長
Public property | UsableCH | 使用可能なチャンネル

See Also

wave..::..MusicData Class
WAVE_file Namespace


Size Property

[image]

A Sandcastle Documented Class Library
wave..::..MusicData..::..Size Property
wave..::..MusicData Class See Also フィードバックの送信
データ長

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Size { get; }
Visual Basic
Public ReadOnly Property Size As Integer
    Get
Visual C++
public:
property int Size {
    int get ();
}

See Also

wave..::..MusicData Class
WAVE_file Namespace


UsableCH Property

[image]

A Sandcastle Documented Class Library
wave..::..MusicData..::..UsableCH Property
wave..::..MusicData Class See Also フィードバックの送信
使用可能なチャンネル

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public wave..::..MusicData..::..UsableChannel UsableCH { get; }
Visual Basic
Public ReadOnly Property UsableCH As wave..::..MusicData..::..UsableChannel
    Get
Visual C++
public:
property wave..::..MusicData..::..UsableChannel UsableCH {
    wave..::..MusicData..::..UsableChannel get ();
}

See Also

wave..::..MusicData Class
WAVE_file Namespace


wave.MusicData.Channel Enumeration

[image]

A Sandcastle Documented Class Library
wave..::..MusicData..::..Channel Enumeration
wave..::..MusicData Class See Also フィードバックの送信
左右を指定するために使用する

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Channel
Visual Basic
Public Enumeration Channel
Visual C++
public enum class Channel

Members

Member name | Value | Description
Right | 0 |
Left | 1 |

See Also

WAVE_file Namespace


wave.MusicData.UsableChannel Enumeration

[image]

A Sandcastle Documented Class Library
wave..::..MusicData..::..UsableChannel Enumeration
wave..::..MusicData Class See Also フィードバックの送信
データの入っている方を教えるのに使用する

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum UsableChannel
Visual Basic
Public Enumeration UsableChannel
Visual C++
public enum class UsableChannel

Members

Member name | Value | Description
Right | 0 |
Left | 1 |
Both | 2 |
NA | 3 |

See Also

WAVE_file Namespace


wave.MusicUnit Structure

[image]

A Sandcastle Documented Class Library
wave..::..MusicUnit Structure
wave Class Members See Also フィードバックの送信
左右の音を格納する構造体

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct MusicUnit
Visual Basic
Public Structure MusicUnit
Visual C++
public value class MusicUnit

See Also

wave..::..MusicUnit Members
WAVE_file Namespace


wave.MusicUnit Members

[image] [image]

A Sandcastle Documented Class Library
wave..::..MusicUnit Members
wave..::..MusicUnit Structure Methods Fields See Also フィードバックの送信

waveファイルを扱うためのクラス

The wave..::..MusicUnit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Left | 左の音
Public field | Right | 右の音

See Also

wave..::..MusicUnit Structure
WAVE_file Namespace


wave.MusicUnit Fields

[image] [image]

A Sandcastle Documented Class Library
wave..::..MusicUnit Fields
wave..::..MusicUnit Structure See Also フィードバックの送信

The wave..::..MusicUnit type exposes the following members.

Fields

 | Name | Description
Public field | Left | 左の音
Public field | Right | 右の音

See Also

wave..::..MusicUnit Structure
WAVE_file Namespace


Left Field

[image]

A Sandcastle Documented Class Library
wave..::..MusicUnit..::..Left Field
wave..::..MusicUnit Structure See Also フィードバックの送信
左の音

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Left
Visual Basic
Public Left As Integer
Visual C++
public:
int Left

See Also

wave..::..MusicUnit Structure
WAVE_file Namespace


Right Field

[image]

A Sandcastle Documented Class Library
wave..::..MusicUnit..::..Right Field
wave..::..MusicUnit Structure See Also フィードバックの送信
右の音

Namespace: WAVE_file
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Right
Visual Basic
Public Right As Integer
Visual C++
public:
int Right

See Also

wave..::..MusicUnit Structure
WAVE_file Namespace


wave.MusicUnit Methods

[image] [image]

A Sandcastle Documented Class Library
wave..::..MusicUnit Methods
wave..::..MusicUnit Structure See Also フィードバックの送信

The wave..::..MusicUnit type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

wave..::..MusicUnit Structure
WAVE_file Namespace


鳥の声で種識別 Namespace

[image]

A Sandcastle Documented Class Library
鳥の声で種識別 Namespace
フィードバックの送信

["N:鳥の声で種識別" の為の説明文 <summary> が欠落しています。]

Classes

 | Class | Description
Public class | FFTtestForm |
Public class | SignalBasic | 音声データの基本的な処理クラス
Public class | SignalBasic..::..SoundDetection | 信号の検出のためのクラス 2011/11/15時点では、一度検出されるとその後は検出の感度が鈍るという副作用がある。 これは検出時には値をセットされてもストックしないことで対応可能といえば可能 ただし、グローバル変数にセットされた値を一時的に保持する必要がある。

Enumerations

 | Enumeration | Description
Public enumeration | SignalBasic..::..SoundDetection..::..Edge | 検出されたエッジの種類


FFTtestForm Class

[image]

A Sandcastle Documented Class Library
FFTtestForm Class
Members See Also フィードバックの送信

["T:鳥の声で種識別.FFTtestForm" の為の説明文 <summary> が欠落しています。]

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FFTtestForm : Form
Visual Basic
Public Class FFTtestForm _
    Inherits Form
Visual C++
public ref class FFTtestForm : public Form

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
System.Windows.Forms..::..ScrollableControl
System.Windows.Forms..::..ContainerControl
System.Windows.Forms..::..Form
鳥の声で種識別..::..FFTtestForm

See Also

FFTtestForm Members
鳥の声で種識別 Namespace


FFTtestForm Members

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm Members
FFTtestForm Class Constructors Methods Properties Events See Also フィードバックの送信

The FFTtestForm type exposes the following members.

Constructors

 | Name | Description
Public method | FFTtestForm | コンストラクタ 始めに実行される

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | 指定した子コントロールの指定した AccessibleEvents をユーザー補助クライアント アプリケーションに通知します。 (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | 指定した子コントロールの指定した AccessibleEvents をユーザー補助クライアント アプリケーションに通知します。 (Inherited from Control.)
Public method | Activate | フォームをアクティブにし、そのフォームにフォーカスを移します。 (Inherited from Form.)
Protected method | ActivateMdiChild | フォームの MDI 子フォームをアクティブにします。 (Inherited from Form.)
Public method | AddOwnedForm | 対象となるフォームに、所有される側のフォームを追加します。 (Inherited from Form.)
Protected method | AdjustFormScrollbars | 現在のコントロールの位置、および現在選択されているコントロールを基準として、コンテナー上のスクロール バーを調節します。 (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. AutoScaleBaseSize プロパティの現在の値、および現在のフォントのサイズに応じて、フォームのサイズを変更します。 (Inherited from Form.)
Public method | BeginInvoke(Delegate) | コントロールの基になるハンドルが作成されたスレッド上で、指定したデリゲートを非同期的に実行します。 (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | コントロールの基になるハンドルが作成されたスレッド上で、指定した引数で指定したデリゲートを非同期的に実行します。 (Inherited from Control.)
Public method | BringToFront | コントロールを z オーダーの最前面へ移動します。 (Inherited from Control.)
Protected method | CenterToParent | フォームを親フォームの境界内の中央に配置します。 (Inherited from Form.)
Protected method | CenterToScreen | フォームを現在の画面の中央に配置します。 (Inherited from Form.)
Public method | Close | フォームを閉じます。 (Inherited from Form.)
Public method | Contains | 指定したコントロールが、コントロールの子かどうかを示す値を取得します。 (Inherited from Control.)
Protected method | CreateAccessibilityInstance | コントロールの新しいユーザー補助オブジェクトを作成します。 (Inherited from Control.)
Public method | CreateControl | ハンドルおよび子コントロールの作成を含めて、強制的にコントロールを作成します。 (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | コントロールの Graphics を作成します。 (Inherited from Control.)
Protected method | CreateHandle | フォームのハンドルを作成します。派生クラスでこの機能をオーバーライドする場合は、基本の実装を呼び出す必要があります。 (Inherited from Form.)
Public method | CreateObjRef | リモート オブジェクトとの通信に使用するプロキシの生成に必要な情報をすべて格納しているオブジェクトを作成します。 (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | コントロールに関連付けられたハンドルを破棄します。 (Inherited from Control.)
Public method | Dispose()()()() | Component によって使用されているすべてのリソースを解放します。 (Inherited from Component.)
Protected method | Dispose(Boolean) | 使用中のリソースをすべてクリーンアップします。 (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | ドラッグ アンド ドロップ操作を開始します。 (Inherited from Control.)
Public method | DrawToBitmap | 指定したビットマップへのレンダリングをサポートします。 (Inherited from Control.)
Public method | EndInvoke | 渡された IAsyncResult によって表される、非同期操作の戻り値を取得します。 (Inherited from Control.)
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Component..::..Finalize()()()().)
Public method | FindForm | コントロールがあるフォームを取得します。 (Inherited from Control.)
Public method | Focus | コントロールに入力フォーカスを設定します。 (Inherited from Control.)
Protected method | GetAccessibilityObjectById | 指定した AccessibleObject を取得します。 (Inherited from Control.)
Protected method | GetAutoSizeMode | AutoSize プロパティが有効なときのコントロールの動作を示す値を取得します。 (Inherited from Control.)
Public method | GetChildAtPoint(Point) | 指定した座標にある子コントロールを取得します。 (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | 特定の種類の子コントロールを無視するかどうかを指定して、指定した座標にある子コントロールを取得します。 (Inherited from Control.)
Public method | GetContainerControl | コントロールの親チェインの 1 つ上の ContainerControl を返します。 (Inherited from Control.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetLifetimeService | 対象のインスタンスの有効期間ポリシーを制御する、現在の有効期間サービス オブジェクトを取得します。 (Inherited from MarshalByRefObject.)
Public method | GetNextControl | 子コントロールのタブ オーダー内の 1 つ前または 1 つ後ろのコントロールを取得します。 (Inherited from Control.)
Public method | GetPreferredSize | コントロールが適合する四角形領域のサイズを取得します。 (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | 指定したフラグが設定されているかどうかを判断します。 (Inherited from ScrollableControl.)
Protected method | GetService | Component またはその Container で提供されるサービスを表すオブジェクトを返します。 (Inherited from Component.)
Protected method | GetStyle | コントロールの指定したコントロール スタイル ビットの値を取得します。 (Inherited from Control.)
Protected method | GetTopLevel | コントロールがトップレベル コントロールかどうかを判断します。 (Inherited from Control.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Public method | Hide | コントロールをユーザーに対して非表示にします。 (Inherited from Control.)
Public method | InitializeLifetimeService | 対象のインスタンスの有効期間ポリシーを制御する、有効期間サービス オブジェクトを取得します。 (Inherited from MarshalByRefObject.)
Protected method | InitLayout | コントロールが別のコンテナーに追加された後、呼び出されます。 (Inherited from Control.)
Public method | Invalidate()()()() | コントロールの表面全体を無効化して、コントロールを再描画します。 (Inherited from Control.)
Public method | Invalidate(Region) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。 (Inherited from Control.)
Public method | Invalidate(Boolean) | コントロールの特定の領域を無効にし、そのコントロールに描画メッセージを送信します。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invalidate(Rectangle) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。 (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invoke(Delegate) | コントロールの基になるウィンドウ ハンドルを所有するスレッド上で、指定したデリゲートを実行します。 (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | コントロールの基になるウィンドウ ハンドルを所有するスレッド上で、指定した引数リストを使用して、指定したデリゲートを実行します。 (Inherited from Control.)
Protected method | InvokeGotFocus | 指定したコントロールの GotFocus イベントを発生させます。 (Inherited from Control.)
Protected method | InvokeLostFocus | 指定したコントロールの LostFocus イベントを発生させます。 (Inherited from Control.)
Protected method | InvokeOnClick | 指定したコントロールの Click イベントを発生させます。 (Inherited from Control.)
Protected method | InvokePaint | 指定したコントロールの Paint イベントを発生させます。 (Inherited from Control.)
Protected method | InvokePaintBackground | 指定したコントロールの PaintBackground イベントを発生させます。 (Inherited from Control.)
Protected method | IsInputChar | 文字が、コントロールによって認識される入力文字かどうかを判断します。 (Inherited from Control.)
Protected method | IsInputKey | 指定されているキーが、通常の入力キーであるか、またはプリプロセスを必要とする特殊なキーであるかを確認します。 (Inherited from Control.)
Public method | LayoutMdi | マルチ ドキュメント インターフェイス (MDI) 親フォーム内に MDI 子フォームを配置します。 (Inherited from Form.)
Protected method | MemberwiseClone()()()() | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | 現在の MarshalByRefObject オブジェクトの簡易コピーを作成します。 (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | 無効化するコントロールの領域を指定して、Invalidated イベントを発生させます。 (Inherited from Control.)
Protected method | OnActivated | Activated イベントを発生させます。 (Inherited from Form.)
Protected method | OnAutoSizeChanged | AutoSizeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnAutoValidateChanged | AutoValidateChanged イベントを発生させます。 (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | BackColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnBackgroundImageChanged | BackgroundImageChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | BackgroundImageLayoutChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnBindingContextChanged | BindingContextChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnCausesValidationChanged | CausesValidationChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnChangeUICues | ChangeUICues イベントを発生させます。 (Inherited from Control.)
Protected method | OnClick | Click イベントを発生させます。 (Inherited from Control.)
Protected method | OnClientSizeChanged | ClientSizeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnClosed | Closed イベントを発生させます。 (Inherited from Form.)
Protected method | OnClosing | Closing イベントを発生させます。 (Inherited from Form.)
Protected method | OnContextMenuChanged | ContextMenuChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnContextMenuStripChanged | ContextMenuStripChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnControlAdded | ControlAdded イベントを発生させます。 (Inherited from Control.)
Protected method | OnControlRemoved | ControlRemoved イベントを発生させます。 (Inherited from Control.)
Protected method | OnCreateControl | CreateControl イベントを発生させます。 (Inherited from Form.)
Protected method | OnCursorChanged | CursorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnDeactivate | Deactivate イベントを発生させます。 (Inherited from Form.)
Protected method | OnDockChanged | DockChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnDoubleClick | DoubleClick イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragDrop | DragDrop イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragEnter | DragEnter イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragLeave | DragLeave イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragOver | DragOver イベントを発生させます。 (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Enter イベントを発生させます。 (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | ForeColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnFormClosed | FormClosed イベントを発生させます。 (Inherited from Form.)
Protected method | OnFormClosing | FormClosing イベントを発生させます。 (Inherited from Form.)
Protected method | OnGiveFeedback | GiveFeedback イベントを発生させます。 (Inherited from Control.)
Protected method | OnGotFocus | GotFocus イベントを発生させます。 (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | HelpButtonClicked イベントを発生させます。 (Inherited from Form.)
Protected method | OnHelpRequested | HelpRequested イベントを発生させます。 (Inherited from Control.)
Protected method | OnImeModeChanged | ImeModeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnInputLanguageChanged | InputLanguageChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnInputLanguageChanging | InputLanguageChanging イベントを発生させます。 (Inherited from Form.)
Protected method | OnInvalidated | Invalidated イベントを発生させます。 (Inherited from Control.)
Protected method | OnKeyDown | KeyDown イベントを発生させます。 (Inherited from Control.)
Protected method | OnKeyPress | KeyPress イベントを発生させます。 (Inherited from Control.)
Protected method | OnKeyUp | KeyUp イベントを発生させます。 (Inherited from Control.)
Protected method | OnLayout | Layout イベントを発生させます。 (Inherited from Form.)
Protected method | OnLeave | Leave イベントを発生させます。 (Inherited from Control.)
Protected method | OnLoad | Load イベントを発生させます。 (Inherited from Form.)
Protected method | OnLocationChanged | LocationChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnLostFocus | LostFocus イベントを発生させます。 (Inherited from Control.)
Protected method | OnMarginChanged | MarginChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | MaximizedBoundsChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnMaximumSizeChanged | MaximumSizeChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnMdiChildActivate | MdiChildActivate イベントを発生させます。 (Inherited from Form.)
Protected method | OnMenuComplete | MenuComplete イベントを発生させます。 (Inherited from Form.)
Protected method | OnMenuStart | MenuStart イベントを発生させます。 (Inherited from Form.)
Protected method | OnMinimumSizeChanged | MinimumSizeChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnMouseCaptureChanged | MouseCaptureChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseClick | MouseClick イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseDoubleClick | MouseDoubleClick イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseDown | MouseDown イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseEnter | MouseEnter イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseHover | MouseHover イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseLeave | MouseLeave イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseMove | MouseMove イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseUp | MouseUp イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseWheel | MouseWheel イベントを発生させます。 (Inherited from ScrollableControl.)
Protected method | OnMove | Move イベントを発生させます。 (Inherited from Control.)
Protected method | OnNotifyMessage | コントロールに Windows メッセージを通知します。 (Inherited from Control.)
Protected method | OnPaddingChanged | PaddingChanged イベントを発生させます。 (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | コントロールの背景を描画します。 (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | コントロールのコンテナーの BackColor プロパティ値が変更された場合に、BackColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | コントロールのコンテナーの BackgroundImage プロパティ値が変更された場合に、BackgroundImageChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentBindingContextChanged | コントロールのコンテナーの BindingContext プロパティ値が変更された場合に、BindingContextChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | CursorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentEnabledChanged | コントロールのコンテナーの Enabled プロパティ値が変更された場合に、EnabledChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentFontChanged | コントロールのコンテナーの Font プロパティ値が変更された場合に、FontChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentForeColorChanged | コントロールのコンテナーの ForeColor プロパティ値が変更された場合に、ForeColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | コントロールのコンテナーの RightToLeft プロパティ値が変更された場合に、RightToLeftChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentVisibleChanged | コントロールのコンテナーの Visible プロパティ値が変更された場合に、VisibleChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnPreviewKeyDown | PreviewKeyDown イベントを発生させます。 (Inherited from Control.)
Protected method | OnPrint | Paint イベントを発生させます。 (Inherited from Control.)
Protected method | OnQueryContinueDrag | QueryContinueDrag イベントを発生させます。 (Inherited from Control.)
Protected method | OnRegionChanged | RegionChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | ResizeBegin イベントを発生させます。 (Inherited from Form.)
Protected method | OnResizeEnd | ResizeEnd イベントを発生させます。 (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | RightToLeftLayoutChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnScroll | Scroll イベントを発生させます。 (Inherited from ScrollableControl.)
Protected method | OnShown | Shown イベントを発生させます。 (Inherited from Form.)
Protected method | OnSizeChanged | SizeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | SystemColorsChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnTabIndexChanged | TabIndexChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnTabStopChanged | TabStopChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Validated イベントを発生させます。 (Inherited from Control.)
Protected method | OnValidating | Validating イベントを発生させます。 (Inherited from Control.)
Protected method | OnVisibleChanged | VisibleChanged イベントを発生させます。 (Inherited from Form.)
Public method | PerformAutoScale | コンテナー コントロールとその子のスケーリングを実行します。 (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | コントロールがレイアウト ロジックをすべての子コントロールに適用するように強制します。 (Inherited from Control.)
Public method | PerformLayout(Control, String) | コントロールがレイアウト ロジックをすべての子コントロールに適用するように強制します。 (Inherited from Control.)
Public method | PointToClient | 指定した画面上のポイントを計算してクライアント座標を算出します。 (Inherited from Control.)
Public method | PointToScreen | 指定したクライアント ポイントを計算して画面座標を算出します。 (Inherited from Control.)
Public method | PreProcessControlMessage | キーボード メッセージまたは入力メッセージがディスパッチされる前に、メッセージ ループ内の入力メッセージを前処理します。 (Inherited from Control.)
Public method | PreProcessMessage | キーボード メッセージまたは入力メッセージがディスパッチされる前に、メッセージ ループ内の入力メッセージを前処理します。 (Inherited from Control.)
Protected method | ProcessCmdKey | コマンド キーを処理します。 (Inherited from Form.)
Protected method | ProcessDialogChar | ダイアログ文字を処理します。 (Inherited from Form.)
Protected method | ProcessDialogKey | ダイアログ ボックスのキーを処理します。 (Inherited from Form.)
Protected method | ProcessKeyEventArgs | キー メッセージを処理し、適切なコントロール イベントを生成します。 (Inherited from Control.)
Protected method | ProcessKeyMessage | キーボード メッセージを処理します。 (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | ニーモニック文字を処理します。 (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | 適切なドラッグ イベントを発生させます。 (Inherited from Control.)
Protected method | RaiseKeyEvent | 適切なキー イベントを発生させます。 (Inherited from Control.)
Protected method | RaiseMouseEvent | 適切なマウス イベントを発生させます。 (Inherited from Control.)
Protected method | RaisePaintEvent | 適切な描画イベントを発生させます。 (Inherited from Control.)
Protected method | RecreateHandle | 強制的にコントロールのハンドルを再作成します。 (Inherited from Control.)
Public method | RectangleToClient | 指定した画面上の四角形のサイズと位置をクライアント座標で算出します。 (Inherited from Control.)
Public method | RectangleToScreen | 指定したクライアント領域の四角形のサイズと位置を画面座標で算出します。 (Inherited from Control.)
Public method | Refresh | 強制的に、コントロールがクライアント領域を無効化し、直後にそのコントロール自体とその子コントロールを再描画するようにします。 (Inherited from Control.)
Public method | RemoveOwnedForm | 対象となるフォームから所有されているフォームを削除します。 (Inherited from Form.)
Public method | ResetBackColor | BackColor プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetBindings | BindingSource にバインドされたコントロールに対し、リスト内のすべての項目を再度読み込んで表示値を更新するよう通知します。 (Inherited from Control.)
Public method | ResetCursor | Cursor プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetFont | Font プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetForeColor | ForeColor プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetImeMode | ImeMode プロパティを既定値にリセットします。 (Inherited from Control.)
Protected method | ResetMouseEventArgs | MouseLeave イベントを処理するためのコントロールをリセットします。 (Inherited from Control.)
Public method | ResetRightToLeft | RightToLeft プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetText | Text プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResumeLayout()()()() | 通常のレイアウト ロジックを再開します。 (Inherited from Control.)
Public method | ResumeLayout(Boolean) | 通常のレイアウト ロジックを再開します。オプションで、保留中のレイアウト要求のレイアウトを強制的に即時実行します。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | 指定した HorizontalAlignment を適切な HorizontalAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | 指定した LeftRightAlignment を適切な LeftRightAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | 指定した ContentAlignment を適切な ContentAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateContent | 指定した ContentAlignment を適切な ContentAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateHorizontal | 指定した HorizontalAlignment を適切な HorizontalAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateLeftRight | 指定した LeftRightAlignment を適切な LeftRightAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Public method | Scale(Single) | Obsolete. コントロールおよび子コントロールのスケールを設定します。 (Inherited from Control.)
Public method | Scale(SizeF) | 指定されたスケール ファクターによってコントロールおよびすべての子コントロールのスケールを設定します。 (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. コントロール全体および子コントロールのスケールを設定します。 (Inherited from Control.)
Protected method | ScaleControl | コントロールの位置、サイズ、埋め込み、およびマージンのスケールを設定します。 (Inherited from Form.)
Protected method | ScaleCore | フォームのスケーリングを実行します。 (Inherited from Form.)
Public method | ScrollControlIntoView | 自動スクロール機能が有効になっているコントロール上で、指定した子コントロールが表示されるまでスクロールします。 (Inherited from ScrollableControl.)
Protected method | ScrollToControl | 指定した子コントロールへのスクロールのオフセットを計算します。 (Inherited from ScrollableControl.)
Public method | Select()()()() | コントロールをアクティブにします。 (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | このフォームを選択し、オプションで次のコントロールまたは前のコントロールを選択します。 (Inherited from Form.)
Public method | SelectNextControl | 次のコントロールをアクティブにします。 (Inherited from Control.)
Public method | SendToBack | コントロールを z オーダーの背面に移動します。 (Inherited from Control.)
Public method | SetAutoScrollMargin | 自動スクロールのマージンのサイズを設定します。 (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | AutoSize プロパティが有効なときのコントロールの動作を示す値を設定します。 (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | コントロールの範囲を指定した位置とサイズに設定します。 (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | コントロールの指定した範囲を指定した位置とサイズに設定します。 (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | フォームのクライアント サイズを設定します。このメソッドは、クライアント サイズを指定されたサイズにするために、フォームの境界を調節します。 (Inherited from Form.)
Public method | SetDesktopBounds | フォームの範囲をデスクトップ座標で設定します。 (Inherited from Form.)
Public method | SetDesktopLocation | フォームの位置をデスクトップ座標で設定します。 (Inherited from Form.)
Protected method | SetDisplayRectLocation | 表示ウィンドウを指定した値に配置します。 (Inherited from ScrollableControl.)
Protected method | SetScrollState | 指定したスクロール状態フラグを設定します。 (Inherited from ScrollableControl.)
Protected method | SetStyle | 指定した ControlStyles フラグを true または false に設定します。 (Inherited from Control.)
Protected method | SetTopLevel | コントロールをトップレベル コントロールとして設定します。 (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | コントロールをユーザーに対して表示します。 (Inherited from Control.)
Public method | Show(IWin32Window) | 所有側フォームを指定してフォームをユーザーに表示します。 (Inherited from Form.)
Public method | ShowDialog()()()() | 現在のアクティブ ウィンドウを所有側フォームに設定して、フォームをモーダル ダイアログ ボックスとして表示します。 (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | 指定した所有者を持つモーダル ダイアログ ボックスとしてフォームを表示します。 (Inherited from Form.)
Protected method | SizeFromClientSize | クライアント領域の高さおよび幅からコントロール全体のサイズを決定します。 (Inherited from Control.)
Public method | SuspendLayout | コントロールのレイアウト ロジックを一時的に中断します。 (Inherited from Control.)
Public method | ToString | フォームの現在のインスタンスを表す文字列を取得します。 (Inherited from Form.)
Public method | Update | コントロールによって、クライアント領域内の無効化された領域が再描画されます。 (Inherited from Control.)
Protected method | UpdateBounds()()()() | コントロールの範囲を現在のサイズと位置で更新します。 (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | コントロールの範囲を指定したサイズと位置で更新します。 (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | コントロールの範囲を指定したサイズ、位置、およびクライアント サイズで更新します。 (Inherited from Control.)
Protected method | UpdateDefaultButton | 既定のボタンを更新します。 (Inherited from Form.)
Protected method | UpdateStyles | 割り当て済みのスタイルを強制的にコントロールに再適用します。 (Inherited from Control.)
Protected method | UpdateZOrder | コントロールを親の z オーダーで更新します。 (Inherited from Control.)
Public method | Validate()()()() | フォーカスを失ったコントロールの値を、Validating イベントと Validated イベントを順に発生させることによって検証します。 (Inherited from ContainerControl.)
Public method | Validate(Boolean) | 自動検証が有効かどうかに応じて、フォーカスを失ったコントロールの値を検証します。 (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

Properties

 | Name | Description
Public property | AcceptButton | ユーザーが Enter キーを押したときにクリックされる、フォーム上のボタンを取得または設定します。 (Inherited from Form.)
Public property | AccessibilityObject | コントロールに割り当てられた AccessibleObject を取得します。 (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | ユーザー補助クライアント アプリケーションによって使用される、コントロールの既定のアクションの説明を取得または設定します。 (Inherited from Control.)
Public property | AccessibleDescription | ユーザー補助クライアント アプリケーションによって使用される、コントロールの説明を取得または設定します。 (Inherited from Control.)
Public property | AccessibleName | ユーザー補助クライアント アプリケーションによって使用されるコントロールの名前を取得または設定します。 (Inherited from Control.)
Public property | AccessibleRole | コントロールのアクセスできる役割を取得または設定します。 (Inherited from Control.)
Public property | ActiveControl | コンテナー コントロール上のアクティブ コントロールを取得または設定します。 (Inherited from ContainerControl.)
Public property | ActiveMdiChild | 現在アクティブなマルチ ドキュメント インターフェイス (MDI) 子ウィンドウを取得します。 (Inherited from Form.)
Public property | AllowDrop | ユーザーがコントロールにドラッグしたデータを、そのコントロールが受け入れることができるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | AllowTransparency | フォームの不透明度を調節できるかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | Anchor | コントロールがバインドされるコンテナーの端を取得または設定し、親のサイズ変更時に、コントロールのサイズがどのように変化するかを決定します。 (Inherited from Control.)
Public property | AutoScale | Obsolete. フォームで使用されるフォントの高さに合わせてフォームのサイズを調整し、そのコントロールをスケールするかどうかを示す値を取得します。 (Inherited from Form.)
Public property | AutoScaleBaseSize | フォームを自動スケールするときに使用する基本サイズを取得または設定します。 (Inherited from Form.)
Public property | AutoScaleDimensions | コントロールがデザインされたときの寸法を取得または設定します。 (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | 現在の自動スケーリングの寸法と設計時の自動スケーリングの寸法の間のスケール ファクターを取得します。 (Inherited from ContainerControl.)
Public property | AutoScaleMode | コントロールの自動スケーリング モードを取得または設定します。 (Inherited from ContainerControl.)
Public property | AutoScroll | フォームで自動スクロールを有効にするかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | AutoScrollMargin | 自動スクロールのマージンのサイズを取得または設定します。 (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | 自動スクロールの最小サイズを取得または設定します。 (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | ScrollControlIntoView(Control) でのこのコントロールのスクロール先を取得または設定します。 (Inherited from Control.)
Public property | AutoScrollPosition | 自動スクロールの位置を取得または設定します。 (Inherited from ScrollableControl.)
Public property | AutoSize | AutoSizeMode の設定に従って、フォームのサイズを変更します。 (Inherited from Form.)
Public property | AutoSizeMode | フォームを自動的にサイズ変更するときに使用するモードを取得または設定します。 (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | コントロールに表示される背景イメージを取得または設定します。 (Inherited from Control.)
Public property | BackgroundImageLayout | ImageLayout 列挙体で定義された背景イメージ レイアウトを取得または設定します。 (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | コントロールの下端とコンテナーのクライアント領域の上端の間の距離をピクセルで取得します。 (Inherited from Control.)
Public property | Bounds | クライアント以外の要素を含むコントロールの、親コントロールに対する相対的なサイズおよび位置をピクセル単位で取得または設定します。 (Inherited from Control.)
Public property | CancelButton | ユーザーが Esc キーを押したときにクリックされるボタン コントロールを取得または設定します。 (Inherited from Form.)
Protected property | CanEnableIme | ImeMode プロパティをアクティブな値に設定して、IME サポートを有効にできるかどうかを示す値を取得します。 (Inherited from ContainerControl.)
Public property | CanFocus | コントロールがフォーカスを受け取ることができるかどうかを示す値を取得します。 (Inherited from Control.)
Protected property | CanRaiseEvents | コントロールでイベントが発生するかどうかを決定します。 (Inherited from Control.)
Public property | CanSelect | コントロールを選択できるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | Capture | コントロールがマウスをキャプチャしたかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | CausesValidation | そのコントロールが原因で、フォーカスを受け取ると検証が必要なコントロールに対して、検証が実行されるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | ClientRectangle | コントロールのクライアント領域を表す四角形を取得します。 (Inherited from Control.)
Public property | ClientSize | フォームのクライアント領域のサイズを取得または設定します。 (Inherited from Form.)
Public property | CompanyName | コントロールを含んでいるアプリケーションの会社または作成者の名前を取得します。 (Inherited from Control.)
Public property | Container | Component を格納している IContainer を取得します。 (Inherited from Component.)
Public property | ContainsFocus | コントロール、またはその子コントロールの 1 つに、現在入力フォーカスがあるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | ContextMenu | コントロールに関連付けられたショートカット メニューを取得または設定します。 (Inherited from Control.)
Public property | ContextMenuStrip | このコントロールに関連付けられている ContextMenuStrip を取得または設定します。 (Inherited from Control.)
Public property | ControlBox | フォームのキャプション バーにコントロール ボックスを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | Controls | コントロール内に格納されているコントロールのコレクションを取得します。 (Inherited from Control.)
Public property | Created | コントロールが作成されているかどうかを示す値を取得します。 (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | 現在の画面の実行時寸法を取得します。 (Inherited from ContainerControl.)
Public property | Cursor | マウス ポインターがコントロールの上にあるときに表示されるカーソルを取得または設定します。 (Inherited from Control.)
Public property | DataBindings | コントロールのデータ連結を取得します。 (Inherited from Control.)
Protected property | DefaultCursor | コントロールの既定のカーソルを取得または設定します。 (Inherited from Control.)
Protected property | DefaultImeMode | コントロールがサポートしている既定の IME (Input Method Editor) モードを取得します。 (Inherited from Form.)
Protected property | DefaultMargin | コントロール間に既定で指定されている空白をピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultMaximumSize | コントロールの既定の最大サイズとして指定されている長さおよび高さをピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultMinimumSize | コントロールの既定の最小サイズとして指定されている長さおよび高さをピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultPadding | コントロールの内容の内部間隔をピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Component が現在デザイン モードかどうかを示す値を取得します。 (Inherited from Component.)
Public property | DesktopBounds | Windows デスクトップ上のフォームのサイズと位置を取得または設定します。 (Inherited from Form.)
Public property | DesktopLocation | Windows デスクトップ上のフォームの位置を取得または設定します。 (Inherited from Form.)
Public property | DialogResult | フォームのダイアログ結果を取得または設定します。 (Inherited from Form.)
Public property | DisplayRectangle | コントロールの仮想表示領域を表す四角形を取得します。 (Inherited from ScrollableControl.)
Public property | Disposing | 基本 Control クラスが破棄処理中かどうかを示す値を取得します。 (Inherited from Control.)
Public property | Dock | コントロールの境界のうち、親コントロールにドッキングする境界を取得または設定します。また、コントロールのサイズが親コントロール内でどのように変化するかを決定します。 (Inherited from Control.)
Public property | DockPadding | コントロールのすべての端に対するドッキング埋め込みの設定を取得します。 (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | ちらつきを軽減または回避するために、2 次バッファーを使用してコントロールの表面を再描画するかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | Enabled | コントロールがユーザーとの対話に応答できるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Protected property | Events | Component に結び付けられているイベント ハンドラーのリストを取得します。 (Inherited from Component.)
Public property | Focused | コントロールに入力フォーカスがあるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | Font | コントロールによって表示されるテキストのフォントを取得または設定します。 (Inherited from Control.)
Protected property | FontHeight | コントロールのフォントの高さを取得または設定します。 (Inherited from Control.)
Public property | ForeColor | コントロールの前景色を取得または設定します。 (Inherited from Control.)
Public property | FormBorderStyle | フォームの境界線スタイルを取得または設定します。 (Inherited from Form.)
Public property | Handle | コントロールのバインド先のウィンドウ ハンドルを取得します。 (Inherited from Control.)
Public property | HasChildren | コントロールに 1 つ以上の子コントロールが格納されているかどうかを示す値を取得します。 (Inherited from Control.)
Public property | Height | コントロールの高さを取得または設定します。 (Inherited from Control.)
Public property | HelpButton | フォームのキャプション ボックスにヘルプ ボタンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | HorizontalScroll | 水平スクロール バーに関連付けられた特性を取得します。 (Inherited from ScrollableControl.)
Protected property | HScroll | 水平スクロール バーが表示されるかどうかを示す値を、取得または設定します。 (Inherited from ScrollableControl.)
Public property | Icon | フォームのアイコンを取得または設定します。 (Inherited from Form.)
Public property | ImeMode | コントロールの IME (Input Method Editor) モードを取得または設定します。 (Inherited from Control.)
Protected property | ImeModeBase | コントロールの IME モードを取得または設定します。 (Inherited from Control.)
Public property | InvokeRequired | 呼び出し元がコントロールの作成されたスレッドと異なるスレッド上にあるため、コントロールに対してメソッドの呼び出しを実行するときに、呼び出し元で invoke メソッドを呼び出す必要があるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsAccessible | コントロールがユーザー補助アプリケーションに表示されるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | IsDisposed | コントロールが破棄されているかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsHandleCreated | コントロールにハンドルが関連付けられているかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsMdiChild | フォームがマルチ ドキュメント インターフェイス (MDI) 子フォームかどうかを示す値を取得します。 (Inherited from Form.)
Public property | IsMdiContainer | フォームがマルチ ドキュメント インターフェイス (MDI: Multiple Document Interface) 子フォームのコンテナーかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | IsMirrored | コントロールがミラー化されるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsRestrictedWindow | フォームがすべてのウィンドウとユーザー入力イベントを制限なく使用できるかどうかを示す値を取得します。 (Inherited from Form.)
Public property | KeyPreview | キー イベントがフォーカスを持つコントロールに渡される前に、フォームがそのイベントを受け取るかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | LayoutEngine | コントロールのレイアウト エンジンのキャッシュされたインスタンスを取得します。 (Inherited from Control.)
Public property | Left | コントロールの左端とコンテナーのクライアント領域の左端の間の距離をピクセルで取得または設定します。 (Inherited from Control.)
Public property | Location | 画面座標における Form の左上隅を表す Point を取得および設定します。 (Inherited from Form.)
Public property | MainMenuStrip | フォームの主要メニューのコンテナーを取得または設定します。 (Inherited from Form.)
Public property | Margin | コントロール間の空白を取得または設定します。 (Inherited from Form.)
Public property | MaximizeBox | フォームのキャプション バーに最大化ボタンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Protected property | MaximizedBounds | 最大化された場合のフォームのサイズを取得および設定します。 (Inherited from Form.)
Public property | MaximumSize | フォームのサイズを変更する場合の最大サイズを取得します。 (Inherited from Form.)
Public property | MdiChildren | 対象のフォームが親フォームであるマルチ ドキュメント インターフェイス (MDI) 子フォームの配列を取得します。 (Inherited from Form.)
Public property | MdiParent | 対象となるフォームの現在のマルチ ドキュメント インターフェイス (MDI) 親フォームを取得または設定します。 (Inherited from Form.)
Public property | Menu | フォームに表示する MainMenu を取得または設定します。 (Inherited from Form.)
Public property | MergedMenu | フォームのマージされたメニューを取得します。 (Inherited from Form.)
Public property | MinimizeBox | フォームのキャプション バーに最小化ボタンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | MinimumSize | フォームのサイズを変更する場合の最小サイズを取得または設定します。 (Inherited from Form.)
Public property | Modal | フォームをモーダルとして表示するかどうかを示す値を取得します。 (Inherited from Form.)
Public property | Name | コントロールの名前を取得または設定します。 (Inherited from Control.)
Public property | Opacity | フォームの不透明度を取得または設定します。 (Inherited from Form.)
Public property | OwnedForms | 対象となるフォームによって所有されている全フォームを表す、Form オブジェクトの配列を取得します。 (Inherited from Form.)
Public property | Owner | 対象のフォームを所有しているフォームを取得または設定します。 (Inherited from Form.)
Public property | Padding | コントロールの埋め込みを取得または設定します。 (Inherited from Control.)
Public property | Parent | コントロールの親コンテナーを取得または設定します。 (Inherited from Control.)
Public property | ParentForm | コンテナー コントロールが割り当てられるフォームを取得します。 (Inherited from ContainerControl.)
Public property | PreferredSize | コントロールが適合する四角形領域のサイズを取得します。 (Inherited from Control.)
Public property | ProductName | コントロールを格納しているアセンブリの製品名を取得します。 (Inherited from Control.)
Public property | ProductVersion | コントロールを格納しているアセンブリのバージョンを取得します。 (Inherited from Control.)
Public property | RecreatingHandle | コントロールが現在そのコントロールのハンドルを再作成中かどうかを示す値を取得します。 (Inherited from Control.)
Public property | Region | コントロールに関連付けられたウィンドウ領域を取得または設定します。 (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. このプロパティは使用されなくなりました。 (Inherited from Control.)
Protected property | ResizeRedraw | サイズが変更されたときに、コントロールがコントロール自体を再描画するかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | RestoreBounds | 通常のウィンドウ状態におけるフォームの位置とサイズを取得します。 (Inherited from Form.)
Public property | Right | コントロールの右端とコンテナーのクライアント領域の左端の間の距離をピクセルで取得します。 (Inherited from Control.)
Public property | RightToLeft | コントロールの要素が、右から左へ表示されるフォントを使用するロケールをサポートするように配置されているかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | RightToLeftLayout | 右から左方向の反転配置を有効にするかどうかを示す値を取得または設定します。 (Inherited from Form.)
Protected property | ScaleChildren | 子コントロールのスケーリングを決定する値を取得します。 (Inherited from Control.)
Protected property | ShowFocusCues | コントロールがフォーカスを示す四角形を表示する必要があるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | ShowIcon | フォームのキャプション バーにアイコンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | ShowInTaskbar | フォームを Windows タスク バーに表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Protected property | ShowKeyboardCues | ユーザー インターフェイスがキーボード アクセラレータを表示または非表示にする適切な状態かどうかを示す値を取得します。 (Inherited from Control.)
Protected property | ShowWithoutActivation | ウィンドウが表示されたときにそのウィンドウをアクティブにするかどうかを示す値を取得します。 (Inherited from Form.)
Public property | Site | コントロールのサイトを取得または設定します。 (Inherited from Control.)
Public property | Size | フォームのサイズを取得または設定します。 (Inherited from Form.)
Public property | SizeGripStyle | フォームの右下隅に表示するサイズ変更グリップのスタイルを取得または設定します。 (Inherited from Form.)
Public property | StartPosition | 実行時にフォームの開始位置を取得または設定します。 (Inherited from Form.)
Public property | TabIndex | コンテナー内のコントロールのタブ オーダーを取得または設定します。 (Inherited from Form.)
Public property | TabStop | ユーザーが Tab キーで、このコントロールにフォーカスを移すことができるかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | Tag | コントロールに関するデータを格納するオブジェクトを取得または設定します。 (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | コントロールの上端とコンテナーのクライアント領域の上端の間の距離をピクセル単位で取得または設定します。 (Inherited from Control.)
Public property | TopLevel | フォームをトップレベル ウィンドウとして表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | TopLevelControl | 別の Windows フォーム コントロールを親として持たない親コントロールを取得します。一般的に、これは、コントロールを格納している、最も外側の Form です。 (Inherited from Control.)
Public property | TopMost | フォームを最上位フォームとして表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | TransparencyKey | フォームの透明な領域を表す色を取得または設定します。 (Inherited from Form.)
Public property | UseWaitCursor | 現在のコントロールおよびすべての子コントロールに待機カーソルを使用するかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | VerticalScroll | 垂直スクロール バーに関連付けられた特性を取得します。 (Inherited from ScrollableControl.)
Public property | Visible | コントロールとそのすべての子コントロールが表示されているかどうかを示す値を取得または設定します。 (Inherited from Control.)
Protected property | VScroll | 垂直スクロール バーが表示されるかどうかを示す値を、取得または設定します。 (Inherited from ScrollableControl.)
Public property | Width | コントロールの幅を取得または設定します。 (Inherited from Control.)
Public property | WindowState | フォームのウィンドウ状態を取得または設定します。 (Inherited from Form.)
Public property | WindowTarget | このクラスでは、このプロパティは使用されません。 (Inherited from Control.)

Events

 | Name | Description
Public event | Activated | フォームがコード内またはユーザーの操作によってアクティブになると発生します。 (Inherited from Form.)
Public event | AutoSizeChanged | AutoSize プロパティが変更されたときに発生します。 (Inherited from Form.)
Public event | AutoValidateChanged | AutoValidate プロパティが変更されると発生します。 (Inherited from Form.)
Public event | BackColorChanged | BackColor プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | BackgroundImageChanged | BackgroundImage プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | BackgroundImageLayout プロパティが変更された場合に発生します。 (Inherited from Control.)
Public event | BindingContextChanged | BindingContext プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | CausesValidationChanged | CausesValidation プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | ChangeUICues | フォーカス四角形またはキーボード インターフェイス (UI) キューが変更されたときに発生します。 (Inherited from Control.)
Public event | Click | コントロールがクリックされたときに発生します。 (Inherited from Control.)
Public event | ClientSizeChanged | ClientSize プロパティの値が変更されたときに発生します。 (Inherited from Control.)
Public event | Closed | フォームが閉じたときに発生します。 (Inherited from Form.)
Public event | Closing | フォームが閉じている間に発生します。 (Inherited from Form.)
Public event | ContextMenuChanged | ContextMenu プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | ContextMenuStripChanged | ContextMenuStrip プロパティの値が変更されたときに発生します。 (Inherited from Control.)
Public event | ControlAdded | 新しいコントロールが Control..::..ControlCollection に追加されたときに発生します。 (Inherited from Control.)
Public event | ControlRemoved | Control..::..ControlCollection からコントロールが削除されたときに発生します。 (Inherited from Control.)
Public event | CursorChanged | Cursor プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | Deactivate | フォームがフォーカスを失い、アクティブでなくなると発生します。 (Inherited from Form.)
Public event | Disposed | Dispose()()()() メソッドの呼び出しによってコンポーネントが破棄されると発生します。 (Inherited from Component.)
Public event | DockChanged | Dock プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | DoubleClick | コントロールがダブルクリックされたときに発生します。 (Inherited from Control.)
Public event | DragDrop | ドラッグ アンド ドロップ操作が完了したときに発生します。 (Inherited from Control.)
Public event | DragEnter | オブジェクトがコントロールの境界内にドラッグされると発生します。 (Inherited from Control.)
Public event | DragLeave | オブジェクトがコントロールの境界の外へドラッグされると発生します。 (Inherited from Control.)
Public event | DragOver | オブジェクトがコントロールの境界を超えてドラッグされると発生します。 (Inherited from Control.)
Public event | EnabledChanged | Enabled プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | Enter | コントロールが入力されると発生します。 (Inherited from Control.)
Public event | FontChanged | Font プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | ForeColorChanged | ForeColor プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | FormClosed | フォームが閉じた後に発生します。 (Inherited from Form.)
Public event | FormClosing | フォームが閉じる前に発生します。 (Inherited from Form.)
Public event | GiveFeedback | ドラッグ操作中に発生します。 (Inherited from Control.)
Public event | GotFocus | コントロールがフォーカスを受け取ると発生します。 (Inherited from Control.)
Public event | HandleCreated | コントロールに対してハンドルが作成されると発生します。 (Inherited from Control.)
Public event | HandleDestroyed | コントロールのハンドルが破棄されているときに発生します。 (Inherited from Control.)
Public event | HelpButtonClicked | ヘルプ ボタンがクリックされると発生します。 (Inherited from Form.)
Public event | HelpRequested | ユーザーがコントロールのヘルプを要求すると発生します。 (Inherited from Control.)
Public event | ImeModeChanged | ImeMode プロパティが変更された場合に発生します。 (Inherited from Control.)
Public event | InputLanguageChanged | フォームの入力言語が変更された後に発生します。 (Inherited from Form.)
Public event | InputLanguageChanging | ユーザーがフォームの入力言語を変更しようとすると発生します。 (Inherited from Form.)
Public event | Invalidated | コントロールの表示で再描画が必要なときに発生します。 (Inherited from Control.)
Public event | KeyDown | コントロールにフォーカスがあるときにキーが押されると発生します。 (Inherited from Control.)
Public event | KeyPress | コントロールにフォーカスがあるときにキーが押されると発生します。 (Inherited from Control.)
Public event | KeyUp | コントロールにフォーカスがあるときにキーが離されると発生します。 (Inherited from Control.)
Public event | Layout | コントロールの子コントロールの位置を変更する必要があるときに発生します。 (Inherited from Control.)
Public event | Leave | 入力フォーカスがコントロールを離れると発生します。 (Inherited from Control.)
Public event | Load | フォームが初めて表示される直前に発生します。 (Inherited from Form.)
Public event | LocationChanged | Location プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | LostFocus | コントロールにフォーカスがなくなると発生します。 (Inherited from Control.)
Public event | MarginChanged | Margin プロパティが変更されると発生します。 (Inherited from Form.)
Public event | MaximizedBoundsChanged | MaximizedBounds プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | MaximumSizeChanged | MaximumSize プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | MdiChildActivate | マルチ ドキュメント インターフェイス (MDI) 子フォームが MDI アプリケーション内でアクティブになった場合、または閉じた場合に発生します。 (Inherited from Form.)
Public event | MenuComplete | フォームのメニューがフォーカスを失ったときに発生します。 (Inherited from Form.)
Public event | MenuStart | フォームのメニューがフォーカスを受け取ると発生します。 (Inherited from Form.)
Public event | MinimumSizeChanged | MinimumSize プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | MouseCaptureChanged | コントロールでマウスのキャプチャを失ったか取得したときに発生します。 (Inherited from Control.)
Public event | MouseClick | コントロールがマウスでクリックされたときに発生します。 (Inherited from Control.)
Public event | MouseDoubleClick | コントロールがマウスでダブルクリックされたときに発生します。 (Inherited from Control.)
Public event | MouseDown | マウス ポインターがコントロール上にあり、マウス ボタンがクリックされると発生します。 (Inherited from Control.)
Public event | MouseEnter | マウス ポインターによってコントロールが入力されると発生します。 (Inherited from Control.)
Public event | MouseHover | マウス ポインターをコントロールの上に重ねると発生します。 (Inherited from Control.)
Public event | MouseLeave | マウス ポインターがコントロールを離れると発生します。 (Inherited from Control.)
Public event | MouseMove | マウス ポインターがコントロール上を移動すると発生します。 (Inherited from Control.)
Public event | MouseUp | マウス ポインターがコントロール上にあり、マウス ボタンが離されると発生します。 (Inherited from Control.)
Public event | MouseWheel | コントロールにフォーカスがあるときにマウス ホイールが動くと発生します。 (Inherited from Control.)
Public event | Move | コントロールが移動されると発生します。 (Inherited from Control.)
Public event | PaddingChanged | コントロールの埋め込みが変更されたときに発生します。 (Inherited from Control.)
Public event | Paint | コントロールが再描画されると発生します。 (Inherited from Control.)
Public event | ParentChanged | Parent プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | PreviewKeyDown | このコントロールにフォーカスがあるときにキーが押された場合、KeyDown イベントの前に発生します。 (Inherited from Control.)
Public event | QueryAccessibilityHelp | AccessibleObject がユーザー補助アプリケーションにヘルプを提供したときに発生します。 (Inherited from Control.)
Public event | QueryContinueDrag | ドラッグ アンド ドロップ操作中に発生し、ドラッグ ソースがドラッグ アンド ドロップ操作をキャンセルする必要があるかどうかを決定できるようにします。 (Inherited from Control.)
Public event | RegionChanged | Region プロパティの値が変更されたときに発生します。 (Inherited from Control.)
Public event | Resize | コントロールのサイズが変更されると発生します。 (Inherited from Control.)
Public event | ResizeBegin | フォームがサイズ変更モードになったときに発生します。 (Inherited from Form.)
Public event | ResizeEnd | フォームがサイズ変更モードでなくなったときに発生します。 (Inherited from Form.)
Public event | RightToLeftChanged | RightToLeft プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | RightToLeftLayoutChanged | RightToLeftLayout プロパティの値が変更された後に発生します。 (Inherited from Form.)
Public event | Scroll | ユーザーまたはコードによってクライアント領域がスクロールされたときに発生します。 (Inherited from ScrollableControl.)
Public event | Shown | フォームが初めて表示されるたびに発生します。 (Inherited from Form.)
Public event | SizeChanged | Size プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | StyleChanged | コントロール スタイルが変更されると発生します。 (Inherited from Control.)
Public event | SystemColorsChanged | システム カラーが変更されると発生します。 (Inherited from Control.)
Public event | TabIndexChanged | TabIndex プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | TabStopChanged | TabStop プロパティが変更されると発生します。 (Inherited from Form.)
Public event | TextChanged | Text プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | Validated | コントロールの検証が終了すると発生します。 (Inherited from Control.)
Public event | Validating | コントロールが検証を行っているときに発生します。 (Inherited from Control.)
Public event | VisibleChanged | Visible プロパティの値が変更された場合に発生します。 (Inherited from Control.)

See Also

FFTtestForm Class
鳥の声で種識別 Namespace


FFTtestForm Constructor

[image]

A Sandcastle Documented Class Library
FFTtestForm Constructor
FFTtestForm Class See Also フィードバックの送信
コンストラクタ 始めに実行される

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTtestForm()
Visual Basic
Public Sub New
Visual C++
public:
FFTtestForm()

See Also

FFTtestForm Class
鳥の声で種識別 Namespace


FFTtestForm Methods

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm Methods
FFTtestForm Class See Also フィードバックの送信

The FFTtestForm type exposes the following members.

Methods

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | 指定した子コントロールの指定した AccessibleEvents をユーザー補助クライアント アプリケーションに通知します。 (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | 指定した子コントロールの指定した AccessibleEvents をユーザー補助クライアント アプリケーションに通知します。 (Inherited from Control.)
Public method | Activate | フォームをアクティブにし、そのフォームにフォーカスを移します。 (Inherited from Form.)
Protected method | ActivateMdiChild | フォームの MDI 子フォームをアクティブにします。 (Inherited from Form.)
Public method | AddOwnedForm | 対象となるフォームに、所有される側のフォームを追加します。 (Inherited from Form.)
Protected method | AdjustFormScrollbars | 現在のコントロールの位置、および現在選択されているコントロールを基準として、コンテナー上のスクロール バーを調節します。 (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. AutoScaleBaseSize プロパティの現在の値、および現在のフォントのサイズに応じて、フォームのサイズを変更します。 (Inherited from Form.)
Public method | BeginInvoke(Delegate) | コントロールの基になるハンドルが作成されたスレッド上で、指定したデリゲートを非同期的に実行します。 (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | コントロールの基になるハンドルが作成されたスレッド上で、指定した引数で指定したデリゲートを非同期的に実行します。 (Inherited from Control.)
Public method | BringToFront | コントロールを z オーダーの最前面へ移動します。 (Inherited from Control.)
Protected method | CenterToParent | フォームを親フォームの境界内の中央に配置します。 (Inherited from Form.)
Protected method | CenterToScreen | フォームを現在の画面の中央に配置します。 (Inherited from Form.)
Public method | Close | フォームを閉じます。 (Inherited from Form.)
Public method | Contains | 指定したコントロールが、コントロールの子かどうかを示す値を取得します。 (Inherited from Control.)
Protected method | CreateAccessibilityInstance | コントロールの新しいユーザー補助オブジェクトを作成します。 (Inherited from Control.)
Public method | CreateControl | ハンドルおよび子コントロールの作成を含めて、強制的にコントロールを作成します。 (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | コントロールの Graphics を作成します。 (Inherited from Control.)
Protected method | CreateHandle | フォームのハンドルを作成します。派生クラスでこの機能をオーバーライドする場合は、基本の実装を呼び出す必要があります。 (Inherited from Form.)
Public method | CreateObjRef | リモート オブジェクトとの通信に使用するプロキシの生成に必要な情報をすべて格納しているオブジェクトを作成します。 (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | コントロールに関連付けられたハンドルを破棄します。 (Inherited from Control.)
Public method | Dispose()()()() | Component によって使用されているすべてのリソースを解放します。 (Inherited from Component.)
Protected method | Dispose(Boolean) | 使用中のリソースをすべてクリーンアップします。 (Overrides Form..::..Dispose(Boolean).)
Public method | DoDragDrop | ドラッグ アンド ドロップ操作を開始します。 (Inherited from Control.)
Public method | DrawToBitmap | 指定したビットマップへのレンダリングをサポートします。 (Inherited from Control.)
Public method | EndInvoke | 渡された IAsyncResult によって表される、非同期操作の戻り値を取得します。 (Inherited from Control.)
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Component..::..Finalize()()()().)
Public method | FindForm | コントロールがあるフォームを取得します。 (Inherited from Control.)
Public method | Focus | コントロールに入力フォーカスを設定します。 (Inherited from Control.)
Protected method | GetAccessibilityObjectById | 指定した AccessibleObject を取得します。 (Inherited from Control.)
Protected method | GetAutoSizeMode | AutoSize プロパティが有効なときのコントロールの動作を示す値を取得します。 (Inherited from Control.)
Public method | GetChildAtPoint(Point) | 指定した座標にある子コントロールを取得します。 (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | 特定の種類の子コントロールを無視するかどうかを指定して、指定した座標にある子コントロールを取得します。 (Inherited from Control.)
Public method | GetContainerControl | コントロールの親チェインの 1 つ上の ContainerControl を返します。 (Inherited from Control.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetLifetimeService | 対象のインスタンスの有効期間ポリシーを制御する、現在の有効期間サービス オブジェクトを取得します。 (Inherited from MarshalByRefObject.)
Public method | GetNextControl | 子コントロールのタブ オーダー内の 1 つ前または 1 つ後ろのコントロールを取得します。 (Inherited from Control.)
Public method | GetPreferredSize | コントロールが適合する四角形領域のサイズを取得します。 (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | 指定したフラグが設定されているかどうかを判断します。 (Inherited from ScrollableControl.)
Protected method | GetService | Component またはその Container で提供されるサービスを表すオブジェクトを返します。 (Inherited from Component.)
Protected method | GetStyle | コントロールの指定したコントロール スタイル ビットの値を取得します。 (Inherited from Control.)
Protected method | GetTopLevel | コントロールがトップレベル コントロールかどうかを判断します。 (Inherited from Control.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Public method | Hide | コントロールをユーザーに対して非表示にします。 (Inherited from Control.)
Public method | InitializeLifetimeService | 対象のインスタンスの有効期間ポリシーを制御する、有効期間サービス オブジェクトを取得します。 (Inherited from MarshalByRefObject.)
Protected method | InitLayout | コントロールが別のコンテナーに追加された後、呼び出されます。 (Inherited from Control.)
Public method | Invalidate()()()() | コントロールの表面全体を無効化して、コントロールを再描画します。 (Inherited from Control.)
Public method | Invalidate(Region) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。 (Inherited from Control.)
Public method | Invalidate(Boolean) | コントロールの特定の領域を無効にし、そのコントロールに描画メッセージを送信します。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invalidate(Rectangle) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。 (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invoke(Delegate) | コントロールの基になるウィンドウ ハンドルを所有するスレッド上で、指定したデリゲートを実行します。 (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | コントロールの基になるウィンドウ ハンドルを所有するスレッド上で、指定した引数リストを使用して、指定したデリゲートを実行します。 (Inherited from Control.)
Protected method | InvokeGotFocus | 指定したコントロールの GotFocus イベントを発生させます。 (Inherited from Control.)
Protected method | InvokeLostFocus | 指定したコントロールの LostFocus イベントを発生させます。 (Inherited from Control.)
Protected method | InvokeOnClick | 指定したコントロールの Click イベントを発生させます。 (Inherited from Control.)
Protected method | InvokePaint | 指定したコントロールの Paint イベントを発生させます。 (Inherited from Control.)
Protected method | InvokePaintBackground | 指定したコントロールの PaintBackground イベントを発生させます。 (Inherited from Control.)
Protected method | IsInputChar | 文字が、コントロールによって認識される入力文字かどうかを判断します。 (Inherited from Control.)
Protected method | IsInputKey | 指定されているキーが、通常の入力キーであるか、またはプリプロセスを必要とする特殊なキーであるかを確認します。 (Inherited from Control.)
Public method | LayoutMdi | マルチ ドキュメント インターフェイス (MDI) 親フォーム内に MDI 子フォームを配置します。 (Inherited from Form.)
Protected method | MemberwiseClone()()()() | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | 現在の MarshalByRefObject オブジェクトの簡易コピーを作成します。 (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | 無効化するコントロールの領域を指定して、Invalidated イベントを発生させます。 (Inherited from Control.)
Protected method | OnActivated | Activated イベントを発生させます。 (Inherited from Form.)
Protected method | OnAutoSizeChanged | AutoSizeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnAutoValidateChanged | AutoValidateChanged イベントを発生させます。 (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | BackColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnBackgroundImageChanged | BackgroundImageChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | BackgroundImageLayoutChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnBindingContextChanged | BindingContextChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnCausesValidationChanged | CausesValidationChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnChangeUICues | ChangeUICues イベントを発生させます。 (Inherited from Control.)
Protected method | OnClick | Click イベントを発生させます。 (Inherited from Control.)
Protected method | OnClientSizeChanged | ClientSizeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnClosed | Closed イベントを発生させます。 (Inherited from Form.)
Protected method | OnClosing | Closing イベントを発生させます。 (Inherited from Form.)
Protected method | OnContextMenuChanged | ContextMenuChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnContextMenuStripChanged | ContextMenuStripChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnControlAdded | ControlAdded イベントを発生させます。 (Inherited from Control.)
Protected method | OnControlRemoved | ControlRemoved イベントを発生させます。 (Inherited from Control.)
Protected method | OnCreateControl | CreateControl イベントを発生させます。 (Inherited from Form.)
Protected method | OnCursorChanged | CursorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnDeactivate | Deactivate イベントを発生させます。 (Inherited from Form.)
Protected method | OnDockChanged | DockChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnDoubleClick | DoubleClick イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragDrop | DragDrop イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragEnter | DragEnter イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragLeave | DragLeave イベントを発生させます。 (Inherited from Control.)
Protected method | OnDragOver | DragOver イベントを発生させます。 (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Enter イベントを発生させます。 (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | ForeColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnFormClosed | FormClosed イベントを発生させます。 (Inherited from Form.)
Protected method | OnFormClosing | FormClosing イベントを発生させます。 (Inherited from Form.)
Protected method | OnGiveFeedback | GiveFeedback イベントを発生させます。 (Inherited from Control.)
Protected method | OnGotFocus | GotFocus イベントを発生させます。 (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | HelpButtonClicked イベントを発生させます。 (Inherited from Form.)
Protected method | OnHelpRequested | HelpRequested イベントを発生させます。 (Inherited from Control.)
Protected method | OnImeModeChanged | ImeModeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnInputLanguageChanged | InputLanguageChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnInputLanguageChanging | InputLanguageChanging イベントを発生させます。 (Inherited from Form.)
Protected method | OnInvalidated | Invalidated イベントを発生させます。 (Inherited from Control.)
Protected method | OnKeyDown | KeyDown イベントを発生させます。 (Inherited from Control.)
Protected method | OnKeyPress | KeyPress イベントを発生させます。 (Inherited from Control.)
Protected method | OnKeyUp | KeyUp イベントを発生させます。 (Inherited from Control.)
Protected method | OnLayout | Layout イベントを発生させます。 (Inherited from Form.)
Protected method | OnLeave | Leave イベントを発生させます。 (Inherited from Control.)
Protected method | OnLoad | Load イベントを発生させます。 (Inherited from Form.)
Protected method | OnLocationChanged | LocationChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnLostFocus | LostFocus イベントを発生させます。 (Inherited from Control.)
Protected method | OnMarginChanged | MarginChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | MaximizedBoundsChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnMaximumSizeChanged | MaximumSizeChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnMdiChildActivate | MdiChildActivate イベントを発生させます。 (Inherited from Form.)
Protected method | OnMenuComplete | MenuComplete イベントを発生させます。 (Inherited from Form.)
Protected method | OnMenuStart | MenuStart イベントを発生させます。 (Inherited from Form.)
Protected method | OnMinimumSizeChanged | MinimumSizeChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnMouseCaptureChanged | MouseCaptureChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseClick | MouseClick イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseDoubleClick | MouseDoubleClick イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseDown | MouseDown イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseEnter | MouseEnter イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseHover | MouseHover イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseLeave | MouseLeave イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseMove | MouseMove イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseUp | MouseUp イベントを発生させます。 (Inherited from Control.)
Protected method | OnMouseWheel | MouseWheel イベントを発生させます。 (Inherited from ScrollableControl.)
Protected method | OnMove | Move イベントを発生させます。 (Inherited from Control.)
Protected method | OnNotifyMessage | コントロールに Windows メッセージを通知します。 (Inherited from Control.)
Protected method | OnPaddingChanged | PaddingChanged イベントを発生させます。 (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | コントロールの背景を描画します。 (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | コントロールのコンテナーの BackColor プロパティ値が変更された場合に、BackColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | コントロールのコンテナーの BackgroundImage プロパティ値が変更された場合に、BackgroundImageChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentBindingContextChanged | コントロールのコンテナーの BindingContext プロパティ値が変更された場合に、BindingContextChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | CursorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentEnabledChanged | コントロールのコンテナーの Enabled プロパティ値が変更された場合に、EnabledChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentFontChanged | コントロールのコンテナーの Font プロパティ値が変更された場合に、FontChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentForeColorChanged | コントロールのコンテナーの ForeColor プロパティ値が変更された場合に、ForeColorChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | コントロールのコンテナーの RightToLeft プロパティ値が変更された場合に、RightToLeftChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnParentVisibleChanged | コントロールのコンテナーの Visible プロパティ値が変更された場合に、VisibleChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnPreviewKeyDown | PreviewKeyDown イベントを発生させます。 (Inherited from Control.)
Protected method | OnPrint | Paint イベントを発生させます。 (Inherited from Control.)
Protected method | OnQueryContinueDrag | QueryContinueDrag イベントを発生させます。 (Inherited from Control.)
Protected method | OnRegionChanged | RegionChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | ResizeBegin イベントを発生させます。 (Inherited from Form.)
Protected method | OnResizeEnd | ResizeEnd イベントを発生させます。 (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | RightToLeftLayoutChanged イベントを発生させます。 (Inherited from Form.)
Protected method | OnScroll | Scroll イベントを発生させます。 (Inherited from ScrollableControl.)
Protected method | OnShown | Shown イベントを発生させます。 (Inherited from Form.)
Protected method | OnSizeChanged | SizeChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | SystemColorsChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnTabIndexChanged | TabIndexChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnTabStopChanged | TabStopChanged イベントを発生させます。 (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Validated イベントを発生させます。 (Inherited from Control.)
Protected method | OnValidating | Validating イベントを発生させます。 (Inherited from Control.)
Protected method | OnVisibleChanged | VisibleChanged イベントを発生させます。 (Inherited from Form.)
Public method | PerformAutoScale | コンテナー コントロールとその子のスケーリングを実行します。 (Inherited from ContainerControl.)
Public method | PerformLayout()()()() | コントロールがレイアウト ロジックをすべての子コントロールに適用するように強制します。 (Inherited from Control.)
Public method | PerformLayout(Control, String) | コントロールがレイアウト ロジックをすべての子コントロールに適用するように強制します。 (Inherited from Control.)
Public method | PointToClient | 指定した画面上のポイントを計算してクライアント座標を算出します。 (Inherited from Control.)
Public method | PointToScreen | 指定したクライアント ポイントを計算して画面座標を算出します。 (Inherited from Control.)
Public method | PreProcessControlMessage | キーボード メッセージまたは入力メッセージがディスパッチされる前に、メッセージ ループ内の入力メッセージを前処理します。 (Inherited from Control.)
Public method | PreProcessMessage | キーボード メッセージまたは入力メッセージがディスパッチされる前に、メッセージ ループ内の入力メッセージを前処理します。 (Inherited from Control.)
Protected method | ProcessCmdKey | コマンド キーを処理します。 (Inherited from Form.)
Protected method | ProcessDialogChar | ダイアログ文字を処理します。 (Inherited from Form.)
Protected method | ProcessDialogKey | ダイアログ ボックスのキーを処理します。 (Inherited from Form.)
Protected method | ProcessKeyEventArgs | キー メッセージを処理し、適切なコントロール イベントを生成します。 (Inherited from Control.)
Protected method | ProcessKeyMessage | キーボード メッセージを処理します。 (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | ニーモニック文字を処理します。 (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | 適切なドラッグ イベントを発生させます。 (Inherited from Control.)
Protected method | RaiseKeyEvent | 適切なキー イベントを発生させます。 (Inherited from Control.)
Protected method | RaiseMouseEvent | 適切なマウス イベントを発生させます。 (Inherited from Control.)
Protected method | RaisePaintEvent | 適切な描画イベントを発生させます。 (Inherited from Control.)
Protected method | RecreateHandle | 強制的にコントロールのハンドルを再作成します。 (Inherited from Control.)
Public method | RectangleToClient | 指定した画面上の四角形のサイズと位置をクライアント座標で算出します。 (Inherited from Control.)
Public method | RectangleToScreen | 指定したクライアント領域の四角形のサイズと位置を画面座標で算出します。 (Inherited from Control.)
Public method | Refresh | 強制的に、コントロールがクライアント領域を無効化し、直後にそのコントロール自体とその子コントロールを再描画するようにします。 (Inherited from Control.)
Public method | RemoveOwnedForm | 対象となるフォームから所有されているフォームを削除します。 (Inherited from Form.)
Public method | ResetBackColor | BackColor プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetBindings | BindingSource にバインドされたコントロールに対し、リスト内のすべての項目を再度読み込んで表示値を更新するよう通知します。 (Inherited from Control.)
Public method | ResetCursor | Cursor プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetFont | Font プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetForeColor | ForeColor プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetImeMode | ImeMode プロパティを既定値にリセットします。 (Inherited from Control.)
Protected method | ResetMouseEventArgs | MouseLeave イベントを処理するためのコントロールをリセットします。 (Inherited from Control.)
Public method | ResetRightToLeft | RightToLeft プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResetText | Text プロパティを既定値にリセットします。 (Inherited from Control.)
Public method | ResumeLayout()()()() | 通常のレイアウト ロジックを再開します。 (Inherited from Control.)
Public method | ResumeLayout(Boolean) | 通常のレイアウト ロジックを再開します。オプションで、保留中のレイアウト要求のレイアウトを強制的に即時実行します。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | 指定した HorizontalAlignment を適切な HorizontalAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | 指定した LeftRightAlignment を適切な LeftRightAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | 指定した ContentAlignment を適切な ContentAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateContent | 指定した ContentAlignment を適切な ContentAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateHorizontal | 指定した HorizontalAlignment を適切な HorizontalAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateLeftRight | 指定した LeftRightAlignment を適切な LeftRightAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Public method | Scale(Single) | Obsolete. コントロールおよび子コントロールのスケールを設定します。 (Inherited from Control.)
Public method | Scale(SizeF) | 指定されたスケール ファクターによってコントロールおよびすべての子コントロールのスケールを設定します。 (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. コントロール全体および子コントロールのスケールを設定します。 (Inherited from Control.)
Protected method | ScaleControl | コントロールの位置、サイズ、埋め込み、およびマージンのスケールを設定します。 (Inherited from Form.)
Protected method | ScaleCore | フォームのスケーリングを実行します。 (Inherited from Form.)
Public method | ScrollControlIntoView | 自動スクロール機能が有効になっているコントロール上で、指定した子コントロールが表示されるまでスクロールします。 (Inherited from ScrollableControl.)
Protected method | ScrollToControl | 指定した子コントロールへのスクロールのオフセットを計算します。 (Inherited from ScrollableControl.)
Public method | Select()()()() | コントロールをアクティブにします。 (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | このフォームを選択し、オプションで次のコントロールまたは前のコントロールを選択します。 (Inherited from Form.)
Public method | SelectNextControl | 次のコントロールをアクティブにします。 (Inherited from Control.)
Public method | SendToBack | コントロールを z オーダーの背面に移動します。 (Inherited from Control.)
Public method | SetAutoScrollMargin | 自動スクロールのマージンのサイズを設定します。 (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | AutoSize プロパティが有効なときのコントロールの動作を示す値を設定します。 (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | コントロールの範囲を指定した位置とサイズに設定します。 (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | コントロールの指定した範囲を指定した位置とサイズに設定します。 (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | フォームのクライアント サイズを設定します。このメソッドは、クライアント サイズを指定されたサイズにするために、フォームの境界を調節します。 (Inherited from Form.)
Public method | SetDesktopBounds | フォームの範囲をデスクトップ座標で設定します。 (Inherited from Form.)
Public method | SetDesktopLocation | フォームの位置をデスクトップ座標で設定します。 (Inherited from Form.)
Protected method | SetDisplayRectLocation | 表示ウィンドウを指定した値に配置します。 (Inherited from ScrollableControl.)
Protected method | SetScrollState | 指定したスクロール状態フラグを設定します。 (Inherited from ScrollableControl.)
Protected method | SetStyle | 指定した ControlStyles フラグを true または false に設定します。 (Inherited from Control.)
Protected method | SetTopLevel | コントロールをトップレベル コントロールとして設定します。 (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show()()()() | コントロールをユーザーに対して表示します。 (Inherited from Control.)
Public method | Show(IWin32Window) | 所有側フォームを指定してフォームをユーザーに表示します。 (Inherited from Form.)
Public method | ShowDialog()()()() | 現在のアクティブ ウィンドウを所有側フォームに設定して、フォームをモーダル ダイアログ ボックスとして表示します。 (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | 指定した所有者を持つモーダル ダイアログ ボックスとしてフォームを表示します。 (Inherited from Form.)
Protected method | SizeFromClientSize | クライアント領域の高さおよび幅からコントロール全体のサイズを決定します。 (Inherited from Control.)
Public method | SuspendLayout | コントロールのレイアウト ロジックを一時的に中断します。 (Inherited from Control.)
Public method | ToString | フォームの現在のインスタンスを表す文字列を取得します。 (Inherited from Form.)
Public method | Update | コントロールによって、クライアント領域内の無効化された領域が再描画されます。 (Inherited from Control.)
Protected method | UpdateBounds()()()() | コントロールの範囲を現在のサイズと位置で更新します。 (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | コントロールの範囲を指定したサイズと位置で更新します。 (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | コントロールの範囲を指定したサイズ、位置、およびクライアント サイズで更新します。 (Inherited from Control.)
Protected method | UpdateDefaultButton | 既定のボタンを更新します。 (Inherited from Form.)
Protected method | UpdateStyles | 割り当て済みのスタイルを強制的にコントロールに再適用します。 (Inherited from Control.)
Protected method | UpdateZOrder | コントロールを親の z オーダーで更新します。 (Inherited from Control.)
Public method | Validate()()()() | フォーカスを失ったコントロールの値を、Validating イベントと Validated イベントを順に発生させることによって検証します。 (Inherited from ContainerControl.)
Public method | Validate(Boolean) | 自動検証が有効かどうかに応じて、フォーカスを失ったコントロールの値を検証します。 (Inherited from ContainerControl.)
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)

See Also

FFTtestForm Class
鳥の声で種識別 Namespace


AccessibilityNotifyClients Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..AccessibilityNotifyClients Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | 指定した子コントロールの指定した AccessibleEvents をユーザー補助クライアント アプリケーションに通知します。 (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | 指定した子コントロールの指定した AccessibleEvents をユーザー補助クライアント アプリケーションに通知します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


BeginInvoke Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..BeginInvoke Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | BeginInvoke(Delegate) | コントロールの基になるハンドルが作成されたスレッド上で、指定したデリゲートを非同期的に実行します。 (Inherited from Control.)
Public method | BeginInvoke(Delegate, array<Object>[]()[][]) | コントロールの基になるハンドルが作成されたスレッド上で、指定した引数で指定したデリゲートを非同期的に実行します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Dispose Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Dispose Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Dispose()()()() | Component によって使用されているすべてのリソースを解放します。 (Inherited from Component.)
Protected method | Dispose(Boolean) | 使用中のリソースをすべてクリーンアップします。 (Overrides Form..::..Dispose(Boolean).)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Dispose Method (Boolean)

[image]

A Sandcastle Documented Class Library
FFTtestForm..::..Dispose Method (Boolean)
FFTtestForm Class See Also フィードバックの送信
使用中のリソースをすべてクリーンアップします。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Dispose(
    bool disposing
)
Visual Basic
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: System..::..Boolean
マネージ リソースが破棄される場合 true、破棄されない場合は false です。

See Also

FFTtestForm Class
Dispose Overload
鳥の声で種識別 Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
FFTtestForm..::..Finalize Method
FFTtestForm Class See Also フィードバックの送信
デスコンストラクタ

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

FFTtestForm Class
鳥の声で種識別 Namespace


GetChildAtPoint Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..GetChildAtPoint Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | GetChildAtPoint(Point) | 指定した座標にある子コントロールを取得します。 (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | 特定の種類の子コントロールを無視するかどうかを指定して、指定した座標にある子コントロールを取得します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Invalidate Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Invalidate Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Invalidate()()()() | コントロールの表面全体を無効化して、コントロールを再描画します。 (Inherited from Control.)
Public method | Invalidate(Region) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。 (Inherited from Control.)
Public method | Invalidate(Boolean) | コントロールの特定の領域を無効にし、そのコントロールに描画メッセージを送信します。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invalidate(Rectangle) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。 (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | コントロールの指定した領域を無効にし (そのコントロールの次の描画操作で再描画される領域を示す更新領域に追加し)、描画メッセージがそのコントロールに送信されるようにします。オプションとして、そのコントロールに割り当てられている子コントロールも無効にします。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Invoke Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Invoke Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Invoke(Delegate) | コントロールの基になるウィンドウ ハンドルを所有するスレッド上で、指定したデリゲートを実行します。 (Inherited from Control.)
Public method | Invoke(Delegate, array<Object>[]()[][]) | コントロールの基になるウィンドウ ハンドルを所有するスレッド上で、指定した引数リストを使用して、指定したデリゲートを実行します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


MemberwiseClone Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..MemberwiseClone Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Protected method | MemberwiseClone()()()() | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | 現在の MarshalByRefObject オブジェクトの簡易コピーを作成します。 (Inherited from MarshalByRefObject.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


PerformLayout Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..PerformLayout Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | PerformLayout()()()() | コントロールがレイアウト ロジックをすべての子コントロールに適用するように強制します。 (Inherited from Control.)
Public method | PerformLayout(Control, String) | コントロールがレイアウト ロジックをすべての子コントロールに適用するように強制します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


ResumeLayout Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..ResumeLayout Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | ResumeLayout()()()() | 通常のレイアウト ロジックを再開します。 (Inherited from Control.)
Public method | ResumeLayout(Boolean) | 通常のレイアウト ロジックを再開します。オプションで、保留中のレイアウト要求のレイアウトを強制的に即時実行します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


RtlTranslateAlignment Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..RtlTranslateAlignment Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Protected method | RtlTranslateAlignment(HorizontalAlignment) | 指定した HorizontalAlignment を適切な HorizontalAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | 指定した LeftRightAlignment を適切な LeftRightAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | 指定した ContentAlignment を適切な ContentAlignment に変換し、テキストを右から左に表示できるようにします。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Scale Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Scale Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Scale(Single) | Obsolete. コントロールおよび子コントロールのスケールを設定します。 (Inherited from Control.)
Public method | Scale(SizeF) | 指定されたスケール ファクターによってコントロールおよびすべての子コントロールのスケールを設定します。 (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. コントロール全体および子コントロールのスケールを設定します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Select Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Select Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Select()()()() | コントロールをアクティブにします。 (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | このフォームを選択し、オプションで次のコントロールまたは前のコントロールを選択します。 (Inherited from Form.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


SetBounds Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..SetBounds Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | SetBounds(Int32, Int32, Int32, Int32) | コントロールの範囲を指定した位置とサイズに設定します。 (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | コントロールの指定した範囲を指定した位置とサイズに設定します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Show Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Show Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Show()()()() | コントロールをユーザーに対して表示します。 (Inherited from Control.)
Public method | Show(IWin32Window) | 所有側フォームを指定してフォームをユーザーに表示します。 (Inherited from Form.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


ShowDialog Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..ShowDialog Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | ShowDialog()()()() | 現在のアクティブ ウィンドウを所有側フォームに設定して、フォームをモーダル ダイアログ ボックスとして表示します。 (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | 指定した所有者を持つモーダル ダイアログ ボックスとしてフォームを表示します。 (Inherited from Form.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


UpdateBounds Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..UpdateBounds Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Protected method | UpdateBounds()()()() | コントロールの範囲を現在のサイズと位置で更新します。 (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | コントロールの範囲を指定したサイズと位置で更新します。 (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | コントロールの範囲を指定したサイズ、位置、およびクライアント サイズで更新します。 (Inherited from Control.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


Validate Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..Validate Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Validate()()()() | フォーカスを失ったコントロールの値を、Validating イベントと Validated イベントを順に発生させることによって検証します。 (Inherited from ContainerControl.)
Public method | Validate(Boolean) | 自動検証が有効かどうかに応じて、フォーカスを失ったコントロールの値を検証します。 (Inherited from ContainerControl.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


ValidateChildren Method

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm..::..ValidateChildren Method
FFTtestForm Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | ValidateChildren()()()() | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)

See Also

FFTtestForm Class
FFTtestForm Members
鳥の声で種識別 Namespace


FFTtestForm Properties

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm Properties
FFTtestForm Class See Also フィードバックの送信

The FFTtestForm type exposes the following members.

Properties

 | Name | Description
Public property | AcceptButton | ユーザーが Enter キーを押したときにクリックされる、フォーム上のボタンを取得または設定します。 (Inherited from Form.)
Public property | AccessibilityObject | コントロールに割り当てられた AccessibleObject を取得します。 (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | ユーザー補助クライアント アプリケーションによって使用される、コントロールの既定のアクションの説明を取得または設定します。 (Inherited from Control.)
Public property | AccessibleDescription | ユーザー補助クライアント アプリケーションによって使用される、コントロールの説明を取得または設定します。 (Inherited from Control.)
Public property | AccessibleName | ユーザー補助クライアント アプリケーションによって使用されるコントロールの名前を取得または設定します。 (Inherited from Control.)
Public property | AccessibleRole | コントロールのアクセスできる役割を取得または設定します。 (Inherited from Control.)
Public property | ActiveControl | コンテナー コントロール上のアクティブ コントロールを取得または設定します。 (Inherited from ContainerControl.)
Public property | ActiveMdiChild | 現在アクティブなマルチ ドキュメント インターフェイス (MDI) 子ウィンドウを取得します。 (Inherited from Form.)
Public property | AllowDrop | ユーザーがコントロールにドラッグしたデータを、そのコントロールが受け入れることができるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | AllowTransparency | フォームの不透明度を調節できるかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | Anchor | コントロールがバインドされるコンテナーの端を取得または設定し、親のサイズ変更時に、コントロールのサイズがどのように変化するかを決定します。 (Inherited from Control.)
Public property | AutoScale | Obsolete. フォームで使用されるフォントの高さに合わせてフォームのサイズを調整し、そのコントロールをスケールするかどうかを示す値を取得します。 (Inherited from Form.)
Public property | AutoScaleBaseSize | フォームを自動スケールするときに使用する基本サイズを取得または設定します。 (Inherited from Form.)
Public property | AutoScaleDimensions | コントロールがデザインされたときの寸法を取得または設定します。 (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | 現在の自動スケーリングの寸法と設計時の自動スケーリングの寸法の間のスケール ファクターを取得します。 (Inherited from ContainerControl.)
Public property | AutoScaleMode | コントロールの自動スケーリング モードを取得または設定します。 (Inherited from ContainerControl.)
Public property | AutoScroll | フォームで自動スクロールを有効にするかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | AutoScrollMargin | 自動スクロールのマージンのサイズを取得または設定します。 (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | 自動スクロールの最小サイズを取得または設定します。 (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | ScrollControlIntoView(Control) でのこのコントロールのスクロール先を取得または設定します。 (Inherited from Control.)
Public property | AutoScrollPosition | 自動スクロールの位置を取得または設定します。 (Inherited from ScrollableControl.)
Public property | AutoSize | AutoSizeMode の設定に従って、フォームのサイズを変更します。 (Inherited from Form.)
Public property | AutoSizeMode | フォームを自動的にサイズ変更するときに使用するモードを取得または設定します。 (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | コントロールに表示される背景イメージを取得または設定します。 (Inherited from Control.)
Public property | BackgroundImageLayout | ImageLayout 列挙体で定義された背景イメージ レイアウトを取得または設定します。 (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | コントロールの下端とコンテナーのクライアント領域の上端の間の距離をピクセルで取得します。 (Inherited from Control.)
Public property | Bounds | クライアント以外の要素を含むコントロールの、親コントロールに対する相対的なサイズおよび位置をピクセル単位で取得または設定します。 (Inherited from Control.)
Public property | CancelButton | ユーザーが Esc キーを押したときにクリックされるボタン コントロールを取得または設定します。 (Inherited from Form.)
Protected property | CanEnableIme | ImeMode プロパティをアクティブな値に設定して、IME サポートを有効にできるかどうかを示す値を取得します。 (Inherited from ContainerControl.)
Public property | CanFocus | コントロールがフォーカスを受け取ることができるかどうかを示す値を取得します。 (Inherited from Control.)
Protected property | CanRaiseEvents | コントロールでイベントが発生するかどうかを決定します。 (Inherited from Control.)
Public property | CanSelect | コントロールを選択できるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | Capture | コントロールがマウスをキャプチャしたかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | CausesValidation | そのコントロールが原因で、フォーカスを受け取ると検証が必要なコントロールに対して、検証が実行されるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | ClientRectangle | コントロールのクライアント領域を表す四角形を取得します。 (Inherited from Control.)
Public property | ClientSize | フォームのクライアント領域のサイズを取得または設定します。 (Inherited from Form.)
Public property | CompanyName | コントロールを含んでいるアプリケーションの会社または作成者の名前を取得します。 (Inherited from Control.)
Public property | Container | Component を格納している IContainer を取得します。 (Inherited from Component.)
Public property | ContainsFocus | コントロール、またはその子コントロールの 1 つに、現在入力フォーカスがあるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | ContextMenu | コントロールに関連付けられたショートカット メニューを取得または設定します。 (Inherited from Control.)
Public property | ContextMenuStrip | このコントロールに関連付けられている ContextMenuStrip を取得または設定します。 (Inherited from Control.)
Public property | ControlBox | フォームのキャプション バーにコントロール ボックスを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | Controls | コントロール内に格納されているコントロールのコレクションを取得します。 (Inherited from Control.)
Public property | Created | コントロールが作成されているかどうかを示す値を取得します。 (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | 現在の画面の実行時寸法を取得します。 (Inherited from ContainerControl.)
Public property | Cursor | マウス ポインターがコントロールの上にあるときに表示されるカーソルを取得または設定します。 (Inherited from Control.)
Public property | DataBindings | コントロールのデータ連結を取得します。 (Inherited from Control.)
Protected property | DefaultCursor | コントロールの既定のカーソルを取得または設定します。 (Inherited from Control.)
Protected property | DefaultImeMode | コントロールがサポートしている既定の IME (Input Method Editor) モードを取得します。 (Inherited from Form.)
Protected property | DefaultMargin | コントロール間に既定で指定されている空白をピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultMaximumSize | コントロールの既定の最大サイズとして指定されている長さおよび高さをピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultMinimumSize | コントロールの既定の最小サイズとして指定されている長さおよび高さをピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultPadding | コントロールの内容の内部間隔をピクセル単位で取得します。 (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Component が現在デザイン モードかどうかを示す値を取得します。 (Inherited from Component.)
Public property | DesktopBounds | Windows デスクトップ上のフォームのサイズと位置を取得または設定します。 (Inherited from Form.)
Public property | DesktopLocation | Windows デスクトップ上のフォームの位置を取得または設定します。 (Inherited from Form.)
Public property | DialogResult | フォームのダイアログ結果を取得または設定します。 (Inherited from Form.)
Public property | DisplayRectangle | コントロールの仮想表示領域を表す四角形を取得します。 (Inherited from ScrollableControl.)
Public property | Disposing | 基本 Control クラスが破棄処理中かどうかを示す値を取得します。 (Inherited from Control.)
Public property | Dock | コントロールの境界のうち、親コントロールにドッキングする境界を取得または設定します。また、コントロールのサイズが親コントロール内でどのように変化するかを決定します。 (Inherited from Control.)
Public property | DockPadding | コントロールのすべての端に対するドッキング埋め込みの設定を取得します。 (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | ちらつきを軽減または回避するために、2 次バッファーを使用してコントロールの表面を再描画するかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | Enabled | コントロールがユーザーとの対話に応答できるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Protected property | Events | Component に結び付けられているイベント ハンドラーのリストを取得します。 (Inherited from Component.)
Public property | Focused | コントロールに入力フォーカスがあるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | Font | コントロールによって表示されるテキストのフォントを取得または設定します。 (Inherited from Control.)
Protected property | FontHeight | コントロールのフォントの高さを取得または設定します。 (Inherited from Control.)
Public property | ForeColor | コントロールの前景色を取得または設定します。 (Inherited from Control.)
Public property | FormBorderStyle | フォームの境界線スタイルを取得または設定します。 (Inherited from Form.)
Public property | Handle | コントロールのバインド先のウィンドウ ハンドルを取得します。 (Inherited from Control.)
Public property | HasChildren | コントロールに 1 つ以上の子コントロールが格納されているかどうかを示す値を取得します。 (Inherited from Control.)
Public property | Height | コントロールの高さを取得または設定します。 (Inherited from Control.)
Public property | HelpButton | フォームのキャプション ボックスにヘルプ ボタンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | HorizontalScroll | 水平スクロール バーに関連付けられた特性を取得します。 (Inherited from ScrollableControl.)
Protected property | HScroll | 水平スクロール バーが表示されるかどうかを示す値を、取得または設定します。 (Inherited from ScrollableControl.)
Public property | Icon | フォームのアイコンを取得または設定します。 (Inherited from Form.)
Public property | ImeMode | コントロールの IME (Input Method Editor) モードを取得または設定します。 (Inherited from Control.)
Protected property | ImeModeBase | コントロールの IME モードを取得または設定します。 (Inherited from Control.)
Public property | InvokeRequired | 呼び出し元がコントロールの作成されたスレッドと異なるスレッド上にあるため、コントロールに対してメソッドの呼び出しを実行するときに、呼び出し元で invoke メソッドを呼び出す必要があるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsAccessible | コントロールがユーザー補助アプリケーションに表示されるかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | IsDisposed | コントロールが破棄されているかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsHandleCreated | コントロールにハンドルが関連付けられているかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsMdiChild | フォームがマルチ ドキュメント インターフェイス (MDI) 子フォームかどうかを示す値を取得します。 (Inherited from Form.)
Public property | IsMdiContainer | フォームがマルチ ドキュメント インターフェイス (MDI: Multiple Document Interface) 子フォームのコンテナーかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | IsMirrored | コントロールがミラー化されるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | IsRestrictedWindow | フォームがすべてのウィンドウとユーザー入力イベントを制限なく使用できるかどうかを示す値を取得します。 (Inherited from Form.)
Public property | KeyPreview | キー イベントがフォーカスを持つコントロールに渡される前に、フォームがそのイベントを受け取るかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | LayoutEngine | コントロールのレイアウト エンジンのキャッシュされたインスタンスを取得します。 (Inherited from Control.)
Public property | Left | コントロールの左端とコンテナーのクライアント領域の左端の間の距離をピクセルで取得または設定します。 (Inherited from Control.)
Public property | Location | 画面座標における Form の左上隅を表す Point を取得および設定します。 (Inherited from Form.)
Public property | MainMenuStrip | フォームの主要メニューのコンテナーを取得または設定します。 (Inherited from Form.)
Public property | Margin | コントロール間の空白を取得または設定します。 (Inherited from Form.)
Public property | MaximizeBox | フォームのキャプション バーに最大化ボタンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Protected property | MaximizedBounds | 最大化された場合のフォームのサイズを取得および設定します。 (Inherited from Form.)
Public property | MaximumSize | フォームのサイズを変更する場合の最大サイズを取得します。 (Inherited from Form.)
Public property | MdiChildren | 対象のフォームが親フォームであるマルチ ドキュメント インターフェイス (MDI) 子フォームの配列を取得します。 (Inherited from Form.)
Public property | MdiParent | 対象となるフォームの現在のマルチ ドキュメント インターフェイス (MDI) 親フォームを取得または設定します。 (Inherited from Form.)
Public property | Menu | フォームに表示する MainMenu を取得または設定します。 (Inherited from Form.)
Public property | MergedMenu | フォームのマージされたメニューを取得します。 (Inherited from Form.)
Public property | MinimizeBox | フォームのキャプション バーに最小化ボタンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | MinimumSize | フォームのサイズを変更する場合の最小サイズを取得または設定します。 (Inherited from Form.)
Public property | Modal | フォームをモーダルとして表示するかどうかを示す値を取得します。 (Inherited from Form.)
Public property | Name | コントロールの名前を取得または設定します。 (Inherited from Control.)
Public property | Opacity | フォームの不透明度を取得または設定します。 (Inherited from Form.)
Public property | OwnedForms | 対象となるフォームによって所有されている全フォームを表す、Form オブジェクトの配列を取得します。 (Inherited from Form.)
Public property | Owner | 対象のフォームを所有しているフォームを取得または設定します。 (Inherited from Form.)
Public property | Padding | コントロールの埋め込みを取得または設定します。 (Inherited from Control.)
Public property | Parent | コントロールの親コンテナーを取得または設定します。 (Inherited from Control.)
Public property | ParentForm | コンテナー コントロールが割り当てられるフォームを取得します。 (Inherited from ContainerControl.)
Public property | PreferredSize | コントロールが適合する四角形領域のサイズを取得します。 (Inherited from Control.)
Public property | ProductName | コントロールを格納しているアセンブリの製品名を取得します。 (Inherited from Control.)
Public property | ProductVersion | コントロールを格納しているアセンブリのバージョンを取得します。 (Inherited from Control.)
Public property | RecreatingHandle | コントロールが現在そのコントロールのハンドルを再作成中かどうかを示す値を取得します。 (Inherited from Control.)
Public property | Region | コントロールに関連付けられたウィンドウ領域を取得または設定します。 (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. このプロパティは使用されなくなりました。 (Inherited from Control.)
Protected property | ResizeRedraw | サイズが変更されたときに、コントロールがコントロール自体を再描画するかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | RestoreBounds | 通常のウィンドウ状態におけるフォームの位置とサイズを取得します。 (Inherited from Form.)
Public property | Right | コントロールの右端とコンテナーのクライアント領域の左端の間の距離をピクセルで取得します。 (Inherited from Control.)
Public property | RightToLeft | コントロールの要素が、右から左へ表示されるフォントを使用するロケールをサポートするように配置されているかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | RightToLeftLayout | 右から左方向の反転配置を有効にするかどうかを示す値を取得または設定します。 (Inherited from Form.)
Protected property | ScaleChildren | 子コントロールのスケーリングを決定する値を取得します。 (Inherited from Control.)
Protected property | ShowFocusCues | コントロールがフォーカスを示す四角形を表示する必要があるかどうかを示す値を取得します。 (Inherited from Control.)
Public property | ShowIcon | フォームのキャプション バーにアイコンを表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | ShowInTaskbar | フォームを Windows タスク バーに表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Protected property | ShowKeyboardCues | ユーザー インターフェイスがキーボード アクセラレータを表示または非表示にする適切な状態かどうかを示す値を取得します。 (Inherited from Control.)
Protected property | ShowWithoutActivation | ウィンドウが表示されたときにそのウィンドウをアクティブにするかどうかを示す値を取得します。 (Inherited from Form.)
Public property | Site | コントロールのサイトを取得または設定します。 (Inherited from Control.)
Public property | Size | フォームのサイズを取得または設定します。 (Inherited from Form.)
Public property | SizeGripStyle | フォームの右下隅に表示するサイズ変更グリップのスタイルを取得または設定します。 (Inherited from Form.)
Public property | StartPosition | 実行時にフォームの開始位置を取得または設定します。 (Inherited from Form.)
Public property | TabIndex | コンテナー内のコントロールのタブ オーダーを取得または設定します。 (Inherited from Form.)
Public property | TabStop | ユーザーが Tab キーで、このコントロールにフォーカスを移すことができるかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | Tag | コントロールに関するデータを格納するオブジェクトを取得または設定します。 (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | コントロールの上端とコンテナーのクライアント領域の上端の間の距離をピクセル単位で取得または設定します。 (Inherited from Control.)
Public property | TopLevel | フォームをトップレベル ウィンドウとして表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | TopLevelControl | 別の Windows フォーム コントロールを親として持たない親コントロールを取得します。一般的に、これは、コントロールを格納している、最も外側の Form です。 (Inherited from Control.)
Public property | TopMost | フォームを最上位フォームとして表示するかどうかを示す値を取得または設定します。 (Inherited from Form.)
Public property | TransparencyKey | フォームの透明な領域を表す色を取得または設定します。 (Inherited from Form.)
Public property | UseWaitCursor | 現在のコントロールおよびすべての子コントロールに待機カーソルを使用するかどうかを示す値を取得または設定します。 (Inherited from Control.)
Public property | VerticalScroll | 垂直スクロール バーに関連付けられた特性を取得します。 (Inherited from ScrollableControl.)
Public property | Visible | コントロールとそのすべての子コントロールが表示されているかどうかを示す値を取得または設定します。 (Inherited from Control.)
Protected property | VScroll | 垂直スクロール バーが表示されるかどうかを示す値を、取得または設定します。 (Inherited from ScrollableControl.)
Public property | Width | コントロールの幅を取得または設定します。 (Inherited from Control.)
Public property | WindowState | フォームのウィンドウ状態を取得または設定します。 (Inherited from Form.)
Public property | WindowTarget | このクラスでは、このプロパティは使用されません。 (Inherited from Control.)

See Also

FFTtestForm Class
鳥の声で種識別 Namespace


FFTtestForm Events

[image] [image]

A Sandcastle Documented Class Library
FFTtestForm Events
FFTtestForm Class See Also フィードバックの送信

The FFTtestForm type exposes the following members.

Events

 | Name | Description
Public event | Activated | フォームがコード内またはユーザーの操作によってアクティブになると発生します。 (Inherited from Form.)
Public event | AutoSizeChanged | AutoSize プロパティが変更されたときに発生します。 (Inherited from Form.)
Public event | AutoValidateChanged | AutoValidate プロパティが変更されると発生します。 (Inherited from Form.)
Public event | BackColorChanged | BackColor プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | BackgroundImageChanged | BackgroundImage プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | BackgroundImageLayout プロパティが変更された場合に発生します。 (Inherited from Control.)
Public event | BindingContextChanged | BindingContext プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | CausesValidationChanged | CausesValidation プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | ChangeUICues | フォーカス四角形またはキーボード インターフェイス (UI) キューが変更されたときに発生します。 (Inherited from Control.)
Public event | Click | コントロールがクリックされたときに発生します。 (Inherited from Control.)
Public event | ClientSizeChanged | ClientSize プロパティの値が変更されたときに発生します。 (Inherited from Control.)
Public event | Closed | フォームが閉じたときに発生します。 (Inherited from Form.)
Public event | Closing | フォームが閉じている間に発生します。 (Inherited from Form.)
Public event | ContextMenuChanged | ContextMenu プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | ContextMenuStripChanged | ContextMenuStrip プロパティの値が変更されたときに発生します。 (Inherited from Control.)
Public event | ControlAdded | 新しいコントロールが Control..::..ControlCollection に追加されたときに発生します。 (Inherited from Control.)
Public event | ControlRemoved | Control..::..ControlCollection からコントロールが削除されたときに発生します。 (Inherited from Control.)
Public event | CursorChanged | Cursor プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | Deactivate | フォームがフォーカスを失い、アクティブでなくなると発生します。 (Inherited from Form.)
Public event | Disposed | Dispose()()()() メソッドの呼び出しによってコンポーネントが破棄されると発生します。 (Inherited from Component.)
Public event | DockChanged | Dock プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | DoubleClick | コントロールがダブルクリックされたときに発生します。 (Inherited from Control.)
Public event | DragDrop | ドラッグ アンド ドロップ操作が完了したときに発生します。 (Inherited from Control.)
Public event | DragEnter | オブジェクトがコントロールの境界内にドラッグされると発生します。 (Inherited from Control.)
Public event | DragLeave | オブジェクトがコントロールの境界の外へドラッグされると発生します。 (Inherited from Control.)
Public event | DragOver | オブジェクトがコントロールの境界を超えてドラッグされると発生します。 (Inherited from Control.)
Public event | EnabledChanged | Enabled プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | Enter | コントロールが入力されると発生します。 (Inherited from Control.)
Public event | FontChanged | Font プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | ForeColorChanged | ForeColor プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | FormClosed | フォームが閉じた後に発生します。 (Inherited from Form.)
Public event | FormClosing | フォームが閉じる前に発生します。 (Inherited from Form.)
Public event | GiveFeedback | ドラッグ操作中に発生します。 (Inherited from Control.)
Public event | GotFocus | コントロールがフォーカスを受け取ると発生します。 (Inherited from Control.)
Public event | HandleCreated | コントロールに対してハンドルが作成されると発生します。 (Inherited from Control.)
Public event | HandleDestroyed | コントロールのハンドルが破棄されているときに発生します。 (Inherited from Control.)
Public event | HelpButtonClicked | ヘルプ ボタンがクリックされると発生します。 (Inherited from Form.)
Public event | HelpRequested | ユーザーがコントロールのヘルプを要求すると発生します。 (Inherited from Control.)
Public event | ImeModeChanged | ImeMode プロパティが変更された場合に発生します。 (Inherited from Control.)
Public event | InputLanguageChanged | フォームの入力言語が変更された後に発生します。 (Inherited from Form.)
Public event | InputLanguageChanging | ユーザーがフォームの入力言語を変更しようとすると発生します。 (Inherited from Form.)
Public event | Invalidated | コントロールの表示で再描画が必要なときに発生します。 (Inherited from Control.)
Public event | KeyDown | コントロールにフォーカスがあるときにキーが押されると発生します。 (Inherited from Control.)
Public event | KeyPress | コントロールにフォーカスがあるときにキーが押されると発生します。 (Inherited from Control.)
Public event | KeyUp | コントロールにフォーカスがあるときにキーが離されると発生します。 (Inherited from Control.)
Public event | Layout | コントロールの子コントロールの位置を変更する必要があるときに発生します。 (Inherited from Control.)
Public event | Leave | 入力フォーカスがコントロールを離れると発生します。 (Inherited from Control.)
Public event | Load | フォームが初めて表示される直前に発生します。 (Inherited from Form.)
Public event | LocationChanged | Location プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | LostFocus | コントロールにフォーカスがなくなると発生します。 (Inherited from Control.)
Public event | MarginChanged | Margin プロパティが変更されると発生します。 (Inherited from Form.)
Public event | MaximizedBoundsChanged | MaximizedBounds プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | MaximumSizeChanged | MaximumSize プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | MdiChildActivate | マルチ ドキュメント インターフェイス (MDI) 子フォームが MDI アプリケーション内でアクティブになった場合、または閉じた場合に発生します。 (Inherited from Form.)
Public event | MenuComplete | フォームのメニューがフォーカスを失ったときに発生します。 (Inherited from Form.)
Public event | MenuStart | フォームのメニューがフォーカスを受け取ると発生します。 (Inherited from Form.)
Public event | MinimumSizeChanged | MinimumSize プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | MouseCaptureChanged | コントロールでマウスのキャプチャを失ったか取得したときに発生します。 (Inherited from Control.)
Public event | MouseClick | コントロールがマウスでクリックされたときに発生します。 (Inherited from Control.)
Public event | MouseDoubleClick | コントロールがマウスでダブルクリックされたときに発生します。 (Inherited from Control.)
Public event | MouseDown | マウス ポインターがコントロール上にあり、マウス ボタンがクリックされると発生します。 (Inherited from Control.)
Public event | MouseEnter | マウス ポインターによってコントロールが入力されると発生します。 (Inherited from Control.)
Public event | MouseHover | マウス ポインターをコントロールの上に重ねると発生します。 (Inherited from Control.)
Public event | MouseLeave | マウス ポインターがコントロールを離れると発生します。 (Inherited from Control.)
Public event | MouseMove | マウス ポインターがコントロール上を移動すると発生します。 (Inherited from Control.)
Public event | MouseUp | マウス ポインターがコントロール上にあり、マウス ボタンが離されると発生します。 (Inherited from Control.)
Public event | MouseWheel | コントロールにフォーカスがあるときにマウス ホイールが動くと発生します。 (Inherited from Control.)
Public event | Move | コントロールが移動されると発生します。 (Inherited from Control.)
Public event | PaddingChanged | コントロールの埋め込みが変更されたときに発生します。 (Inherited from Control.)
Public event | Paint | コントロールが再描画されると発生します。 (Inherited from Control.)
Public event | ParentChanged | Parent プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | PreviewKeyDown | このコントロールにフォーカスがあるときにキーが押された場合、KeyDown イベントの前に発生します。 (Inherited from Control.)
Public event | QueryAccessibilityHelp | AccessibleObject がユーザー補助アプリケーションにヘルプを提供したときに発生します。 (Inherited from Control.)
Public event | QueryContinueDrag | ドラッグ アンド ドロップ操作中に発生し、ドラッグ ソースがドラッグ アンド ドロップ操作をキャンセルする必要があるかどうかを決定できるようにします。 (Inherited from Control.)
Public event | RegionChanged | Region プロパティの値が変更されたときに発生します。 (Inherited from Control.)
Public event | Resize | コントロールのサイズが変更されると発生します。 (Inherited from Control.)
Public event | ResizeBegin | フォームがサイズ変更モードになったときに発生します。 (Inherited from Form.)
Public event | ResizeEnd | フォームがサイズ変更モードでなくなったときに発生します。 (Inherited from Form.)
Public event | RightToLeftChanged | RightToLeft プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | RightToLeftLayoutChanged | RightToLeftLayout プロパティの値が変更された後に発生します。 (Inherited from Form.)
Public event | Scroll | ユーザーまたはコードによってクライアント領域がスクロールされたときに発生します。 (Inherited from ScrollableControl.)
Public event | Shown | フォームが初めて表示されるたびに発生します。 (Inherited from Form.)
Public event | SizeChanged | Size プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | StyleChanged | コントロール スタイルが変更されると発生します。 (Inherited from Control.)
Public event | SystemColorsChanged | システム カラーが変更されると発生します。 (Inherited from Control.)
Public event | TabIndexChanged | TabIndex プロパティの値が変更されたときに発生します。 (Inherited from Form.)
Public event | TabStopChanged | TabStop プロパティが変更されると発生します。 (Inherited from Form.)
Public event | TextChanged | Text プロパティの値が変更された場合に発生します。 (Inherited from Control.)
Public event | Validated | コントロールの検証が終了すると発生します。 (Inherited from Control.)
Public event | Validating | コントロールが検証を行っているときに発生します。 (Inherited from Control.)
Public event | VisibleChanged | Visible プロパティの値が変更された場合に発生します。 (Inherited from Control.)

See Also

FFTtestForm Class
鳥の声で種識別 Namespace


SignalBasic Class

[image]

A Sandcastle Documented Class Library
SignalBasic Class
Members See Also フィードバックの送信
音声データの基本的な処理クラス

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SignalBasic
Visual Basic
Public Class SignalBasic
Visual C++
public ref class SignalBasic

Inheritance Hierarchy

System..::..Object
鳥の声で種識別..::..SignalBasic

See Also

SignalBasic Members
鳥の声で種識別 Namespace


SignalBasic Members

[image] [image]

A Sandcastle Documented Class Library
SignalBasic Members
SignalBasic Class Constructors Methods Properties See Also フィードバックの送信

The SignalBasic type exposes the following members.

Constructors

 | Name | Description
Public method | SignalBasic(Int32, FFTresult..::..Band, TimeSpan, TimeSpan) | コンストラクタ 帯域構造体を使用したバージョンです。
Public method | SignalBasic(Int32, Int64, TimeSpan, TimeSpan) | コンストラクタ 最低周波数は0となります。
Public method | SignalBasic(Int32, Int64, Int64, TimeSpan, TimeSpan) | コンストラクタ 帯域や分割数、監視する時間幅を指定してください。

Methods

 | Name | Description
Public method | CheckDetection | 任意の帯域において発声が検出されているかどうかを返す 検査対象外の帯域だったり、検出されていなければfalseが返ります。
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetBands | 本クラスが内部に保持している帯域のリストを返す
Public method | GetDetectedBands | 検出された帯域情報を返す
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | RecognizeSignal | 強制的に、指定帯域で発声があることを認識させる 2011/11/18 呼び出し先が未実装・・・
Public method | Save | 指定されたインデックスの帯域における状況をファイルに出力する 帯域とインデックスを結び付けるメソッドを用意しないと意味があまりないかも
Public method | Set | FFT処理後のデータをセットする
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | Detection | 検出結果
Public property | Edge | 検出されたエッジの種類 多数の検出器があるのに、どうやって知らせたらいいのか？
Public property | SetTimeSpan4minLeve | PSDの最低値検出窓の時間幅を設定する 2011/11/18現在、未完成 sensorオブジェクトを全て呼び出して設定する予定

See Also

SignalBasic Class
鳥の声で種識別 Namespace


SignalBasic Constructor

[image] [image]

A Sandcastle Documented Class Library
SignalBasic Constructor
SignalBasic Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | SignalBasic(Int32, FFTresult..::..Band, TimeSpan, TimeSpan) | コンストラクタ 帯域構造体を使用したバージョンです。
Public method | SignalBasic(Int32, Int64, TimeSpan, TimeSpan) | コンストラクタ 最低周波数は0となります。
Public method | SignalBasic(Int32, Int64, Int64, TimeSpan, TimeSpan) | コンストラクタ 帯域や分割数、監視する時間幅を指定してください。

See Also

SignalBasic Class
SignalBasic Members
鳥の声で種識別 Namespace


SignalBasic Constructor (Int32, FFTresult.Band, TimeSpan, TimeSpan)

[image]

A Sandcastle Documented Class Library
SignalBasic Constructor (Int32, FFTresult..::..Band, TimeSpan, TimeSpan)
SignalBasic Class See Also フィードバックの送信
コンストラクタ 帯域構造体を使用したバージョンです。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SignalBasic(
    int numberOfPartitions,
    FFTresult..::..Band band,
    TimeSpan timespan,
    TimeSpan samplingPeriod
)
Visual Basic
Public Sub New ( _
    numberOfPartitions As Integer, _
    band As FFTresult..::..Band, _
    timespan As TimeSpan, _
    samplingPeriod As TimeSpan _
)
Visual C++
public:
SignalBasic(
    int numberOfPartitions,
    FFTresult..::..Band band,
    TimeSpan timespan,
    TimeSpan samplingPeriod
)

Parameters

numberOfPartitions
Type: System..::..Int32

["M:鳥の声で種識別.SignalBasic.#ctor(System.Int32,Signal_Process.FFTresult.Band,System.TimeSpan,System.TimeSpan)" の為の説明文 <param name="numberOfPartitions"/> が欠落しています。]

band
Type: Signal_Process..::..FFTresult..::..Band
検査対象領域
timespan
Type: System..::..TimeSpan
検査時間 時間窓をずらしながら検査するので、応答速度や計算精度に影響します。
samplingPeriod
Type: System..::..TimeSpan
サンプリング周期

See Also

SignalBasic Class
SignalBasic Overload
鳥の声で種識別 Namespace


SignalBasic Constructor (Int32, Int64, TimeSpan, TimeSpan)

[image]

A Sandcastle Documented Class Library
SignalBasic Constructor (Int32, Int64, TimeSpan, TimeSpan)
SignalBasic Class See Also フィードバックの送信
コンストラクタ 最低周波数は0となります。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SignalBasic(
    int numberOfPartitions,
    long maxFrequency,
    TimeSpan timespan,
    TimeSpan samplingPeriod
)
Visual Basic
Public Sub New ( _
    numberOfPartitions As Integer, _
    maxFrequency As Long, _
    timespan As TimeSpan, _
    samplingPeriod As TimeSpan _
)
Visual C++
public:
SignalBasic(
    int numberOfPartitions,
    long long maxFrequency,
    TimeSpan timespan,
    TimeSpan samplingPeriod
)

Parameters

numberOfPartitions
Type: System..::..Int32
帯域分割数
maxFrequency
Type: System..::..Int64
最大周波数[Hz]
timespan
Type: System..::..TimeSpan
検査時間 時間窓をずらしながら検査するので、応答速度や計算精度に影響します。
samplingPeriod
Type: System..::..TimeSpan
サンプリング周期

See Also

SignalBasic Class
SignalBasic Overload
鳥の声で種識別 Namespace


SignalBasic Constructor (Int32, Int64, Int64, TimeSpan, TimeSpan)

[image]

A Sandcastle Documented Class Library
SignalBasic Constructor (Int32, Int64, Int64, TimeSpan, TimeSpan)
SignalBasic Class See Also フィードバックの送信
コンストラクタ 帯域や分割数、監視する時間幅を指定してください。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SignalBasic(
    int numberOfPartitions,
    long maxFrequency,
    long minFrequency,
    TimeSpan timespan,
    TimeSpan samplingPeriod
)
Visual Basic
Public Sub New ( _
    numberOfPartitions As Integer, _
    maxFrequency As Long, _
    minFrequency As Long, _
    timespan As TimeSpan, _
    samplingPeriod As TimeSpan _
)
Visual C++
public:
SignalBasic(
    int numberOfPartitions,
    long long maxFrequency,
    long long minFrequency,
    TimeSpan timespan,
    TimeSpan samplingPeriod
)

Parameters

numberOfPartitions
Type: System..::..Int32
帯域分割数
maxFrequency
Type: System..::..Int64
最大周波数[Hz]
minFrequency
Type: System..::..Int64
最小周波数[Hz]
timespan
Type: System..::..TimeSpan
検査時間 時間窓をずらしながら検査するので、応答速度や計算精度に影響します。
samplingPeriod
Type: System..::..TimeSpan
サンプリング周期

See Also

SignalBasic Class
SignalBasic Overload
鳥の声で種識別 Namespace


SignalBasic Methods

[image] [image]

A Sandcastle Documented Class Library
SignalBasic Methods
SignalBasic Class See Also フィードバックの送信

The SignalBasic type exposes the following members.

Methods

 | Name | Description
Public method | CheckDetection | 任意の帯域において発声が検出されているかどうかを返す 検査対象外の帯域だったり、検出されていなければfalseが返ります。
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetBands | 本クラスが内部に保持している帯域のリストを返す
Public method | GetDetectedBands | 検出された帯域情報を返す
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | RecognizeSignal | 強制的に、指定帯域で発声があることを認識させる 2011/11/18 呼び出し先が未実装・・・
Public method | Save | 指定されたインデックスの帯域における状況をファイルに出力する 帯域とインデックスを結び付けるメソッドを用意しないと意味があまりないかも
Public method | Set | FFT処理後のデータをセットする
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

SignalBasic Class
鳥の声で種識別 Namespace


CheckDetection Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..CheckDetection Method
SignalBasic Class See Also フィードバックの送信
任意の帯域において発声が検出されているかどうかを返す 検査対象外の帯域だったり、検出されていなければfalseが返ります。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool CheckDetection(
    FFTresult..::..Band band
)
Visual Basic
Public Function CheckDetection ( _
    band As FFTresult..::..Band _
) As Boolean
Visual C++
public:
bool CheckDetection(
    FFTresult..::..Band band
)

Parameters

band
Type: Signal_Process..::..FFTresult..::..Band
指定帯域

Return Value

検出されていればtrue

See Also

SignalBasic Class
鳥の声で種識別 Namespace


GetBands Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..GetBands Method
SignalBasic Class See Also フィードバックの送信
本クラスが内部に保持している帯域のリストを返す

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult..::..Band[] GetBands()
Visual Basic
Public Function GetBands As FFTresult..::..Band()
Visual C++
public:
array<FFTresult..::..Band>^ GetBands()

Return Value

帯域のリスト

See Also

SignalBasic Class
鳥の声で種識別 Namespace


GetDetectedBands Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..GetDetectedBands Method
SignalBasic Class See Also フィードバックの送信
検出された帯域情報を返す

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FFTresult..::..Band[] GetDetectedBands()
Visual Basic
Public Function GetDetectedBands As FFTresult..::..Band()
Visual C++
public:
array<FFTresult..::..Band>^ GetDetectedBands()

Return Value

帯域情報

See Also

SignalBasic Class
鳥の声で種識別 Namespace


RecognizeSignal Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..RecognizeSignal Method
SignalBasic Class See Also フィードバックの送信
強制的に、指定帯域で発声があることを認識させる 2011/11/18 呼び出し先が未実装・・・

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RecognizeSignal(
    FFTresult..::..Band band
)
Visual Basic
Public Sub RecognizeSignal ( _
    band As FFTresult..::..Band _
)
Visual C++
public:
void RecognizeSignal(
    FFTresult..::..Band band
)

Parameters

band
Type: Signal_Process..::..FFTresult..::..Band
指定帯域

See Also

SignalBasic Class
鳥の声で種識別 Namespace


Save Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..Save Method
SignalBasic Class See Also フィードバックの送信
指定されたインデックスの帯域における状況をファイルに出力する 帯域とインデックスを結び付けるメソッドを用意しないと意味があまりないかも

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Save(
    int index,
    string fname
)
Visual Basic
Public Sub Save ( _
    index As Integer, _
    fname As String _
)
Visual C++
public:
void Save(
    int index,
    String^ fname
)

Parameters

index
Type: System..::..Int32
インデックス番号
fname
Type: System..::..String
ファイル名

See Also

SignalBasic Class
鳥の声で種識別 Namespace


Set Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..Set Method
SignalBasic Class See Also フィードバックの送信
FFT処理後のデータをセットする

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    FFTresult data
)
Visual Basic
Public Sub Set ( _
    data As FFTresult _
)
Visual C++
public:
void Set(
    FFTresult^ data
)

Parameters

data
Type: Signal_Process..::..FFTresult

["M:鳥の声で種識別.SignalBasic.Set(Signal_Process.FFTresult)" の為の説明文 <param name="data"/> が欠落しています。]

See Also

SignalBasic Class
鳥の声で種識別 Namespace


SignalBasic Properties

[image] [image]

A Sandcastle Documented Class Library
SignalBasic Properties
SignalBasic Class See Also フィードバックの送信

The SignalBasic type exposes the following members.

Properties

 | Name | Description
Public property | Detection | 検出結果
Public property | Edge | 検出されたエッジの種類 多数の検出器があるのに、どうやって知らせたらいいのか？
Public property | SetTimeSpan4minLeve | PSDの最低値検出窓の時間幅を設定する 2011/11/18現在、未完成 sensorオブジェクトを全て呼び出して設定する予定

See Also

SignalBasic Class
鳥の声で種識別 Namespace


Detection Property

[image]

A Sandcastle Documented Class Library
SignalBasic..::..Detection Property
SignalBasic Class See Also フィードバックの送信
検出結果

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Detection { get; }
Visual Basic
Public ReadOnly Property Detection As Boolean
    Get
Visual C++
public:
property bool Detection {
    bool get ();
}

See Also

SignalBasic Class
鳥の声で種識別 Namespace


Edge Property

[image]

A Sandcastle Documented Class Library
SignalBasic..::..Edge Property
SignalBasic Class See Also フィードバックの送信
検出されたエッジの種類 多数の検出器があるのに、どうやって知らせたらいいのか？

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SignalBasic..::..SoundDetection..::..Edge Edge { get; }
Visual Basic
Public ReadOnly Property Edge As SignalBasic..::..SoundDetection..::..Edge
    Get
Visual C++
public:
property SignalBasic..::..SoundDetection..::..Edge Edge {
    SignalBasic..::..SoundDetection..::..Edge get ();
}

See Also

SignalBasic Class
鳥の声で種識別 Namespace


SetTimeSpan4minLeve Property

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SetTimeSpan4minLeve Property
SignalBasic Class See Also フィードバックの送信
PSDの最低値検出窓の時間幅を設定する 2011/11/18現在、未完成 sensorオブジェクトを全て呼び出して設定する予定

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TimeSpan SetTimeSpan4minLeve { set; }
Visual Basic
Public WriteOnly Property SetTimeSpan4minLeve As TimeSpan
    Set
Visual C++
public:
property TimeSpan SetTimeSpan4minLeve {
    void set (TimeSpan value);
}

See Also

SignalBasic Class
鳥の声で種識別 Namespace


SignalBasic.SoundDetection Class

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection Class
SignalBasic Class Members See Also フィードバックの送信
信号の検出のためのクラス 2011/11/15時点では、一度検出されるとその後は検出の感度が鈍るという副作用がある。 これは検出時には値をセットされてもストックしないことで対応可能といえば可能 ただし、グローバル変数にセットされた値を一時的に保持する必要がある。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SoundDetection
Visual Basic
Public Class SoundDetection
Visual C++
public ref class SoundDetection

Inheritance Hierarchy

System..::..Object
鳥の声で種識別..::..SignalBasic..::..SoundDetection

See Also

SignalBasic..::..SoundDetection Members
鳥の声で種識別 Namespace


SignalBasic.SoundDetection Members

[image] [image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection Members
SignalBasic..::..SoundDetection Class Constructors Methods Properties See Also フィードバックの送信

音声データの基本的な処理クラス

The SignalBasic..::..SoundDetection type exposes the following members.

Constructors

 | Name | Description
Public method | SignalBasic..::..SoundDetection | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | RecognizeSignal | 強制的に現状を音声が入力されていると認識させる 2011/11/18現在、未実装
Public method | Save | 結果をファイルに保存する
Public method | Set | データをセットする
Public method | ToString | フィルタ状況を文字列で出力 (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DetectedEdge | 検出されたエッジの種類
Public property | FrontDetection | 前方音声検出フラグ 検出されると、tureとなる。
Public property | RearDetection | 後方音声検出フラグ 検出されると、tureとなる。

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


SignalBasic.SoundDetection Constructor

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection Constructor
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
コンストラクタ

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SoundDetection(
    int numOfMean,
    TimeSpan samplingPeriod,
    TimeSpan timespan4minlevel
)
Visual Basic
Public Sub New ( _
    numOfMean As Integer, _
    samplingPeriod As TimeSpan, _
    timespan4minlevel As TimeSpan _
)
Visual C++
public:
SoundDetection(
    int numOfMean,
    TimeSpan samplingPeriod,
    TimeSpan timespan4minlevel
)

Parameters

numOfMean
Type: System..::..Int32
平均数
samplingPeriod
Type: System..::..TimeSpan
サンプリング周期
timespan4minlevel
Type: System..::..TimeSpan
最低値を検出するための時間幅

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


SignalBasic.SoundDetection Methods

[image] [image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection Methods
SignalBasic..::..SoundDetection Class See Also フィードバックの送信

The SignalBasic..::..SoundDetection type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | RecognizeSignal | 強制的に現状を音声が入力されていると認識させる 2011/11/18現在、未実装
Public method | Save | 結果をファイルに保存する
Public method | Set | データをセットする
Public method | ToString | フィルタ状況を文字列で出力 (Overrides Object..::..ToString()()()().)

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


RecognizeSignal Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..RecognizeSignal Method
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
強制的に現状を音声が入力されていると認識させる 2011/11/18現在、未実装

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void RecognizeSignal()
Visual Basic
Public Sub RecognizeSignal
Visual C++
public:
void RecognizeSignal()

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


Save Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..Save Method
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
結果をファイルに保存する

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Save(
    string fname
)
Visual Basic
Public Sub Save ( _
    fname As String _
)
Visual C++
public:
void Save(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


Set Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..Set Method
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
データをセットする

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    double PSD
)
Visual Basic
Public Sub Set ( _
    PSD As Double _
)
Visual C++
public:
void Set(
    double PSD
)

Parameters

PSD
Type: System..::..Double
パワースペクトル密度[V^2/Hz]

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..ToString Method
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
フィルタ状況を文字列で出力

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

フィルタ情報

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


SignalBasic.SoundDetection Properties

[image] [image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection Properties
SignalBasic..::..SoundDetection Class See Also フィードバックの送信

The SignalBasic..::..SoundDetection type exposes the following members.

Properties

 | Name | Description
Public property | DetectedEdge | 検出されたエッジの種類
Public property | FrontDetection | 前方音声検出フラグ 検出されると、tureとなる。
Public property | RearDetection | 後方音声検出フラグ 検出されると、tureとなる。

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


DetectedEdge Property

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..DetectedEdge Property
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
検出されたエッジの種類

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SignalBasic..::..SoundDetection..::..Edge DetectedEdge { get; }
Visual Basic
Public ReadOnly Property DetectedEdge As SignalBasic..::..SoundDetection..::..Edge
    Get
Visual C++
public:
property SignalBasic..::..SoundDetection..::..Edge DetectedEdge {
    SignalBasic..::..SoundDetection..::..Edge get ();
}

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


FrontDetection Property

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..FrontDetection Property
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
前方音声検出フラグ 検出されると、tureとなる。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool FrontDetection { get; }
Visual Basic
Public ReadOnly Property FrontDetection As Boolean
    Get
Visual C++
public:
property bool FrontDetection {
    bool get ();
}

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


RearDetection Property

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..RearDetection Property
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
後方音声検出フラグ 検出されると、tureとなる。

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool RearDetection { get; }
Visual Basic
Public ReadOnly Property RearDetection As Boolean
    Get
Visual C++
public:
property bool RearDetection {
    bool get ();
}

See Also

SignalBasic..::..SoundDetection Class
鳥の声で種識別 Namespace


SignalBasic.SoundDetection.Edge Enumeration

[image]

A Sandcastle Documented Class Library
SignalBasic..::..SoundDetection..::..Edge Enumeration
SignalBasic..::..SoundDetection Class See Also フィードバックの送信
検出されたエッジの種類

Namespace: 鳥の声で種識別
Assembly: 鳥の声で種識別 (鳥の声で種識別.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Edge
Visual Basic
Public Enumeration Edge
Visual C++
public enum class Edge

Members

Member name | Value | Description
rising | 0 |
falling | 1 |
NA | 2 |

See Also

鳥の声で種識別 Namespace