GIS Namespace

[image]

A Sandcastle Documented Class Library
GIS Namespace
フィードバックの送信

["N:GIS" の為の説明文 <summary> が欠落しています。]

Classes

 | Class | Description
Public class | DEM | 数値標高データを扱うクラス
Public class | Gravity |
Public class | MapBase | ラスタデータで構成される地図情報を扱うクラスです。 DEMデータ（デジタル標高データ）等を扱うことを念頭に入れています。
Public class | TerrainInformation | 地形情報を格納するためのクラス

Structures

 | Structure | Description
Public structure | MapBase..::..LocalData | とある座標のデータを表す、座標と値のセット
Public structure | MapBase..::..MapCoo | マップの右上・左下の境界における座標を緯度・経度で表す構造体
Public structure | MapBase..::..Pos | x,yの座標セット構造体 マップのアドレス計算用

Enumerations

 | Enumeration | Description
Public enumeration | TerrainInformation..::..GeographicalFeature | 地形の特徴を表す 順に、崖・急峻・なだらか・平坦・不明


DEM Class

[image]

A Sandcastle Documented Class Library
DEM Class
Members See Also フィードバックの送信
数値標高データを扱うクラス

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class DEM
Visual Basic
<SerializableAttribute> _
Public Class DEM
Visual C++
[SerializableAttribute]
public ref class DEM

Inheritance Hierarchy

System..::..Object
GIS..::..DEM

See Also

DEM Members
GIS Namespace


DEM Members

[image] [image]

A Sandcastle Documented Class Library
DEM Members
DEM Class Constructors Methods Properties See Also フィードバックの送信

The DEM type exposes the following members.

Constructors

 | Name | Description
Public method | DEM | コンストラクタです。 まずDEMファイルの入っているフォルダを指定します。 すると自動的に全ファイルを走査して必要なファイルを読み込む準備を行います。

Methods

 | Name | Description
Public method | Conform2DEM | 任意に作出されたマップの座標を、DEMのメッシュと一致させる。 データ表示等において、DEMと重ね合わせたい際に使用します。 読み込んだデータの中に該当データが存在しなかった場合は、本クラスのerrorフラグがtrueになります。
Public method | DEMexit | 指定座標を含んだDEMを読み込み可能かどうかを確認する
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetHeight(BLH) | 標高を緯度経度の指定で読み込む。 該当なしの場合は、NAを返す。
Public method | GetHeight(array<BLH>[]()[][]) | 指定された緯度経度に沿った標高を配列で返す
Public method | GetHeight(BLH, MapBase..::..Pos) | 指定された緯度経度を中心とした、相対座標位置のマップ情報を返す
Public method | GetMap | マップ確認用メソッド
Public method | GetMeshSize | 指定座標の入っているメッシュのサイズを取得する
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ResetError | エラーフラグをリセットする。
Public method | SetXML | 外部より読み込みを強制できるメソッド
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | Error | エラー情報
Public property | IsMapSet | DEMのXMLファイル読み込み準備ができていればtrue
Public property | UsefulDEMdataNum | 読み込み可能なDEMファイル数

See Also

DEM Class
GIS Namespace


DEM Constructor

[image]

A Sandcastle Documented Class Library
DEM Constructor
DEM Class See Also フィードバックの送信
コンストラクタです。 まずDEMファイルの入っているフォルダを指定します。 すると自動的に全ファイルを走査して必要なファイルを読み込む準備を行います。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DEM()
Visual Basic
Public Sub New
Visual C++
public:
DEM()

See Also

DEM Class
GIS Namespace


DEM Methods

[image] [image]

A Sandcastle Documented Class Library
DEM Methods
DEM Class See Also フィードバックの送信

The DEM type exposes the following members.

Methods

 | Name | Description
Public method | Conform2DEM | 任意に作出されたマップの座標を、DEMのメッシュと一致させる。 データ表示等において、DEMと重ね合わせたい際に使用します。 読み込んだデータの中に該当データが存在しなかった場合は、本クラスのerrorフラグがtrueになります。
Public method | DEMexit | 指定座標を含んだDEMを読み込み可能かどうかを確認する
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetHeight(BLH) | 標高を緯度経度の指定で読み込む。 該当なしの場合は、NAを返す。
Public method | GetHeight(array<BLH>[]()[][]) | 指定された緯度経度に沿った標高を配列で返す
Public method | GetHeight(BLH, MapBase..::..Pos) | 指定された緯度経度を中心とした、相対座標位置のマップ情報を返す
Public method | GetMap | マップ確認用メソッド
Public method | GetMeshSize | 指定座標の入っているメッシュのサイズを取得する
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ResetError | エラーフラグをリセットする。
Public method | SetXML | 外部より読み込みを強制できるメソッド
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

DEM Class
GIS Namespace


Conform2DEM Method

[image]

A Sandcastle Documented Class Library
DEM..::..Conform2DEM Method
DEM Class See Also フィードバックの送信
任意に作出されたマップの座標を、DEMのメッシュと一致させる。 データ表示等において、DEMと重ね合わせたい際に使用します。 読み込んだデータの中に該当データが存在しなかった場合は、本クラスのerrorフラグがtrueになります。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase Conform2DEM(
    MapBase _obj
)
Visual Basic
Public Function Conform2DEM ( _
    _obj As MapBase _
) As MapBase
Visual C++
public:
MapBase^ Conform2DEM(
    MapBase^ _obj
)

Parameters

_obj
Type: GIS..::..MapBase
任意のマップ

Return Value

調整済みマップ

See Also

DEM Class
GIS Namespace


DEMexit Method

[image]

A Sandcastle Documented Class Library
DEM..::..DEMexit Method
DEM Class See Also フィードバックの送信
指定座標を含んだDEMを読み込み可能かどうかを確認する

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool DEMexit(
    BLH _position
)
Visual Basic
Public Function DEMexit ( _
    _position As BLH _
) As Boolean
Visual C++
public:
bool DEMexit(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH
指定座標（lat,lon）

Return Value

使用可能ならtrue，不可能ならfalseを返す

See Also

DEM Class
GIS Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
DEM..::..Finalize Method
DEM Class See Also フィードバックの送信
デスコンストラクタ

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

DEM Class
GIS Namespace


GetHeight Method

[image] [image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method
DEM Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | GetHeight(BLH) | 標高を緯度経度の指定で読み込む。 該当なしの場合は、NAを返す。
Public method | GetHeight(array<BLH>[]()[][]) | 指定された緯度経度に沿った標高を配列で返す
Public method | GetHeight(BLH, MapBase..::..Pos) | 指定された緯度経度を中心とした、相対座標位置のマップ情報を返す

See Also

DEM Class
DEM Members
GIS Namespace


GetHeight Method (BLH)

[image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method (BLH)
DEM Class See Also フィードバックの送信
標高を緯度経度の指定で読み込む。 該当なしの場合は、NAを返す。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float GetHeight(
    BLH _position
)
Visual Basic
Public Function GetHeight ( _
    _position As BLH _
) As Single
Visual C++
public:
float GetHeight(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH
指定座標

Return Value

指定された座標のマップ情報を返す

See Also

DEM Class
GetHeight Overload
GIS Namespace


GetHeight Method (BLH[])

[image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method (array<BLH>[]()[][])
DEM Class See Also フィードバックの送信
指定された緯度経度に沿った標高を配列で返す

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[] GetHeight(
    BLH[] _positions
)
Visual Basic
Public Function GetHeight ( _
    _positions As BLH() _
) As Single()
Visual C++
public:
array<float>^ GetHeight(
    array<BLH>^ _positions
)

Parameters

_positions
Type: array< GPS..::..BLH >[]()[][]

["M:GIS.DEM.GetHeight(GPS.BLH[])" の為の説明文 <param name="_positions"/> が欠落しています。]

Return Value

指定された座標のマップ情報を返す

See Also

DEM Class
GetHeight Overload
GIS Namespace


GetHeight Method (BLH, MapBase.Pos)

[image]

A Sandcastle Documented Class Library
DEM..::..GetHeight Method (BLH, MapBase..::..Pos)
DEM Class See Also フィードバックの送信
指定された緯度経度を中心とした、相対座標位置のマップ情報を返す

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase..::..LocalData GetHeight(
    BLH _center_position,
    MapBase..::..Pos _delta_position
)
Visual Basic
Public Function GetHeight ( _
    _center_position As BLH, _
    _delta_position As MapBase..::..Pos _
) As MapBase..::..LocalData
Visual C++
public:
MapBase..::..LocalData GetHeight(
    BLH _center_position,
    MapBase..::..Pos _delta_position
)

Parameters

_center_position
Type: GPS..::..BLH

["M:GIS.DEM.GetHeight(GPS.BLH,GIS.MapBase.Pos)" の為の説明文 <param name="_center_position"/> が欠落しています。]

_delta_position
Type: GIS..::..MapBase..::..Pos
相対座標（メッシュ数でカウントする）。x軸は右向きで正，y軸は下向きで正であることに注意。

Return Value

指定された座標のマップ情報を座標（緯度・経度）と一緒に返す

See Also

DEM Class
GetHeight Overload
GIS Namespace


GetMap Method

[image]

A Sandcastle Documented Class Library
DEM..::..GetMap Method
DEM Class See Also フィードバックの送信
マップ確認用メソッド

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase GetMap(
    BLH _position
)
Visual Basic
Public Function GetMap ( _
    _position As BLH _
) As MapBase
Visual C++
public:
MapBase^ GetMap(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH
出力したいマップが含む座標（緯度・経度）

Return Value

マップクラス（実態のクローンではない）

See Also

DEM Class
GIS Namespace


GetMeshSize Method

[image]

A Sandcastle Documented Class Library
DEM..::..GetMeshSize Method
DEM Class See Also フィードバックの送信
指定座標の入っているメッシュのサイズを取得する

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public length GetMeshSize(
    BLH _position
)
Visual Basic
Public Function GetMeshSize ( _
    _position As BLH _
) As length
Visual C++
public:
length GetMeshSize(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH
指定座標（緯度・経度）

Return Value

メッシュサイズ[m]

See Also

DEM Class
GIS Namespace


ResetError Method

[image]

A Sandcastle Documented Class Library
DEM..::..ResetError Method
DEM Class See Also フィードバックの送信
エラーフラグをリセットする。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ResetError()
Visual Basic
Public Sub ResetError
Visual C++
public:
void ResetError()

See Also

DEM Class
GIS Namespace


SetXML Method

[image]

A Sandcastle Documented Class Library
DEM..::..SetXML Method
DEM Class See Also フィードバックの送信
外部より読み込みを強制できるメソッド

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool SetXML(
    int i
)
Visual Basic
Public Function SetXML ( _
    i As Integer _
) As Boolean
Visual C++
public:
bool SetXML(
    int i
)

Parameters

i
Type: System..::..Int32
読み込ませたいファイル番号

Return Value

指定した番号で読み込み可能であればtrue

See Also

DEM Class
GIS Namespace


DEM Properties

[image] [image]

A Sandcastle Documented Class Library
DEM Properties
DEM Class See Also フィードバックの送信

The DEM type exposes the following members.

Properties

 | Name | Description
Public property | Error | エラー情報
Public property | IsMapSet | DEMのXMLファイル読み込み準備ができていればtrue
Public property | UsefulDEMdataNum | 読み込み可能なDEMファイル数

See Also

DEM Class
GIS Namespace


Error Property

[image]

A Sandcastle Documented Class Library
DEM..::..Error Property
DEM Class See Also フィードバックの送信
エラー情報

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Error { get; }
Visual Basic
Public ReadOnly Property Error As Boolean
    Get
Visual C++
public:
property bool Error {
    bool get ();
}

See Also

DEM Class
GIS Namespace


IsMapSet Property

[image]

A Sandcastle Documented Class Library
DEM..::..IsMapSet Property
DEM Class See Also フィードバックの送信
DEMのXMLファイル読み込み準備ができていればtrue

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsMapSet { get; }
Visual Basic
Public ReadOnly Property IsMapSet As Boolean
    Get
Visual C++
public:
property bool IsMapSet {
    bool get ();
}

See Also

DEM Class
GIS Namespace


UsefulDEMdataNum Property

[image]

A Sandcastle Documented Class Library
DEM..::..UsefulDEMdataNum Property
DEM Class See Also フィードバックの送信
読み込み可能なDEMファイル数

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int UsefulDEMdataNum { get; }
Visual Basic
Public ReadOnly Property UsefulDEMdataNum As Integer
    Get
Visual C++
public:
property int UsefulDEMdataNum {
    int get ();
}

See Also

DEM Class
GIS Namespace


Gravity Class

[image]

A Sandcastle Documented Class Library
Gravity Class
Members See Also フィードバックの送信

["T:GIS.Gravity" の為の説明文 <summary> が欠落しています。]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class Gravity
Visual Basic
Public NotInheritable Class Gravity
Visual C++
public ref class Gravity abstract sealed

Inheritance Hierarchy

System..::..Object
GIS..::..Gravity

See Also

Gravity Members
GIS Namespace


Gravity Members

[image] [image]

A Sandcastle Documented Class Library
Gravity Members
Gravity Class Methods See Also フィードバックの送信

The Gravity type exposes the following members.

Methods

Name Description
GetGravity
正規重力（楕円体表面での正規化された重力（引力と遠心力の合力））のチェビシェフ近似. 測地基準系1980での正規重力を表わす重力式1980の展開を用いた。

Remarks

測地学会が編集している測地学WEB版 http://www.geod.jpn.org/web-text/part2/2-2/2-2-1-4.html を参考にした。 誤差は0.1μGal（だそうだ） 国土地理院の http://vldb.gsi.go.jp/sokuchi/gravity/grv_jpn/gr_table.pl?103 と比較して正規重力値に0.01 mGal以内の誤差しかないことを確認済み

See Also

Gravity Class
GIS Namespace


Gravity Methods

[image] [image]

A Sandcastle Documented Class Library
Gravity Methods
Gravity Class See Also フィードバックの送信

The Gravity type exposes the following members.

Methods

Name Description
GetGravity
正規重力（楕円体表面での正規化された重力（引力と遠心力の合力））のチェビシェフ近似. 測地基準系1980での正規重力を表わす重力式1980の展開を用いた。

Remarks

測地学会が編集している測地学WEB版 http://www.geod.jpn.org/web-text/part2/2-2/2-2-1-4.html を参考にした。 誤差は0.1μGal（だそうだ） 国土地理院の http://vldb.gsi.go.jp/sokuchi/gravity/grv_jpn/gr_table.pl?103 と比較して正規重力値に0.01 mGal以内の誤差しかないことを確認済み

See Also

Gravity Class
GIS Namespace


GetGravity Method

[image]

A Sandcastle Documented Class Library
Gravity..::..GetGravity Method
Gravity Class See Also フィードバックの送信
正規重力（楕円体表面での正規化された重力（引力と遠心力の合力））のチェビシェフ近似. 測地基準系1980での正規重力を表わす重力式1980の展開を用いた。

Remarks

測地学会が編集している測地学WEB版 http://www.geod.jpn.org/web-text/part2/2-2/2-2-1-4.html を参考にした。 誤差は0.1μGal（だそうだ） 国土地理院の http://vldb.gsi.go.jp/sokuchi/gravity/grv_jpn/gr_table.pl?103 と比較して正規重力値に0.01 mGal以内の誤差しかないことを確認済み

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double GetGravity(
    double latitude
)
Visual Basic
Public Shared Function GetGravity ( _
    latitude As Double _
) As Double
Visual C++
public:
static double GetGravity(
    double latitude
)

Parameters

latitude
Type: System..::..Double
緯度[°]　単位に注意

Return Value

重力値[m/s2]　単位がGalではないことに注意

See Also

Gravity Class
GIS Namespace


MapBase Class

[image]

A Sandcastle Documented Class Library
MapBase Class
Members See Also フィードバックの送信
ラスタデータで構成される地図情報を扱うクラスです。 DEMデータ（デジタル標高データ）等を扱うことを念頭に入れています。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class MapBase
Visual Basic
Public Class MapBase
Visual C++
public ref class MapBase

Inheritance Hierarchy

System..::..Object
GIS..::..MapBase

See Also

MapBase Members
GIS Namespace


MapBase Members

[image] [image]

A Sandcastle Documented Class Library
MapBase Members
MapBase Class Constructors Methods Fields Properties See Also フィードバックの送信

The MapBase type exposes the following members.

Constructors

 | Name | Description
Public method | MapBase(MapBase..::..MapCoo) | コンストラクタです。 座標計算を特に使用しない場合に推奨します。
Public method | MapBase(MapBase..::..MapCoo, MapBase..::..Pos) | コンストラクタです。 サイズをセットさせて、様々な座標の計算を行いたい場合に使用します。 マップデータ（例えば標高）を読み込ませなくとも計算できることは多々あります。 コンストラクタ呼び出し後、マップをセットする際のマップサイズとここでの指定サイズ（_size）が異なる場合はマップセット時の値が優先されます。 ご注意ください。
Public method | MapBase(MapBase..::..MapCoo, length) | コンストラクタです。 コーナーの境界座標値とメッシュのサイズ（分解能）からマップの座標調整まで行います。 マップの境界値があいまいだけども任意のマップを生成したいという場合に使用します。 マップセット時に配列のサイズによりマップサイズが変更されてしまう事ともあり得ることに注意して下さい。

Methods

 | Name | Description
Public method | AddValue | 座標（緯度・経度）に指定された値を加算する
Public method | AddValues | 座標（緯度・経度の配列）に指定された値（配列）を加算する
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetMap | マップを返します。
Public method | GetPosDiff | 指定された座標を中心として、指定された相対アドレスの緯度と経度を返します。
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Public method | GetValue | 指定座標のマップデータを返す。 計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度
Public method | Initialize | マップの初期化メソッド マップサイズを定義済みであれば、マップの初期化を行う。 マップデータはデフォルトでは0.0fで上書きされる。
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Position2MeshCorner | 指定座標の属するメッシュの右上・左上の座標を返す (任意に作出されたマップの位置を本クラスのメッシュ位置と一致させる特殊用途で使用可能なメソッド）
Public method | SaveFileAsXML | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SaveFileForRcmdr | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SetMapData | マップデータをセットします。 メッシュサイズに矛盾が存在してそうなことは一応計算します。
Public method | ToString | 本マップの情報を文字列にして返す。 確認用です。 (Overrides Object..::..ToString()()()().)
Public method | ToStringAsXML | 本マップの情報を、XMLフォーマットの文字列にして返す。 マップとしてはデフォルト形式です。 確認用です。
Public method | ToStringForRcmdr | 本マップの情報を、Rコマンダー用フォーマットの文字列にして返す。 緯度・経度とマップ情報をカンマ区切りで出力します。 確認用です。
Public method | Useful | 渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。

Fields

Name | Description
NA | not applicable: 該当データがない場合の値

Properties

 | Name | Description
Public property | corner | マップの右上・左下の座標（緯度・経度）を取得したり、再セットする。 セット時には、メッシュサイズとマップサイズがセットされていた場合に、一応目安程度の矛盾チェックも行う。
Public property | IsErrorMeshSize | メッシュサイズに矛盾がありそうだとtrueとなる。
Public property | IsErrorSize | newでセットしたマップサイズとSetMapでセットされたサイズ間に差があるとtrueとなる。
Public property | IsMapSet | マップがセット済みかどうかをtrue or falseで返す。
Public property | IsSizeSet | マップのサイズがセットされているかを確認する。 セットされていればtrue。
Public property | MeshSize | セットされているメッシュサイズを返します。
Public property | RealMeshSize | 計算して求めたメッシュサイズを返します。

See Also

MapBase Class
GIS Namespace


MapBase Constructor

[image] [image]

A Sandcastle Documented Class Library
MapBase Constructor
MapBase Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | MapBase(MapBase..::..MapCoo) | コンストラクタです。 座標計算を特に使用しない場合に推奨します。
Public method | MapBase(MapBase..::..MapCoo, MapBase..::..Pos) | コンストラクタです。 サイズをセットさせて、様々な座標の計算を行いたい場合に使用します。 マップデータ（例えば標高）を読み込ませなくとも計算できることは多々あります。 コンストラクタ呼び出し後、マップをセットする際のマップサイズとここでの指定サイズ（_size）が異なる場合はマップセット時の値が優先されます。 ご注意ください。
Public method | MapBase(MapBase..::..MapCoo, length) | コンストラクタです。 コーナーの境界座標値とメッシュのサイズ（分解能）からマップの座標調整まで行います。 マップの境界値があいまいだけども任意のマップを生成したいという場合に使用します。 マップセット時に配列のサイズによりマップサイズが変更されてしまう事ともあり得ることに注意して下さい。

See Also

MapBase Class
MapBase Members
GIS Namespace


MapBase Constructor (MapBase.MapCoo)

[image]

A Sandcastle Documented Class Library
MapBase Constructor (MapBase..::..MapCoo)
MapBase Class See Also フィードバックの送信
コンストラクタです。 座標計算を特に使用しない場合に推奨します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase(
    MapBase..::..MapCoo _coordinate
)
Visual Basic
Public Sub New ( _
    _coordinate As MapBase..::..MapCoo _
)
Visual C++
public:
MapBase(
    MapBase..::..MapCoo _coordinate
)

Parameters

_coordinate
Type: GIS..::..MapBase..::..MapCoo
マップの座標情報

See Also

MapBase Class
MapBase Overload
GIS Namespace


MapBase Constructor (MapBase.MapCoo, MapBase.Pos)

[image]

A Sandcastle Documented Class Library
MapBase Constructor (MapBase..::..MapCoo, MapBase..::..Pos)
MapBase Class See Also フィードバックの送信
コンストラクタです。 サイズをセットさせて、様々な座標の計算を行いたい場合に使用します。 マップデータ（例えば標高）を読み込ませなくとも計算できることは多々あります。 コンストラクタ呼び出し後、マップをセットする際のマップサイズとここでの指定サイズ（_size）が異なる場合はマップセット時の値が優先されます。 ご注意ください。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase(
    MapBase..::..MapCoo _coordinate,
    MapBase..::..Pos _size
)
Visual Basic
Public Sub New ( _
    _coordinate As MapBase..::..MapCoo, _
    _size As MapBase..::..Pos _
)
Visual C++
public:
MapBase(
    MapBase..::..MapCoo _coordinate,
    MapBase..::..Pos _size
)

Parameters

_coordinate
Type: GIS..::..MapBase..::..MapCoo
マップの座標情報
_size
Type: GIS..::..MapBase..::..Pos

["M:GIS.MapBase.#ctor(GIS.MapBase.MapCoo,GIS.MapBase.Pos)" の為の説明文 <param name="_size"/> が欠落しています。]

See Also

MapBase Class
MapBase Overload
GIS Namespace


MapBase Constructor (MapBase.MapCoo, length)

[image]

A Sandcastle Documented Class Library
MapBase Constructor (MapBase..::..MapCoo, length)
MapBase Class See Also フィードバックの送信
コンストラクタです。 コーナーの境界座標値とメッシュのサイズ（分解能）からマップの座標調整まで行います。 マップの境界値があいまいだけども任意のマップを生成したいという場合に使用します。 マップセット時に配列のサイズによりマップサイズが変更されてしまう事ともあり得ることに注意して下さい。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase(
    MapBase..::..MapCoo _coordinate,
    length _meshSize
)
Visual Basic
Public Sub New ( _
    _coordinate As MapBase..::..MapCoo, _
    _meshSize As length _
)
Visual C++
public:
MapBase(
    MapBase..::..MapCoo _coordinate,
    length _meshSize
)

Parameters

_coordinate
Type: GIS..::..MapBase..::..MapCoo
作りたいマップの右上・左下の座標（緯度・経度）
_meshSize
Type: GPS..::..length
緯度・経度方向にそれぞれ定義されたメッシュサイズ[m]

See Also

MapBase Class
MapBase Overload
GIS Namespace


MapBase Fields

[image] [image]

A Sandcastle Documented Class Library
MapBase Fields
MapBase Class See Also フィードバックの送信

The MapBase type exposes the following members.

Fields

Name | Description
NA | not applicable: 該当データがない場合の値

See Also

MapBase Class
GIS Namespace


NA Field

[image]

A Sandcastle Documented Class Library
MapBase..::..NA Field
MapBase Class See Also フィードバックの送信
not applicable: 該当データがない場合の値

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const float NA
Visual Basic
Public Const NA As Single
Visual C++
public:
literal float NA

See Also

MapBase Class
GIS Namespace


MapBase Methods

[image] [image]

A Sandcastle Documented Class Library
MapBase Methods
MapBase Class See Also フィードバックの送信

The MapBase type exposes the following members.

Methods

 | Name | Description
Public method | AddValue | 座標（緯度・経度）に指定された値を加算する
Public method | AddValues | 座標（緯度・経度の配列）に指定された値（配列）を加算する
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetMap | マップを返します。
Public method | GetPosDiff | 指定された座標を中心として、指定された相対アドレスの緯度と経度を返します。
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Public method | GetValue | 指定座標のマップデータを返す。 計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度
Public method | Initialize | マップの初期化メソッド マップサイズを定義済みであれば、マップの初期化を行う。 マップデータはデフォルトでは0.0fで上書きされる。
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Position2MeshCorner | 指定座標の属するメッシュの右上・左上の座標を返す (任意に作出されたマップの位置を本クラスのメッシュ位置と一致させる特殊用途で使用可能なメソッド）
Public method | SaveFileAsXML | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SaveFileForRcmdr | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | SetMapData | マップデータをセットします。 メッシュサイズに矛盾が存在してそうなことは一応計算します。
Public method | ToString | 本マップの情報を文字列にして返す。 確認用です。 (Overrides Object..::..ToString()()()().)
Public method | ToStringAsXML | 本マップの情報を、XMLフォーマットの文字列にして返す。 マップとしてはデフォルト形式です。 確認用です。
Public method | ToStringForRcmdr | 本マップの情報を、Rコマンダー用フォーマットの文字列にして返す。 緯度・経度とマップ情報をカンマ区切りで出力します。 確認用です。
Public method | Useful | 渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。

See Also

MapBase Class
GIS Namespace


AddValue Method

[image]

A Sandcastle Documented Class Library
MapBase..::..AddValue Method
MapBase Class See Also フィードバックの送信
座標（緯度・経度）に指定された値を加算する

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddValue(
    BLH _position,
    float value
)
Visual Basic
Public Sub AddValue ( _
    _position As BLH, _
    value As Single _
)
Visual C++
public:
void AddValue(
    BLH _position,
    float value
)

Parameters

_position
Type: GPS..::..BLH
指定座標（緯度・経度）
value
Type: System..::..Single
加算値

See Also

MapBase Class
GIS Namespace


AddValues Method

[image]

A Sandcastle Documented Class Library
MapBase..::..AddValues Method
MapBase Class See Also フィードバックの送信
座標（緯度・経度の配列）に指定された値（配列）を加算する

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void AddValues(
    BLH[] _position,
    float[] values
)
Visual Basic
Public Sub AddValues ( _
    _position As BLH(), _
    values As Single() _
)
Visual C++
public:
void AddValues(
    array<BLH>^ _position,
    array<float>^ values
)

Parameters

_position
Type: array< GPS..::..BLH >[]()[][]
指定座標（緯度・経度）
values
Type: array< System..::..Single >[]()[][]

["M:GIS.MapBase.AddValues(GPS.BLH[],System.Single[])" の為の説明文 <param name="values"/> が欠落しています。]

See Also

MapBase Class
GIS Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
MapBase..::..Finalize Method
MapBase Class See Also フィードバックの送信
デスコンストラクタ

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

MapBase Class
GIS Namespace


GetMap Method

[image]

A Sandcastle Documented Class Library
MapBase..::..GetMap Method
MapBase Class See Also フィードバックの送信
マップを返します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[,] GetMap()
Visual Basic
Public Function GetMap As Single(,)
Visual C++
public:
array<float,2>^ GetMap()

Return Value

["M:GIS.MapBase.GetMap" の為の説明文 <returns> が欠落しています。]

See Also

MapBase Class
GIS Namespace


GetPosDiff Method

[image]

A Sandcastle Documented Class Library
MapBase..::..GetPosDiff Method
MapBase Class See Also フィードバックの送信
指定された座標を中心として、指定された相対アドレスの緯度と経度を返します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH GetPosDiff(
    BLH _center_position,
    MapBase..::..Pos _delta_address
)
Visual Basic
Public Function GetPosDiff ( _
    _center_position As BLH, _
    _delta_address As MapBase..::..Pos _
) As BLH
Visual C++
public:
BLH GetPosDiff(
    BLH _center_position,
    MapBase..::..Pos _delta_address
)

Parameters

_center_position
Type: GPS..::..BLH
指定座標
_delta_address
Type: GIS..::..MapBase..::..Pos
相対座標（メッシュ数でカウントする）

Return Value

指定された座標のマップ情報を返す

See Also

MapBase Class
GIS Namespace


GetValue Method

[image]

A Sandcastle Documented Class Library
MapBase..::..GetValue Method
MapBase Class See Also フィードバックの送信
指定座標のマップデータを返す。 計算式の関係上、東経を基準にしているので西経のデータを扱う場合は東経に変換してから使用する事。 同様に、南緯は北緯に変換して使用して下さい。 例：西経15度=>東経-15度

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float GetValue(
    BLH _position
)
Visual Basic
Public Function GetValue ( _
    _position As BLH _
) As Single
Visual C++
public:
float GetValue(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH

["M:GIS.MapBase.GetValue(GPS.BLH)" の為の説明文 <param name="_position"/> が欠落しています。]

Return Value

指定座標のマップデータ。ただし、該当なしの場合はNAを返す。

See Also

MapBase Class
GIS Namespace


Initialize Method

[image]

A Sandcastle Documented Class Library
MapBase..::..Initialize Method
MapBase Class See Also フィードバックの送信
マップの初期化メソッド マップサイズを定義済みであれば、マップの初期化を行う。 マップデータはデフォルトでは0.0fで上書きされる。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Initialize(
    float _value
)
Visual Basic
Public Sub Initialize ( _
    _value As Single _
)
Visual C++
public:
void Initialize(
    float _value
)

Parameters

_value
Type: System..::..Single
初期化で埋めたい数値.省略すると0.0となる.

See Also

MapBase Class
GIS Namespace


Position2MeshCorner Method

[image]

A Sandcastle Documented Class Library
MapBase..::..Position2MeshCorner Method
MapBase Class See Also フィードバックの送信
指定座標の属するメッシュの右上・左上の座標を返す (任意に作出されたマップの位置を本クラスのメッシュ位置と一致させる特殊用途で使用可能なメソッド）

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase..::..MapCoo Position2MeshCorner(
    BLH _position
)
Visual Basic
Public Function Position2MeshCorner ( _
    _position As BLH _
) As MapBase..::..MapCoo
Visual C++
public:
MapBase..::..MapCoo Position2MeshCorner(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH
指定座標（緯度・経度）

Return Value

メッシュの右上・左上の座標（緯度・経度）

See Also

MapBase Class
GIS Namespace


SaveFileAsXML Method

[image]

A Sandcastle Documented Class Library
MapBase..::..SaveFileAsXML Method
MapBase Class See Also フィードバックの送信
指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveFileAsXML(
    string fname
)
Visual Basic
Public Sub SaveFileAsXML ( _
    fname As String _
)
Visual C++
public:
void SaveFileAsXML(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

MapBase Class
GIS Namespace


SaveFileForRcmdr Method

[image]

A Sandcastle Documented Class Library
MapBase..::..SaveFileForRcmdr Method
MapBase Class See Also フィードバックの送信
指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveFileForRcmdr(
    string fname
)
Visual Basic
Public Sub SaveFileForRcmdr ( _
    fname As String _
)
Visual C++
public:
void SaveFileForRcmdr(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

MapBase Class
GIS Namespace


SetMapData Method

[image]

A Sandcastle Documented Class Library
MapBase..::..SetMapData Method
MapBase Class See Also フィードバックの送信
マップデータをセットします。 メッシュサイズに矛盾が存在してそうなことは一応計算します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SetMapData(
    float[,] _map,
    float _meshSize
)
Visual Basic
Public Sub SetMapData ( _
    _map As Single(,), _
    _meshSize As Single _
)
Visual C++
public:
void SetMapData(
    array<float,2>^ _map,
    float _meshSize
)

Parameters

_map
Type: array< System..::..Single ,2>[,](,)[,][,]
マップのラスタデータ
_meshSize
Type: System..::..Single
メッシュのサイズ（マップの分解能）

See Also

MapBase Class
GIS Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
MapBase..::..ToString Method
MapBase Class See Also フィードバックの送信
本マップの情報を文字列にして返す。 確認用です。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

["M:GIS.MapBase.ToString" の為の説明文 <returns> が欠落しています。]

See Also

MapBase Class
GIS Namespace


ToStringAsXML Method

[image]

A Sandcastle Documented Class Library
MapBase..::..ToStringAsXML Method
MapBase Class See Also フィードバックの送信
本マップの情報を、XMLフォーマットの文字列にして返す。 マップとしてはデフォルト形式です。 確認用です。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToStringAsXML()
Visual Basic
Public Function ToStringAsXML As String
Visual C++
public:
String^ ToStringAsXML()

Return Value

["M:GIS.MapBase.ToStringAsXML" の為の説明文 <returns> が欠落しています。]

See Also

MapBase Class
GIS Namespace


ToStringForRcmdr Method

[image]

A Sandcastle Documented Class Library
MapBase..::..ToStringForRcmdr Method
MapBase Class See Also フィードバックの送信
本マップの情報を、Rコマンダー用フォーマットの文字列にして返す。 緯度・経度とマップ情報をカンマ区切りで出力します。 確認用です。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ToStringForRcmdr()
Visual Basic
Public Function ToStringForRcmdr As String
Visual C++
public:
String^ ToStringForRcmdr()

Return Value

["M:GIS.MapBase.ToStringForRcmdr" の為の説明文 <returns> が欠落しています。]

See Also

MapBase Class
GIS Namespace


Useful Method

[image]

A Sandcastle Documented Class Library
MapBase..::..Useful Method
MapBase Class See Also フィードバックの送信
渡された緯度経度がこのマップの範囲内にあるかどうかをBoolで返す。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Useful(
    BLH _position
)
Visual Basic
Public Function Useful ( _
    _position As BLH _
) As Boolean
Visual C++
public:
bool Useful(
    BLH _position
)

Parameters

_position
Type: GPS..::..BLH
検査座標

Return Value

trueなら使用可能

See Also

MapBase Class
GIS Namespace


MapBase Properties

[image] [image]

A Sandcastle Documented Class Library
MapBase Properties
MapBase Class See Also フィードバックの送信

The MapBase type exposes the following members.

Properties

 | Name | Description
Public property | corner | マップの右上・左下の座標（緯度・経度）を取得したり、再セットする。 セット時には、メッシュサイズとマップサイズがセットされていた場合に、一応目安程度の矛盾チェックも行う。
Public property | IsErrorMeshSize | メッシュサイズに矛盾がありそうだとtrueとなる。
Public property | IsErrorSize | newでセットしたマップサイズとSetMapでセットされたサイズ間に差があるとtrueとなる。
Public property | IsMapSet | マップがセット済みかどうかをtrue or falseで返す。
Public property | IsSizeSet | マップのサイズがセットされているかを確認する。 セットされていればtrue。
Public property | MeshSize | セットされているメッシュサイズを返します。
Public property | RealMeshSize | 計算して求めたメッシュサイズを返します。

See Also

MapBase Class
GIS Namespace


corner Property

[image]

A Sandcastle Documented Class Library
MapBase..::..corner Property
MapBase Class See Also フィードバックの送信
マップの右上・左下の座標（緯度・経度）を取得したり、再セットする。 セット時には、メッシュサイズとマップサイズがセットされていた場合に、一応目安程度の矛盾チェックも行う。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapBase..::..MapCoo corner { get; set; }
Visual Basic
Public Property corner As MapBase..::..MapCoo
    Get
    Set
Visual C++
public:
property MapBase..::..MapCoo corner {
    MapBase..::..MapCoo get ();
    void set (MapBase..::..MapCoo value);
}

See Also

MapBase Class
GIS Namespace


IsErrorMeshSize Property

[image]

A Sandcastle Documented Class Library
MapBase..::..IsErrorMeshSize Property
MapBase Class See Also フィードバックの送信
メッシュサイズに矛盾がありそうだとtrueとなる。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsErrorMeshSize { get; }
Visual Basic
Public ReadOnly Property IsErrorMeshSize As Boolean
    Get
Visual C++
public:
property bool IsErrorMeshSize {
    bool get ();
}

See Also

MapBase Class
GIS Namespace


IsErrorSize Property

[image]

A Sandcastle Documented Class Library
MapBase..::..IsErrorSize Property
MapBase Class See Also フィードバックの送信
newでセットしたマップサイズとSetMapでセットされたサイズ間に差があるとtrueとなる。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsErrorSize { get; }
Visual Basic
Public ReadOnly Property IsErrorSize As Boolean
    Get
Visual C++
public:
property bool IsErrorSize {
    bool get ();
}

See Also

MapBase Class
GIS Namespace


IsMapSet Property

[image]

A Sandcastle Documented Class Library
MapBase..::..IsMapSet Property
MapBase Class See Also フィードバックの送信
マップがセット済みかどうかをtrue or falseで返す。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsMapSet { get; }
Visual Basic
Public ReadOnly Property IsMapSet As Boolean
    Get
Visual C++
public:
property bool IsMapSet {
    bool get ();
}

See Also

MapBase Class
GIS Namespace


IsSizeSet Property

[image]

A Sandcastle Documented Class Library
MapBase..::..IsSizeSet Property
MapBase Class See Also フィードバックの送信
マップのサイズがセットされているかを確認する。 セットされていればtrue。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsSizeSet { get; }
Visual Basic
Public ReadOnly Property IsSizeSet As Boolean
    Get
Visual C++
public:
property bool IsSizeSet {
    bool get ();
}

See Also

MapBase Class
GIS Namespace


MeshSize Property

[image]

A Sandcastle Documented Class Library
MapBase..::..MeshSize Property
MapBase Class See Also フィードバックの送信
セットされているメッシュサイズを返します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float MeshSize { get; }
Visual Basic
Public ReadOnly Property MeshSize As Single
    Get
Visual C++
public:
property float MeshSize {
    float get ();
}

See Also

MapBase Class
GIS Namespace


RealMeshSize Property

[image]

A Sandcastle Documented Class Library
MapBase..::..RealMeshSize Property
MapBase Class See Also フィードバックの送信
計算して求めたメッシュサイズを返します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public length RealMeshSize { get; }
Visual Basic
Public ReadOnly Property RealMeshSize As length
    Get
Visual C++
public:
property length RealMeshSize {
    length get ();
}

See Also

MapBase Class
GIS Namespace


MapBase.LocalData Structure

[image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Structure
MapBase Class Members See Also フィードバックの送信
とある座標のデータを表す、座標と値のセット

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct LocalData
Visual Basic
Public Structure LocalData
Visual C++
public value class LocalData

See Also

MapBase..::..LocalData Members
GIS Namespace


MapBase.LocalData Members

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Members
MapBase..::..LocalData Structure Constructors Methods Fields See Also フィードバックの送信

ラスタデータで構成される地図情報を扱うクラスです。 DEMデータ（デジタル標高データ）等を扱うことを念頭に入れています。

The MapBase..::..LocalData type exposes the following members.

Constructors

 | Name | Description
Public method | MapBase..::..LocalData(BLH, Single) | コンストラクタによる初期化（引数の省略はvalueについては可能）
Public method | MapBase..::..LocalData(Double, Double, Single) | コンストラクタによる初期化（引数の省略は可能）

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | DEM情報の文字列化 (Overrides ValueType..::..ToString()()()().)

Fields

 | Name | Description
Public field | position | 緯度・経度表現による座標
Public field | value | 値（ex.標高）

See Also

MapBase..::..LocalData Structure
GIS Namespace


MapBase.LocalData Constructor

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Constructor
MapBase..::..LocalData Structure See Also フィードバックの送信

Overload List

 | Name | Description
Public method | MapBase..::..LocalData(BLH, Single) | コンストラクタによる初期化（引数の省略はvalueについては可能）
Public method | MapBase..::..LocalData(Double, Double, Single) | コンストラクタによる初期化（引数の省略は可能）

See Also

MapBase..::..LocalData Structure
MapBase..::..LocalData Members
GIS Namespace


MapBase.LocalData Constructor (BLH, Single)

[image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Constructor (BLH, Single)
MapBase..::..LocalData Structure See Also フィードバックの送信
コンストラクタによる初期化（引数の省略はvalueについては可能）

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LocalData(
    BLH _pos,
    float _value
)
Visual Basic
Public Sub New ( _
    _pos As BLH, _
    _value As Single _
)
Visual C++
public:
LocalData(
    BLH _pos,
    float _value
)

Parameters

_pos
Type: GPS..::..BLH
緯度・経度の座標
_value
Type: System..::..Single
値

See Also

MapBase..::..LocalData Structure
MapBase..::..LocalData Overload
GIS Namespace


MapBase.LocalData Constructor (Double, Double, Single)

[image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Constructor (Double, Double, Single)
MapBase..::..LocalData Structure See Also フィードバックの送信
コンストラクタによる初期化（引数の省略は可能）

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public LocalData(
    double lat,
    double lon,
    float _value
)
Visual Basic
Public Sub New ( _
    lat As Double, _
    lon As Double, _
    _value As Single _
)
Visual C++
public:
LocalData(
    double lat,
    double lon,
    float _value
)

Parameters

lat
Type: System..::..Double
緯度
lon
Type: System..::..Double
経度
_value
Type: System..::..Single
値

See Also

MapBase..::..LocalData Structure
MapBase..::..LocalData Overload
GIS Namespace


MapBase.LocalData Fields

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Fields
MapBase..::..LocalData Structure See Also フィードバックの送信

The MapBase..::..LocalData type exposes the following members.

Fields

 | Name | Description
Public field | position | 緯度・経度表現による座標
Public field | value | 値（ex.標高）

See Also

MapBase..::..LocalData Structure
GIS Namespace


position Field

[image]

A Sandcastle Documented Class Library
MapBase..::..LocalData..::..position Field
MapBase..::..LocalData Structure See Also フィードバックの送信
緯度・経度表現による座標

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH position
Visual Basic
Public position As BLH
Visual C++
public:
BLH position

See Also

MapBase..::..LocalData Structure
GIS Namespace


value Field

[image]

A Sandcastle Documented Class Library
MapBase..::..LocalData..::..value Field
MapBase..::..LocalData Structure See Also フィードバックの送信
値（ex.標高）

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float value
Visual Basic
Public value As Single
Visual C++
public:
float value

See Also

MapBase..::..LocalData Structure
GIS Namespace


MapBase.LocalData Methods

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..LocalData Methods
MapBase..::..LocalData Structure See Also フィードバックの送信

The MapBase..::..LocalData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | DEM情報の文字列化 (Overrides ValueType..::..ToString()()()().)

See Also

MapBase..::..LocalData Structure
GIS Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
MapBase..::..LocalData..::..ToString Method
MapBase..::..LocalData Structure See Also フィードバックの送信
DEM情報の文字列化

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

["M:GIS.MapBase.LocalData.ToString" の為の説明文 <returns> が欠落しています。]

See Also

MapBase..::..LocalData Structure
GIS Namespace


MapBase.MapCoo Structure

[image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo Structure
MapBase Class Members See Also フィードバックの送信
マップの右上・左下の境界における座標を緯度・経度で表す構造体

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct MapCoo
Visual Basic
Public Structure MapCoo
Visual C++
public value class MapCoo

See Also

MapBase..::..MapCoo Members
GIS Namespace


MapBase.MapCoo Members

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo Members
MapBase..::..MapCoo Structure Constructors Methods Fields See Also フィードバックの送信

ラスタデータで構成される地図情報を扱うクラスです。 DEMデータ（デジタル標高データ）等を扱うことを念頭に入れています。

The MapBase..::..MapCoo type exposes the following members.

Constructors

 | Name | Description
Public method | MapBase..::..MapCoo | コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Fields

 | Name | Description
Public field | lowerLeft | 左下の座標
Public field | upperRight | 右上の座標

See Also

MapBase..::..MapCoo Structure
GIS Namespace


MapBase.MapCoo Constructor

[image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo Constructor
MapBase..::..MapCoo Structure See Also フィードバックの送信
コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MapCoo(
    BLH x1,
    BLH x2
)
Visual Basic
Public Sub New ( _
    x1 As BLH, _
    x2 As BLH _
)
Visual C++
public:
MapCoo(
    BLH x1,
    BLH x2
)

Parameters

x1
Type: GPS..::..BLH

["M:GIS.MapBase.MapCoo.#ctor(GPS.BLH,GPS.BLH)" の為の説明文 <param name="x1"/> が欠落しています。]

x2
Type: GPS..::..BLH

["M:GIS.MapBase.MapCoo.#ctor(GPS.BLH,GPS.BLH)" の為の説明文 <param name="x2"/> が欠落しています。]

See Also

MapBase..::..MapCoo Structure
GIS Namespace


MapBase.MapCoo Fields

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo Fields
MapBase..::..MapCoo Structure See Also フィードバックの送信

The MapBase..::..MapCoo type exposes the following members.

Fields

 | Name | Description
Public field | lowerLeft | 左下の座標
Public field | upperRight | 右上の座標

See Also

MapBase..::..MapCoo Structure
GIS Namespace


lowerLeft Field

[image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo..::..lowerLeft Field
MapBase..::..MapCoo Structure See Also フィードバックの送信
左下の座標

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH lowerLeft
Visual Basic
Public lowerLeft As BLH
Visual C++
public:
BLH lowerLeft

See Also

MapBase..::..MapCoo Structure
GIS Namespace


upperRight Field

[image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo..::..upperRight Field
MapBase..::..MapCoo Structure See Also フィードバックの送信
右上の座標

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH upperRight
Visual Basic
Public upperRight As BLH
Visual C++
public:
BLH upperRight

See Also

MapBase..::..MapCoo Structure
GIS Namespace


MapBase.MapCoo Methods

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..MapCoo Methods
MapBase..::..MapCoo Structure See Also フィードバックの送信

The MapBase..::..MapCoo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

MapBase..::..MapCoo Structure
GIS Namespace


MapBase.Pos Structure

[image]

A Sandcastle Documented Class Library
MapBase..::..Pos Structure
MapBase Class Members See Also フィードバックの送信
x,yの座標セット構造体 マップのアドレス計算用

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct Pos
Visual Basic
Public Structure Pos
Visual C++
public value class Pos

See Also

MapBase..::..Pos Members
GIS Namespace


MapBase.Pos Members

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..Pos Members
MapBase..::..Pos Structure Constructors Methods Operators Fields See Also フィードバックの送信

ラスタデータで構成される地図情報を扱うクラスです。 DEMデータ（デジタル標高データ）等を扱うことを念頭に入れています。

The MapBase..::..Pos type exposes the following members.

Constructors

 | Name | Description
Public method | MapBase..::..Pos | MapBase..::..Pos クラスの新しいインスタンスを初期化します。

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Operators

Name | Description
Addition |
Subtraction |

Fields

 | Name | Description
Public field | x |
Public field | y |

See Also

MapBase..::..Pos Structure
GIS Namespace


MapBase.Pos Constructor

[image]

A Sandcastle Documented Class Library
MapBase..::..Pos Constructor
MapBase..::..Pos Structure See Also フィードバックの送信
MapBase..::..Pos クラスの新しいインスタンスを初期化します。

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Pos(
    int x0,
    int y0
)
Visual Basic
Public Sub New ( _
    x0 As Integer, _
    y0 As Integer _
)
Visual C++
public:
Pos(
    int x0,
    int y0
)

Parameters

x0
Type: System..::..Int32

["M:GIS.MapBase.Pos.#ctor(System.Int32,System.Int32)" の為の説明文 <param name="x0"/> が欠落しています。]

y0
Type: System..::..Int32

["M:GIS.MapBase.Pos.#ctor(System.Int32,System.Int32)" の為の説明文 <param name="y0"/> が欠落しています。]

See Also

MapBase..::..Pos Structure
GIS Namespace


MapBase.Pos Fields

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..Pos Fields
MapBase..::..Pos Structure See Also フィードバックの送信

The MapBase..::..Pos type exposes the following members.

Fields

 | Name | Description
Public field | x |
Public field | y |

See Also

MapBase..::..Pos Structure
GIS Namespace


x Field

[image]

A Sandcastle Documented Class Library
MapBase..::..Pos..::..x Field
MapBase..::..Pos Structure See Also フィードバックの送信

["F:GIS.MapBase.Pos.x" の為の説明文 <summary> が欠落しています。]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int x
Visual Basic
Public x As Integer
Visual C++
public:
int x

See Also

MapBase..::..Pos Structure
GIS Namespace


y Field

[image]

A Sandcastle Documented Class Library
MapBase..::..Pos..::..y Field
MapBase..::..Pos Structure See Also フィードバックの送信

["F:GIS.MapBase.Pos.y" の為の説明文 <summary> が欠落しています。]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int y
Visual Basic
Public y As Integer
Visual C++
public:
int y

See Also

MapBase..::..Pos Structure
GIS Namespace


MapBase.Pos Methods

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..Pos Methods
MapBase..::..Pos Structure See Also フィードバックの送信

The MapBase..::..Pos type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

MapBase..::..Pos Structure
GIS Namespace


MapBase.Pos Operators

[image] [image]

A Sandcastle Documented Class Library
MapBase..::..Pos Operators
MapBase..::..Pos Structure See Also フィードバックの送信

The MapBase..::..Pos type exposes the following members.

Operators

Name | Description
Addition |
Subtraction |

See Also

MapBase..::..Pos Structure
GIS Namespace


Addition Operator

[image]

A Sandcastle Documented Class Library
MapBase..::..Pos..::..Addition Operator
MapBase..::..Pos Structure See Also フィードバックの送信

["M:GIS.MapBase.Pos.op_Addition(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <summary> が欠落しています。]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static MapBase..::..Pos operator +(
    MapBase..::..Pos c1,
    MapBase..::..Pos c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As MapBase..::..Pos, _
    c2 As MapBase..::..Pos _
) As MapBase..::..Pos
Visual C++
public:
static MapBase..::..Pos operator +(
    MapBase..::..Pos c1,
    MapBase..::..Pos c2
)

Parameters

c1
Type: GIS..::..MapBase..::..Pos

["M:GIS.MapBase.Pos.op_Addition(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <param name="c1"/> が欠落しています。]

c2
Type: GIS..::..MapBase..::..Pos

["M:GIS.MapBase.Pos.op_Addition(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <param name="c2"/> が欠落しています。]

Return Value

["M:GIS.MapBase.Pos.op_Addition(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <returns> が欠落しています。]

See Also

MapBase..::..Pos Structure
GIS Namespace


Subtraction Operator

[image]

A Sandcastle Documented Class Library
MapBase..::..Pos..::..Subtraction Operator
MapBase..::..Pos Structure See Also フィードバックの送信

["M:GIS.MapBase.Pos.op_Subtraction(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <summary> が欠落しています。]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static MapBase..::..Pos operator -(
    MapBase..::..Pos c1,
    MapBase..::..Pos c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As MapBase..::..Pos, _
    c2 As MapBase..::..Pos _
) As MapBase..::..Pos
Visual C++
public:
static MapBase..::..Pos operator -(
    MapBase..::..Pos c1,
    MapBase..::..Pos c2
)

Parameters

c1
Type: GIS..::..MapBase..::..Pos

["M:GIS.MapBase.Pos.op_Subtraction(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <param name="c1"/> が欠落しています。]

c2
Type: GIS..::..MapBase..::..Pos

["M:GIS.MapBase.Pos.op_Subtraction(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <param name="c2"/> が欠落しています。]

Return Value

["M:GIS.MapBase.Pos.op_Subtraction(GIS.MapBase.Pos,GIS.MapBase.Pos)" の為の説明文 <returns> が欠落しています。]

See Also

MapBase..::..Pos Structure
GIS Namespace


TerrainInformation Class

[image]

A Sandcastle Documented Class Library
TerrainInformation Class
Members See Also フィードバックの送信
地形情報を格納するためのクラス

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class TerrainInformation
Visual Basic
<SerializableAttribute> _
Public Class TerrainInformation
Visual C++
[SerializableAttribute]
public ref class TerrainInformation

Remarks

唯の高度情報ではなく、DEMと連動した高度な地形情報を扱うためのクラスとして整備する予定 開空度などを計算できるようにしたら面白いかもね。 ついでに、継承を使ってGPS用に拡張したって面白い。

Inheritance Hierarchy

System..::..Object
GIS..::..TerrainInformation

See Also

TerrainInformation Members
GIS Namespace


TerrainInformation Members

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation Members
TerrainInformation Class Constructors Methods Properties See Also フィードバックの送信

The TerrainInformation type exposes the following members.

Constructors

 | Name | Description
Public method | TerrainInformation | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | Error | 演算エラーがあるとtrue
Public property | GeoFeature | 周囲地形（ex. 急峻(Precipitous)）
Public property | Height | 高度[m]
Public property | MaxHeight | 周囲の地形から勘案した最高標高[m]
Public property | MinHeight | 周囲の地形から勘案した最低標高[m]

See Also

TerrainInformation Class
GIS Namespace


TerrainInformation Constructor

[image]

A Sandcastle Documented Class Library
TerrainInformation Constructor
TerrainInformation Class See Also フィードバックの送信
コンストラクタ

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TerrainInformation(
    BLH _pos,
    DEM _dem
)
Visual Basic
Public Sub New ( _
    _pos As BLH, _
    _dem As DEM _
)
Visual C++
public:
TerrainInformation(
    BLH _pos,
    DEM^ _dem
)

Parameters

_pos
Type: GPS..::..BLH
座標
_dem
Type: GIS..::..DEM
DEM操作用のクラス（インスタンス生成済みのもの）

Remarks

地形情報を取得する

See Also

TerrainInformation Class
GIS Namespace


TerrainInformation Methods

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation Methods
TerrainInformation Class See Also フィードバックの送信

The TerrainInformation type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

TerrainInformation Class
GIS Namespace


TerrainInformation Properties

[image] [image]

A Sandcastle Documented Class Library
TerrainInformation Properties
TerrainInformation Class See Also フィードバックの送信

The TerrainInformation type exposes the following members.

Properties

 | Name | Description
Public property | Error | 演算エラーがあるとtrue
Public property | GeoFeature | 周囲地形（ex. 急峻(Precipitous)）
Public property | Height | 高度[m]
Public property | MaxHeight | 周囲の地形から勘案した最高標高[m]
Public property | MinHeight | 周囲の地形から勘案した最低標高[m]

See Also

TerrainInformation Class
GIS Namespace


Error Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Error Property
TerrainInformation Class See Also フィードバックの送信
演算エラーがあるとtrue

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Error { get; }
Visual Basic
Public ReadOnly Property Error As Boolean
    Get
Visual C++
public:
property bool Error {
    bool get ();
}

See Also

TerrainInformation Class
GIS Namespace


GeoFeature Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..GeoFeature Property
TerrainInformation Class See Also フィードバックの送信
周囲地形（ex. 急峻(Precipitous)）

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TerrainInformation..::..GeographicalFeature GeoFeature { get; }
Visual Basic
Public ReadOnly Property GeoFeature As TerrainInformation..::..GeographicalFeature
    Get
Visual C++
public:
property TerrainInformation..::..GeographicalFeature GeoFeature {
    TerrainInformation..::..GeographicalFeature get ();
}

See Also

TerrainInformation Class
GIS Namespace


Height Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..Height Property
TerrainInformation Class See Also フィードバックの送信
高度[m]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double Height { get; }
Visual Basic
Public ReadOnly Property Height As Double
    Get
Visual C++
public:
property double Height {
    double get ();
}

See Also

TerrainInformation Class
GIS Namespace


MaxHeight Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..MaxHeight Property
TerrainInformation Class See Also フィードバックの送信
周囲の地形から勘案した最高標高[m]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MaxHeight { get; }
Visual Basic
Public ReadOnly Property MaxHeight As Double
    Get
Visual C++
public:
property double MaxHeight {
    double get ();
}

See Also

TerrainInformation Class
GIS Namespace


MinHeight Property

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..MinHeight Property
TerrainInformation Class See Also フィードバックの送信
周囲の地形から勘案した最低標高[m]

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double MinHeight { get; }
Visual Basic
Public ReadOnly Property MinHeight As Double
    Get
Visual C++
public:
property double MinHeight {
    double get ();
}

See Also

TerrainInformation Class
GIS Namespace


TerrainInformation.GeographicalFeature Enumeration

[image]

A Sandcastle Documented Class Library
TerrainInformation..::..GeographicalFeature Enumeration
TerrainInformation Class See Also フィードバックの送信
地形の特徴を表す 順に、崖・急峻・なだらか・平坦・不明

Namespace: GIS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GeographicalFeature
Visual Basic
Public Enumeration GeographicalFeature
Visual C++
public enum class GeographicalFeature

Members

Member name | Value | Description
Cliff | 0 |
Precipitous | 1 |
Gentleness | 2 |
Flat | 3 |
NA | 4 |

See Also

GIS Namespace


GPS Namespace

[image]

A Sandcastle Documented Class Library
GPS Namespace
フィードバックの送信

["N:GPS" の為の説明文 <summary> が欠落しています。]

Classes

 | Class | Description
Public class | NMEA | 2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる 開発時間を優先した。 今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。 string nmea_str = "$GPGGA,*******"; GPS.NMEA nmea_parser = new GPS.NMEA(); object hoge; hoge = nmea_parser.parse(nmea_str); // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。 if(hoge.GetType() == tyepof(GPS.NMEA)) // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。 { // たとえば、こんな感じか？ int sat = hoge.sat; } NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理） 3)
Public class | NMEA..::..GGA |
Public class | NMEA..::..PositioningInfo | 観測データを取り扱うクラス 構造体にしないのは、構造体だと初期化を必ず求められるため。
Public class | NMEA..::..PositioningInfos | 測位情報を配列をして格納
Public class | rectangleField | 2点で張られる長方形領域を緯度・経度で表すクラス たとえば、GPSのログ領域の広さやマップの広さを表すことができる。
Public class | WGS84 | WGS84座標系における各種パラメータ 参考：西修二郎訳，GNSSのすべて，p.265，2010.2．

Structures

 | Structure | Description
Public structure | BLH | 緯度・経度・楕円体高を表すクラス 語源はドイツ語らしい。
Public structure | length | 南北、東西方向の距離・長さを収めるための構造体。
Public structure | XYZ | x,y,zを格納する構造体 半径の取得も簡単 BLH座標系（緯度・経度・楕円体高[m]）への変換も簡単

Enumerations

 | Enumeration | Description
Public enumeration | BLH..::..units |


BLH Structure

[image]

A Sandcastle Documented Class Library
BLH Structure
Members See Also フィードバックの送信
緯度・経度・楕円体高を表すクラス 語源はドイツ語らしい。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public struct BLH
Visual Basic
<SerializableAttribute> _
Public Structure BLH
Visual C++
[SerializableAttribute]
public value class BLH

See Also

BLH Members
GPS Namespace


BLH Members

[image] [image]

A Sandcastle Documented Class Library
BLH Members
BLH Structure Constructors Methods Operators Fields Properties See Also フィードバックの送信

The BLH type exposes the following members.

Constructors

 | Name | Description
Public method | BLH | コンストラクタ

Methods

 | Name | Description
Public method | ChangeToDegree | 自身の単位を度へ変換する
Public method | ChangeToRadian | 自身の単位をラジアン単位へ変換する
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetDistance | 引数で渡された座標までの距離を返す。 簡易計算なので、距離が数十km以下で有効です。
Public method | GetDistance2 | 簡易な距離演算その2 精度は、近距離では（少なくとも20km程度）その1の方法と大して変わらない。 参考：http://homepage3.nifty.com/kubota01/distance.htm 距離が50kmを超えるようなら、こちらのメソッドの方が実際の距離を表すと思う。 [2011/7/18 追記] 現時点ではXYZの直交座標系への変換精度が悪く、極近距離で精度が出ない。
Public method | GetDistance3 | GetDistanceを利用して、直線距離を求めるメソッド
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 緯度・経度・楕円体高の文字列化 Excelに合わせて、経度から先に出力する。 (Overrides ValueType..::..ToString()()()().)
Public method | ToXYZ | XYZ座標系へ変換したオブジェクトを返す 参考：理科年表，p.563，2003． [2011/7/18 追記]計算精度が悪い気がしてならん。

Operators

Name | Description
Addition |
Subtraction |

Fields

 | Name | Description
Public field | B |
Public field | H |
Public field | L |
Public field | unit |

Properties

 | Name | Description
Public property | GetUnitLengthForEN | 楕円体に沿った、東西方向の単位長[m/deg]を返す 実際は高度の分だけ若干の誤差が発生するし、2地点の高度差は考慮しない。 参考：理科年表，p.563，2003． ちなみに、http://yamadarake.web.fc2.com/trdi/2009/report000001.html を見るとヒュベニの公式と言うものであることが分かる
Public property | ToDegree | 単位を度へ変換した物を返す
Public property | ToRadian | 単位をラジアン単位へ変換した物を返す

See Also

BLH Structure


BLH Constructor

[image]

A Sandcastle Documented Class Library
BLH Constructor
BLH Structure See Also フィードバックの送信
コンストラクタ

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH(
    double _B,
    double _L,
    double _H,
    BLH..::..units _unit
)
Visual Basic
Public Sub New ( _
    _B As Double, _
    _L As Double, _
    _H As Double, _
    _unit As BLH..::..units _
)
Visual C++
public:
BLH(
    double _B,
    double _L,
    double _H,
    BLH..::..units _unit
)

Parameters

_B
Type: System..::..Double

["M:GPS.BLH.#ctor(System.Double,System.Double,System.Double,GPS.BLH.units)" の為の説明文 <param name="_B"/> が欠落しています。]

_L
Type: System..::..Double

["M:GPS.BLH.#ctor(System.Double,System.Double,System.Double,GPS.BLH.units)" の為の説明文 <param name="_L"/> が欠落しています。]

_H
Type: System..::..Double

["M:GPS.BLH.#ctor(System.Double,System.Double,System.Double,GPS.BLH.units)" の為の説明文 <param name="_H"/> が欠落しています。]

_unit
Type: GPS..::..BLH..::..units

["M:GPS.BLH.#ctor(System.Double,System.Double,System.Double,GPS.BLH.units)" の為の説明文 <param name="_unit"/> が欠落しています。]

See Also

BLH Structure


BLH Fields

[image] [image]

A Sandcastle Documented Class Library
BLH Fields
BLH Structure See Also フィードバックの送信

The BLH type exposes the following members.

Fields

 | Name | Description
Public field | B |
Public field | H |
Public field | L |
Public field | unit |

See Also

BLH Structure


B Field

[image]

A Sandcastle Documented Class Library
BLH..::..B Field
BLH Structure See Also フィードバックの送信

["F:GPS.BLH.B" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double B
Visual Basic
Public B As Double
Visual C++
public:
double B

See Also

BLH Structure


H Field

[image]

A Sandcastle Documented Class Library
BLH..::..H Field
BLH Structure See Also フィードバックの送信

["F:GPS.BLH.H" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double H
Visual Basic
Public H As Double
Visual C++
public:
double H

See Also

BLH Structure


L Field

[image]

A Sandcastle Documented Class Library
BLH..::..L Field
BLH Structure See Also フィードバックの送信

["F:GPS.BLH.L" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double L
Visual Basic
Public L As Double
Visual C++
public:
double L

See Also

BLH Structure


unit Field

[image]

A Sandcastle Documented Class Library
BLH..::..unit Field
BLH Structure See Also フィードバックの送信

["F:GPS.BLH.unit" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH..::..units unit
Visual Basic
Public unit As BLH..::..units
Visual C++
public:
BLH..::..units unit

See Also

BLH Structure


BLH Methods

[image] [image]

A Sandcastle Documented Class Library
BLH Methods
BLH Structure See Also フィードバックの送信

The BLH type exposes the following members.

Methods

 | Name | Description
Public method | ChangeToDegree | 自身の単位を度へ変換する
Public method | ChangeToRadian | 自身の単位をラジアン単位へ変換する
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetDistance | 引数で渡された座標までの距離を返す。 簡易計算なので、距離が数十km以下で有効です。
Public method | GetDistance2 | 簡易な距離演算その2 精度は、近距離では（少なくとも20km程度）その1の方法と大して変わらない。 参考：http://homepage3.nifty.com/kubota01/distance.htm 距離が50kmを超えるようなら、こちらのメソッドの方が実際の距離を表すと思う。 [2011/7/18 追記] 現時点ではXYZの直交座標系への変換精度が悪く、極近距離で精度が出ない。
Public method | GetDistance3 | GetDistanceを利用して、直線距離を求めるメソッド
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 緯度・経度・楕円体高の文字列化 Excelに合わせて、経度から先に出力する。 (Overrides ValueType..::..ToString()()()().)
Public method | ToXYZ | XYZ座標系へ変換したオブジェクトを返す 参考：理科年表，p.563，2003． [2011/7/18 追記]計算精度が悪い気がしてならん。

See Also

BLH Structure


ChangeToDegree Method

[image]

A Sandcastle Documented Class Library
BLH..::..ChangeToDegree Method
BLH Structure See Also フィードバックの送信
自身の単位を度へ変換する

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ChangeToDegree()
Visual Basic
Public Sub ChangeToDegree
Visual C++
public:
void ChangeToDegree()

See Also

BLH Structure


ChangeToRadian Method

[image]

A Sandcastle Documented Class Library
BLH..::..ChangeToRadian Method
BLH Structure See Also フィードバックの送信
自身の単位をラジアン単位へ変換する

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void ChangeToRadian()
Visual Basic
Public Sub ChangeToRadian
Visual C++
public:
void ChangeToRadian()

See Also

BLH Structure


GetDistance Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetDistance Method
BLH Structure See Also フィードバックの送信
引数で渡された座標までの距離を返す。 簡易計算なので、距離が数十km以下で有効です。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public length GetDistance(
    BLH secondPos
)
Visual Basic
Public Function GetDistance ( _
    secondPos As BLH _
) As length
Visual C++
public:
length GetDistance(
    BLH secondPos
)

Parameters

secondPos
Type: GPS..::..BLH
求めたい地点の座標

Return Value

南北・東西方向の距離[m]を構造体で返す

See Also

BLH Structure


GetDistance2 Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetDistance2 Method
BLH Structure See Also フィードバックの送信
簡易な距離演算その2 精度は、近距離では（少なくとも20km程度）その1の方法と大して変わらない。 参考：http://homepage3.nifty.com/kubota01/distance.htm 距離が50kmを超えるようなら、こちらのメソッドの方が実際の距離を表すと思う。 [2011/7/18　追記] 現時点ではXYZの直交座標系への変換精度が悪く、極近距離で精度が出ない。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetDistance2(
    BLH secondPos
)
Visual Basic
Public Function GetDistance2 ( _
    secondPos As BLH _
) As Double
Visual C++
public:
double GetDistance2(
    BLH secondPos
)

Parameters

secondPos
Type: GPS..::..BLH
求めたい地点の座標

Return Value

距離

See Also

BLH Structure


GetDistance3 Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetDistance3 Method
BLH Structure See Also フィードバックの送信
GetDistanceを利用して、直線距離を求めるメソッド

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetDistance3(
    BLH secondPos
)
Visual Basic
Public Function GetDistance3 ( _
    secondPos As BLH _
) As Double
Visual C++
public:
double GetDistance3(
    BLH secondPos
)

Parameters

secondPos
Type: GPS..::..BLH
求めたい地点の座標

Return Value

距離

See Also

BLH Structure


ToString Method

[image]

A Sandcastle Documented Class Library
BLH..::..ToString Method
BLH Structure See Also フィードバックの送信
緯度・経度・楕円体高の文字列化 Excelに合わせて、経度から先に出力する。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

文字列化した位置座標

See Also

BLH Structure


ToXYZ Method

[image]

A Sandcastle Documented Class Library
BLH..::..ToXYZ Method
BLH Structure See Also フィードバックの送信
XYZ座標系へ変換したオブジェクトを返す 参考：理科年表，p.563，2003． [2011/7/18　追記]計算精度が悪い気がしてならん。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XYZ ToXYZ()
Visual Basic
Public Function ToXYZ As XYZ
Visual C++
public:
XYZ ToXYZ()

Return Value

変換したXYZ座標

See Also

BLH Structure


BLH Operators

[image] [image]

A Sandcastle Documented Class Library
BLH Operators
BLH Structure See Also フィードバックの送信

The BLH type exposes the following members.

Operators

Name | Description
Addition |
Subtraction |

See Also

BLH Structure


Addition Operator

[image]

A Sandcastle Documented Class Library
BLH..::..Addition Operator
BLH Structure See Also フィードバックの送信

["M:GPS.BLH.op_Addition(GPS.BLH,GPS.BLH)" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static BLH operator +(
    BLH c1,
    BLH c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As BLH, _
    c2 As BLH _
) As BLH
Visual C++
public:
static BLH operator +(
    BLH c1,
    BLH c2
)

Parameters

c1
Type: GPS..::..BLH

["M:GPS.BLH.op_Addition(GPS.BLH,GPS.BLH)" の為の説明文 <param name="c1"/> が欠落しています。]

c2
Type: GPS..::..BLH

["M:GPS.BLH.op_Addition(GPS.BLH,GPS.BLH)" の為の説明文 <param name="c2"/> が欠落しています。]

Return Value

["M:GPS.BLH.op_Addition(GPS.BLH,GPS.BLH)" の為の説明文 <returns> が欠落しています。]

See Also

BLH Structure


Subtraction Operator

[image]

A Sandcastle Documented Class Library
BLH..::..Subtraction Operator
BLH Structure See Also フィードバックの送信

["M:GPS.BLH.op_Subtraction(GPS.BLH,GPS.BLH)" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static BLH operator -(
    BLH c1,
    BLH c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As BLH, _
    c2 As BLH _
) As BLH
Visual C++
public:
static BLH operator -(
    BLH c1,
    BLH c2
)

Parameters

c1
Type: GPS..::..BLH

["M:GPS.BLH.op_Subtraction(GPS.BLH,GPS.BLH)" の為の説明文 <param name="c1"/> が欠落しています。]

c2
Type: GPS..::..BLH

["M:GPS.BLH.op_Subtraction(GPS.BLH,GPS.BLH)" の為の説明文 <param name="c2"/> が欠落しています。]

Return Value

["M:GPS.BLH.op_Subtraction(GPS.BLH,GPS.BLH)" の為の説明文 <returns> が欠落しています。]

See Also

BLH Structure


BLH Properties

[image] [image]

A Sandcastle Documented Class Library
BLH Properties
BLH Structure See Also フィードバックの送信

The BLH type exposes the following members.

Properties

 | Name | Description
Public property | GetUnitLengthForEN | 楕円体に沿った、東西方向の単位長[m/deg]を返す 実際は高度の分だけ若干の誤差が発生するし、2地点の高度差は考慮しない。 参考：理科年表，p.563，2003． ちなみに、http://yamadarake.web.fc2.com/trdi/2009/report000001.html を見るとヒュベニの公式と言うものであることが分かる
Public property | ToDegree | 単位を度へ変換した物を返す
Public property | ToRadian | 単位をラジアン単位へ変換した物を返す

See Also

BLH Structure


GetUnitLengthForEN Property

[image]

A Sandcastle Documented Class Library
BLH..::..GetUnitLengthForEN Property
BLH Structure See Also フィードバックの送信
楕円体に沿った、東西方向の単位長[m/deg]を返す 実際は高度の分だけ若干の誤差が発生するし、2地点の高度差は考慮しない。 参考：理科年表，p.563，2003． ちなみに、http://yamadarake.web.fc2.com/trdi/2009/report000001.html　を見るとヒュベニの公式と言うものであることが分かる

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public length GetUnitLengthForEN { get; }
Visual Basic
Public ReadOnly Property GetUnitLengthForEN As length
    Get
Visual C++
public:
property length GetUnitLengthForEN {
    length get ();
}

Return Value

See Also

BLH Structure


ToDegree Property

[image]

A Sandcastle Documented Class Library
BLH..::..ToDegree Property
BLH Structure See Also フィードバックの送信
単位を度へ変換した物を返す

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH ToDegree { get; }
Visual Basic
Public ReadOnly Property ToDegree As BLH
    Get
Visual C++
public:
property BLH ToDegree {
    BLH get ();
}

See Also

BLH Structure


ToRadian Property

[image]

A Sandcastle Documented Class Library
BLH..::..ToRadian Property
BLH Structure See Also フィードバックの送信
単位をラジアン単位へ変換した物を返す

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH ToRadian { get; }
Visual Basic
Public ReadOnly Property ToRadian As BLH
    Get
Visual C++
public:
property BLH ToRadian {
    BLH get ();
}

See Also

BLH Structure


BLH.units Enumeration

[image]

A Sandcastle Documented Class Library
BLH..::..units Enumeration
BLH Structure See Also フィードバックの送信

["T:GPS.BLH.units" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum units
Visual Basic
Public Enumeration units
Visual C++
public enum class units

Members

Member name | Value | Description
Degree | 0 |
Radian | 1 |

See Also


length Structure

[image]

A Sandcastle Documented Class Library
length Structure
Members See Also フィードバックの送信
南北、東西方向の距離・長さを収めるための構造体。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public struct length
Visual Basic
<SerializableAttribute> _
Public Structure length
Visual C++
[SerializableAttribute]
public value class length

See Also

length Members


length Members

[image] [image]

A Sandcastle Documented Class Library
length Members
length Structure Constructors Methods Fields See Also フィードバックの送信

The length type exposes the following members.

Constructors

 | Name | Description
Public method | length | 構造体初期化

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Fields

 | Name | Description
Public field | E | 東西方向の長さ
Public field | N | 南北方向の長さ

See Also

length Structure


length Constructor

[image]

A Sandcastle Documented Class Library
length Constructor
length Structure See Also フィードバックの送信
構造体初期化

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public length(
    double _E,
    double _N
)
Visual Basic
Public Sub New ( _
    _E As Double, _
    _N As Double _
)
Visual C++
public:
length(
    double _E,
    double _N
)

Parameters

_E
Type: System..::..Double
経度方向の長さ
_N
Type: System..::..Double
緯度方向の長さ

See Also

length Structure


length Fields

[image] [image]

A Sandcastle Documented Class Library
length Fields
length Structure See Also フィードバックの送信

The length type exposes the following members.

Fields

 | Name | Description
Public field | E | 東西方向の長さ
Public field | N | 南北方向の長さ

See Also

length Structure


E Field

[image]

A Sandcastle Documented Class Library
length..::..E Field
length Structure See Also フィードバックの送信
東西方向の長さ

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double E
Visual Basic
Public E As Double
Visual C++
public:
double E

See Also

length Structure


N Field

[image]

A Sandcastle Documented Class Library
length..::..N Field
length Structure See Also フィードバックの送信
南北方向の長さ

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double N
Visual Basic
Public N As Double
Visual C++
public:
double N

See Also

length Structure


length Methods

[image] [image]

A Sandcastle Documented Class Library
length Methods
length Structure See Also フィードバックの送信

The length type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

length Structure


NMEA Class

[image]

A Sandcastle Documented Class Library
NMEA Class
Members See Also フィードバックの送信
2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる 開発時間を優先した。 今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。 string nmea_str = "$GPGGA,*******"; GPS.NMEA nmea_parser = new GPS.NMEA(); object hoge; hoge = nmea_parser.parse(nmea_str); // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。 if(hoge.GetType() == tyepof(GPS.NMEA)) // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。 { // たとえば、こんな感じか？ int sat = hoge.sat; } NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理） 3)

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class NMEA
Visual Basic
<SerializableAttribute> _
Public Class NMEA
Visual C++
[SerializableAttribute]
public ref class NMEA

Inheritance Hierarchy

System..::..Object
GPS..::..NMEA

See Also

NMEA Members


NMEA Members

[image] [image]

A Sandcastle Documented Class Library
NMEA Members
NMEA Class Constructors Methods Properties See Also フィードバックの送信

The NMEA type exposes the following members.

Constructors

 | Name | Description
Public method | NMEA | NMEA クラスの新しいインスタンスを初期化します。

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetDateTimes | ZDAから時刻データ列のみを取得する GGAのトリガはないのでGetPositioningResults()とは時刻がずれる可能性がある。 日付も考慮してみる。
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetPositioningResults | GPGGAをトリガにして、タイミングごとに測位情報をまとめて配列として返すメソッド NMEAはセンテンスの出力順序を規定していないので、もしかすると時刻と測位位置がずれるかもしれない。
Public method | GetPositions | GGAとZDAから緯度・経度を配列で取得する
Public method | GetTimes | GGAからUTCの秒単位の時刻を配列で得る 日付の経過などは考慮していない。
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Open()()()() | NMEA形式のファイルが格納されたファイルを開いて、処理の準備を行う。 NMEAの処理の仕方はたくさんあるはずなので、オーバーロードを利用してこれから増やす予定。 バイナリ交じりのデータだとstreamがエラーを起こす可能性がある。 その場合はバイナリ読み取り指定が必要。
Public method | Open(String) | ファイル名の指定で開く 開いた後は、メモリ上に全展開
Public method | OpenStream | ストリームを使用したファイルのオープン。 巨大なログファイルを処理する際に使用する。 ストリームを使用した処理に関しては未実装です。
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | IsOpen | バッファ上に読み込み済みならtrueとなる。 2011/7/20 時点では、streamに関しては関知しない。

See Also

NMEA Class


NMEA Constructor

[image]

A Sandcastle Documented Class Library
NMEA Constructor
NMEA Class See Also フィードバックの送信
NMEA クラスの新しいインスタンスを初期化します。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NMEA()
Visual Basic
Public Sub New
Visual C++
public:
NMEA()

See Also

NMEA Class


NMEA Methods

[image] [image]

A Sandcastle Documented Class Library
NMEA Methods
NMEA Class See Also フィードバックの送信

The NMEA type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetDateTimes | ZDAから時刻データ列のみを取得する GGAのトリガはないのでGetPositioningResults()とは時刻がずれる可能性がある。 日付も考慮してみる。
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetPositioningResults | GPGGAをトリガにして、タイミングごとに測位情報をまとめて配列として返すメソッド NMEAはセンテンスの出力順序を規定していないので、もしかすると時刻と測位位置がずれるかもしれない。
Public method | GetPositions | GGAとZDAから緯度・経度を配列で取得する
Public method | GetTimes | GGAからUTCの秒単位の時刻を配列で得る 日付の経過などは考慮していない。
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | Open()()()() | NMEA形式のファイルが格納されたファイルを開いて、処理の準備を行う。 NMEAの処理の仕方はたくさんあるはずなので、オーバーロードを利用してこれから増やす予定。 バイナリ交じりのデータだとstreamがエラーを起こす可能性がある。 その場合はバイナリ読み取り指定が必要。
Public method | Open(String) | ファイル名の指定で開く 開いた後は、メモリ上に全展開
Public method | OpenStream | ストリームを使用したファイルのオープン。 巨大なログファイルを処理する際に使用する。 ストリームを使用した処理に関しては未実装です。
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

NMEA Class


Finalize Method

[image]

A Sandcastle Documented Class Library
NMEA..::..Finalize Method
NMEA Class See Also フィードバックの送信

["M:GPS.NMEA.Finalize" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

NMEA Class


GetDateTimes Method

[image]

A Sandcastle Documented Class Library
NMEA..::..GetDateTimes Method
NMEA Class See Also フィードバックの送信
ZDAから時刻データ列のみを取得する GGAのトリガはないのでGetPositioningResults()とは時刻がずれる可能性がある。 日付も考慮してみる。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime[] GetDateTimes()
Visual Basic
Public Function GetDateTimes As DateTime()
Visual C++
public:
array<DateTime>^ GetDateTimes()

Return Value

["M:GPS.NMEA.GetDateTimes" の為の説明文 <returns> が欠落しています。]

See Also

NMEA Class


GetPositioningResults Method

[image]

A Sandcastle Documented Class Library
NMEA..::..GetPositioningResults Method
NMEA Class See Also フィードバックの送信
GPGGAをトリガにして、タイミングごとに測位情報をまとめて配列として返すメソッド NMEAはセンテンスの出力順序を規定していないので、もしかすると時刻と測位位置がずれるかもしれない。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NMEA..::..PositioningInfos GetPositioningResults()
Visual Basic
Public Function GetPositioningResults As NMEA..::..PositioningInfos
Visual C++
public:
NMEA..::..PositioningInfos^ GetPositioningResults()

Return Value

["M:GPS.NMEA.GetPositioningResults" の為の説明文 <returns> が欠落しています。]

See Also

NMEA Class


GetPositions Method

[image]

A Sandcastle Documented Class Library
NMEA..::..GetPositions Method
NMEA Class See Also フィードバックの送信
GGAとZDAから緯度・経度を配列で取得する

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH[] GetPositions()
Visual Basic
Public Function GetPositions As BLH()
Visual C++
public:
array<BLH>^ GetPositions()

Return Value

["M:GPS.NMEA.GetPositions" の為の説明文 <returns> が欠落しています。]

See Also

NMEA Class


GetTimes Method

[image]

A Sandcastle Documented Class Library
NMEA..::..GetTimes Method
NMEA Class See Also フィードバックの送信
GGAからUTCの秒単位の時刻を配列で得る 日付の経過などは考慮していない。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[] GetTimes()
Visual Basic
Public Function GetTimes As Single()
Visual C++
public:
array<float>^ GetTimes()

Return Value

["M:GPS.NMEA.GetTimes" の為の説明文 <returns> が欠落しています。]

See Also

NMEA Class


Open Method

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..Open Method
NMEA Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | Open()()()() | NMEA形式のファイルが格納されたファイルを開いて、処理の準備を行う。 NMEAの処理の仕方はたくさんあるはずなので、オーバーロードを利用してこれから増やす予定。 バイナリ交じりのデータだとstreamがエラーを起こす可能性がある。 その場合はバイナリ読み取り指定が必要。
Public method | Open(String) | ファイル名の指定で開く 開いた後は、メモリ上に全展開

See Also

NMEA Class
NMEA Members


Open Method

[image]

A Sandcastle Documented Class Library
NMEA..::..Open Method
NMEA Class See Also フィードバックの送信
NMEA形式のファイルが格納されたファイルを開いて、処理の準備を行う。 NMEAの処理の仕方はたくさんあるはずなので、オーバーロードを利用してこれから増やす予定。 バイナリ交じりのデータだとstreamがエラーを起こす可能性がある。 その場合はバイナリ読み取り指定が必要。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Open()
Visual Basic
Public Sub Open
Visual C++
public:
void Open()

See Also

NMEA Class
Open Overload


Open Method (String)

[image]

A Sandcastle Documented Class Library
NMEA..::..Open Method (String)
NMEA Class See Also フィードバックの送信
ファイル名の指定で開く 開いた後は、メモリ上に全展開

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Open(
    string fname
)
Visual Basic
Public Sub Open ( _
    fname As String _
)
Visual C++
public:
void Open(
    String^ fname
)

Parameters

fname
Type: System..::..String

["M:GPS.NMEA.Open(System.String)" の為の説明文 <param name="fname"/> が欠落しています。]

See Also

NMEA Class
Open Overload


OpenStream Method

[image]

A Sandcastle Documented Class Library
NMEA..::..OpenStream Method
NMEA Class See Also フィードバックの送信
ストリームを使用したファイルのオープン。 巨大なログファイルを処理する際に使用する。 ストリームを使用した処理に関しては未実装です。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void OpenStream(
    string fname
)
Visual Basic
Public Sub OpenStream ( _
    fname As String _
)
Visual C++
public:
void OpenStream(
    String^ fname
)

Parameters

fname
Type: System..::..String

["M:GPS.NMEA.OpenStream(System.String)" の為の説明文 <param name="fname"/> が欠落しています。]

See Also

NMEA Class


NMEA Properties

[image] [image]

A Sandcastle Documented Class Library
NMEA Properties
NMEA Class See Also フィードバックの送信

The NMEA type exposes the following members.

Properties

 | Name | Description
Public property | IsOpen | バッファ上に読み込み済みならtrueとなる。 2011/7/20 時点では、streamに関しては関知しない。

See Also

NMEA Class


IsOpen Property

[image]

A Sandcastle Documented Class Library
NMEA..::..IsOpen Property
NMEA Class See Also フィードバックの送信
バッファ上に読み込み済みならtrueとなる。 2011/7/20　時点では、streamに関しては関知しない。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsOpen { get; }
Visual Basic
Public ReadOnly Property IsOpen As Boolean
    Get
Visual C++
public:
property bool IsOpen {
    bool get ();
}

See Also

NMEA Class


NMEA.GGA Class

[image]

A Sandcastle Documented Class Library
NMEA..::..GGA Class
NMEA Class Members See Also フィードバックの送信

["T:GPS.NMEA.GGA" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GGA
Visual Basic
Public Class GGA
Visual C++
public ref class GGA

Inheritance Hierarchy

System..::..Object
GPS..::..NMEA..::..GGA

See Also

NMEA..::..GGA Members


NMEA.GGA Members

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..GGA Members
NMEA..::..GGA Class Constructors Methods See Also フィードバックの送信

2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる 開発時間を優先した。 今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。 string nmea_str = "$GPGGA,*******"; GPS.NMEA nmea_parser = new GPS.NMEA(); object hoge; hoge = nmea_parser.parse(nmea_str); // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。 if(hoge.GetType() == tyepof(GPS.NMEA)) // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。 { // たとえば、こんな感じか？ int sat = hoge.sat; } NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理） 3)

The NMEA..::..GGA type exposes the following members.

Constructors

 | Name | Description
Public method | NMEA..::..GGA | NMEA..::..GGA クラスの新しいインスタンスを初期化します。

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

NMEA..::..GGA Class


NMEA.GGA Constructor

[image]

A Sandcastle Documented Class Library
NMEA..::..GGA Constructor
NMEA..::..GGA Class See Also フィードバックの送信
NMEA..::..GGA クラスの新しいインスタンスを初期化します。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GGA()
Visual Basic
Public Sub New
Visual C++
public:
GGA()

See Also

NMEA..::..GGA Class


NMEA.GGA Methods

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..GGA Methods
NMEA..::..GGA Class See Also フィードバックの送信

The NMEA..::..GGA type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

NMEA..::..GGA Class


Finalize Method

[image]

A Sandcastle Documented Class Library
NMEA..::..GGA..::..Finalize Method
NMEA..::..GGA Class See Also フィードバックの送信

["M:GPS.NMEA.GGA.Finalize" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

NMEA..::..GGA Class


NMEA.PositioningInfo Class

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo Class
NMEA Class Members See Also フィードバックの送信
観測データを取り扱うクラス 構造体にしないのは、構造体だと初期化を必ず求められるため。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class PositioningInfo
Visual Basic
<SerializableAttribute> _
Public Class PositioningInfo
Visual C++
[SerializableAttribute]
public ref class PositioningInfo

Inheritance Hierarchy

System..::..Object
GPS..::..NMEA..::..PositioningInfo

See Also

NMEA..::..PositioningInfo Members


NMEA.PositioningInfo Members

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo Members
NMEA..::..PositioningInfo Class Constructors Methods Fields See Also フィードバックの送信

2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる 開発時間を優先した。 今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。 string nmea_str = "$GPGGA,*******"; GPS.NMEA nmea_parser = new GPS.NMEA(); object hoge; hoge = nmea_parser.parse(nmea_str); // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。 if(hoge.GetType() == tyepof(GPS.NMEA)) // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。 { // たとえば、こんな感じか？ int sat = hoge.sat; } NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理） 3)

The NMEA..::..PositioningInfo type exposes the following members.

Constructors

 | Name | Description
Public method | NMEA..::..PositioningInfo | NMEA..::..PositioningInfo クラスの新しいインスタンスを初期化します。

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | position |
Public field | time |

See Also

NMEA..::..PositioningInfo Class


NMEA.PositioningInfo Constructor

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo Constructor
NMEA..::..PositioningInfo Class See Also フィードバックの送信
NMEA..::..PositioningInfo クラスの新しいインスタンスを初期化します。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PositioningInfo()
Visual Basic
Public Sub New
Visual C++
public:
PositioningInfo()

See Also

NMEA..::..PositioningInfo Class


NMEA.PositioningInfo Fields

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo Fields
NMEA..::..PositioningInfo Class See Also フィードバックの送信

The NMEA..::..PositioningInfo type exposes the following members.

Fields

 | Name | Description
Public field | position |
Public field | time |

See Also

NMEA..::..PositioningInfo Class


position Field

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo..::..position Field
NMEA..::..PositioningInfo Class See Also フィードバックの送信

["F:GPS.NMEA.PositioningInfo.position" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH position
Visual Basic
Public position As BLH
Visual C++
public:
BLH position

See Also

NMEA..::..PositioningInfo Class


time Field

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo..::..time Field
NMEA..::..PositioningInfo Class See Also フィードバックの送信

["F:GPS.NMEA.PositioningInfo.time" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime time
Visual Basic
Public time As DateTime
Visual C++
public:
DateTime time

See Also

NMEA..::..PositioningInfo Class


NMEA.PositioningInfo Methods

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo Methods
NMEA..::..PositioningInfo Class See Also フィードバックの送信

The NMEA..::..PositioningInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

NMEA..::..PositioningInfo Class


Finalize Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfo..::..Finalize Method
NMEA..::..PositioningInfo Class See Also フィードバックの送信

["M:GPS.NMEA.PositioningInfo.Finalize" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

NMEA..::..PositioningInfo Class


NMEA.PositioningInfos Class

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos Class
NMEA Class Members See Also フィードバックの送信
測位情報を配列をして格納

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class PositioningInfos
Visual Basic
<SerializableAttribute> _
Public Class PositioningInfos
Visual C++
[SerializableAttribute]
public ref class PositioningInfos

Inheritance Hierarchy

System..::..Object
GPS..::..NMEA..::..PositioningInfos

See Also

NMEA..::..PositioningInfos Members


NMEA.PositioningInfos Members

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos Members
NMEA..::..PositioningInfos Class Constructors Methods Fields See Also フィードバックの送信

2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる 開発時間を優先した。 今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。 string nmea_str = "$GPGGA,*******"; GPS.NMEA nmea_parser = new GPS.NMEA(); object hoge; hoge = nmea_parser.parse(nmea_str); // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。 if(hoge.GetType() == tyepof(GPS.NMEA)) // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。 { // たとえば、こんな感じか？ int sat = hoge.sat; } NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理） 3)

The NMEA..::..PositioningInfos type exposes the following members.

Constructors

 | Name | Description
Public method | NMEA..::..PositioningInfos | NMEA..::..PositioningInfos クラスの新しいインスタンスを初期化します。

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetPositions | 測位点情報をコピーする専用メソッド
Public method | GetRectangleField | 経路を全操作し、2つ以上のフィールドがあれば領域の右上・左下の座標のセットを返す
Public method | GetTimes | 時刻情報をコピーしてくれる専用メソッド
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | SaveFileAsNormal | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | ToString | データ内容をstring型にして返す データには、時刻・経度・緯度・高度が含まれます。 (Overrides Object..::..ToString()()()().)

Fields

 | Name | Description
Public field | data |

See Also

NMEA..::..PositioningInfos Class


NMEA.PositioningInfos Constructor

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos Constructor
NMEA..::..PositioningInfos Class See Also フィードバックの送信
NMEA..::..PositioningInfos クラスの新しいインスタンスを初期化します。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PositioningInfos()
Visual Basic
Public Sub New
Visual C++
public:
PositioningInfos()

See Also

NMEA..::..PositioningInfos Class


NMEA.PositioningInfos Fields

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos Fields
NMEA..::..PositioningInfos Class See Also フィードバックの送信

The NMEA..::..PositioningInfos type exposes the following members.

Fields

 | Name | Description
Public field | data |

See Also

NMEA..::..PositioningInfos Class


data Field

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..data Field
NMEA..::..PositioningInfos Class See Also フィードバックの送信

["F:GPS.NMEA.PositioningInfos.data" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NMEA..::..PositioningInfo[] data
Visual Basic
Public data As NMEA..::..PositioningInfo()
Visual C++
public:
array<NMEA..::..PositioningInfo^>^ data

See Also

NMEA..::..PositioningInfos Class


NMEA.PositioningInfos Methods

[image] [image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos Methods
NMEA..::..PositioningInfos Class See Also フィードバックの送信

The NMEA..::..PositioningInfos type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetPositions | 測位点情報をコピーする専用メソッド
Public method | GetRectangleField | 経路を全操作し、2つ以上のフィールドがあれば領域の右上・左下の座標のセットを返す
Public method | GetTimes | 時刻情報をコピーしてくれる専用メソッド
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | SaveFileAsNormal | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | ToString | データ内容をstring型にして返す データには、時刻・経度・緯度・高度が含まれます。 (Overrides Object..::..ToString()()()().)

See Also

NMEA..::..PositioningInfos Class


Finalize Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..Finalize Method
NMEA..::..PositioningInfos Class See Also フィードバックの送信

["M:GPS.NMEA.PositioningInfos.Finalize" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

NMEA..::..PositioningInfos Class


GetPositions Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..GetPositions Method
NMEA..::..PositioningInfos Class See Also フィードバックの送信
測位点情報をコピーする専用メソッド

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH[] GetPositions()
Visual Basic
Public Function GetPositions As BLH()
Visual C++
public:
array<BLH>^ GetPositions()

Return Value

["M:GPS.NMEA.PositioningInfos.GetPositions" の為の説明文 <returns> が欠落しています。]

See Also

NMEA..::..PositioningInfos Class


GetRectangleField Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..GetRectangleField Method
NMEA..::..PositioningInfos Class See Also フィードバックの送信
経路を全操作し、2つ以上のフィールドがあれば領域の右上・左下の座標のセットを返す

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public rectangleField GetRectangleField()
Visual Basic
Public Function GetRectangleField As rectangleField
Visual C++
public:
rectangleField^ GetRectangleField()

Return Value

領域またはnull

See Also

NMEA..::..PositioningInfos Class


GetTimes Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..GetTimes Method
NMEA..::..PositioningInfos Class See Also フィードバックの送信
時刻情報をコピーしてくれる専用メソッド

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime[] GetTimes()
Visual Basic
Public Function GetTimes As DateTime()
Visual C++
public:
array<DateTime>^ GetTimes()

Return Value

["M:GPS.NMEA.PositioningInfos.GetTimes" の為の説明文 <returns> が欠落しています。]

See Also

NMEA..::..PositioningInfos Class


SaveFileAsNormal Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..SaveFileAsNormal Method
NMEA..::..PositioningInfos Class See Also フィードバックの送信
指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveFileAsNormal(
    string fname
)
Visual Basic
Public Sub SaveFileAsNormal ( _
    fname As String _
)
Visual C++
public:
void SaveFileAsNormal(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

NMEA..::..PositioningInfos Class


ToString Method

[image]

A Sandcastle Documented Class Library
NMEA..::..PositioningInfos..::..ToString Method
NMEA..::..PositioningInfos Class See Also フィードバックの送信
データ内容をstring型にして返す データには、時刻・経度・緯度・高度が含まれます。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

["M:GPS.NMEA.PositioningInfos.ToString" の為の説明文 <returns> が欠落しています。]

See Also

NMEA..::..PositioningInfos Class


rectangleField Class

[image]

A Sandcastle Documented Class Library
rectangleField Class
Members See Also フィードバックの送信
2点で張られる長方形領域を緯度・経度で表すクラス たとえば、GPSのログ領域の広さやマップの広さを表すことができる。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public class rectangleField
Visual Basic
<SerializableAttribute> _
Public Class rectangleField
Visual C++
[SerializableAttribute]
public ref class rectangleField

Inheritance Hierarchy

System..::..Object
GPS..::..rectangleField

See Also

rectangleField Members


rectangleField Members

[image] [image]

A Sandcastle Documented Class Library
rectangleField Members
rectangleField Class Constructors Methods Fields See Also フィードバックの送信

The rectangleField type exposes the following members.

Constructors

 | Name | Description
Public method | rectangleField()()()() | 引数省略時のコンストラクタ
Public method | rectangleField(BLH, BLH) | コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | lowerLeft | 左下の座標
Public field | upperRight | 右上の座標

See Also

rectangleField Class


rectangleField Constructor

[image] [image]

A Sandcastle Documented Class Library
rectangleField Constructor
rectangleField Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | rectangleField()()()() | 引数省略時のコンストラクタ
Public method | rectangleField(BLH, BLH) | コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。

See Also

rectangleField Class
rectangleField Members


rectangleField Constructor

[image]

A Sandcastle Documented Class Library
rectangleField Constructor
rectangleField Class See Also フィードバックの送信
引数省略時のコンストラクタ

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public rectangleField()
Visual Basic
Public Sub New
Visual C++
public:
rectangleField()

See Also

rectangleField Class
rectangleField Overload


rectangleField Constructor (BLH, BLH)

[image]

A Sandcastle Documented Class Library
rectangleField Constructor (BLH, BLH)
rectangleField Class See Also フィードバックの送信
コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public rectangleField(
    BLH x1,
    BLH x2
)
Visual Basic
Public Sub New ( _
    x1 As BLH, _
    x2 As BLH _
)
Visual C++
public:
rectangleField(
    BLH x1,
    BLH x2
)

Parameters

x1
Type: GPS..::..BLH
座標1
x2
Type: GPS..::..BLH
座標2

See Also

rectangleField Class
rectangleField Overload


rectangleField Fields

[image] [image]

A Sandcastle Documented Class Library
rectangleField Fields
rectangleField Class See Also フィードバックの送信

The rectangleField type exposes the following members.

Fields

 | Name | Description
Public field | lowerLeft | 左下の座標
Public field | upperRight | 右上の座標

See Also

rectangleField Class


lowerLeft Field

[image]

A Sandcastle Documented Class Library
rectangleField..::..lowerLeft Field
rectangleField Class See Also フィードバックの送信
左下の座標

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH lowerLeft
Visual Basic
Public lowerLeft As BLH
Visual C++
public:
BLH lowerLeft

See Also

rectangleField Class


upperRight Field

[image]

A Sandcastle Documented Class Library
rectangleField..::..upperRight Field
rectangleField Class See Also フィードバックの送信
右上の座標

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH upperRight
Visual Basic
Public upperRight As BLH
Visual C++
public:
BLH upperRight

See Also

rectangleField Class


rectangleField Methods

[image] [image]

A Sandcastle Documented Class Library
rectangleField Methods
rectangleField Class See Also フィードバックの送信

The rectangleField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

rectangleField Class


WGS84 Class

[image]

A Sandcastle Documented Class Library
WGS84 Class
Members See Also フィードバックの送信
WGS84座標系における各種パラメータ 参考：西修二郎訳，GNSSのすべて，p.265，2010.2．

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public static class WGS84
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class WGS84
Visual C++
[SerializableAttribute]
public ref class WGS84 abstract sealed

Inheritance Hierarchy

System..::..Object
GPS..::..WGS84

See Also

WGS84 Members


WGS84 Members

[image] [image]

A Sandcastle Documented Class Library
WGS84 Members
WGS84 Class Fields Properties See Also フィードバックの送信

The WGS84 type exposes the following members.

Fields

Name | Description
a | Equatorial Radius 赤道半径（楕円体長半径）[m]
b | Short Radius 短半径
c |
e2 | Square Eccentricity 離心率^2
f | 扁平率
invers_oblateness | 扁平率の逆数
PI |
u | Gravitational Constant of The Earth 地球重力定数[m^3/s^-2]
wE | Angular Velocity of The Earth 地球の角速度[rad/sec]

Properties

Name | Description
e | Eccentricity 離心率

See Also

WGS84 Class


WGS84 Fields

[image] [image]

A Sandcastle Documented Class Library
WGS84 Fields
WGS84 Class See Also フィードバックの送信

The WGS84 type exposes the following members.

Fields

Name | Description
a | Equatorial Radius 赤道半径（楕円体長半径）[m]
b | Short Radius 短半径
c |
e2 | Square Eccentricity 離心率^2
f | 扁平率
invers_oblateness | 扁平率の逆数
PI |
u | Gravitational Constant of The Earth 地球重力定数[m^3/s^-2]
wE | Angular Velocity of The Earth 地球の角速度[rad/sec]

See Also

WGS84 Class


a Field

[image]

A Sandcastle Documented Class Library
WGS84..::..a Field
WGS84 Class See Also フィードバックの送信
Equatorial Radius 赤道半径（楕円体長半径）[m]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double a
Visual Basic
Public Const a As Double
Visual C++
public:
literal double a

See Also

WGS84 Class


b Field

[image]

A Sandcastle Documented Class Library
WGS84..::..b Field
WGS84 Class See Also フィードバックの送信
Short Radius 短半径

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double b
Visual Basic
Public Const b As Double
Visual C++
public:
literal double b

See Also

WGS84 Class


c Field

[image]

A Sandcastle Documented Class Library
WGS84..::..c Field
WGS84 Class See Also フィードバックの送信

["F:GPS.WGS84.c" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double c
Visual Basic
Public Const c As Double
Visual C++
public:
literal double c

See Also

WGS84 Class


e2 Field

[image]

A Sandcastle Documented Class Library
WGS84..::..e2 Field
WGS84 Class See Also フィードバックの送信
Square Eccentricity 離心率^2

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double e2
Visual Basic
Public Const e2 As Double
Visual C++
public:
literal double e2

See Also

WGS84 Class


f Field

[image]

A Sandcastle Documented Class Library
WGS84..::..f Field
WGS84 Class See Also フィードバックの送信
扁平率

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double f
Visual Basic
Public Const f As Double
Visual C++
public:
literal double f

See Also

WGS84 Class


invers_oblateness Field

[image]

A Sandcastle Documented Class Library
WGS84..::..invers_oblateness Field
WGS84 Class See Also フィードバックの送信
扁平率の逆数

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double invers_oblateness
Visual Basic
Public Const invers_oblateness As Double
Visual C++
public:
literal double invers_oblateness

See Also

WGS84 Class


PI Field

[image]

A Sandcastle Documented Class Library
WGS84..::..PI Field
WGS84 Class See Also フィードバックの送信

["F:GPS.WGS84.PI" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double PI
Visual Basic
Public Const PI As Double
Visual C++
public:
literal double PI

See Also

WGS84 Class


u Field

[image]

A Sandcastle Documented Class Library
WGS84..::..u Field
WGS84 Class See Also フィードバックの送信
Gravitational Constant of The Earth 地球重力定数[m^3/s^-2]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double u
Visual Basic
Public Const u As Double
Visual C++
public:
literal double u

See Also

WGS84 Class


wE Field

[image]

A Sandcastle Documented Class Library
WGS84..::..wE Field
WGS84 Class See Also フィードバックの送信
Angular Velocity of The Earth 地球の角速度[rad/sec]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double wE
Visual Basic
Public Const wE As Double
Visual C++
public:
literal double wE

See Also

WGS84 Class


WGS84 Properties

[image] [image]

A Sandcastle Documented Class Library
WGS84 Properties
WGS84 Class See Also フィードバックの送信

The WGS84 type exposes the following members.

Properties

Name | Description
e | Eccentricity 離心率

See Also

WGS84 Class


e Property

[image]

A Sandcastle Documented Class Library
WGS84..::..e Property
WGS84 Class See Also フィードバックの送信
Eccentricity 離心率

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double e { get; }
Visual Basic
Public Shared ReadOnly Property e As Double
    Get
Visual C++
public:
static property double e {
    double get ();
}

See Also

WGS84 Class


XYZ Structure

[image]

A Sandcastle Documented Class Library
XYZ Structure
Members See Also フィードバックの送信
x,y,zを格納する構造体 半径の取得も簡単 BLH座標系（緯度・経度・楕円体高[m]）への変換も簡単

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public struct XYZ
Visual Basic
<SerializableAttribute> _
Public Structure XYZ
Visual C++
[SerializableAttribute]
public value class XYZ

See Also

XYZ Members


XYZ Members

[image] [image]

A Sandcastle Documented Class Library
XYZ Members
XYZ Structure Constructors Methods Operators Fields Properties See Also フィードバックの送信

The XYZ type exposes the following members.

Constructors

 | Name | Description
Public method | XYZ | コンストラクタ

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToBLH | XYZからBLH座標系（緯度・経度・楕円体高[m]）へ変換
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

Operators

Name | Description
Addition |
Subtraction |

Fields

 | Name | Description
Public field | x |
Public field | y |
Public field | z |

Properties

 | Name | Description
Public property | r | 半径（地心からの距離）をプロパティとして提供（呼び出すたびに計算する）

See Also

XYZ Structure


XYZ Constructor

[image]

A Sandcastle Documented Class Library
XYZ Constructor
XYZ Structure See Also フィードバックの送信
コンストラクタ

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XYZ(
    double _x,
    double _y,
    double _z
)
Visual Basic
Public Sub New ( _
    _x As Double, _
    _y As Double, _
    _z As Double _
)
Visual C++
public:
XYZ(
    double _x,
    double _y,
    double _z
)

Parameters

_x
Type: System..::..Double

["M:GPS.XYZ.#ctor(System.Double,System.Double,System.Double)" の為の説明文 <param name="_x"/> が欠落しています。]

_y
Type: System..::..Double

["M:GPS.XYZ.#ctor(System.Double,System.Double,System.Double)" の為の説明文 <param name="_y"/> が欠落しています。]

_z
Type: System..::..Double

["M:GPS.XYZ.#ctor(System.Double,System.Double,System.Double)" の為の説明文 <param name="_z"/> が欠落しています。]

See Also

XYZ Structure


XYZ Fields

[image] [image]

A Sandcastle Documented Class Library
XYZ Fields
XYZ Structure See Also フィードバックの送信

The XYZ type exposes the following members.

Fields

 | Name | Description
Public field | x |
Public field | y |
Public field | z |

See Also

XYZ Structure


x Field

[image]

A Sandcastle Documented Class Library
XYZ..::..x Field
XYZ Structure See Also フィードバックの送信

["F:GPS.XYZ.x" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double x
Visual Basic
Public x As Double
Visual C++
public:
double x

See Also

XYZ Structure


y Field

[image]

A Sandcastle Documented Class Library
XYZ..::..y Field
XYZ Structure See Also フィードバックの送信

["F:GPS.XYZ.y" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double y
Visual Basic
Public y As Double
Visual C++
public:
double y

See Also

XYZ Structure


z Field

[image]

A Sandcastle Documented Class Library
XYZ..::..z Field
XYZ Structure See Also フィードバックの送信

["F:GPS.XYZ.z" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double z
Visual Basic
Public z As Double
Visual C++
public:
double z

See Also

XYZ Structure


XYZ Methods

[image] [image]

A Sandcastle Documented Class Library
XYZ Methods
XYZ Structure See Also フィードバックの送信

The XYZ type exposes the following members.

Methods

 | Name | Description
Public method | Equals | このインスタンスと指定したオブジェクトが等しいかどうかを示します。 (Inherited from ValueType.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | このインスタンスのハッシュ コードを返します。 (Inherited from ValueType.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToBLH | XYZからBLH座標系（緯度・経度・楕円体高[m]）へ変換
Public method | ToString | このインスタンスの完全修飾型名を返します。 (Inherited from ValueType.)

See Also

XYZ Structure


ToBLH Method

[image]

A Sandcastle Documented Class Library
XYZ..::..ToBLH Method
XYZ Structure See Also フィードバックの送信
XYZからBLH座標系（緯度・経度・楕円体高[m]）へ変換

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH ToBLH()
Visual Basic
Public Function ToBLH As BLH
Visual C++
public:
BLH ToBLH()

Return Value

BLHに変換した結果

See Also

XYZ Structure


XYZ Operators

[image] [image]

A Sandcastle Documented Class Library
XYZ Operators
XYZ Structure See Also フィードバックの送信

The XYZ type exposes the following members.

Operators

Name | Description
Addition |
Subtraction |

See Also

XYZ Structure


Addition Operator

[image]

A Sandcastle Documented Class Library
XYZ..::..Addition Operator
XYZ Structure See Also フィードバックの送信

["M:GPS.XYZ.op_Addition(GPS.XYZ,GPS.XYZ)" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static XYZ operator +(
    XYZ c1,
    XYZ c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As XYZ, _
    c2 As XYZ _
) As XYZ
Visual C++
public:
static XYZ operator +(
    XYZ c1,
    XYZ c2
)

Parameters

c1
Type: GPS..::..XYZ

["M:GPS.XYZ.op_Addition(GPS.XYZ,GPS.XYZ)" の為の説明文 <param name="c1"/> が欠落しています。]

c2
Type: GPS..::..XYZ

["M:GPS.XYZ.op_Addition(GPS.XYZ,GPS.XYZ)" の為の説明文 <param name="c2"/> が欠落しています。]

Return Value

["M:GPS.XYZ.op_Addition(GPS.XYZ,GPS.XYZ)" の為の説明文 <returns> が欠落しています。]

See Also

XYZ Structure


Subtraction Operator

[image]

A Sandcastle Documented Class Library
XYZ..::..Subtraction Operator
XYZ Structure See Also フィードバックの送信

["M:GPS.XYZ.op_Subtraction(GPS.XYZ,GPS.XYZ)" の為の説明文 <summary> が欠落しています。]

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static XYZ operator -(
    XYZ c1,
    XYZ c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As XYZ, _
    c2 As XYZ _
) As XYZ
Visual C++
public:
static XYZ operator -(
    XYZ c1,
    XYZ c2
)

Parameters

c1
Type: GPS..::..XYZ

["M:GPS.XYZ.op_Subtraction(GPS.XYZ,GPS.XYZ)" の為の説明文 <param name="c1"/> が欠落しています。]

c2
Type: GPS..::..XYZ

["M:GPS.XYZ.op_Subtraction(GPS.XYZ,GPS.XYZ)" の為の説明文 <param name="c2"/> が欠落しています。]

Return Value

["M:GPS.XYZ.op_Subtraction(GPS.XYZ,GPS.XYZ)" の為の説明文 <returns> が欠落しています。]

See Also

XYZ Structure


XYZ Properties

[image] [image]

A Sandcastle Documented Class Library
XYZ Properties
XYZ Structure See Also フィードバックの送信

The XYZ type exposes the following members.

Properties

 | Name | Description
Public property | r | 半径（地心からの距離）をプロパティとして提供（呼び出すたびに計算する）

See Also

XYZ Structure


r Property

[image]

A Sandcastle Documented Class Library
XYZ..::..r Property
XYZ Structure See Also フィードバックの送信
半径（地心からの距離）をプロパティとして提供（呼び出すたびに計算する）

Namespace: GPS
Assembly: HeightBased2route (HeightBased2route.exe 内) バージョン: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double r { get; }
Visual Basic
Public ReadOnly Property r As Double
    Get
Visual C++
public:
property double r {
    double get ();
}

See Also

XYZ Structure