GNSS Namespace

[image]

A Sandcastle Documented Class Library
GNSS Namespace
Send Feedback

[Missing <summary> documentation for "N:GNSS"]

Classes

 | Class | Description
Public class | GnssTest | GNSS名前空間に属するクラス群をテストする静的クラス

Structures

 | Structure | Description
Public structure | BLH | 緯度・経度・楕円体高を表す構造体 語源はドイツ語らしい。 座標変換処理等を実装する必要もあるが、現時点ではWGS84専用となっている。
Public structure | Length | 南北、東西方向の距離・長さを収めるための構造体
Public structure | XYZ | x,y,zを格納する構造体 半径の取得も簡単 BLH座標系（緯度・経度・楕円体高[m]）への変換も簡単 座標変換処理等を実装する必要もあるのだろうけど、現時点ではWGS84専用となっている。

Enumerations

 | Enumeration | Description
Public enumeration | AngleUnit | 角度の単位


AngleUnit Enumeration

[image]

A Sandcastle Documented Class Library
AngleUnit Enumeration
See Also Send Feedback
角度の単位

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum AngleUnit
Visual Basic
Public Enumeration AngleUnit
Visual C++
public enum class AngleUnit

Members

Member name | Value | Description
Degree | 0 | 度
Radian | 1 | ラジアン

See Also

GNSS Namespace


BLH Structure

[image]

A Sandcastle Documented Class Library
BLH Structure
Members See Also Send Feedback
緯度・経度・楕円体高を表す構造体

語源はドイツ語らしい。

座標変換処理等を実装する必要もあるが、現時点ではWGS84専用となっている。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public struct BLH
Visual Basic
Public Structure BLH
Visual C++
public value class BLH

See Also

BLH Members
GNSS Namespace


BLH Members

[image] [image]

A Sandcastle Documented Class Library
BLH Members
BLH Structure Constructors Methods Operators Properties See Also Send Feedback

The BLH type exposes the following members.

Constructors

 | Name | Description
Public method | BLH | BLHのコンストラクタ 引数は省略も可能です。

Methods

 | Name | Description
Public method | Equals | objと自分自身が等価のときはtrueを返す (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | 引数で渡された座標までの距離を返す 簡易計算なので、距離が数十km以下で有効です。 最短距離を求めているわけではないことに注意してください。
Public method | GetDistance2 | 簡易な距離演算その2 精度は、近距離では（少なくとも20km程度）その1の方法と大して変わらない。 参考：http://homepage3.nifty.com/kubota01/distance.htm 距離が50kmを超えるようなら、こちらのメソッドの方が実際の距離を表すと思う。 [2011/7/18 追記] 現時点ではXYZの直交座標系への変換精度が悪く、極近距離で精度が出ない。
Public method | GetDistance3 | GetDistanceを利用して、直線距離を求めるメソッド
Public method | GetHashCode | ハッシュ値を返す (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetMedian | 2地点間の中間座標を返す （現時点では）メルカトル図法上の中間点を算出します。従って極点をまたがるような2点間の中点を求める用途には向いていません。 また、2地点間の中間地点は地球上に2点取り得ますが、2点間を結ぶ距離が短くなる方を採用しています。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitLengthForEN | 楕円体に沿った、東西方向の単位長[m/deg]を返す 実際は高度の分だけ若干の誤差が発生するし、2地点の高度差は考慮しない。 参考：理科年表，p.563，2003． ちなみに、http://yamadarake.web.fc2.com/trdi/2009/report000001.html を見ると使用した公式がヒュベニの公式と言うものであることが分かる
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDegree | 単位を度へ変換したオブジェクトを返す
Public method | ToRadian | 単位をラジアン単位へ変換したオブジェクトを返す
Public method | ToString | 緯度・経度・楕円体高の文字列化 Excelに合わせて、経度から先に出力する。 (Overrides ValueType..::..ToString()()()().)
Public method | ToXYZ()()()() | XYZ座標系へ変換したオブジェクトを返す 引数を省略できます。変換後の測地系は本オブジェクトの測地系と同じになります。 ToXYZ(Datum nextDatum)を利用して値を返します。
Public method | ToXYZ(Datum) | XYZ座標系へ変換したオブジェクトを返す 参考：理科年表，p.563，2003． [2011/7/18 追記]計算精度が悪い気がしてならん。

Operators

Name | Description
Addition | 二項+演算子（これで足し算が簡単にできる） 単位はdegreeとなる
Equality | 比較演算子== 単位及び測地系の設定も含めて一致しなければtrueとはしません。
Inequality | 比較演算子!=
Subtraction | 二項-演算子（これで引き算が簡単にできる） 単位はdegreeとなる

Properties

 | Name | Description
Public property | B | 緯度 緯度は-90～90 degの範囲に丸められます。 もしセットした値の絶対値が90°を超えている場合、極の向こう側へ移動したとみなして経度が自動的に半周します。
Public property | DatumKind | 測地系 測地系の変更に対しての処理は未実装
Public property | H | 楕円体高 楕円体表面からの鉛直距離
Public property | Healthy | 本オブジェクトの状態を表す true: 正常, 利用可能
Public property | L | 経度 経度は-180～180 degの範囲に丸められます。
Public property | Unit | 演算単位 deg or radian

See Also

BLH Structure
GNSS Namespace


BLH Constructor

[image]

A Sandcastle Documented Class Library
BLH Constructor
BLH Structure See Also Send Feedback
BLHのコンストラクタ

引数は省略も可能です。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH(
    double B,
    double L,
    double H,
    AngleUnit unit,
    Datum datum
)
Visual Basic
Public Sub New ( _
    B As Double, _
    L As Double, _
    H As Double, _
    unit As AngleUnit, _
    datum As Datum _
)
Visual C++
public:
BLH(
    double B,
    double L,
    double H,
    AngleUnit unit,
    Datum datum
)

Parameters

B
Type: System..::..Double
緯度: Latitude
L
Type: System..::..Double
経度: Longitude
H
Type: System..::..Double
高度: Ellipsoidal altitude
unit
Type: GNSS..::..AngleUnit
単位(°or rad)
datum
Type: GNSS.GeodeticDatum..::..Datum
測地系

省略するとWGS84となる。

See Also

BLH Structure
GNSS Namespace


BLH Methods

[image] [image]

A Sandcastle Documented Class Library
BLH Methods
BLH Structure See Also Send Feedback

The BLH type exposes the following members.

Methods

 | Name | Description
Public method | Equals | objと自分自身が等価のときはtrueを返す (Overrides ValueType..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDistance | 引数で渡された座標までの距離を返す 簡易計算なので、距離が数十km以下で有効です。 最短距離を求めているわけではないことに注意してください。
Public method | GetDistance2 | 簡易な距離演算その2 精度は、近距離では（少なくとも20km程度）その1の方法と大して変わらない。 参考：http://homepage3.nifty.com/kubota01/distance.htm 距離が50kmを超えるようなら、こちらのメソッドの方が実際の距離を表すと思う。 [2011/7/18 追記] 現時点ではXYZの直交座標系への変換精度が悪く、極近距離で精度が出ない。
Public method | GetDistance3 | GetDistanceを利用して、直線距離を求めるメソッド
Public method | GetHashCode | ハッシュ値を返す (Overrides ValueType..::..GetHashCode()()()().)
Public method | GetMedian | 2地点間の中間座標を返す （現時点では）メルカトル図法上の中間点を算出します。従って極点をまたがるような2点間の中点を求める用途には向いていません。 また、2地点間の中間地点は地球上に2点取り得ますが、2点間を結ぶ距離が短くなる方を採用しています。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnitLengthForEN | 楕円体に沿った、東西方向の単位長[m/deg]を返す 実際は高度の分だけ若干の誤差が発生するし、2地点の高度差は考慮しない。 参考：理科年表，p.563，2003． ちなみに、http://yamadarake.web.fc2.com/trdi/2009/report000001.html を見ると使用した公式がヒュベニの公式と言うものであることが分かる
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDegree | 単位を度へ変換したオブジェクトを返す
Public method | ToRadian | 単位をラジアン単位へ変換したオブジェクトを返す
Public method | ToString | 緯度・経度・楕円体高の文字列化 Excelに合わせて、経度から先に出力する。 (Overrides ValueType..::..ToString()()()().)
Public method | ToXYZ()()()() | XYZ座標系へ変換したオブジェクトを返す 引数を省略できます。変換後の測地系は本オブジェクトの測地系と同じになります。 ToXYZ(Datum nextDatum)を利用して値を返します。
Public method | ToXYZ(Datum) | XYZ座標系へ変換したオブジェクトを返す 参考：理科年表，p.563，2003． [2011/7/18 追記]計算精度が悪い気がしてならん。

See Also

BLH Structure
GNSS Namespace


Equals Method

[image]

A Sandcastle Documented Class Library
BLH..::..Equals Method
BLH Structure See Also Send Feedback
objと自分自身が等価のときはtrueを返す

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object
比較したいオブジェクト

Return Value

等価であればtrue

See Also

BLH Structure
GNSS Namespace


GetDistance Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetDistance Method
BLH Structure See Also Send Feedback
引数で渡された座標までの距離を返す

簡易計算なので、距離が数十km以下で有効です。

最短距離を求めているわけではないことに注意してください。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Length GetDistance(
    BLH pos
)
Visual Basic
Public Function GetDistance ( _
    pos As BLH _
) As Length
Visual C++
public:
Length GetDistance(
    BLH pos
)

Parameters

pos
Type: GNSS..::..BLH
求めたい地点の座標

Return Value

南北・東西方向の距離[m]を構造体で返す

See Also

BLH Structure
GNSS Namespace


GetDistance2 Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetDistance2 Method
BLH Structure See Also Send Feedback
簡易な距離演算その2

精度は、近距離では（少なくとも20km程度）その1の方法と大して変わらない。 参考：http://homepage3.nifty.com/kubota01/distance.htm 距離が50kmを超えるようなら、こちらのメソッドの方が実際の距離を表すと思う。 [2011/7/18　追記] 現時点ではXYZの直交座標系への変換精度が悪く、極近距離で精度が出ない。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetDistance2(
    BLH pos
)
Visual Basic
Public Function GetDistance2 ( _
    pos As BLH _
) As Double
Visual C++
public:
double GetDistance2(
    BLH pos
)

Parameters

pos
Type: GNSS..::..BLH
求めたい地点の座標

Return Value

距離

See Also

BLH Structure
GNSS Namespace


GetDistance3 Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetDistance3 Method
BLH Structure See Also Send Feedback
GetDistanceを利用して、直線距離を求めるメソッド

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double GetDistance3(
    BLH pos
)
Visual Basic
Public Function GetDistance3 ( _
    pos As BLH _
) As Double
Visual C++
public:
double GetDistance3(
    BLH pos
)

Parameters

pos
Type: GNSS..::..BLH
求めたい地点の座標

Return Value

距離

See Also

BLH Structure
GNSS Namespace


GetHashCode Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetHashCode Method
BLH Structure See Also Send Feedback
ハッシュ値を返す

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

全メンバのXOR結果

See Also

BLH Structure
GNSS Namespace


GetMedian Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetMedian Method
BLH Structure See Also Send Feedback
2地点間の中間座標を返す

（現時点では）メルカトル図法上の中間点を算出します。従って極点をまたがるような2点間の中点を求める用途には向いていません。

また、2地点間の中間地点は地球上に2点取り得ますが、2点間を結ぶ距離が短くなる方を採用しています。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH GetMedian(
    BLH pos
)
Visual Basic
Public Function GetMedian ( _
    pos As BLH _
) As BLH
Visual C++
public:
BLH GetMedian(
    BLH pos
)

Parameters

pos
Type: GNSS..::..BLH
第2の座標

Return Value

本インスタンスと第2の座標間の中間座標

新しく生成する座標の単位と測地系は本オブジェクトに合わせます。

See Also

BLH Structure
GNSS Namespace


GetUnitLengthForEN Method

[image]

A Sandcastle Documented Class Library
BLH..::..GetUnitLengthForEN Method
BLH Structure See Also Send Feedback
楕円体に沿った、東西方向の単位長[m/deg]を返す

実際は高度の分だけ若干の誤差が発生するし、2地点の高度差は考慮しない。

参考：理科年表，p.563，2003．

ちなみに、http://yamadarake.web.fc2.com/trdi/2009/report000001.html　を見ると使用した公式がヒュベニの公式と言うものであることが分かる

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Length GetUnitLengthForEN(
    Datum datum
)
Visual Basic
Public Function GetUnitLengthForEN ( _
    datum As Datum _
) As Length
Visual C++
public:
Length GetUnitLengthForEN(
    Datum datum
)

Parameters

datum
Type: GNSS.GeodeticDatum..::..Datum

[Missing <param name="datum"/> documentation for "M:GNSS.BLH.GetUnitLengthForEN(GNSS.GeodeticDatum.Datum)"]

Return Value

[Missing <returns> documentation for "M:GNSS.BLH.GetUnitLengthForEN(GNSS.GeodeticDatum.Datum)"]

See Also

BLH Structure
GNSS Namespace


ToDegree Method

[image]

A Sandcastle Documented Class Library
BLH..::..ToDegree Method
BLH Structure See Also Send Feedback
単位を度へ変換したオブジェクトを返す

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH ToDegree()
Visual Basic
Public Function ToDegree As BLH
Visual C++
public:
BLH ToDegree()

Return Value

[Missing <returns> documentation for "M:GNSS.BLH.ToDegree"]

See Also

BLH Structure
GNSS Namespace


ToRadian Method

[image]

A Sandcastle Documented Class Library
BLH..::..ToRadian Method
BLH Structure See Also Send Feedback
単位をラジアン単位へ変換したオブジェクトを返す

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH ToRadian()
Visual Basic
Public Function ToRadian As BLH
Visual C++
public:
BLH ToRadian()

Return Value

[Missing <returns> documentation for "M:GNSS.BLH.ToRadian"]

See Also

BLH Structure
GNSS Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
BLH..::..ToString Method
BLH Structure See Also Send Feedback
緯度・経度・楕円体高の文字列化 Excelに合わせて、経度から先に出力する。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

文字列化した位置座標

See Also

BLH Structure
GNSS Namespace


ToXYZ Method

[image] [image]

A Sandcastle Documented Class Library
BLH..::..ToXYZ Method
BLH Structure See Also Send Feedback

Overload List

 | Name | Description
Public method | ToXYZ()()()() | XYZ座標系へ変換したオブジェクトを返す 引数を省略できます。変換後の測地系は本オブジェクトの測地系と同じになります。 ToXYZ(Datum nextDatum)を利用して値を返します。
Public method | ToXYZ(Datum) | XYZ座標系へ変換したオブジェクトを返す 参考：理科年表，p.563，2003． [2011/7/18 追記]計算精度が悪い気がしてならん。

See Also

BLH Structure
BLH Members
GNSS Namespace


ToXYZ Method

[image]

A Sandcastle Documented Class Library
BLH..::..ToXYZ Method
BLH Structure See Also Send Feedback
XYZ座標系へ変換したオブジェクトを返す

引数を省略できます。変換後の測地系は本オブジェクトの測地系と同じになります。

ToXYZ(Datum nextDatum)を利用して値を返します。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XYZ ToXYZ()
Visual Basic
Public Function ToXYZ As XYZ
Visual C++
public:
XYZ ToXYZ()

Return Value

変換したXYZ座標

See Also

BLH Structure
ToXYZ Overload
GNSS Namespace


ToXYZ Method (Datum)

[image]

A Sandcastle Documented Class Library
BLH..::..ToXYZ Method (Datum)
BLH Structure See Also Send Feedback
XYZ座標系へ変換したオブジェクトを返す

参考：理科年表，p.563，2003．

[2011/7/18　追記]計算精度が悪い気がしてならん。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XYZ ToXYZ(
    Datum nextDatum
)
Visual Basic
Public Function ToXYZ ( _
    nextDatum As Datum _
) As XYZ
Visual C++
public:
XYZ ToXYZ(
    Datum nextDatum
)

Parameters

nextDatum
Type: GNSS.GeodeticDatum..::..Datum
変換後の測地系

Return Value

変換したXYZ座標

See Also

BLH Structure
ToXYZ Overload
GNSS Namespace


BLH Operators

[image] [image]

A Sandcastle Documented Class Library
BLH Operators
BLH Structure See Also Send Feedback

The BLH type exposes the following members.

Operators

Name | Description
Addition | 二項+演算子（これで足し算が簡単にできる） 単位はdegreeとなる
Equality | 比較演算子== 単位及び測地系の設定も含めて一致しなければtrueとはしません。
Inequality | 比較演算子!=
Subtraction | 二項-演算子（これで引き算が簡単にできる） 単位はdegreeとなる

See Also

BLH Structure
GNSS Namespace


Addition Operator

[image]

A Sandcastle Documented Class Library
BLH..::..Addition Operator
BLH Structure See Also Send Feedback
二項+演算子（これで足し算が簡単にできる）

単位はdegreeとなる

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static BLH operator +(
    BLH c1,
    BLH c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As BLH, _
    c2 As BLH _
) As BLH
Visual C++
public:
static BLH operator +(
    BLH c1,
    BLH c2
)

Parameters

c1
Type: GNSS..::..BLH
被加算値
c2
Type: GNSS..::..BLH
加算値

Return Value

2値を加算した結果

See Also

BLH Structure
GNSS Namespace


Equality Operator

[image]

A Sandcastle Documented Class Library
BLH..::..Equality Operator
BLH Structure See Also Send Feedback
比較演算子==

単位及び測地系の設定も含めて一致しなければtrueとはしません。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator ==(
    BLH c1,
    BLH c2
)
Visual Basic
Public Shared Operator = ( _
    c1 As BLH, _
    c2 As BLH _
) As Boolean
Visual C++
public:
static bool operator ==(
    BLH c1,
    BLH c2
)

Parameters

c1
Type: GNSS..::..BLH
比較対象その1
c2
Type: GNSS..::..BLH
比較対象その2

Return Value

等しければture

See Also

BLH Structure
GNSS Namespace


Inequality Operator

[image]

A Sandcastle Documented Class Library
BLH..::..Inequality Operator
BLH Structure See Also Send Feedback
比較演算子!=

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool operator !=(
    BLH c1,
    BLH c2
)
Visual Basic
Public Shared Operator <> ( _
    c1 As BLH, _
    c2 As BLH _
) As Boolean
Visual C++
public:
static bool operator !=(
    BLH c1,
    BLH c2
)

Parameters

c1
Type: GNSS..::..BLH
比較対象その1
c2
Type: GNSS..::..BLH
比較対象その2

Return Value

等しくなければture

See Also

BLH Structure
GNSS Namespace


Subtraction Operator

[image]

A Sandcastle Documented Class Library
BLH..::..Subtraction Operator
BLH Structure See Also Send Feedback
二項-演算子（これで引き算が簡単にできる）

単位はdegreeとなる

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static BLH operator -(
    BLH c1,
    BLH c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As BLH, _
    c2 As BLH _
) As BLH
Visual C++
public:
static BLH operator -(
    BLH c1,
    BLH c2
)

Parameters

c1
Type: GNSS..::..BLH
被減算値
c2
Type: GNSS..::..BLH
減算値

Return Value

2値の引き算の結果

See Also

BLH Structure
GNSS Namespace


BLH Properties

[image] [image]

A Sandcastle Documented Class Library
BLH Properties
BLH Structure See Also Send Feedback

The BLH type exposes the following members.

Properties

 | Name | Description
Public property | B | 緯度 緯度は-90～90 degの範囲に丸められます。 もしセットした値の絶対値が90°を超えている場合、極の向こう側へ移動したとみなして経度が自動的に半周します。
Public property | DatumKind | 測地系 測地系の変更に対しての処理は未実装
Public property | H | 楕円体高 楕円体表面からの鉛直距離
Public property | Healthy | 本オブジェクトの状態を表す true: 正常, 利用可能
Public property | L | 経度 経度は-180～180 degの範囲に丸められます。
Public property | Unit | 演算単位 deg or radian

See Also

BLH Structure
GNSS Namespace


B Property

[image]

A Sandcastle Documented Class Library
BLH..::..B Property
BLH Structure See Also Send Feedback
緯度

緯度は-90～90 degの範囲に丸められます。

もしセットした値の絶対値が90°を超えている場合、極の向こう側へ移動したとみなして経度が自動的に半周します。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double B { get; set; }
Visual Basic
Public Property B As Double
    Get
    Set
Visual C++
public:
property double B {
    double get ();
    void set (double value);
}

See Also

BLH Structure
GNSS Namespace


DatumKind Property

[image]

A Sandcastle Documented Class Library
BLH..::..DatumKind Property
BLH Structure See Also Send Feedback
測地系

測地系の変更に対しての処理は未実装

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Datum DatumKind { get; set; }
Visual Basic
Public Property DatumKind As Datum
    Get
    Set
Visual C++
public:
property Datum DatumKind {
    Datum get ();
    void set (Datum value);
}

See Also

BLH Structure
GNSS Namespace


H Property

[image]

A Sandcastle Documented Class Library
BLH..::..H Property
BLH Structure See Also Send Feedback
楕円体高

楕円体表面からの鉛直距離

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double H { get; set; }
Visual Basic
Public Property H As Double
    Get
    Set
Visual C++
public:
property double H {
    double get ();
    void set (double value);
}

See Also

BLH Structure
GNSS Namespace


Healthy Property

[image]

A Sandcastle Documented Class Library
BLH..::..Healthy Property
BLH Structure See Also Send Feedback
本オブジェクトの状態を表す

true: 正常, 利用可能

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Healthy { get; }
Visual Basic
Public ReadOnly Property Healthy As Boolean
    Get
Visual C++
public:
property bool Healthy {
    bool get ();
}

See Also

BLH Structure
GNSS Namespace


L Property

[image]

A Sandcastle Documented Class Library
BLH..::..L Property
BLH Structure See Also Send Feedback
経度

経度は-180～180 degの範囲に丸められます。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double L { get; set; }
Visual Basic
Public Property L As Double
    Get
    Set
Visual C++
public:
property double L {
    double get ();
    void set (double value);
}

See Also

BLH Structure
GNSS Namespace


Unit Property

[image]

A Sandcastle Documented Class Library
BLH..::..Unit Property
BLH Structure See Also Send Feedback
演算単位

deg or radian

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AngleUnit Unit { get; set; }
Visual Basic
Public Property Unit As AngleUnit
    Get
    Set
Visual C++
public:
property AngleUnit Unit {
    AngleUnit get ();
    void set (AngleUnit value);
}

See Also

BLH Structure
GNSS Namespace


GnssTest Class

[image]

A Sandcastle Documented Class Library
GnssTest Class
Members See Also Send Feedback
GNSS名前空間に属するクラス群をテストする静的クラス

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class GnssTest
Visual Basic
Public NotInheritable Class GnssTest
Visual C++
public ref class GnssTest abstract sealed

Inheritance Hierarchy

System..::..Object
GNSS..::..GnssTest

See Also

GnssTest Members
GNSS Namespace


GnssTest Members

[image] [image]

A Sandcastle Documented Class Library
GnssTest Members
GnssTest Class Methods See Also Send Feedback

The GnssTest type exposes the following members.

Methods

Name | Description
BlhTest | 未実装
ReadNmeaToRectangleFeild | NMEA読み出し機能およびRectangleFieldクラスのテスト ダイアログを利用してNMEAファイルを開きます。 NMEA読み取り後に、測位結果を配列化して測位結果全体が収まるRectangleFieldオブジェクトを生成します。 未測位データは除いています。

See Also

GnssTest Class
GNSS Namespace


GnssTest Methods

[image] [image]

A Sandcastle Documented Class Library
GnssTest Methods
GnssTest Class See Also Send Feedback

The GnssTest type exposes the following members.

Methods

Name | Description
BlhTest | 未実装
ReadNmeaToRectangleFeild | NMEA読み出し機能およびRectangleFieldクラスのテスト ダイアログを利用してNMEAファイルを開きます。 NMEA読み取り後に、測位結果を配列化して測位結果全体が収まるRectangleFieldオブジェクトを生成します。 未測位データは除いています。

See Also

GnssTest Class
GNSS Namespace


BlhTest Method

[image]

A Sandcastle Documented Class Library
GnssTest..::..BlhTest Method
GnssTest Class See Also Send Feedback
未実装

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void BlhTest()
Visual Basic
Public Shared Sub BlhTest
Visual C++
public:
static void BlhTest()

See Also

GnssTest Class
GNSS Namespace


ReadNmeaToRectangleFeild Method

[image]

A Sandcastle Documented Class Library
GnssTest..::..ReadNmeaToRectangleFeild Method
GnssTest Class See Also Send Feedback
NMEA読み出し機能およびRectangleFieldクラスのテスト

ダイアログを利用してNMEAファイルを開きます。

NMEA読み取り後に、測位結果を配列化して測位結果全体が収まるRectangleFieldオブジェクトを生成します。

未測位データは除いています。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static RectangleField ReadNmeaToRectangleFeild()
Visual Basic
Public Shared Function ReadNmeaToRectangleFeild As RectangleField
Visual C++
public:
static RectangleField^ ReadNmeaToRectangleFeild()

Return Value

測位データ全体を覆う長方形領域情報

See Also

GnssTest Class
GNSS Namespace


Length Structure

[image]

A Sandcastle Documented Class Library
Length Structure
Members See Also Send Feedback
南北、東西方向の距離・長さを収めるための構造体

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public struct Length
Visual Basic
<SerializableAttribute> _
Public Structure Length
Visual C++
[SerializableAttribute]
public value class Length

See Also

Length Members
GNSS Namespace


Length Members

[image] [image]

A Sandcastle Documented Class Library
Length Members
Length Structure Constructors Methods Fields See Also Send Feedback

The Length type exposes the following members.

Constructors

 | Name | Description
Public method | Length | 構造体初期化

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | E | 東西方向の長さ
Public field | N | 南北方向の長さ

See Also

Length Structure
GNSS Namespace


Length Constructor

[image]

A Sandcastle Documented Class Library
Length Constructor
Length Structure See Also Send Feedback
構造体初期化

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Length(
    double _E,
    double _N
)
Visual Basic
Public Sub New ( _
    _E As Double, _
    _N As Double _
)
Visual C++
public:
Length(
    double _E,
    double _N
)

Parameters

_E
Type: System..::..Double
経度方向の長さ
_N
Type: System..::..Double
緯度方向の長さ

See Also

Length Structure
GNSS Namespace


Length Fields

[image] [image]

A Sandcastle Documented Class Library
Length Fields
Length Structure See Also Send Feedback

The Length type exposes the following members.

Fields

 | Name | Description
Public field | E | 東西方向の長さ
Public field | N | 南北方向の長さ

See Also

Length Structure
GNSS Namespace


E Field

[image]

A Sandcastle Documented Class Library
Length..::..E Field
Length Structure See Also Send Feedback
東西方向の長さ

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double E
Visual Basic
Public E As Double
Visual C++
public:
double E

See Also

Length Structure
GNSS Namespace


N Field

[image]

A Sandcastle Documented Class Library
Length..::..N Field
Length Structure See Also Send Feedback
南北方向の長さ

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double N
Visual Basic
Public N As Double
Visual C++
public:
double N

See Also

Length Structure
GNSS Namespace


Length Methods

[image] [image]

A Sandcastle Documented Class Library
Length Methods
Length Structure See Also Send Feedback

The Length type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Length Structure
GNSS Namespace


XYZ Structure

[image]

A Sandcastle Documented Class Library
XYZ Structure
Members See Also Send Feedback
x,y,zを格納する構造体

半径の取得も簡単 BLH座標系（緯度・経度・楕円体高[m]）への変換も簡単 座標変換処理等を実装する必要もあるのだろうけど、現時点ではWGS84専用となっている。

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public struct XYZ
Visual Basic
<SerializableAttribute> _
Public Structure XYZ
Visual C++
[SerializableAttribute]
public value class XYZ

See Also

XYZ Members
GNSS Namespace


XYZ Members

[image] [image]

A Sandcastle Documented Class Library
XYZ Members
XYZ Structure Constructors Methods Operators Fields Properties See Also Send Feedback

The XYZ type exposes the following members.

Constructors

 | Name | Description
Public method | XYZ | コンストラクタ

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBLH | XYZからBLH座標系（緯度・経度・楕円体高[m]）へ変換
Public method | ToString | 文字列化 (Overrides ValueType..::..ToString()()()().)

Operators

Name | Description
Addition | 二項+演算子（これで足し算が簡単にできる）
Subtraction | 二項-演算子（これで足し算が簡単にできる）

Fields

 | Name | Description
Public field | x | x座標[m]
Public field | y | y座標[m]
Public field | z | z座標[m]

Properties

 | Name | Description
Public property | r | 半径（地心からの距離）

See Also

XYZ Structure
GNSS Namespace


XYZ Constructor

[image]

A Sandcastle Documented Class Library
XYZ Constructor
XYZ Structure See Also Send Feedback
コンストラクタ

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public XYZ(
    double _x,
    double _y,
    double _z
)
Visual Basic
Public Sub New ( _
    _x As Double, _
    _y As Double, _
    _z As Double _
)
Visual C++
public:
XYZ(
    double _x,
    double _y,
    double _z
)

Parameters

_x
Type: System..::..Double

[Missing <param name="_x"/> documentation for "M:GNSS.XYZ.#ctor(System.Double,System.Double,System.Double)"]

_y
Type: System..::..Double

[Missing <param name="_y"/> documentation for "M:GNSS.XYZ.#ctor(System.Double,System.Double,System.Double)"]

_z
Type: System..::..Double

[Missing <param name="_z"/> documentation for "M:GNSS.XYZ.#ctor(System.Double,System.Double,System.Double)"]

See Also

XYZ Structure
GNSS Namespace


XYZ Fields

[image] [image]

A Sandcastle Documented Class Library
XYZ Fields
XYZ Structure See Also Send Feedback

The XYZ type exposes the following members.

Fields

 | Name | Description
Public field | x | x座標[m]
Public field | y | y座標[m]
Public field | z | z座標[m]

See Also

XYZ Structure
GNSS Namespace


x Field

[image]

A Sandcastle Documented Class Library
XYZ..::..x Field
XYZ Structure See Also Send Feedback
x座標[m]

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double x
Visual Basic
Public x As Double
Visual C++
public:
double x

See Also

XYZ Structure
GNSS Namespace


y Field

[image]

A Sandcastle Documented Class Library
XYZ..::..y Field
XYZ Structure See Also Send Feedback
y座標[m]

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double y
Visual Basic
Public y As Double
Visual C++
public:
double y

See Also

XYZ Structure
GNSS Namespace


z Field

[image]

A Sandcastle Documented Class Library
XYZ..::..z Field
XYZ Structure See Also Send Feedback
z座標[m]

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double z
Visual Basic
Public z As Double
Visual C++
public:
double z

See Also

XYZ Structure
GNSS Namespace


XYZ Methods

[image] [image]

A Sandcastle Documented Class Library
XYZ Methods
XYZ Structure See Also Send Feedback

The XYZ type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBLH | XYZからBLH座標系（緯度・経度・楕円体高[m]）へ変換
Public method | ToString | 文字列化 (Overrides ValueType..::..ToString()()()().)

See Also

XYZ Structure
GNSS Namespace


ToBLH Method

[image]

A Sandcastle Documented Class Library
XYZ..::..ToBLH Method
XYZ Structure See Also Send Feedback
XYZからBLH座標系（緯度・経度・楕円体高[m]）へ変換

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH ToBLH()
Visual Basic
Public Function ToBLH As BLH
Visual C++
public:
BLH ToBLH()

Return Value

BLHに変換した結果

See Also

XYZ Structure
GNSS Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
XYZ..::..ToString Method
XYZ Structure See Also Send Feedback
文字列化

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

メンバ変数x,y,zを文字列化したしたstring型変数

See Also

XYZ Structure
GNSS Namespace


XYZ Operators

[image] [image]

A Sandcastle Documented Class Library
XYZ Operators
XYZ Structure See Also Send Feedback

The XYZ type exposes the following members.

Operators

Name | Description
Addition | 二項+演算子（これで足し算が簡単にできる）
Subtraction | 二項-演算子（これで足し算が簡単にできる）

See Also

XYZ Structure
GNSS Namespace


Addition Operator

[image]

A Sandcastle Documented Class Library
XYZ..::..Addition Operator
XYZ Structure See Also Send Feedback
二項+演算子（これで足し算が簡単にできる）

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static XYZ operator +(
    XYZ c1,
    XYZ c2
)
Visual Basic
Public Shared Operator + ( _
    c1 As XYZ, _
    c2 As XYZ _
) As XYZ
Visual C++
public:
static XYZ operator +(
    XYZ c1,
    XYZ c2
)

Parameters

c1
Type: GNSS..::..XYZ
被加算値
c2
Type: GNSS..::..XYZ
加算値

Return Value

2値を加算した結果

See Also

XYZ Structure
GNSS Namespace


Subtraction Operator

[image]

A Sandcastle Documented Class Library
XYZ..::..Subtraction Operator
XYZ Structure See Also Send Feedback
二項-演算子（これで足し算が簡単にできる）

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static XYZ operator -(
    XYZ c1,
    XYZ c2
)
Visual Basic
Public Shared Operator - ( _
    c1 As XYZ, _
    c2 As XYZ _
) As XYZ
Visual C++
public:
static XYZ operator -(
    XYZ c1,
    XYZ c2
)

Parameters

c1
Type: GNSS..::..XYZ
被減算値
c2
Type: GNSS..::..XYZ
減算値

Return Value

2値の引き算の結果

See Also

XYZ Structure
GNSS Namespace


XYZ Properties

[image] [image]

A Sandcastle Documented Class Library
XYZ Properties
XYZ Structure See Also Send Feedback

The XYZ type exposes the following members.

Properties

 | Name | Description
Public property | r | 半径（地心からの距離）

See Also

XYZ Structure
GNSS Namespace


r Property

[image]

A Sandcastle Documented Class Library
XYZ..::..r Property
XYZ Structure See Also Send Feedback
半径（地心からの距離）

Namespace: GNSS
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double r { get; }
Visual Basic
Public ReadOnly Property r As Double
    Get
Visual C++
public:
property double r {
    double get ();
}

See Also

XYZ Structure
GNSS Namespace


GNSS.Field Namespace

[image]

A Sandcastle Documented Class Library
GNSS.Field Namespace
Send Feedback

[Missing <summary> documentation for "N:GNSS.Field"]

Classes

 | Class | Description
Public class | RectangleField | 緯度経度により表現する長方形領域（緯度経度座標系では長方形ですがxyz座標系では台形のような曲面となります） 例えば、GPSのログ領域の広さやマップの広さを表すことができる。 経度180°をまたぐ様な領域は表現できますが、極をまたぐ領域や東西南北に対して斜めに張るような領域は表現できません。 2012/5/14時点では、インスタンス生成後に単位と測地系を変更することはできない。 途中での変更を可能にするには、UpperRightとUnderLeftを取得してこれをBLH構造体の機能で変換後、paramへパラメータ再格納という手順を踏む必要がある。 従ってまずはBLH構造体の拡張を進める必要がある。

Enumerations

 | Enumeration | Description
Public enumeration | FieldKind | 領域の表し方を規定する列挙体


FieldKind Enumeration

[image]

A Sandcastle Documented Class Library
FieldKind Enumeration
See Also Send Feedback
領域の表し方を規定する列挙体

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum FieldKind
Visual Basic
Public Enumeration FieldKind
Visual C++
public enum class FieldKind

Members

Member name | Value | Description
Rectangle | 0 | 長方形の領域 高さ方向に厚みがなくてもエラー扱いとはしません。
Circlle | 1 | 円形領域 高さ方向に厚みがなくてもエラー扱いとはしません。
RectangularParallelepiped | 2 | 直方体
Shere | 3 | 球状領域

See Also

GNSS.Field Namespace


RectangleField Class

[image]

A Sandcastle Documented Class Library
RectangleField Class
Members See Also Send Feedback
緯度経度により表現する長方形領域（緯度経度座標系では長方形ですがxyz座標系では台形のような曲面となります）

例えば、GPSのログ領域の広さやマップの広さを表すことができる。

経度180°をまたぐ様な領域は表現できますが、極をまたぐ領域や東西南北に対して斜めに張るような領域は表現できません。

2012/5/14時点では、インスタンス生成後に単位と測地系を変更することはできない。 途中での変更を可能にするには、UpperRightとUnderLeftを取得してこれをBLH構造体の機能で変換後、paramへパラメータ再格納という手順を踏む必要がある。 従ってまずはBLH構造体の拡張を進める必要がある。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class RectangleField
Visual Basic
Public Class RectangleField
Visual C++
public ref class RectangleField

Inheritance Hierarchy

System..::..Object
GNSS.Field..::..RectangleField

See Also

RectangleField Members
GNSS.Field Namespace


RectangleField Members

[image] [image]

A Sandcastle Documented Class Library
RectangleField Members
RectangleField Class Constructors Methods Properties See Also Send Feedback

The RectangleField type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleField(AngleUnit, Datum) | 座標省略時のコンストラクタ 内部パラメータには非値が代入され、使う準備は行われますが値をセットしない限り運用できません。
Public method | RectangleField(BLH, BLH, AngleUnit, Datum) | コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。 経度に関しては、より小さな領域となる座標を選択する。

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(BLH) | 座標をセットする 自動的に過去の履歴と比較されて領域が拡張されます。
Public method | Set(array<BLH>[]()[][]) | 座標の配列から領域を生成する 自動的に過去の履歴と比較されて領域が拡張されます。
Public method | ToArray | 領域をBLH型の配列として返す 格納の順番はKMLのポリゴンで四角く描かれる順番にしています。
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Public property AreaIsZero
面積が存在するかを返す

true: 面積は0。

Public property Center
中央の座標
Public property DifferInLat
緯度差

南北方向の領域における緯度の差

定義不可能な場合はNaNとなります。

単位は本フィールドの定義に基づきます。単位にお気を付け下さい。

Public property DifferInLon
経度差

東西方向の領域における経度の差

定義不可能な場合はNaNとなります。

単位は本フィールドの定義に基づきます。単位にお気を付け下さい。

Public property LowerLeft
左下の座標
Public property LowerRight
右下の座標

定義できない場合はnullを返します。

Public property Size
サイズ

領域のサイズ（緯度経度長）を返します。

Public property UpperLeft
左上の座標
Public property UpperRight
右上の座標

Examples

CopyC#
RectangleField field = new RectangleField(利用可能になる初期化);
BLH hoge;
if (field.Available) hoge = (BLH)filed.UpperRight;

See Also

RectangleField Class
GNSS.Field Namespace


RectangleField Constructor

[image] [image]

A Sandcastle Documented Class Library
RectangleField Constructor
RectangleField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangleField(AngleUnit, Datum) | 座標省略時のコンストラクタ 内部パラメータには非値が代入され、使う準備は行われますが値をセットしない限り運用できません。
Public method | RectangleField(BLH, BLH, AngleUnit, Datum) | コンストラクタ 2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。 経度に関しては、より小さな領域となる座標を選択する。

See Also

RectangleField Class
RectangleField Members
GNSS.Field Namespace


RectangleField Constructor (AngleUnit, Datum)

[image]

A Sandcastle Documented Class Library
RectangleField Constructor (AngleUnit, Datum)
RectangleField Class See Also Send Feedback
座標省略時のコンストラクタ

内部パラメータには非値が代入され、使う準備は行われますが値をセットしない限り運用できません。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RectangleField(
    AngleUnit unit,
    Datum datum
)
Visual Basic
Public Sub New ( _
    unit As AngleUnit, _
    datum As Datum _
)
Visual C++
public:
RectangleField(
    AngleUnit unit,
    Datum datum
)

Parameters

unit
Type: GNSS..::..AngleUnit
単位(°or rad)
datum
Type: GNSS.GeodeticDatum..::..Datum
測地系

See Also

RectangleField Class
RectangleField Overload
GNSS.Field Namespace


RectangleField Constructor (BLH, BLH, AngleUnit, Datum)

[image]

A Sandcastle Documented Class Library
RectangleField Constructor (BLH, BLH, AngleUnit, Datum)
RectangleField Class See Also Send Feedback
コンストラクタ

2つの座標を指定すると、大小関係からマップの座標を自動的に決定する。

経度に関しては、より小さな領域となる座標を選択する。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RectangleField(
    BLH x1,
    BLH x2,
    AngleUnit unit,
    Datum datum
)
Visual Basic
Public Sub New ( _
    x1 As BLH, _
    x2 As BLH, _
    unit As AngleUnit, _
    datum As Datum _
)
Visual C++
public:
RectangleField(
    BLH x1,
    BLH x2,
    AngleUnit unit,
    Datum datum
)

Parameters

x1
Type: GNSS..::..BLH
座標1
x2
Type: GNSS..::..BLH
座標2
unit
Type: GNSS..::..AngleUnit
単位(°or rad)
datum
Type: GNSS.GeodeticDatum..::..Datum
測地系

See Also

RectangleField Class
RectangleField Overload
GNSS.Field Namespace


RectangleField Methods

[image] [image]

A Sandcastle Documented Class Library
RectangleField Methods
RectangleField Class See Also Send Feedback

The RectangleField type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set(BLH) | 座標をセットする 自動的に過去の履歴と比較されて領域が拡張されます。
Public method | Set(array<BLH>[]()[][]) | 座標の配列から領域を生成する 自動的に過去の履歴と比較されて領域が拡張されます。
Public method | ToArray | 領域をBLH型の配列として返す 格納の順番はKMLのポリゴンで四角く描かれる順番にしています。
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RectangleField Class
GNSS.Field Namespace


Set Method

[image] [image]

A Sandcastle Documented Class Library
RectangleField..::..Set Method
RectangleField Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Set(BLH) | 座標をセットする 自動的に過去の履歴と比較されて領域が拡張されます。
Public method | Set(array<BLH>[]()[][]) | 座標の配列から領域を生成する 自動的に過去の履歴と比較されて領域が拡張されます。

See Also

RectangleField Class
RectangleField Members
GNSS.Field Namespace


Set Method (BLH)

[image]

A Sandcastle Documented Class Library
RectangleField..::..Set Method (BLH)
RectangleField Class See Also Send Feedback
座標をセットする

自動的に過去の履歴と比較されて領域が拡張されます。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    BLH pos
)
Visual Basic
Public Sub Set ( _
    pos As BLH _
)
Visual C++
public:
void Set(
    BLH pos
)

Parameters

pos
Type: GNSS..::..BLH
セットする座標

See Also

RectangleField Class
Set Overload
GNSS.Field Namespace


Set Method (BLH[])

[image]

A Sandcastle Documented Class Library
RectangleField..::..Set Method (array<BLH>[]()[][])
RectangleField Class See Also Send Feedback
座標の配列から領域を生成する

自動的に過去の履歴と比較されて領域が拡張されます。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    BLH[] pos
)
Visual Basic
Public Sub Set ( _
    pos As BLH() _
)
Visual C++
public:
void Set(
    array<BLH>^ pos
)

Parameters

pos
Type: array< GNSS..::..BLH >[]()[][]
セットする座標

See Also

RectangleField Class
Set Overload
GNSS.Field Namespace


ToArray Method

[image]

A Sandcastle Documented Class Library
RectangleField..::..ToArray Method
RectangleField Class See Also Send Feedback
領域をBLH型の配列として返す

格納の順番はKMLのポリゴンで四角く描かれる順番にしています。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH[] ToArray()
Visual Basic
Public Function ToArray As BLH()
Visual C++
public:
array<BLH>^ ToArray()

Return Value

領域の四隅をBLH型の配列に加工したもの

See Also

RectangleField Class
GNSS.Field Namespace


RectangleField Properties

[image] [image]

A Sandcastle Documented Class Library
RectangleField Properties
RectangleField Class See Also Send Feedback

The RectangleField type exposes the following members.

Properties

Name Description
Public property AreaIsZero
面積が存在するかを返す

true: 面積は0。

Public property Center
中央の座標
Public property DifferInLat
緯度差

南北方向の領域における緯度の差

定義不可能な場合はNaNとなります。

単位は本フィールドの定義に基づきます。単位にお気を付け下さい。

Public property DifferInLon
経度差

東西方向の領域における経度の差

定義不可能な場合はNaNとなります。

単位は本フィールドの定義に基づきます。単位にお気を付け下さい。

Public property LowerLeft
左下の座標
Public property LowerRight
右下の座標

定義できない場合はnullを返します。

Public property Size
サイズ

領域のサイズ（緯度経度長）を返します。

Public property UpperLeft
左上の座標
Public property UpperRight
右上の座標

Examples

CopyC#
RectangleField field = new RectangleField(利用可能になる初期化);
BLH hoge;
if (field.Available) hoge = (BLH)filed.UpperRight;

See Also

RectangleField Class
GNSS.Field Namespace


AreaIsZero Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..AreaIsZero Property
RectangleField Class See Also Send Feedback
面積が存在するかを返す

true: 面積は0。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool AreaIsZero { get; }
Visual Basic
Public ReadOnly Property AreaIsZero As Boolean
    Get
Visual C++
public:
property bool AreaIsZero {
    bool get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


Center Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..Center Property
RectangleField Class See Also Send Feedback
中央の座標

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH Center { get; }
Visual Basic
Public ReadOnly Property Center As BLH
    Get
Visual C++
public:
property BLH Center {
    BLH get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


DifferInLat Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..DifferInLat Property
RectangleField Class See Also Send Feedback
緯度差

南北方向の領域における緯度の差

定義不可能な場合はNaNとなります。

単位は本フィールドの定義に基づきます。単位にお気を付け下さい。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DifferInLat { get; }
Visual Basic
Public ReadOnly Property DifferInLat As Double
    Get
Visual C++
public:
property double DifferInLat {
    double get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


DifferInLon Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..DifferInLon Property
RectangleField Class See Also Send Feedback
経度差

東西方向の領域における経度の差

定義不可能な場合はNaNとなります。

単位は本フィールドの定義に基づきます。単位にお気を付け下さい。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public double DifferInLon { get; }
Visual Basic
Public ReadOnly Property DifferInLon As Double
    Get
Visual C++
public:
property double DifferInLon {
    double get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


LowerLeft Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..LowerLeft Property
RectangleField Class See Also Send Feedback
左下の座標

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH LowerLeft { get; }
Visual Basic
Public ReadOnly Property LowerLeft As BLH
    Get
Visual C++
public:
property BLH LowerLeft {
    BLH get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


LowerRight Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..LowerRight Property
RectangleField Class See Also Send Feedback
右下の座標

定義できない場合はnullを返します。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH LowerRight { get; }
Visual Basic
Public ReadOnly Property LowerRight As BLH
    Get
Visual C++
public:
property BLH LowerRight {
    BLH get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


Size Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..Size Property
RectangleField Class See Also Send Feedback
サイズ

領域のサイズ（緯度経度長）を返します。

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH Size { get; }
Visual Basic
Public ReadOnly Property Size As BLH
    Get
Visual C++
public:
property BLH Size {
    BLH get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


UpperLeft Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..UpperLeft Property
RectangleField Class See Also Send Feedback
左上の座標

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH UpperLeft { get; }
Visual Basic
Public ReadOnly Property UpperLeft As BLH
    Get
Visual C++
public:
property BLH UpperLeft {
    BLH get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


UpperRight Property

[image]

A Sandcastle Documented Class Library
RectangleField..::..UpperRight Property
RectangleField Class See Also Send Feedback
右上の座標

Examples

CopyC#
RectangleField field = new RectangleField(利用可能になる初期化);
BLH hoge;
if (field.Available) hoge = (BLH)filed.UpperRight;

Namespace: GNSS.Field
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH UpperRight { get; }
Visual Basic
Public ReadOnly Property UpperRight As BLH
    Get
Visual C++
public:
property BLH UpperRight {
    BLH get ();
}

See Also

RectangleField Class
GNSS.Field Namespace


GNSS.GeodeticDatum Namespace

[image]

A Sandcastle Documented Class Library
GNSS.GeodeticDatum Namespace
Send Feedback

[Missing <summary> documentation for "N:GNSS.GeodeticDatum"]

Classes

 | Class | Description
Public class | WGS84 | WGS84座標系における各種パラメータ 参考：西修二郎訳，GNSSのすべて，p.265，2010.2．

Enumerations

 | Enumeration | Description
Public enumeration | Datum | 測地系


Datum Enumeration

[image]

A Sandcastle Documented Class Library
Datum Enumeration
See Also Send Feedback
測地系

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum Datum
Visual Basic
Public Enumeration Datum
Visual C++
public enum class Datum

Members

Member name | Value | Description
WGS84 | 0 | WGS84測地系
Unknown | 1 | 未知の座標系

See Also

GNSS.GeodeticDatum Namespace


WGS84 Class

[image]

A Sandcastle Documented Class Library
WGS84 Class
Members See Also Send Feedback
WGS84座標系における各種パラメータ

参考：西修二郎訳，GNSSのすべて，p.265，2010.2．

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[SerializableAttribute]
public static class WGS84
Visual Basic
<SerializableAttribute> _
Public NotInheritable Class WGS84
Visual C++
[SerializableAttribute]
public ref class WGS84 abstract sealed

Inheritance Hierarchy

System..::..Object
GNSS.GeodeticDatum..::..WGS84

See Also

WGS84 Members
GNSS.GeodeticDatum Namespace


WGS84 Members

[image] [image]

A Sandcastle Documented Class Library
WGS84 Members
WGS84 Class Fields Properties See Also Send Feedback

The WGS84 type exposes the following members.

Fields

Name | Description
a | Equatorial Radius 赤道半径（楕円体長半径）[m]
b | Short Radius 短半径
c | 光速[m/s]
e2 | Square Eccentricity 離心率^2
f | 扁平率
invers_oblateness | 扁平率の逆数
PI | 円周率π
u | Gravitational Constant of The Earth 地球重力定数[m^3/s^-2]
wE | Angular Velocity of The Earth 地球の角速度[rad/sec]

Properties

Name | Description
e | Eccentricity 離心率e

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


WGS84 Fields

[image] [image]

A Sandcastle Documented Class Library
WGS84 Fields
WGS84 Class See Also Send Feedback

The WGS84 type exposes the following members.

Fields

Name | Description
a | Equatorial Radius 赤道半径（楕円体長半径）[m]
b | Short Radius 短半径
c | 光速[m/s]
e2 | Square Eccentricity 離心率^2
f | 扁平率
invers_oblateness | 扁平率の逆数
PI | 円周率π
u | Gravitational Constant of The Earth 地球重力定数[m^3/s^-2]
wE | Angular Velocity of The Earth 地球の角速度[rad/sec]

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


a Field

[image]

A Sandcastle Documented Class Library
WGS84..::..a Field
WGS84 Class See Also Send Feedback
Equatorial Radius 赤道半径（楕円体長半径）[m]

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double a
Visual Basic
Public Const a As Double
Visual C++
public:
literal double a

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


b Field

[image]

A Sandcastle Documented Class Library
WGS84..::..b Field
WGS84 Class See Also Send Feedback
Short Radius 短半径

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double b
Visual Basic
Public Const b As Double
Visual C++
public:
literal double b

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


c Field

[image]

A Sandcastle Documented Class Library
WGS84..::..c Field
WGS84 Class See Also Send Feedback
光速[m/s]

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double c
Visual Basic
Public Const c As Double
Visual C++
public:
literal double c

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


e2 Field

[image]

A Sandcastle Documented Class Library
WGS84..::..e2 Field
WGS84 Class See Also Send Feedback
Square Eccentricity 離心率^2

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double e2
Visual Basic
Public Const e2 As Double
Visual C++
public:
literal double e2

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


f Field

[image]

A Sandcastle Documented Class Library
WGS84..::..f Field
WGS84 Class See Also Send Feedback
扁平率

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double f
Visual Basic
Public Const f As Double
Visual C++
public:
literal double f

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


invers_oblateness Field

[image]

A Sandcastle Documented Class Library
WGS84..::..invers_oblateness Field
WGS84 Class See Also Send Feedback
扁平率の逆数

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double invers_oblateness
Visual Basic
Public Const invers_oblateness As Double
Visual C++
public:
literal double invers_oblateness

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


PI Field

[image]

A Sandcastle Documented Class Library
WGS84..::..PI Field
WGS84 Class See Also Send Feedback
円周率π

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double PI
Visual Basic
Public Const PI As Double
Visual C++
public:
literal double PI

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


u Field

[image]

A Sandcastle Documented Class Library
WGS84..::..u Field
WGS84 Class See Also Send Feedback
Gravitational Constant of The Earth 地球重力定数[m^3/s^-2]

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double u
Visual Basic
Public Const u As Double
Visual C++
public:
literal double u

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


wE Field

[image]

A Sandcastle Documented Class Library
WGS84..::..wE Field
WGS84 Class See Also Send Feedback
Angular Velocity of The Earth 地球の角速度[rad/sec]

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public const double wE
Visual Basic
Public Const wE As Double
Visual C++
public:
literal double wE

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


WGS84 Properties

[image] [image]

A Sandcastle Documented Class Library
WGS84 Properties
WGS84 Class See Also Send Feedback

The WGS84 type exposes the following members.

Properties

Name | Description
e | Eccentricity 離心率e

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


e Property

[image]

A Sandcastle Documented Class Library
WGS84..::..e Property
WGS84 Class See Also Send Feedback
Eccentricity 離心率e

Namespace: GNSS.GeodeticDatum
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static double e { get; }
Visual Basic
Public Shared ReadOnly Property e As Double
    Get
Visual C++
public:
static property double e {
    double get ();
}

See Also

WGS84 Class
GNSS.GeodeticDatum Namespace


GNSS.GPS.NMEA Namespace

[image]

A Sandcastle Documented Class Library
GNSS.GPS.NMEA Namespace
Send Feedback

[Missing <summary> documentation for "N:GNSS.GPS.NMEA"]

Classes

Class Description
Public class GGA
GGAのみを扱うクラス

未完成

staticクラスとして宣言するので、インスタンスの確保を宣言せずとも使えます。

南緯と西経は負数で表します。

Public class NmeaReader
NMEAパーサー

NMEAのログを解析して、解析結果を返します。

2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる。 開発時間を優先した。

今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。

CopyC#
string nmea_str = "$GPGGA,*******";
GPS.NMEA nmea_parser = new GPS.NMEA();
object hoge;

hoge = nmea_parser.parse(nmea_str);         // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。
if(hoge.GetType() == tyepof(GPS.NMEA))      // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。
{
    // たとえば、こんな感じか？
    int sat = hoge.sat;
}
NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理）

Public class PositioningInfo
観測データを取り扱うクラス

構造体だと初期化を必ず求められるためクラスとした。

Public class PositioningInfos
測位情報
Public class ZDA
ZDAのみを扱うクラス

未完成

staticクラスとして宣言するので、インスタンスの確保を宣言せずとも使えます。


GGA Class

[image]

A Sandcastle Documented Class Library
GGA Class
Members See Also Send Feedback
GGAのみを扱うクラス

未完成

staticクラスとして宣言するので、インスタンスの確保を宣言せずとも使えます。

南緯と西経は負数で表します。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class GGA
Visual Basic
Public NotInheritable Class GGA
Visual C++
public ref class GGA abstract sealed

Inheritance Hierarchy

System..::..Object
GNSS.GPS.NMEA..::..GGA

See Also

GGA Members
GNSS.GPS.NMEA Namespace


GGA Members

[image] [image]

A Sandcastle Documented Class Library
GGA Members
GGA Class Methods See Also Send Feedback

The GGA type exposes the following members.

Methods

Name | Description
CheckMatch | 文字列を検査してセンテンスにマッチするかどうかを確認する
FindAll | 検査文字列の中にあるマッチするものをすべて抽出する Pythonのfindallを参考にした。 テスト未実施
Parse | GGAを解析して、測位情報を返す 現時点では緯度と経度と楕円体高しか返していないんだけど・・・
Selftest | セルフテスト 本クラスのテストを実施する。 未実装。 返り値はHealthyかUnhealthyにするか、各メソッドへの入力と返り値を並べたstringとするか。。。

See Also

GGA Class
GNSS.GPS.NMEA Namespace


GGA Methods

[image] [image]

A Sandcastle Documented Class Library
GGA Methods
GGA Class See Also Send Feedback

The GGA type exposes the following members.

Methods

Name | Description
CheckMatch | 文字列を検査してセンテンスにマッチするかどうかを確認する
FindAll | 検査文字列の中にあるマッチするものをすべて抽出する Pythonのfindallを参考にした。 テスト未実施
Parse | GGAを解析して、測位情報を返す 現時点では緯度と経度と楕円体高しか返していないんだけど・・・
Selftest | セルフテスト 本クラスのテストを実施する。 未実装。 返り値はHealthyかUnhealthyにするか、各メソッドへの入力と返り値を並べたstringとするか。。。

See Also

GGA Class
GNSS.GPS.NMEA Namespace


CheckMatch Method

[image]

A Sandcastle Documented Class Library
GGA..::..CheckMatch Method
GGA Class See Also Send Feedback
文字列を検査してセンテンスにマッチするかどうかを確認する

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool CheckMatch(
    string txt
)
Visual Basic
Public Shared Function CheckMatch ( _
    txt As String _
) As Boolean
Visual C++
public:
static bool CheckMatch(
    String^ txt
)

Parameters

txt
Type: System..::..String
被検査文字列

Return Value

検査結果

true: ヒット

See Also

GGA Class
GNSS.GPS.NMEA Namespace


FindAll Method

[image]

A Sandcastle Documented Class Library
GGA..::..FindAll Method
GGA Class See Also Send Feedback
検査文字列の中にあるマッチするものをすべて抽出する

Pythonのfindallを参考にした。

テスト未実施

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static MatchCollection FindAll(
    string txt
)
Visual Basic
Public Shared Function FindAll ( _
    txt As String _
) As MatchCollection
Visual C++
public:
static MatchCollection^ FindAll(
    String^ txt
)

Parameters

txt
Type: System..::..String
被検査文字列

Return Value

検査結果

See Also

GGA Class
GNSS.GPS.NMEA Namespace


Parse Method

[image]

A Sandcastle Documented Class Library
GGA..::..Parse Method
GGA Class See Also Send Feedback
GGAを解析して、測位情報を返す

現時点では緯度と経度と楕円体高しか返していないんだけど・・・

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static PositioningInfo Parse(
    string str
)
Visual Basic
Public Shared Function Parse ( _
    str As String _
) As PositioningInfo
Visual C++
public:
static PositioningInfo^ Parse(
    String^ str
)

Parameters

str
Type: System..::..String
解析文字列

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.GGA.Parse(System.String)"]

See Also

GGA Class
GNSS.GPS.NMEA Namespace


Selftest Method

[image]

A Sandcastle Documented Class Library
GGA..::..Selftest Method
GGA Class See Also Send Feedback
セルフテスト

本クラスのテストを実施する。 未実装。 返り値はHealthyかUnhealthyにするか、各メソッドへの入力と返り値を並べたstringとするか。。。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool Selftest()
Visual Basic
Public Shared Function Selftest As Boolean
Visual C++
public:
static bool Selftest()

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.GGA.Selftest"]

See Also

GGA Class
GNSS.GPS.NMEA Namespace


NmeaReader Class

[image]

A Sandcastle Documented Class Library
NmeaReader Class
Members See Also Send Feedback
NMEAパーサー

NMEAのログを解析して、解析結果を返します。

2011/7/17作りかけ 突貫で作ったので設計思想が固まっているわけでもない。 現時点では、ログを一旦全て読み込んでいるのでメモリ量がかなり必要となっている。 処理にも若干時間がかかる。 開発時間を優先した。

今後は、NMEAパーサが必要とされるなら、“object型でGGAクラスを返す”などの動作を実装する予定。 受け側では、以下の様にして呼び出す。

CopyC#
string nmea_str = "$GPGGA,*******";
GPS.NMEA nmea_parser = new GPS.NMEA();
object hoge;

hoge = nmea_parser.parse(nmea_str);         // NMEAフォーマットの文字列を処理して、オブジェクトを返してもらう。
if(hoge.GetType() == tyepof(GPS.NMEA))      // オブジェクトの型をチェックし、任意の型と一致した場合に所望の処理を呼び出す。
{
    // たとえば、こんな感じか？
    int sat = hoge.sat;
}
NMEAパーサとして想定される使用環境 1) ログを処理する（センテンス毎・1エポック毎） 2) リアルタイムで処理する（センテンス毎に処理）

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NmeaReader : IDisposable
Visual Basic
Public Class NmeaReader _
    Implements IDisposable
Visual C++
public ref class NmeaReader : IDisposable

Inheritance Hierarchy

System..::..Object
GNSS.GPS.NMEA..::..NmeaReader

See Also

NmeaReader Members
GNSS.GPS.NMEA Namespace


NmeaReader Members

[image] [image]

A Sandcastle Documented Class Library
NmeaReader Members
NmeaReader Class Constructors Methods Properties See Also Send Feedback

The NmeaReader type exposes the following members.

Constructors

 | Name | Description
Public method | NmeaReader | コンストラクタ

Methods

 | Name | Description
Public method | Close | ファイルを閉じる
Public method | Dispose | リソースを開放します
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ インスタンスの廃棄時に呼び出されるメソッド (Overrides Object..::..Finalize()()()().)
Public method | GetDateTimes | ZDAから時刻データ列のみを取得する GGAのトリガはないのでGetPositioningResults()とは時刻がずれる可能性がある。 日付も考慮してみる。
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositioningResults | GPGGAをトリガにして、タイミングごとにまとめた測位情報を返す NMEAはセンテンスの出力順序を規定していないので、もしかすると時刻と測位位置がずれるかもしれない。
Public method | GetPositions | GGAから緯度・経度を配列で取得する
Public method | GetTimes | GGAからUTCの秒単位の時刻を配列で得る 日付の経過などは考慮していない。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | 指定されたファイルを開く 開いた後は、メモリ上に全展開となる。 現時点ではデータ内にバイナリが入っているとエラーとなる。
Public method | OpenStream | ストリームを使用してファイルを開く 巨大なログファイルを処理する際に使用する。 ストリームを使用した処理に関しては未実装です。
Public method | OpenWithDialog | ダイアログを用いてNMEA形式のログファイルを開く
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsOpen | バッファ上に読み込み済みならtrueとなる。 2011/7/20 時点では、streamに関しては関知しない。

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


NmeaReader Constructor

[image]

A Sandcastle Documented Class Library
NmeaReader Constructor
NmeaReader Class See Also Send Feedback
コンストラクタ

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NmeaReader()
Visual Basic
Public Sub New
Visual C++
public:
NmeaReader()

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


NmeaReader Methods

[image] [image]

A Sandcastle Documented Class Library
NmeaReader Methods
NmeaReader Class See Also Send Feedback

The NmeaReader type exposes the following members.

Methods

 | Name | Description
Public method | Close | ファイルを閉じる
Public method | Dispose | リソースを開放します
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ インスタンスの廃棄時に呼び出されるメソッド (Overrides Object..::..Finalize()()()().)
Public method | GetDateTimes | ZDAから時刻データ列のみを取得する GGAのトリガはないのでGetPositioningResults()とは時刻がずれる可能性がある。 日付も考慮してみる。
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositioningResults | GPGGAをトリガにして、タイミングごとにまとめた測位情報を返す NMEAはセンテンスの出力順序を規定していないので、もしかすると時刻と測位位置がずれるかもしれない。
Public method | GetPositions | GGAから緯度・経度を配列で取得する
Public method | GetTimes | GGAからUTCの秒単位の時刻を配列で得る 日付の経過などは考慮していない。
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | 指定されたファイルを開く 開いた後は、メモリ上に全展開となる。 現時点ではデータ内にバイナリが入っているとエラーとなる。
Public method | OpenStream | ストリームを使用してファイルを開く 巨大なログファイルを処理する際に使用する。 ストリームを使用した処理に関しては未実装です。
Public method | OpenWithDialog | ダイアログを用いてNMEA形式のログファイルを開く
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


Close Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..Close Method
NmeaReader Class See Also Send Feedback
ファイルを閉じる

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


Dispose Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..Dispose Method
NmeaReader Class See Also Send Feedback
リソースを開放します

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..Finalize Method
NmeaReader Class See Also Send Feedback
デスコンストラクタ

インスタンスの廃棄時に呼び出されるメソッド

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


GetDateTimes Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..GetDateTimes Method
NmeaReader Class See Also Send Feedback
ZDAから時刻データ列のみを取得する GGAのトリガはないのでGetPositioningResults()とは時刻がずれる可能性がある。 日付も考慮してみる。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime[] GetDateTimes()
Visual Basic
Public Function GetDateTimes As DateTime()
Visual C++
public:
array<DateTime>^ GetDateTimes()

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.NmeaReader.GetDateTimes"]

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


GetPositioningResults Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..GetPositioningResults Method
NmeaReader Class See Also Send Feedback
GPGGAをトリガにして、タイミングごとにまとめた測位情報を返す

NMEAはセンテンスの出力順序を規定していないので、もしかすると時刻と測位位置がずれるかもしれない。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PositioningInfos GetPositioningResults()
Visual Basic
Public Function GetPositioningResults As PositioningInfos
Visual C++
public:
PositioningInfos^ GetPositioningResults()

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.NmeaReader.GetPositioningResults"]

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


GetPositions Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..GetPositions Method
NmeaReader Class See Also Send Feedback
GGAから緯度・経度を配列で取得する

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH[] GetPositions()
Visual Basic
Public Function GetPositions As BLH()
Visual C++
public:
array<BLH>^ GetPositions()

Return Value

座標を表すBLH構造体の配列

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


GetTimes Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..GetTimes Method
NmeaReader Class See Also Send Feedback
GGAからUTCの秒単位の時刻を配列で得る

日付の経過などは考慮していない。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public float[] GetTimes()
Visual Basic
Public Function GetTimes As Single()
Visual C++
public:
array<float>^ GetTimes()

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.NmeaReader.GetTimes"]

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


Open Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..Open Method
NmeaReader Class See Also Send Feedback
指定されたファイルを開く

開いた後は、メモリ上に全展開となる。

現時点ではデータ内にバイナリが入っているとエラーとなる。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Open(
    string fname
)
Visual Basic
Public Sub Open ( _
    fname As String _
)
Visual C++
public:
void Open(
    String^ fname
)

Parameters

fname
Type: System..::..String

[Missing <param name="fname"/> documentation for "M:GNSS.GPS.NMEA.NmeaReader.Open(System.String)"]

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


OpenStream Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..OpenStream Method
NmeaReader Class See Also Send Feedback
ストリームを使用してファイルを開く

巨大なログファイルを処理する際に使用する。

ストリームを使用した処理に関しては未実装です。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void OpenStream(
    string fname
)
Visual Basic
Public Sub OpenStream ( _
    fname As String _
)
Visual C++
public:
void OpenStream(
    String^ fname
)

Parameters

fname
Type: System..::..String

[Missing <param name="fname"/> documentation for "M:GNSS.GPS.NMEA.NmeaReader.OpenStream(System.String)"]

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


OpenWithDialog Method

[image]

A Sandcastle Documented Class Library
NmeaReader..::..OpenWithDialog Method
NmeaReader Class See Also Send Feedback
ダイアログを用いてNMEA形式のログファイルを開く

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void OpenWithDialog()
Visual Basic
Public Sub OpenWithDialog
Visual C++
public:
void OpenWithDialog()

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


NmeaReader Properties

[image] [image]

A Sandcastle Documented Class Library
NmeaReader Properties
NmeaReader Class See Also Send Feedback

The NmeaReader type exposes the following members.

Properties

 | Name | Description
Public property | IsOpen | バッファ上に読み込み済みならtrueとなる。 2011/7/20 時点では、streamに関しては関知しない。

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


IsOpen Property

[image]

A Sandcastle Documented Class Library
NmeaReader..::..IsOpen Property
NmeaReader Class See Also Send Feedback
バッファ上に読み込み済みならtrueとなる。 2011/7/20　時点では、streamに関しては関知しない。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool IsOpen { get; }
Visual Basic
Public ReadOnly Property IsOpen As Boolean
    Get
Visual C++
public:
property bool IsOpen {
    bool get ();
}

See Also

NmeaReader Class
GNSS.GPS.NMEA Namespace


PositioningInfo Class

[image]

A Sandcastle Documented Class Library
PositioningInfo Class
Members See Also Send Feedback
観測データを取り扱うクラス

構造体だと初期化を必ず求められるためクラスとした。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PositioningInfo
Visual Basic
Public Class PositioningInfo
Visual C++
public ref class PositioningInfo

Inheritance Hierarchy

System..::..Object
GNSS.GPS.NMEA..::..PositioningInfo

See Also

PositioningInfo Members
GNSS.GPS.NMEA Namespace


PositioningInfo Members

[image] [image]

A Sandcastle Documented Class Library
PositioningInfo Members
PositioningInfo Class Constructors Methods Fields See Also Send Feedback

The PositioningInfo type exposes the following members.

Constructors

 | Name | Description
Public method | PositioningInfo | コンストラクタ

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | position | 測位座標
Public field | time | 測位時刻（エポック）

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


PositioningInfo Constructor

[image]

A Sandcastle Documented Class Library
PositioningInfo Constructor
PositioningInfo Class See Also Send Feedback
コンストラクタ

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PositioningInfo()
Visual Basic
Public Sub New
Visual C++
public:
PositioningInfo()

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


PositioningInfo Fields

[image] [image]

A Sandcastle Documented Class Library
PositioningInfo Fields
PositioningInfo Class See Also Send Feedback

The PositioningInfo type exposes the following members.

Fields

 | Name | Description
Public field | position | 測位座標
Public field | time | 測位時刻（エポック）

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


position Field

[image]

A Sandcastle Documented Class Library
PositioningInfo..::..position Field
PositioningInfo Class See Also Send Feedback
測位座標

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH position
Visual Basic
Public position As BLH
Visual C++
public:
BLH position

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


time Field

[image]

A Sandcastle Documented Class Library
PositioningInfo..::..time Field
PositioningInfo Class See Also Send Feedback
測位時刻（エポック）

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime time
Visual Basic
Public time As DateTime
Visual C++
public:
DateTime time

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


PositioningInfo Methods

[image] [image]

A Sandcastle Documented Class Library
PositioningInfo Methods
PositioningInfo Class See Also Send Feedback

The PositioningInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
PositioningInfo..::..Finalize Method
PositioningInfo Class See Also Send Feedback
デスコンストラクタ

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

PositioningInfo Class
GNSS.GPS.NMEA Namespace


PositioningInfos Class

[image]

A Sandcastle Documented Class Library
PositioningInfos Class
Members See Also Send Feedback
測位情報

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class PositioningInfos
Visual Basic
Public Class PositioningInfos
Visual C++
public ref class PositioningInfos

Inheritance Hierarchy

System..::..Object
GNSS.GPS.NMEA..::..PositioningInfos

See Also

PositioningInfos Members
GNSS.GPS.NMEA Namespace


PositioningInfos Members

[image] [image]

A Sandcastle Documented Class Library
PositioningInfos Members
PositioningInfos Class Constructors Methods Properties See Also Send Feedback

The PositioningInfos type exposes the following members.

Constructors

 | Name | Description
Public method | PositioningInfos | コンストラクタ

Methods

 | Name | Description
Public method | Add | 測位情報を追加する
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositions | 測位座標情報をコピーする
Public method | GetRectangleField | ログを全走査し、2つ以上のログが存在した場合に、ログを覆う長方形領域を返す
Public method | GetTimes | 時刻情報をコピーしてくれる専用メソッド
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveFileAsNormal | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | ToString | データ内容をstring型にして返す データには、時刻・経度・緯度・高度が含まれます。 (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Length | 保持しているデータ数

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


PositioningInfos Constructor

[image]

A Sandcastle Documented Class Library
PositioningInfos Constructor
PositioningInfos Class See Also Send Feedback
コンストラクタ

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public PositioningInfos()
Visual Basic
Public Sub New
Visual C++
public:
PositioningInfos()

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


PositioningInfos Methods

[image] [image]

A Sandcastle Documented Class Library
PositioningInfos Methods
PositioningInfos Class See Also Send Feedback

The PositioningInfos type exposes the following members.

Methods

 | Name | Description
Public method | Add | 測位情報を追加する
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | デスコンストラクタ (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPositions | 測位座標情報をコピーする
Public method | GetRectangleField | ログを全走査し、2つ以上のログが存在した場合に、ログを覆う長方形領域を返す
Public method | GetTimes | 時刻情報をコピーしてくれる専用メソッド
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveFileAsNormal | 指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。
Public method | ToString | データ内容をstring型にして返す データには、時刻・経度・緯度・高度が含まれます。 (Overrides Object..::..ToString()()()().)

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


Add Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..Add Method
PositioningInfos Class See Also Send Feedback
測位情報を追加する

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Add(
    PositioningInfo pos
)
Visual Basic
Public Sub Add ( _
    pos As PositioningInfo _
)
Visual C++
public:
void Add(
    PositioningInfo^ pos
)

Parameters

pos
Type: GNSS.GPS.NMEA..::..PositioningInfo

[Missing <param name="pos"/> documentation for "M:GNSS.GPS.NMEA.PositioningInfos.Add(GNSS.GPS.NMEA.PositioningInfo)"]

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


Finalize Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..Finalize Method
PositioningInfos Class See Also Send Feedback
デスコンストラクタ

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


GetPositions Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..GetPositions Method
PositioningInfos Class See Also Send Feedback
測位座標情報をコピーする

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BLH[] GetPositions()
Visual Basic
Public Function GetPositions As BLH()
Visual C++
public:
array<BLH>^ GetPositions()

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.PositioningInfos.GetPositions"]

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


GetRectangleField Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..GetRectangleField Method
PositioningInfos Class See Also Send Feedback
ログを全走査し、2つ以上のログが存在した場合に、ログを覆う長方形領域を返す

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public RectangleField GetRectangleField()
Visual Basic
Public Function GetRectangleField As RectangleField
Visual C++
public:
RectangleField^ GetRectangleField()

Return Value

領域情報またはnull

領域を構成できない場合はnullを返します。

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


GetTimes Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..GetTimes Method
PositioningInfos Class See Also Send Feedback
時刻情報をコピーしてくれる専用メソッド

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime[] GetTimes()
Visual Basic
Public Function GetTimes As DateTime()
Visual C++
public:
array<DateTime>^ GetTimes()

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.PositioningInfos.GetTimes"]

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


SaveFileAsNormal Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..SaveFileAsNormal Method
PositioningInfos Class See Also Send Feedback
指定ファイル名でデータを保存する KMLに加工するメソッドもその内作りたいなぁ。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void SaveFileAsNormal(
    string fname
)
Visual Basic
Public Sub SaveFileAsNormal ( _
    fname As String _
)
Visual C++
public:
void SaveFileAsNormal(
    String^ fname
)

Parameters

fname
Type: System..::..String
ファイル名

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


ToString Method

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..ToString Method
PositioningInfos Class See Also Send Feedback
データ内容をstring型にして返す データには、時刻・経度・緯度・高度が含まれます。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:GNSS.GPS.NMEA.PositioningInfos.ToString"]

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


PositioningInfos Properties

[image] [image]

A Sandcastle Documented Class Library
PositioningInfos Properties
PositioningInfos Class See Also Send Feedback

The PositioningInfos type exposes the following members.

Properties

 | Name | Description
Public property | Length | 保持しているデータ数

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


Length Property

[image]

A Sandcastle Documented Class Library
PositioningInfos..::..Length Property
PositioningInfos Class See Also Send Feedback
保持しているデータ数

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int Length { get; }
Visual Basic
Public ReadOnly Property Length As Integer
    Get
Visual C++
public:
property int Length {
    int get ();
}

See Also

PositioningInfos Class
GNSS.GPS.NMEA Namespace


ZDA Class

[image]

A Sandcastle Documented Class Library
ZDA Class
Members See Also Send Feedback
ZDAのみを扱うクラス

未完成

staticクラスとして宣言するので、インスタンスの確保を宣言せずとも使えます。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class ZDA
Visual Basic
Public NotInheritable Class ZDA
Visual C++
public ref class ZDA abstract sealed

Inheritance Hierarchy

System..::..Object
GNSS.GPS.NMEA..::..ZDA

See Also

ZDA Members
GNSS.GPS.NMEA Namespace


ZDA Members

[image] [image]

A Sandcastle Documented Class Library
ZDA Members
ZDA Class Methods See Also Send Feedback

The ZDA type exposes the following members.

Methods

Name | Description
CheckMatch | 文字列を検査してセンテンスにマッチするかどうかを確認する
FindAll | 検査文字列の中にあるマッチするものをすべて抽出する Pythonのfindallを参考にした。 テスト未実施
Parse | ZDAを解析して、測位時刻を返す 正規表現を利用したマッチをかけているので文字列処理でエラーが生じるとは思えませんが、エラー対策をかませています。

See Also

ZDA Class
GNSS.GPS.NMEA Namespace


ZDA Methods

[image] [image]

A Sandcastle Documented Class Library
ZDA Methods
ZDA Class See Also Send Feedback

The ZDA type exposes the following members.

Methods

Name | Description
CheckMatch | 文字列を検査してセンテンスにマッチするかどうかを確認する
FindAll | 検査文字列の中にあるマッチするものをすべて抽出する Pythonのfindallを参考にした。 テスト未実施
Parse | ZDAを解析して、測位時刻を返す 正規表現を利用したマッチをかけているので文字列処理でエラーが生じるとは思えませんが、エラー対策をかませています。

See Also

ZDA Class
GNSS.GPS.NMEA Namespace


CheckMatch Method

[image]

A Sandcastle Documented Class Library
ZDA..::..CheckMatch Method
ZDA Class See Also Send Feedback
文字列を検査してセンテンスにマッチするかどうかを確認する

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool CheckMatch(
    string txt
)
Visual Basic
Public Shared Function CheckMatch ( _
    txt As String _
) As Boolean
Visual C++
public:
static bool CheckMatch(
    String^ txt
)

Parameters

txt
Type: System..::..String
被検査文字列

Return Value

検査結果

true: ヒット

See Also

ZDA Class
GNSS.GPS.NMEA Namespace


FindAll Method

[image]

A Sandcastle Documented Class Library
ZDA..::..FindAll Method
ZDA Class See Also Send Feedback
検査文字列の中にあるマッチするものをすべて抽出する

Pythonのfindallを参考にした。

テスト未実施

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static MatchCollection FindAll(
    string txt
)
Visual Basic
Public Shared Function FindAll ( _
    txt As String _
) As MatchCollection
Visual C++
public:
static MatchCollection^ FindAll(
    String^ txt
)

Parameters

txt
Type: System..::..String
被検査文字列

Return Value

検査結果

See Also

ZDA Class
GNSS.GPS.NMEA Namespace


Parse Method

[image]

A Sandcastle Documented Class Library
ZDA..::..Parse Method
ZDA Class See Also Send Feedback
ZDAを解析して、測位時刻を返す

正規表現を利用したマッチをかけているので文字列処理でエラーが生じるとは思えませんが、エラー対策をかませています。

Namespace: GNSS.GPS.NMEA
Assembly: GNSS (in GNSS.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DateTime Parse(
    string str
)
Visual Basic
Public Shared Function Parse ( _
    str As String _
) As DateTime
Visual C++
public:
static DateTime Parse(
    String^ str
)

Parameters

str
Type: System..::..String
解析文字列

Return Value

時刻（UTC）

See Also

ZDA Class
GNSS.GPS.NMEA Namespace